Subject: [Iotops] OPC UA FLC and TLS

From: Christer Holmberg <[email-masked]>
Date: Thu, 29 Jul 2021 11:20:20 +0000

Hi,

When I watched the YouTube video from them iotops session someone claimed that OPC UA FLC "re-invented" TLS. What was meant by that?

Someone also mentioned "IP over Modbus", but I assume that was a joke?

Regards,

Christer

---

From: Eliot Lear <[email-masked]>
Date: Thu, 29 Jul 2021 14:09:36 +0200

Christer,

On 29.07.21 13:20, Christer Holmberg wrote:
>
> When I watched the YouTube video from them iotops session someone 
> claimed that OPC UA FLC “re-invented” TLS. What was meant by that?
>
That was my mistake.  Other organizations (not OPC UA) have reinvented 
TLS, but OPC UA is just out of date, so far as I can tell.[1]

Eliot

[1] https://reference.opcfoundation.org/Core/docs/Part2/

---

From: Michael Richardson <[email-masked]>
Date: Thu, 29 Jul 2021 14:38:56 -0400

Eliot Lear <[email-masked]> wrote:
    >> When I watched the YouTube video from them iotops session someone claimed
    >> that OPC UA FLC “re-invented” TLS. What was meant by that?
    >>
    > That was my mistake.  Other organizations (not OPC UA) have reinvented TLS,
    > but OPC UA is just out of date, so far as I can tell.[1]

My understanding is that OPC UA has a legacy DCOM based system that uses RSA
signature for authentication, but is not related to TLS/SSL/etc.
But that they use TLS and DTLS (1.3 even) in the latest specifications.

--
]               Never tell me the odds!                 | ipv6 mesh networks [
]   Michael Richardson, Sandelman Software Works        |    IoT architect   [
]     [email-masked]  http://www.sandelman.ca/        |   ruby on rails    [