Subject: [Iotops] Fwd: New Version Notification for draft-nordmark-iotops-onboarding-00.txt

From: Erik Nordmark <[email-masked]>
Date: Tue, 27 Jul 2021 00:02:55 +0200

-------- Forwarded Message --------
Subject: New Version Notification for 
draft-nordmark-iotops-onboarding-00.txt
Date: Mon, 26 Jul 2021 15:01:47 -0700
From: [email-masked]
To: Erik Nordmark <[email-masked]>

A new version of I-D, draft-nordmark-iotops-onboarding-00.txt
has been successfully submitted by Erik Nordmark and posted to the
IETF repository.

Name:		draft-nordmark-iotops-onboarding
Revision:	00
Title:		Different aspects of onboarding for IoT/Edge Devices
Document date:	2021-07-26
Group:		Individual Submission
Pages:		8
URL: 
https://www.ietf.org/archive/id/draft-nordmark-iotops-onboarding-00.txt
Status: 
https://datatracker.ietf.org/doc/draft-nordmark-iotops-onboarding/
Html: 
https://www.ietf.org/archive/id/draft-nordmark-iotops-onboarding-00.html
Htmlized: 
https://datatracker.ietf.org/doc/html/draft-nordmark-iotops-onboarding

Abstract:
    Previous onboarding discussions have focused on network onboarding.
    In this note we put that in the context of the larger onboarding
    picture to also discuss the onboarding to some management or
    orchestration system.

The IETF Secretariat

---

From: Hannes Tschofenig <[email-masked]>
Date: Tue, 27 Jul 2021 10:20:28 +0000

Thanks for sharing the draft and for your presentation yesterday.

A short note:

> Project EVE [eve] is an example of a secure but minimal approach to enable secure onboarding, without having a hard dependency on manufacturers and manufacturer certificates.

> Imprint device which controller to trust (a root certificate) and initial URL to contact

Isn't the root certificate the manufacturer certificate?

So far, only two approaches have been developed:

(1) During manufacturing you provision keys into the device. Then, you use those keys to create further keys when the device is put in use. FIDO Device Onboard, LwM2M bootstrap, ANIMA, ... etc. fall into that category.

(2) At first use you provision something into the device under the assumption that an attacker is not around (for example based on proximity). For example, BLE uses this technique.

Both approaches have pros and cons. I understand that people want the security benefits of (1) without the drawbacks of (2). I just have not seen that solution yet.

Ciao
Hannes

-----Original Message-----
From: Iotops <[email-masked]> On Behalf Of Erik Nordmark
Sent: Tuesday, July 27, 2021 12:03 AM
To: [email-masked]
Subject: [Iotops] Fwd: New Version Notification for draft-nordmark-iotops-onboarding-00.txt

-------- Forwarded Message --------

Abstract:

The IETF Secretariat

--
Iotops mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/iotops
IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.