Subject: [Iotsi] interactive vs. programmatic IoT

From: Andy Bierman <[email-masked]>
Date: Tue, 22 Mar 2016 10:28:49 -0700

Hi,

It seems to me that the use-cases discussed at the meeting
assume there is a human with access to UI driving the client.

Does this mean use-cases which do not assume any human interrupts
are possible are not IoT, but something else? In this environment
everything is usually programmed in advance. HATEOAS doesn't
really help here.  It is not likely the client can make decisions
about code-points it has never seen before.

Are there any expectations that IoT includes programmatic clients
or is it just for interactive clients?

Andy

---

From: "Subramaniam, Ravi" <[email-masked]>
Date: Tue, 22 Mar 2016 17:49:06 +0000

Hi Andy,

IMHO, for IOT to be successful it would be primarily (what you are calling) “programmatic clients” – most *useful* IOT systems would tend to be relatively or fully autonomous with human interactions at the “periphery” of such systems.

OCF has called out that it is “declarative and late binding” because the expectation is that a “human” would declare “what” they wanted the system to be and its objectives and the rest is done by autonomous interactions of “programmatic participants” (well… at this stage, OCF spec is in the “crawl” stage so this ‘vision’ is hard to see but the basic concepts support this direction ☺ )

Ravi

From: Iotsi [mailto:[email-masked]] On Behalf Of Andy Bierman
Sent: Tuesday, March 22, 2016 10:29 AM
To: [email-masked]
Subject: [Iotsi] interactive vs. programmatic IoT

Hi,

Andy

---

From: "Kreuzer, Kai" <[email-masked]>
Date: Thu, 24 Mar 2016 15:37:26 +0000

Hi,

I fully second Ravi on this – the ultimate goal is that algorithms can make “sense” out of the services that they find. Being able to only operate through UIs pushes the semantic knowledge” onto the user, so I would not even talk about semantic interoperability, but rather “only” about technical interoperability (see also the second half of my blog post here<http://kaikreuzer.blogspot.de/2016/03/semantic-interoperability-in-internet.html>).

> HATEOAS doesn't really help here

I do not agree on this. The idea of having the links on the resources is to make them self-descriptive and navigatable. So algorithms should be able to dynamically “discover” what the service is about and use it adequately without any prior knowledge. But Matthias is probably the best person to comment on this.

Best regards,
Kai

Von: Iotsi [mailto:[email-masked]] Im Auftrag von Subramaniam, Ravi
Gesendet: Dienstag, 22. März 2016 18:49
An: Andy Bierman; [email-masked]
Betreff: Re: [Iotsi] interactive vs. programmatic IoT

Hi Andy,

Ravi

From: Iotsi [mailto:[email-masked]] On Behalf Of Andy Bierman
Sent: Tuesday, March 22, 2016 10:29 AM
To: [email-masked]<mailto:[email-masked]>
Subject: [Iotsi] interactive vs. programmatic IoT

Hi,

Andy

---

From: Michel Kohanim <[email-masked]>
Date: Thu, 24 Mar 2016 16:01:09 +0000

Ummm …. Where does one draw the boundary between what must be relegated to the user vs. the machine?  If we expect the machine to make all the decisions, then:

1.       The machine must know everything a priori … this means, for every change in the semantic world, there needs to be a change in the machine world

2.       Or, the machine has to learn … this means that we would have to use some AI techniques. Are we up for it? If so, which AI paradigm are we going to use?

With kind regards,

******************************
  Michel Kohanim
  CEO

  (p) 818.631.0333
  (f)  818.436.0702
  http://www.universal-devices.com<http://www.universal-devices.com/>
******************************

From: Iotsi [mailto:[email-masked]] On Behalf Of Kreuzer, Kai
Sent: Thursday, March 24, 2016 8:37 AM
To: Subramaniam, Ravi <[email-masked]>; Andy Bierman <[email-masked]>; [email-masked]
Subject: Re: [Iotsi] interactive vs. programmatic IoT

Hi,

Best regards,
Kai

Von: Iotsi [mailto:[email-masked]] Im Auftrag von Subramaniam, Ravi
Gesendet: Dienstag, 22. März 2016 18:49
An: Andy Bierman; [email-masked]<mailto:[email-masked]>
Betreff: Re: [Iotsi] interactive vs. programmatic IoT

Hi Andy,

Ravi

Hi,

Andy

---

From: "Subramaniam, Ravi" <[email-masked]>
Date: Thu, 24 Mar 2016 16:38:16 +0000

Hi Michel,

I do agree that there may be a boundary between user and machine but I find it hard to follow the conclusions that you have derived …

1.     The boundary may not be a distinct and stark transition – it may be more diffuse. We are already seeing evidence of serious and useful technology where this boundary has been blurred.

2.    I am not sure that the machine “must know everything a priori” – much of what is needed can be late-binding and discovered. But it does make it necessary for a lot of information and data to be explicit and not implicitly encoded in some code/SW implementation. This has always been true in adaptive systems.

3.    Yes, learning is useful but there are very sophisticated behaviors in the aggregate that are possible with simple rules of behavior and dynamic application based on environment – we have analogs in the insect world (bees, ants and other social creatures) and fractals. So if IOT were to be viewed as many such simple elements manifesting complex and sophisticated behavior in the aggregate then we need some well-defined patterns of behavior and explicit definitions and we can see some very useful and complex results.

4.    Sure we would also like to add machine learning to the mix but that would be another element higher in the “logical” system hierarchy very similar to the architecture of the human brain. The systems that are designed for 2 and 3 will make it easier for the learning to be “integrated” into or be “part” of the system. There are many techniques for learnings and from my knowledge of this area, I cannot discern one paradigm that is universal though there are many that make a good starting point.

Thanks!

Ravi

From: Michel Kohanim [mailto:[email-masked]]
Sent: Thursday, March 24, 2016 9:01 AM
To: Kreuzer, Kai <[email-masked]>; Subramaniam, Ravi <[email-masked]>; Andy Bierman <[email-masked]>; [email-masked]
Subject: RE: [Iotsi] interactive vs. programmatic IoT

With kind regards,

  (p) 818.631.0333
  (f)  818.436.0702

From: Iotsi [mailto:[email-masked]] On Behalf Of Kreuzer, Kai
Sent: Thursday, March 24, 2016 8:37 AM
To: Subramaniam, Ravi <[email-masked]<mailto:[email-masked]>>; Andy Bierman <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Re: [Iotsi] interactive vs. programmatic IoT

Hi,

Best regards,
Kai

Hi Andy,

Ravi

Hi,

Andy

---

From: Andy Bierman <[email-masked]>
Date: Thu, 24 Mar 2016 09:59:38 -0700

On Thu, Mar 24, 2016 at 9:01 AM, Michel Kohanim <
[email-masked]> wrote:

> Ummm …. Where does one draw the boundary between what must be relegated to
> the user vs. the machine?  If we expect the machine to make all the
> decisions, then:
>
> 1.       The machine must know everything a priori … this means, for
> every change in the semantic world, there needs to be a change in the
> machine world
>
> 2.       Or, the machine has to learn … this means that we would have to
> use some AI techniques. Are we up for it? If so, which AI paradigm are we
> going to use?
>
>
>

(1)

Typically new functionality only shows up when new firmware or new devices
are added.
This is true for SNMP and NETCONF devices that use SMIv2 or YANG modules
to define the functionality.  The client is typically hard-coded to utilize
specific
revisions of specific modules.  Any new managed device simply advertises
known modules and the client works.

Perhaps IoT devices can do better.

>
> With kind regards,
>
>
>
> ********************************
>
>   *Michel Kohanim*
>

Andy

>   CEO
>
>
>
>   (p) 818.631.0333
>
>   (f)  818.436.0702
>
>   http://www.universal-devices.com
>
> ********************************
>
>
>
> *From:* Iotsi [mailto:[email-masked]] *On Behalf Of *Kreuzer, Kai
> *Sent:* Thursday, March 24, 2016 8:37 AM
> *To:* Subramaniam, Ravi <[email-masked]>; Andy Bierman <
> [email-masked]>; [email-masked]
> *Subject:* Re: [Iotsi] interactive vs. programmatic IoT
>
>
>
> Hi,
>
>
>
> I fully second Ravi on this – the ultimate goal is that algorithms can
> make “sense” out of the services that they find. Being able to only operate
> through UIs pushes the semantic knowledge” onto the user, so I would not
> even talk about semantic interoperability, but rather “only” about
> technical interoperability (see also the second half of my blog post here
> <http://kaikreuzer.blogspot.de/2016/03/semantic-interoperability-in-internet.html>
> ).
>
>
>
> I do not agree on this. The idea of having the links on the resources is
> to make them self-descriptive and navigatable. So algorithms should be able
> to dynamically “discover” what the service is about and use it adequately
> without any prior knowledge. But Matthias is probably the best person to
> comment on this.
>
>
>
> Best regards,
> Kai
>
>
>
> *Von:* Iotsi [mailto:[email-masked] <[email-masked]>] *Im
> Auftrag von *Subramaniam, Ravi
> *Gesendet:* Dienstag, 22. März 2016 18:49
> *An:* Andy Bierman; [email-masked]
> *Betreff:* Re: [Iotsi] interactive vs. programmatic IoT
>
>
>
> Hi Andy,
>
>
>
> IMHO, for IOT to be successful it would be primarily (what you are
> calling) “programmatic clients” – most **useful** IOT systems would tend
> to be relatively or fully autonomous with human interactions at the
> “periphery” of such systems.
>
>
>
> OCF has called out that it is “declarative and late binding” because the
> expectation is that a “human” would declare “what” they wanted the system
> to be and its objectives and the rest is done by autonomous interactions of
> “programmatic participants” (well… at this stage, OCF spec is in the
> “crawl” stage so this ‘vision’ is hard to see but the basic concepts
> support this direction J )
>
>
>
> Ravi
>
>
>
> *From:* Iotsi [mailto:[email-masked] <[email-masked]>] *On
> Behalf Of *Andy Bierman
> *Sent:* Tuesday, March 22, 2016 10:29 AM
> *To:* [email-masked]
> *Subject:* [Iotsi] interactive vs. programmatic IoT
>
>
>
> Hi,
>
>
>

---

From: Michel Kohanim <[email-masked]>
Date: Thu, 24 Mar 2016 17:09:05 +0000

Hi Ravi,

Thank you for the details alas I cannot discern anything practical in what you are suggesting (i.e. how would I implement it?).

1.     The boundary may not be a distinct and stark transition – it may be more diffuse. We are already seeing evidence of serious and useful technology where this boundary has been blurred.
[MK] If you don’t mind, please provide links to some of this useful technology.

2.    I am not sure that the machine “must know everything a priori” – much of what is needed can be late-binding and discovered.

[MK] How much does “much” refer to? Late binding and discovered does not mean that the machine “understands” them. In short, either the machine has to know about what’s being discovered OR have some mechanism to discern the high level natures thereof.  I propose the latter. Although I would love nothing more than having philosophical and theoretical discussions about IoT, however – and from a manufacturer of automation devices perspective – words such as “blurred” and “diffused” do not easily translate to requirements (use cases), design (classes, interactions, sequences), and ultimately code.

 But it does make it necessary for a lot of information and data to be explicit and not implicitly encoded in some code/SW implementation.
       [MK] Explicit as in coded in the machine? If not, then where? Who are the consumers of this information and data?

 This has always been true in adaptive systems.

[MK] Would you please give me a link to one of these adaptive systems?

[MK] I am no longer certain what we are trying to solve here!

[MK] I agree and thus my point: we are not trying to solve AI and learning. We are trying to solve how things can understand each other at the highest level (late binding/discovery) . My question is: are there any boundaries with regards to decision making? i.e. if X::A == n then Y::B() && Z::C(w , y1)

With kind regards,

  (p) 818.631.0333
  (f)  818.436.0702

From: Subramaniam, Ravi [mailto:[email-masked]]
Sent: Thursday, March 24, 2016 9:38 AM
To: Michel Kohanim <[email-masked]>; Kreuzer, Kai <[email-masked]>; Andy Bierman <[email-masked]>; [email-masked]
Subject: RE: [Iotsi] interactive vs. programmatic IoT

Hi Michel,

Thanks!

Ravi

From: Michel Kohanim [mailto:[email-masked]]
Sent: Thursday, March 24, 2016 9:01 AM
To: Kreuzer, Kai <[email-masked]<mailto:[email-masked]>>; Subramaniam, Ravi <[email-masked]<mailto:[email-masked]>>; Andy Bierman <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: RE: [Iotsi] interactive vs. programmatic IoT

With kind regards,

  (p) 818.631.0333
  (f)  818.436.0702

Hi,

Best regards,
Kai

Hi Andy,

Ravi

Hi,

Andy

---

From: Michel Kohanim <[email-masked]>
Date: Thu, 24 Mar 2016 17:10:54 +0000

Hi Andy,

Thank you and precisely my point.

With kind regards,

  (p) 818.631.0333
  (f)  818.436.0702

From: Andy Bierman [mailto:[email-masked]]
Sent: Thursday, March 24, 2016 10:00 AM
To: Michel Kohanim <[email-masked]>
Cc: Kreuzer, Kai <[email-masked]>; Subramaniam, Ravi <[email-masked]>; [email-masked]
Subject: Re: [Iotsi] interactive vs. programmatic IoT

On Thu, Mar 24, 2016 at 9:01 AM, Michel Kohanim <[email-masked]<mailto:[email-masked]>> wrote:
Ummm …. Where does one draw the boundary between what must be relegated to the user vs. the machine?  If we expect the machine to make all the decisions, then:

(1)

Typically new functionality only shows up when new firmware or new devices are added.
This is true for SNMP and NETCONF devices that use SMIv2 or YANG modules
to define the functionality.  The client is typically hard-coded to utilize specific
revisions of specific modules.  Any new managed device simply advertises
known modules and the client works.

With kind regards,

Andy

  CEO

  (p) 818.631.0333
  (f)  818.436.0702

From: Iotsi [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Kreuzer, Kai
Sent: Thursday, March 24, 2016 8:37 AM
To: Subramaniam, Ravi <[email-masked]<mailto:[email-masked]>>; Andy Bierman <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Re: [Iotsi] interactive vs. programmatic IoT

Hi,

Best regards,
Kai

Hi Andy,

Ravi

Hi,

Andy

---

From: Dave Raggett <[email-masked]>
Date: Thu, 24 Mar 2016 17:53:51 +0000

Late binding is necessary where the data is not fully defined in advance. The recipient may have complete knowledge of the range of types that are late bound. If not, it may be sufficient to pass the data on to another agent that does. Alternatively, the recipient may in some cases be able to extend itself so that it now is capable of dealing with the data. This could just be a matter of referencing an external library and is in reach of gateways and cloud based systems that run relatively powerful software, e.g. based upon NodeJS. 

Another perspective is to consider the process of defining a distributed service composition involving a suite of devices. Metadata about the capabilities of individual devices can be used to match tasks to devices according to their known capabilities. An example is a smart factory where you want to allocate production cells to an order book for bespoke products. Dynamic reconfiguration is necessary when problems arise on particular cells or there are hold ups in the supply chain. This can involve cooperation with the human workers, e.g. to review proposed solutions.

—
   Dave Raggett <[email-masked] <mailto:[email-masked]>>

---

From: Michel Kohanim <[email-masked]>
Date: Thu, 24 Mar 2016 17:57:58 +0000

Hi Dave,

Thank you and not only I totally agree with your comments but I subscribe to them wholeheartedly.

My main questions (as the subject of this email chain suggests) is how does a developer (such as our company) figure out “interactive” vs. “programmatic” IoT. Where is that boundary? Is it organic? If not, what are the constraints?

With kind regards,

  (p) 818.631.0333
  (f)  818.436.0702

From: Dave Raggett [mailto:[email-masked]]
Sent: Thursday, March 24, 2016 10:54 AM
To: Michel Kohanim <[email-masked]>
Cc: Subramaniam, Ravi <[email-masked]>; Kreuzer, Kai <[email-masked]>; Andy Bierman <[email-masked]>; [email-masked]
Subject: Re: [Iotsi] interactive vs. programmatic IoT

—
   Dave Raggett <[email-masked]<mailto:[email-masked]>>

---

From: Andy Bierman <[email-masked]>
Date: Thu, 24 Mar 2016 12:57:13 -0700

Hi,

Most of the ontology stuff looked like simple codepoints to me,
that needed to be coded by hand by somebody who understands the semantics.
This is not fatal flaw though.

In our terminology, if I have code that understands certain atoms well
enough,
can new molecules be supported from known atoms?  This seems easier with
human interaction, but it might be possible to some degree with
non-interactive clients
as well.

In other terms, if my modular software knows about setting the
alarm on the clock, can it learn to set "wake to music"
when the "radio" module is added to the "alarm-clock" module?
(Note that wake-to-music is NOT a function built into a radio.
It only exists when a radio is combined with an alarm clock.).
If "wake-to-music" can be learned, is it learned for just radios or also
MP3 players?

Andy

On Thu, Mar 24, 2016 at 10:10 AM, Michel Kohanim <
[email-masked]> wrote:

> *From:* Andy Bierman [mailto:[email-masked]]
> *Sent:* Thursday, March 24, 2016 10:00 AM
> *To:* Michel Kohanim <[email-masked]>
> *Cc:* Kreuzer, Kai <[email-masked]>; Subramaniam, Ravi <
> [email-masked]>; [email-masked]

---

From: Michel Kohanim <[email-masked]>
Date: Thu, 24 Mar 2016 20:36:37 +0000

Hi Andy,

Thanks for the clarifications. My question to you is: would the human want your modular software make those decisions for him/her? i.e. I very much prefer having my wake up tone (to which I am familiar) and if, one day, my phone decided to play radio instead of my wake up tone on its own, I would be quite mad. I would probably even throw away my phone.

Anecdote from  Amazon Echo: Amazon decided that the completion prompt should be a tone instead of “OK”. They had such a huge backlash that they had to put the “OK” back and now they are dealing with backlash from those who liked the tone. So, they have finally decided to make it configuration: i.e. human intervention.

All and all, I do very much like the concept of autonomy but we do need to find a boundary between what humans constitute as infringing on their free-will vs. those that they would welcome.

With kind regards,

  (p) 818.631.0333
  (f)  818.436.0702

Sent: Thursday, March 24, 2016 12:57 PM

Hi,

In our terminology, if I have code that understands certain atoms well enough,
can new molecules be supported from known atoms?  This seems easier with
human interaction, but it might be possible to some degree with non-interactive clients
as well.

If "wake-to-music" can be learned, is it learned for just radios or also MP3 players?

Andy

On Thu, Mar 24, 2016 at 10:10 AM, Michel Kohanim <[email-masked]<mailto:[email-masked]>> wrote:
Hi Andy,

With kind regards,

  (p) 818.631.0333
  (f)  818.436.0702

From: Andy Bierman [mailto:[email-masked]<mailto:[email-masked]>]
Sent: Thursday, March 24, 2016 10:00 AM
To: Michel Kohanim <[email-masked]<mailto:[email-masked]>>
Cc: Kreuzer, Kai <[email-masked]<mailto:[email-masked]>>; Subramaniam, Ravi <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Re: [Iotsi] interactive vs. programmatic IoT

(1)

With kind regards,

Andy

  CEO

  (p) 818.631.0333
  (f)  818.436.0702

Hi,

Best regards,
Kai

Hi Andy,

Ravi

Hi,

Andy

---

From: Clarke Stevens <[email-masked]>
Date: Thu, 24 Mar 2016 15:24:32 -0600

For a start, maybe we can look at it in this way:

A human should be able to control things in real time in a logical way through some UI (e.g. push a button on a smart phone to turn on a light).
A human should be able to specify automated rules in a logical way through some UI (e.g. set a rule to turn on the porch light when I get home).
Semantic interoperability should take care of most other tasks (e.g. How do I recognize a light? How do I make functionally similar lights from multiple manufacturers and ecosystem all look like logical lights? How do I recognize when the user is home?)

There is a lot of functionality that is left out here, but I think this is plenty difficult as a starting goal.

-Clarke

> On Mar 24, 2016, at 2:36 PM, Michel Kohanim <[email-masked]> wrote:
> 
> Hi Andy,
>  
>   http://www.universal-devices.com <http://www.universal-devices.com/>
> On Thu, Mar 24, 2016 at 10:10 AM, Michel Kohanim <[email-masked] <mailto:[email-masked]>> wrote:
> Hi Andy,
>  
>   http://www.universal-devices.com <http://www.universal-devices.com/>
> From: Andy Bierman [mailto:[email-masked] <mailto:[email-masked]>] 
> To: Michel Kohanim <[email-masked] <mailto:[email-masked]>>
> Cc: Kreuzer, Kai <[email-masked] <mailto:[email-masked]>>; Subramaniam, Ravi <[email-masked] <mailto:[email-masked]>>;[email-masked] <mailto:[email-masked]>
> On Thu, Mar 24, 2016 at 9:01 AM, Michel Kohanim <[email-masked] <mailto:[email-masked]>> wrote:
>   http://www.universal-devices.com <http://www.universal-devices.com/>
> From: Iotsi [mailto:[email-masked] <mailto:[email-masked]>] On Behalf Of Kreuzer, Kai
> To: Subramaniam, Ravi <[email-masked] <mailto:[email-masked]>>; Andy Bierman <[email-masked] <mailto:[email-masked]>>;[email-masked] <mailto:[email-masked]>
> I fully second Ravi on this – the ultimate goal is that algorithms can make “sense” out of the services that they find. Being able to only operate through UIs pushes the semantic knowledge” onto the user, so I would not even talk about semantic interoperability, but rather “only” about technical interoperability (see also the second half of my blog post here <http://kaikreuzer.blogspot.de/2016/03/semantic-interoperability-in-internet.html>).
>  
> Von: Iotsi [mailto:[email-masked] <mailto:[email-masked]>] Im Auftrag von Subramaniam, Ravi
> An: Andy Bierman; [email-masked] <mailto:[email-masked]>
> OCF has called out that it is “declarative and late binding” because the expectation is that a “human” would declare “what” they wanted the system to be and its objectives and the rest is done by autonomous interactions of “programmatic participants” (well… at this stage, OCF spec is in the “crawl” stage so this ‘vision’ is hard to see but the basic concepts support this direction J )
>  
> Ravi
>  
>  <>From: Iotsi [mailto:[email-masked] <mailto:[email-masked]>] On Behalf Of Andy Bierman
> To: [email-masked] <mailto:[email-masked]>
> _______________________________________________
> Iotsi mailing list
> [email-masked]
> https://www.iab.org/mailman/listinfo/iotsi

---

From: Dave Raggett <[email-masked]>
Date: Fri, 25 Mar 2016 10:30:31 +0000

That sounds like a question for innovators to explore according to the circumstances.  One example is the way that device UIs can indicate that an action has been accepted but not yet acted upon. e.g. when waiting for a sleeping device to wake up and deal with the action. Standards are important for enabling a marketplace of apps that can be installed on gateways for greater flexibility.  User interaction is needed here for managing services and their permissions. This could be through a web application hosted through the gateway or cloud. For me the question is what kinds of standards are needed to encourage an open market of devices and services. 

> On 24 Mar 2016, at 17:57, Michel Kohanim <[email-masked]> wrote:
> 
> Hi Dave,
>  

—

---

From: Dave Raggett <[email-masked]>
Date: Fri, 25 Mar 2016 10:54:45 +0000

> On 24 Mar 2016, at 21:24, Clarke Stevens <[email-masked]> wrote:
> 

Semantic interoperability makes it practical to relate information from different sources. This is key to realizing the value of the IoT in the broader sense. In the absence of standards, we are left with the problem of needing to know direct mappings between each of the sources, which would act as a brake on innovation and market activity.

W3C’s work on the resource description framework provides a scalable basis for an interlingua for translating between the semantic representations used by different platforms. The challenge is then how to encourage innovators to publish their semantic models and enable re-use where it makes sense.  For instance, could we agree on standard that enable search engines to index models published via the Web?  Can we encourage royalty free use of published models? Can we decouple application logic from the complexities of the underlying platforms and protocols?

—

---

From: Michel Kohanim <[email-masked]>
Date: Fri, 25 Mar 2016 15:51:10 +0000

Agreed.

With kind regards,

  (p) 818.631.0333
  (f)  818.436.0702

Sent: Friday, March 25, 2016 3:31 AM

On 24 Mar 2016, at 17:57, Michel Kohanim <[email-masked]<mailto:[email-masked]>> wrote:

Hi Dave,

With kind regards,

  (p) 818.631.0333
  (f)  818.436.0702

Cc: Subramaniam, Ravi <[email-masked]<mailto:[email-masked]>>; Kreuzer, Kai <[email-masked]<mailto:[email-masked]>>; Andy Bierman <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>

—

—

---

From: Clarke Stevens <[email-masked]>
Date: Fri, 25 Mar 2016 11:39:29 -0600

See below.

-Clarke

> On Mar 25, 2016, at 4:54 AM, Dave Raggett <[email-masked]> wrote:
> 
> 
>> On 24 Mar 2016, at 21:24, Clarke Stevens <[email-masked] <mailto:[email-masked]>> wrote:
>> 
> W3C’s work on the resource description framework provides a scalable basis for an interlingua for translating between the semantic representations used by different platforms. The challenge is then how to encourage innovators to publish their semantic models and enable re-use where it makes sense.  

> For instance, could we agree on standard that enable search engines to index models published via the Web?  

I believe so.

> Can we encourage royalty free use of published models?

Certainly. This is one thing the OCF is trying to do and is part of the agreement for liaisons where data models are intended to be shared. Some of these have been executed and others are in process.

> Can we decouple application logic from the complexities of the underlying platforms and protocols?

Yes. This is one of the goals of OCF. Admittedly, OCF defines how to do this with OCF. It would be even nicer if there were a more universally accepted way.

---

From: Michel Kohanim <[email-masked]>
Date: Fri, 25 Mar 2016 18:10:23 +0000

Hi Dave,

Our market is smart building/energy management and I totally agree with you.

With kind regards,

  (p) 818.631.0333
  (f)  818.436.0702

From: Dave Raggett [mailto:[email-masked]]
Sent: Friday, March 25, 2016 11:09 AM
To: Michel Kohanim <[email-masked]>
Subject: Re: [Iotsi] interactive vs. programmatic IoT

On 25 Mar 2016, at 15:53, Michel Kohanim <[email-masked]<mailto:[email-masked]>> wrote:

I think our proposal, HATEOAS, and IOTDB all address the last part in one form or another. This said, does the consumer really need to know that it’s dealing with a “light” rather than a generic device that supports on/off/dim/brighten/on level/ramp rate/color, etc.?

What kind of consumer are you talking about?  If it is someone living in a smart home, then they will for the most part not be interested in the technical details, and would be much more interested in what a particular company’s products can offer them for controlling their home.  The user interface offered to the end user would adapt to the devices discovered in the home.   On the other hand an application developer would indeed be interested in the capabilities of particular devices and how these could be exploited to provide an innovative service.

—

---

From: Dave Raggett <[email-masked]>
Date: Fri, 25 Mar 2016 18:11:30 +0000

> On 25 Mar 2016, at 17:39, Clarke Stevens <[email-masked]> wrote:
> 

This is indeed what the W3C hopes to realize with the web of things as an abstraction layer that will work across a wide range of platforms and standards.  

—

---

From: Michael Koster <[email-masked]>
Date: Fri, 25 Mar 2016 11:31:30 -0700

I think this defines a use case for what we are doing: 

"Service providers have royalty-free use of shared information models that provide access to resources hosted in various "ecosystems", where ecosystems include but are not limited to: OCF, ZigBee, Bluetooth, IPSO, OneM2M, Z-Wave and emerging ecosystems like the "native web" thing ecosystem."

What this means is we are not defining a new framework for people to build things to, rather a way forward to model common things that we can all share on a royalty-free basis to promote semantic interoperability across connected things and services.

This, practically by definition, enables application logic to be decoupled from thing specifications.

Michael

> On Mar 25, 2016, at 11:11 AM, Dave Raggett <[email-masked]> wrote:
> 
> 
>> On 25 Mar 2016, at 17:39, Clarke Stevens <[email-masked] <mailto:[email-masked]>> wrote:
>>

---

From: David Janes <[email-masked]>
Date: Mon, 28 Mar 2016 07:29:04 -0400

+1!

On Fri, Mar 25, 2016 at 2:31 PM, Michael Koster <[email-masked]
> wrote:

> "Service providers have royalty-free use of shared information models that
> provide access to resources hosted in various "ecosystems", where
> ecosystems include but are not limited to: OCF, ZigBee, Bluetooth, IPSO,
> OneM2M, Z-Wave and emerging ecosystems like the "native web" thing
> ecosystem."
>
> What this means is we are not defining a new framework for people to build
> things to, rather a way forward to model common things that we can all
> share on a royalty-free basis to promote semantic interoperability across
> connected things and services.
>
> Certainly. This is one thing the OCF is trying to do and is part of the
> agreement for liaisons where data models are intended to be shared. Some of
> these have been executed and others are in process.
>
> Yes. This is one of the goals of OCF. Admittedly, OCF defines how to do
> this with OCF. It would be even nicer if there were a more universally
> accepted way.
>
>
> This is indeed what the W3C hopes to realize with the web of things as an
> abstraction layer that will work across a wide range of platforms and
> standards.
>
> —
>    Dave Raggett <[email-masked]>
>
>
>

---

From: Dave Raggett <[email-masked]>
Date: Tue, 29 Mar 2016 12:22:25 +0100

> On 25 Mar 2016, at 18:31, Michael Koster <[email-masked]> wrote:
> 

If everyone uses different frameworks for representing models, the challenge will be how to map between them. The suggestion is to use RDF as an interlingua as a way to avoid having to define direct mappings of terms between all modelling languages. This means that terms used in modelling languages need to be mapped to RDF URIs. We want to encourage people to use the same URIs for terms with the same meaning.  However, people can define their own URIs if appropriate.

—

---

From: Kerry Lynn <[email-masked]>
Date: Tue, 29 Mar 2016 08:45:00 -0400

On Tue, Mar 29, 2016 at 7:22 AM, Dave Raggett <[email-masked]> wrote:

> If everyone uses different frameworks for representing models, the
> challenge will be how to map between them. The suggestion is to use RDF as
> an interlingua as a way to avoid having to define direct mappings of terms
> between all modelling languages. This means that terms used in modelling
> languages need to be mapped to RDF URIs. We want to encourage people to use
> the same URIs for terms with the same meaning.  However, people can define
> their own URIs if appropriate.
>
> Dave

I think some of us prefer JSON-LD (at least in the higher layer models).
My understanding is
that the mapping to RDF is straightforward, but I have no experience.
What's your opinion?

Kerry

—

---

From: David Janes <[email-masked]>
Date: Tue, 29 Mar 2016 09:01:56 -0400

JSON-LD can be viewed as a serialization of RDF. The JSON-LD people don't
talk this up too much.

On Tue, Mar 29, 2016 at 8:45 AM, Kerry Lynn <[email-masked]> wrote:

>> "Service providers have royalty-free use of shared information models
>> that provide access to resources hosted in various "ecosystems", where
>> What this means is we are not defining a new framework for people to
>> build things to, rather a way forward to model common things that we can
>> all share on a royalty-free basis to promote semantic interoperability
>> across connected things and services.
>>

---

From: Dave Raggett <[email-masked]>
Date: Tue, 29 Mar 2016 15:32:13 +0100

JSON-LD allows web developers to use short names that are bound to RDF URIs in linked context definitions.  

> On 29 Mar 2016, at 13:45, Kerry Lynn <[email-masked]> wrote:
> 
> On Tue, Mar 29, 2016 at 7:22 AM, Dave Raggett <[email-masked] <mailto:[email-masked]>> wrote:
> 
>> On 25 Mar 2016, at 18:31, Michael Koster <[email-masked] <mailto:[email-masked]>> wrote:
>> 
> I think some of us prefer JSON-LD (at least in the higher layer models).  My understanding is
> that the mapping to RDF is straightforward, but I have no experience.  What's your opinion?
> 
> Kerry
> 
> —
> [email-masked] <mailto:[email-masked]>
> https://www.iab.org/mailman/listinfo/iotsi <https://www.iab.org/mailman/listinfo/iotsi>
> 
> 
> [email-masked] <mailto:[email-masked]>
> https://www.iab.org/mailman/listinfo/iotsi <https://www.iab.org/mailman/listinfo/iotsi>
—