Subject: Padding in OHCI!

From: Venkatesh V <[email-masked]>
Date: Thu, 11 Feb 1999 18:17:53 +0530

Hi ,
I have a doubt regarding padding as far as Asynchronous Transmit in OHCI is concerned..

OHCI spec states that for Isochronous transmit, padding is performed by the Host Controller, if required(Rfr . pg 113, sec 9.6 of OHCI). But it refrains from stating the same for Block Asynchronous Transmit (Rfr. Pg 77, sec 7.6 of OHCI)..

Does the software, which prepares the context program, perform this padding as far as Block asynchronous transmit is concerned or does Host controller take care of it?????

Thanx in advance,

Eagerly awaiting a reply,

Venkatesh.

---

From: Diana Klashman - Sun BOS Software <[email-masked]>
Date: Thu, 11 Feb 1999 22:38:38 -0500

Venkatesh,

The Host Controller adds the necessary padding for block AT packets too.

Diana

>Date: Thu, 11 Feb 1999 18:17:53 +0530
>From: Venkatesh V <[email-masked]>
>Subject: Padding in OHCI!
>Comments: To: Intel 1394 <[email-masked]>, DVCent 1394
<[email-masked]>
>To: [email-masked]
>
>Hi ,
>OHCI spec states that for Isochronous transmit, padding is performed by the
Host Controller, if required(Rfr . pg 113, sec 9.6 of OHCI). But it refrains
from stating the same for Block Asynchronous Transmit (Rfr. Pg 77, sec 7.6 of
OHCI)..
>
>Does the software, which prepares the context program, perform this padding as
far as Block asynchronous transmit is concerned or does Host controller take
care of it?????
>Eagerly awaiting a reply,

-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
| Diana Klashman              email: [email-masked] |
| Staff Engineer              phone: (781) 442-0575        |
| Sun Microsystems              fax: (781) 442-1672        |
| 1 Network Drive          mailstop: UBUR03-302            |
| Burlington, MA 01803                                     |
=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-