Subject: Re: WG Last Call on IPv4/1394

From: "Hattig, Myron" <[email-masked]>
Date: Wed, 24 Mar 1999 09:59:55 -0800

Kenji,

Thanks for your diligence! Peter and I talked about the
issue before the draft was published and agreed that you
concern about responding to ARPs from another bus should
be stated. We missed the part about the response. ;-)

In short, I agree the text should change, but not exactly
as you have indicated. I think the text should just state:

"The recipient of an ARP request or response SHALL ignore
it unless the most significant ten bits of the source_ID
field in the GASP header are equal to either 0x3FF or the
most significant ten bits of the recipient's NODE IDS
register".

I don't think we should introduce the term "bridge aware".
If we introduce the term bridge aware, then we would have
to define bridge aware which may have a broader definition
beyond the simple issue that we are concerned with in this paragraph.
Specifically the issue in this paragraph is "do not process
ARP rqst/resp from another bus". The above text addresses the
issue of concern without introducing unrelated issues.

Do you agree?

-myron

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Tuesday, March 23, 1999 6:40 PM
> To: [email-masked]; Hattig, Myron
> Cc: [email-masked]
> Subject: Re: WG Last Call on IPv4/1394
>
>
>
> Hi,
>
> I'm sorry to raise this issue again, but...
>
> draft-14 says, "The recipient of an ARP request SHALL ignore ..."
>                                         =======
> What I said was,
> :  The (bridge unaware) recipient SHALL ignore ARP request
> and response
> :  from remote bus (with different source_bus_ID).
> ====================
>
> If brige-unaware node accepts an ARP response from a brige-aware
> node on the remote bus, it will initiate Async Write transactions
> to the remote bus. It may cause some problems.
>
>       --+-----------Bridge-----------+---
>       node-A                       node-B
>
>       ARP-req ------------------->
>               <------------------- ARP-resp
>
>       node-A  bridge unaware (current node)
>       node-B  bridge aware (future node)
>
> What do you think of?
>
> Best Regards,
>
> Kenji Fujisawa
>

---

From: Kenji Fujisawa <[email-masked]>
Date: Thu, 25 Mar 1999 10:09:00 +0900

>most significant ten bits of the recipient's NODE IDS

        [snip]

>Do you agree?

I agree. Thanks!

Kenji Fujisawa