Subject: Broadcast & multicast

From: "Hattig, Myron" <[email-masked]>
Date: Wed, 28 Feb 2001 09:50:25 -0800

Kenji has another excellent point. How can broadcast & multicast be
supported with a memory mapped model.

-myron

> -----Original Message-----
> From: Kenji Fujisawa [mailto:[email-masked]]
> Sent: Thursday, February 22, 2001 8:08 PM
> To: [email-masked]
> Subject: Re: Last Call: Transmission of IPv6 Packets over IEEE 1394
> Networks to Proposed Standard
>
>
> >I think we should hold off on this. There have been
> considerable problems
> >with the performance of IP1394 in PCs and other OHCI-based
> platforms due to
> >the FIFO-model data transfer (forces an interrupt for each
> received 1394
> >packet). I think we should consider using a direct memory model data
> >transfer in the future (OHCI is optimized for this), and
> IPv6 offers us an
> >opportunity for a changeover.
>
> As we discussed in IP1394 WG at the early stage, we have to negotiate
> the memory address between paticular two nodes to utilize
> memory-model.
> It may be another overhead, and we can not use it for
> broadcast/multicast.
> Although we might have an extension to utilize the
> memory-model in the future,
> I believe we need the FIFO-model as a baseline.
>
> Best Regards,
>
> Kenji Fujisawa
>

---

From: Peter Johansson <[email-masked]>
Date: Wed, 28 Feb 2001 10:48:27 -0800

At 09:50 AM 2/28/01, Hattig, Myron wrote:

>supported with a memory mapped model?

They wouldn't be---a hybrid model would be used. In other words, I have
little quarrel with RFC 2734 as far as it goes; it just doesn't go far enough.

Regards,

Peter Johansson

Congruent Software, Inc.
98 Colorado Avenue
Berkeley, CA  94707

(510) 527-3926
(510) 527-3856 FAX

[email-masked]