Subject: CSR Protocol ID

From: Kenji Fujisawa <[email-masked]>
Date: Fri, 11 May 2001 10:28:22 +0900

http://www.iana.org/assignments/csr-protocol-ids
says as follows,

: 0x00 0001       unit_sw_version                 [RFC2734]

But the word "unit_sw_version" does not indicate a protocol,
it is just another name of the field of the structure.
Other protocol will have another value of "unit_sw_version".

RFC2734 "10. IANA CONSIDERATIONS" says,
: The value one is allocated to this document.
"this document" here is RFC2734 itself.

I think it should be,
 0x00 0001       IPv4 over IEEE1394              [RFC2734]

What do others think?

Kenji Fujisawa

---

From: Peter Johansson <[email-masked]>
Date: Sun, 13 May 2001 13:23:28 -0700

>What do others think?

Kenji, you're absolutely correct. The value of 0x00 0001, preemptively
seized by RFC 2734 prior to IANA's creation of the CSR Protocol ID
registry, should be described as "IPv4 over IEEE 1394" with a reference to
the RFC.

As a footnote, it is unimportant that the values 0x00 0000 and 0xFF FFFF
reference RFC 2734. It is important that the registry capture the fact that
they are reserved FOREVER, NEVER TO BE ALLOCATED.

Regards,

Peter Johansson

Congruent Software, Inc.
98 Colorado Avenue
Berkeley, CA  94707

(510) 527-3926
(510) 527-3856 FAX

[email-masked]