Subject: RE: [ipcdn] Said Type

From: "Ziper, Anna" <[email-masked]>
Date: Thu, 9 Nov 2000 13:57:30 -0800

Rich,

You are right,
if type Integer16 does not exist for MIBS?
It looks like it is enough 16 bits for Said.

thanks, Anna

-----Original Message-----
From: Rich Woundy [mailto:[email-masked]]
Sent: Thursday, November 09, 2000 12:53 PM
To: Ziper, Anna; [email-masked]
Subject: Re: [ipcdn] Said Type

Anna,

I assume your question is in reference to the BPI+ MIB, and to objects that 
use "Integer32" SYNTAX to hold SAID values.

A typical MIB object in the BPI+ MIB is:

docsBpi2CmTEKSAId   OBJECT-TYPE
      SYNTAX         Integer32 (1..16383)
...

The constraint of (1..16383) keeps this MIB object value to 14 bits.

Note that this is actually the same syntax as docsIfCmServiceId (DOCSIS 1.0 
SID) in RFC 2670. The DOCSIS 1.0 SID is also a 14 bit value.

docsIfCmServiceId OBJECT-TYPE
         SYNTAX      Integer32 (1..16383)
...

According to RFC 2578, Integer32 is "indistinguishable from INTEGER, but 
never needs more than 32-bits for a two's complement representation".

I think the MIB object SYNTAX is OK. Do you agree?

-- Rich

At 11:53 AM 11/9/00 -0800, Ziper, Anna wrote:

>Hi,
>
>Why type of Said is 32 bits,
>if it cannot be more than 14 bits?
>
>thank you,
>Anna
>
>_______________________________________________
>IPCDN mailing list
>[email-masked]
>http://www1.ietf.org/mailman/listinfo/ipcdn

_______________________________________________
IPCDN mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/ipcdn

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Thu, 9 Nov 2000 23:27:35 +0100

>>>>> Ziper, Anna writes:

Anna> You are right, if type Integer16 does not exist for MIBS?  It
Anna> looks like it is enough 16 bits for Said.

You can easily define a TEXTUAL-CONVENTION (TC) which introduces an
Integer16. You can also introduce a more specific TCs for a SAID which
has more specific semantics as an Integer16.

I do not really know the context of this MIB, but it looks like you
should consider to introduce TCs for these application specific types.
And it is often also a good idea to introduce pairs of ID types, such
as InterfaceIndex and InterfaceIndexOrZero in the IF-MIB.

[Just ignore this comment if it does not apply here.]

/js

-- 
Juergen Schoenwaelder      Technical University Braunschweig
<[email-masked]>  Dept. Operating Systems & Computer Networks
Phone: +49 531 391 3289    Bueltenweg 74/75, 38106 Braunschweig, Germany
Fax:   +49 531 391 5936    <URL:http://www.ibr.cs.tu-bs.de/~schoenw/>

---

From: Rich Woundy <[email-masked]>
Date: Thu, 09 Nov 2000 20:49:56 -0500

I would let the BPI+ MIB author, and/or the consensus of the working group, 
decide whether such a new textual-convention is necessary for a 
SAID-related object. The BPI+ MIB is not strictly incorrect if it does not 
employ such a textual-convention...

-- Rich