Subject: [ipcdn] Said Type

From: "Ziper, Anna" <[email-masked]>
Date: Thu, 9 Nov 2000 11:53:40 -0800

Hi, 

Why type of Said is 32 bits,
if it cannot be more than 14 bits?

thank you, 
Anna

_______________________________________________
IPCDN mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/ipcdn

---

From: Rich Woundy <[email-masked]>
Date: Thu, 09 Nov 2000 15:52:55 -0500

Anna,

I assume your question is in reference to the BPI+ MIB, and to objects that 
use "Integer32" SYNTAX to hold SAID values.

A typical MIB object in the BPI+ MIB is:

docsBpi2CmTEKSAId   OBJECT-TYPE
      SYNTAX         Integer32 (1..16383)
...

The constraint of (1..16383) keeps this MIB object value to 14 bits.

Note that this is actually the same syntax as docsIfCmServiceId (DOCSIS 1.0 
SID) in RFC 2670. The DOCSIS 1.0 SID is also a 14 bit value.

docsIfCmServiceId OBJECT-TYPE
         SYNTAX      Integer32 (1..16383)
...

According to RFC 2578, Integer32 is "indistinguishable from INTEGER, but 
never needs more than 32-bits for a two's complement representation".

I think the MIB object SYNTAX is OK. Do you agree?

-- Rich