Subject: RE: re: [ipcdn] Signaling MIB - Draft 3 - Last Call - Defaultval ues

From: Beacham Gordon-CGB005 <[email-masked]>
Date: Mon, 16 Feb 2004 16:18:23 -0800

>As NCS Spec does not have any specific reqs for L-package except for ref to GR-506 (appendix A.2 of the NCS Spec), we feel comfortable with the original tComLabs' proposal: "A default value MUST be provided, but it is left up to the implementation to choose a reasonable default." 

My concern is whether the MIB Drs are going to flag this statement as having no value during review. The object, when queried,
is going to return a value whether the statement above is included in the description clause or not.

Suggestions:

1. The MTA MUST provide a default value for this object in accordance with published specifications for the country of operation.

Reference "TR 101 183 Specification."

OR

2. As Mark indicated DEFVAL can be used. Since tComlabs proposed this change, perhaps they could identify the exact DEFVAL clause to be used.

Gordon Beacham
Digital Core Gateways, BCS
Motorola, Inc.
858-404-2335
[email-masked]

_______________________________________________
IPCDN mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipcdn

---

From: "Eugene Nechamkin" <[email-masked]>
Date: Mon, 16 Feb 2004 18:09:01 -0800

#1 - agreed.

#2 - do not agree: it does not seem logical to have single DEFVAL value for the MIB object which has cross-country applicability. 

Eugene Nechamkin.
Broadcom Corp.

ph: (604) 233-8500

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
Beacham Gordon-CGB005
Sent: Monday, February 16, 2004 4:18 PM
To: [email-masked]'
Subject: RE: re: [ipcdn] Signaling MIB - Draft 3 - Last Call -
Defaultval ues

Suggestions:

OR

Gordon Beacham

---

From: "Wijnen, Bert (Bert)" <[email-masked]>
Date: Tue, 17 Feb 2004 11:49:26 +0100

You should check what specifying a DEFVAL in the OBJECT-TYPE
definition means. RFC2578 says:

   7.9.  Mapping of the DEFVAL clause

   The DEFVAL clause, which need not be present, defines an acceptable
   default value which may be used at the discretion of an agent when an
   object instance is created.  That is, the value is a "hint" to
   implementors.

   During conceptual row creation, if an instance of a columnar object
   is not present as one of the operands in the correspondent management
   protocol set operation, then the value of the DEFVAL clause, if
   present, indicates an acceptable default value that an agent might
   use (especially for a read-only object).

There is more text in 2578, but the above should make it clear that it
is at the discretion of the agent if it will use the exact DEFVAL value
speified or not. It is only a "hint". It does help though that in case
of a row-create, that column does nto have to be specified, since the
presence of a DEFVAL clause means that the agent will fill out
an acceptable default value (possibly the one specified).

Hope this helps,
Bert 

> From: Beacham Gordon-CGB005 [mailto:[email-masked]]
> Sent: dinsdag 17 februari 2004 1:18
> To: [email-masked]'
> >As NCS Spec does not have any specific reqs for L-package 
> except for ref to GR-506 (appendix A.2 of the NCS Spec), we 
> feel comfortable with the original tComLabs' proposal: "A 
> default value MUST be provided, but it is left up to the 
> implementation to choose a reasonable default." 
> 
> My concern is whether the MIB Drs are going to flag this 
> statement as having no value during review. The object, when queried,
> is going to return a value whether the statement above is 
> included in the description clause or not.
> 
> Suggestions:
> 
> 1. The MTA MUST provide a default value for this object in 
> accordance with published specifications for the country of operation.
> 
> 2. As Mark indicated DEFVAL can be used. Since tComlabs 
> proposed this change, perhaps they could identify the exact 
> DEFVAL clause to be used.
> 
> Gordon Beacham

---

From: "Kumar, Satish" <[email-masked]>
Date: Wed, 18 Feb 2004 00:32:51 +0530

Country specific MIB defaults has to be defined in description or leave with
"...but it is left up to the implementation to choose a reasonable default"

Satish Kumar
Texas Instruments

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
Eugene Nechamkin
Sent: Tuesday, February 17, 2004 2:09 AM
To: Beacham Gordon-CGB005; [email-masked]
Subject: RE: re: [ipcdn] Signaling MIB - Draft 3 - Last Call -
Defaultval ues

#1 - agreed.

#2 - do not agree: it does not seem logical to have single DEFVAL value for
the MIB object which has cross-country applicability. 

Eugene Nechamkin.
Broadcom Corp.

ph: (604) 233-8500

-----Original Message-----

>As NCS Spec does not have any specific reqs for L-package except for ref to
GR-506 (appendix A.2 of the NCS Spec), we feel comfortable with the original
tComLabs' proposal: "A default value MUST be provided, but it is left up to
the implementation to choose a reasonable default." 

My concern is whether the MIB Drs are going to flag this statement as having
no value during review. The object, when queried,
is going to return a value whether the statement above is included in the
description clause or not.

Suggestions:

1. The MTA MUST provide a default value for this object in accordance with
published specifications for the country of operation.

OR

2. As Mark indicated DEFVAL can be used. Since tComlabs proposed this
change, perhaps they could identify the exact DEFVAL clause to be used.

Gordon Beacham