Subject: RE: [ipcdn] pktcSigDevStandardRingCadence and pktcSigDevRingSplas hCadence are redundant

From: Beacham Gordon-CGB005 <[email-masked]>
Date: Fri, 27 Feb 2004 13:58:37 -0800

Interesting. Thanks for pointing that out. However, I don't follow why the mapping has been made that way in the "Clarification of L Package for Euro-PacketCable Document v6.0 (2004/1/20)."

The objects referenced in 2.19 and 2.21 for the L package rg and rs cadences are in the international group with a max cadence of 13.2s. The other distinctive ring cadences in the above document map to core L package objects r0..r7 with a max cadence of 6.0s. The cadence mapping seems to be inconsistent. I would have expected the 2.19 and 2.21 cadence for rg/rs to be mapped to the pktcSigDevRgCadence and pktcSigDevRsCadence core L package objects. International cadences would then be handled via the E package extensions and associated object (pktcSigDevRingCadenceTable).

Wim,

Can you comment/clarify why the rg/rs cadences are mapped to objects in the international group instead of the pktcSigDevRgCadence and pktcSigDevRsCadence objects? Thanks.

Gordon

-----Original Message-----
From: Eugene Nechamkin [mailto:[email-masked]]
Sent: Wednesday, February 25, 2004 5:21 PM
To: Beacham Gordon-CGB005; [email-masked]
Subject: RE: [ipcdn] pktcSigDevStandardRingCadence and
pktcSigDevRingSplashCadence are redundant

> The pktcSigDevStandardRingCadence and pktcSigDevRingSplashCadence 
> objects are redundant. 
I am not sure I can completely agree with this statement (if I understand it correctly). Both of these objects are required for Euro-L-package, because of the way the RG and RS signalls are currently defined:

For Euro-L-Package: 
   - RG -> pktcSigDevStandardRingCadence
   - RS -> pktcSigDevRingSplashCadence

The "pktcSigDevRingCadenceTable" contains the cadence values for the E-package. Having in mind that E-package is optional, and L-package is mandatory, I am not sure I understand how pktcSigDevStandardRingCadence and pktcSigDevRingSplashCadence can be "merged" into the "pktcSigDevRingCadenceTable".

Or, are you suggesting that "pktcSigDevRingCadenceTable" should contain the RG and RS cadencies for Euro-L-Package along with the values for E-package? If yes, I think the proper mapping of the table indexes to the corresponding signal should be somehow defined, and corresponding modifications of the Euro-L-Package should also be put in place. 

Though from the MIB optimization stand point of view the proposed modification might make sense, however, from the currently imlemented and intended funtionality prospective it looks unnecessary (please correct me if my understanding of your proposal deviates from what you had in mind).

Eugene Nechamkin,
Broadcom Corp.,
ph: (604) 233-8500

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
Beacham Gordon-CGB005
Sent: Wednesday, February 25, 2004 11:01 AM
To: [email-masked]
Subject: [ipcdn] pktcSigDevStandardRingCadence and
pktcSigDevRingSplashCadence are redundant

The pktcSigDevStandardRingCadence and pktcSigDevRingSplashCadence objects are redundant. These objects are recommended to be deleted from the NCS Signaling MIB. The use of separate pktcSigDevStandardRingCadence and pktcSigDevRingSplashCadence objects is a carryover from the L line package and they are not needed in the E line package. Instead, normal ring and ring splash cadences can be defined using the pktcSigDevRingCadenceTable object.

Gordon Beacham
Digital Core Gateways, BCS
Motorola, Inc.
858-404-2335
[email-masked]

_______________________________________________
IPCDN mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipcdn

_______________________________________________
IPCDN mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipcdn

---

From: "Eugene Nechamkin" <[email-masked]>
Date: Fri, 27 Feb 2004 14:13:11 -0800

It's might also be worth noting that the "pktcSigDevRgCadence" and "pktcSigDevRsCadence" on one hand, and "pktcSigDevStandardRingCadence" and "pktcSigDevRingSplashCadence" - on the other have different requirement for the Cadence timing granularity, hence the "pktcSigDevRgCadence" and "pktcSigDevRsCadence" could not have been used to represent Euro-PC Cadence resolution requirement reflected in "pktcSigDevStandardRingCadence" and "pktcSigDevRingSplashCadence".

Eugene.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
Beacham Gordon-CGB005
Sent: Friday, February 27, 2004 1:59 PM
To: 'Wim De Ketelaere'; Eugene Nechamkin; [email-masked]
Subject: RE: [ipcdn] pktcSigDevStandardRingCadence and
pktcSigDevRingSplas hCadence are redundant

Wim,

Gordon

-----Original Message-----
From: Eugene Nechamkin [mailto:[email-masked]]
Sent: Wednesday, February 25, 2004 5:21 PM
To: Beacham Gordon-CGB005; [email-masked]
Subject: RE: [ipcdn] pktcSigDevStandardRingCadence and

For Euro-L-Package: 

Eugene Nechamkin,
Broadcom Corp.,
ph: (604) 233-8500

-----Original Message-----

Gordon Beacham

---

From: Beacham Gordon-CGB005 <[email-masked]>
Date: Fri, 27 Feb 2004 14:45:53 -0800

Exactly. This is precisely what the pktcSigDevRingCadenceTable object is defined to handle (international ring cadences to 13.2s) using the V5.x "cr(x)" mechanism noted in the object description. For example, an international operator could define cr5 for standard ring and cr9 for ring splash, etc for up to 128 international cadences.

V5.x defined 128 possible ring cadences for international ring messages without concern for what those cadences are named. The 101 909-4 spec does not name these cadences either and the name should not be a concern for the MIB definitions.

Gordon

-----Original Message-----
From: Eugene Nechamkin [mailto:[email-masked]]
Sent: Friday, February 27, 2004 2:13 PM
To: Beacham Gordon-CGB005; Wim De Ketelaere; [email-masked]
Subject: RE: [ipcdn] pktcSigDevStandardRingCadence and

Eugene.

-----Original Message-----

Wim,

Gordon

-----Original Message-----
From: Eugene Nechamkin [mailto:[email-masked]]
Sent: Wednesday, February 25, 2004 5:21 PM
To: Beacham Gordon-CGB005; [email-masked]
Subject: RE: [ipcdn] pktcSigDevStandardRingCadence and

For Euro-L-Package: 

Eugene Nechamkin,
Broadcom Corp.,
ph: (604) 233-8500

-----Original Message-----

Gordon Beacham

---

From: "Kumar, Satish" <[email-masked]>
Date: Fri, 27 Feb 2004 16:50:15 -0600

It would be better to mark the MIB with usage like E-Package or L-package.
This avoids possible confusion.

-Satish

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
Beacham Gordon-CGB005
Sent: Friday, February 27, 2004 10:46 PM
To: 'Eugene Nechamkin'; Beacham Gordon-CGB005; Wim De Ketelaere;
[email-masked]
Subject: RE: [ipcdn] pktcSigDevStandardRingCadence and
pktcSigDevRingSplas hCadence are redundant

Gordon

-----Original Message-----
From: Eugene Nechamkin [mailto:[email-masked]]
Sent: Friday, February 27, 2004 2:13 PM
To: Beacham Gordon-CGB005; Wim De Ketelaere; [email-masked]
Subject: RE: [ipcdn] pktcSigDevStandardRingCadence and

Eugene.

-----Original Message-----

Wim,

Gordon

-----Original Message-----
From: Eugene Nechamkin [mailto:[email-masked]]
Sent: Wednesday, February 25, 2004 5:21 PM
To: Beacham Gordon-CGB005; [email-masked]
Subject: RE: [ipcdn] pktcSigDevStandardRingCadence and

For Euro-L-Package: 

Eugene Nechamkin,
Broadcom Corp.,
ph: (604) 233-8500

-----Original Message-----

Gordon Beacham

---

From: "Eugene Nechamkin" <[email-masked]>
Date: Fri, 27 Feb 2004 14:55:16 -0800

As a reminder - "pktcSigDevRingCadenceTable" is currently defined as the holder of all cadence related objects for the E-Package only, so it cannot accommodate the L-package objects unless the definition of the L-Package in the Euro-L-Package Document is properly changed.

Eugene.

-----Original Message-----
From: Beacham Gordon-CGB005 [mailto:[email-masked]]
Sent: Friday, February 27, 2004 2:46 PM
To: Eugene Nechamkin; Beacham Gordon-CGB005; Wim De Ketelaere;
[email-masked]

Gordon

-----Original Message-----
From: Eugene Nechamkin [mailto:[email-masked]]
Sent: Friday, February 27, 2004 2:13 PM
To: Beacham Gordon-CGB005; Wim De Ketelaere; [email-masked]
Subject: RE: [ipcdn] pktcSigDevStandardRingCadence and

Eugene.

-----Original Message-----

Wim,

Gordon

-----Original Message-----
From: Eugene Nechamkin [mailto:[email-masked]]
Sent: Wednesday, February 25, 2004 5:21 PM
To: Beacham Gordon-CGB005; [email-masked]
Subject: RE: [ipcdn] pktcSigDevStandardRingCadence and

For Euro-L-Package: 

Eugene Nechamkin,
Broadcom Corp.,
ph: (604) 233-8500

-----Original Message-----

Gordon Beacham