Subject: RE: [ipcdn] RE: IETF IPCDN Signaling MIB - Draft 3 - Last Call fo r Comments

From: Beacham Gordon-CGB005 <[email-masked]>
Date: Mon, 2 Feb 2004 16:17:54 -0800

The following summarizes the proposed changes to pktcSigDevCodecTable based on the suggestion(s) from David and Eugene:

DELETE THE FOLLOWING:

	--
	-- The codec table (pktcSigDevCodecTable) defines all combinations
	-- of codecs supported by the Multimedia Terminal Adapter (MTA). 
	-- For example, an MTA may support the following codecs and maximum
	-- number of connections for each codec:
	--
	-- Codec Type     Maximum Number of Connections
	--     pcmu                      2
	--     g728                      1
	--
	-- or
	--
	--     pcmu                      1
	--     g728                      1
	--     g729E                     1
	--
	-- Based on this example, the entries in the codec table would be: 
	--
	-- pktcSigDevCodecComboIndex pktcSigDevCodecType pktcSigDevCodecMax
	--             1                      pcmu                2
	--             1                      g728                1
	--             2                      pcmu                1
	--             2                      g728                1
	--             2                      g729E               1
	--

ADD THE FOLLOWING:

	--
	-- The codec table (pktcSigDevCodecTable) defines all possible
	-- combinations of codecs supported for simultaneous operation by the
	-- Multimedia Terminal Adapter (MTA).
	-- 
	-- For example, an MTA with two endpoints may be designed with a
	-- particular DSP and memory architecture that allows it to support
	-- the following fixed combinations of codecs for simultaneous
	-- operation:
	--
   -- Codec Type     Maximum Number of Simultaneous Codec Instantiations
   --
   -- PCMA						    3
   -- 
   -- PCMA						    2
   -- PCMU						    1
   --
   -- PCMA						    1
   -- PCMU						    2
   --
   -- PCMU						    3
   --
   -- PCMA						    1
   -- G729						    1
   --
   -- G729						    2
   --
   -- 1 PCMU						    1
   -- 1 G729						    1
	--
	-- Based on this example, the entries in the codec table would be: 
	--
	-- pktcSigDevCodecComboIndex pktcSigDevCodecType pktcSigDevCodecMax
	--
	--            1                     pcma                3
   --            2                     pcma                2
   --            2                     pcmu                1
   --            3                     pcma                1
   --            3                     pcmu                2
   --            4                     pcmu                3
   --            5                     pcma                1
   --            5                     g729                1
   --            6                     g729                2
   --            7                     pcmu                1
   --            7                     g729                1

REPLACE THE pktcSigDevCodecTable DESCRIPTION WITH THE FOLLOWING:

	pktcSigDevCodecTable OBJECT-TYPE
	    SYNTAX      SEQUENCE OF PktcSigDevCodecEntry 
	    MAX-ACCESS  not-accessible 
	    STATUS      current 
	    DESCRIPTION 
	        " This table describes the MTA supported codec types. An MTA
	          MUST populate this table with all possible combinations of
	          codecs it supports for simultaneous operation. An operator
	          querying this table is able to determine all possible
	          codec combinations the MTA is capable of simultaneously
	          supporting." 
	    ::= { pktcSigDevConfigObjects 1 }

Gordon Beacham
Digital Core Gateways, BCS
Motorola, Inc.
858-404-2335
[email-masked]

_______________________________________________
IPCDN mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipcdn

---

From: "Wijnen, Bert (Bert)" <[email-masked]>
Date: Tue, 3 Feb 2004 13:52:33 +0100

In general, instead of having extensive ASN.1 comment lines, 
I prefer to see the extra information in DESCRIPTION clauses.
That is hwere it belongs (I think).

Thanks,
Bert 

> -----Original Message-----
> From: Beacham Gordon-CGB005 [mailto:[email-masked]]
> Sent: dinsdag 3 februari 2004 1:18
> To: [email-masked]'
> Subject: RE: [ipcdn] RE: IETF IPCDN Signaling MIB - Draft 3 - 
> Last Call
> fo r Comments
> 
> 
> The following summarizes the proposed changes to 
> pktcSigDevCodecTable based on the suggestion(s) from David and Eugene:
> 
> DELETE THE FOLLOWING:
> 
> 	--