Subject: [ipcdn] Comments on draft-ietf-ipcdn-pktc-mtamib-07 during the IETF-64 meeting

From: "Eugene Nechamkin" <[email-masked]>
Date: Mon, 21 Nov 2005 13:39:21 -0800

During the presentation of the draft-ietf-ipcdn-pktc-mtamib-07 at
IETF-64 meeting, there were the following comments made on the presented
material:
 
    - the max length of the "pktcMtaDevRealmOrgName" currently defined
as being 255 does not correspond to the actual number of octets the MIB
object may contain which is calculated as max number of UTF-8 characters
(64) each of which may consist of up to 6 octets.
    - the value of the MIB object should not include the prefix 'O=' in
the Organization Name.
 
The current definition of the "pktcMtaDevRealmOrgName" in the draft-07
is as follows:
 
   pktcMtaDevRealmOrgName  OBJECT-TYPE 
       SYNTAX      SnmpAdminString(SIZE (1..255)) 
       MAX-ACCESS  read-create 
       STATUS      current 
       DESCRIPTION 
           " This object contains the X.500 organization name attribute

             as defined in the subject name of the service provider  
             certificate. The value of the organization name includes 
             the prefix 'O='." 
       REFERENCE 
           " PacketCable Security Specification." 
       ::= { pktcMtaDevRealmEntry 5 } 

To address these two comments, co-authors are proposing the following:
 
1. Add the following to the IMPORTS section of the MTA MIB:
 
    LongUtf8String  
            FROM SYSAPPL-MIB                 -- [RFC2287]
 
2. Modify the definition of the pktcMtaDevRealmOrgName to be the
following:

pktcMtaDevRealmOrgName OBJECT-TYPE 
    SYNTAX LongUtf8String 
         ^^^^^^^^^^^
    MAX-ACCESS read-create 
    STATUS current 
    DESCRIPTION 
        " This object contains the X.500 organization name attribute 
        as defined in the subject name of the service provider 
        X.509 certificate."
    REFERENCE 
        " PacketCable Security Specification." 
    ::= { pktcMtaDevRealmEntry 5 }
 
3. Add the following compliance statement to the MTA MIB compliance
section:
 
    OBJECT pktcMtaDevRealmOrgName
    SYNTAX LongUtf8String (SIZE (1..384))
    DESCRIPTION
        " Compliant devices are only required to support
        pktcMtaDevRealmOrgName values of 64 UTF-8 encoded 
        characters.
        The Organization Name of the X.509 certificate can
        contain up to 64 UTF-8 encoded characters as 
        specified in RFC 2459.
        Given that, in UTF-8, characters are encoded using
        sequences of 1 to 6 octets (RFC 2279), compliant 
        devices must support a maximum size of 384 octets for 
        pktcMtaDevRealmOrgName."

Please feel free to provide comments on proposed modifications.
 
Regards,
 
Eugene Nechamkin.
 
_______________________________________________
IPCDN mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipcdn

---

From: "Woundy, Richard" <[email-masked]>
Date: Mon, 21 Nov 2005 20:47:40 -0500

Eugene,
 
I agree.
 
-- Rich

	-----Original Message-----
	From: [email-masked] [mailto:[email-masked]] On
Behalf Of Eugene Nechamkin
	Sent: Monday, November 21, 2005 4:39 PM
	To: Ipcdn (E-mail)
	Cc: Jean-Francois Mule
	Subject: [ipcdn] Comments on draft-ietf-ipcdn-pktc-mtamib-07
during the IETF-64 meeting

	During the presentation of the draft-ietf-ipcdn-pktc-mtamib-07
at IETF-64 meeting, there were the following comments made on the
presented material:
	 
	    - the max length of the "pktcMtaDevRealmOrgName" currently
defined as being 255 does not correspond to the actual number of octets
the MIB object may contain which is calculated as max number of UTF-8
characters (64) each of which may consist of up to 6 octets.
	    - the value of the MIB object should not include the prefix
'O=' in the Organization Name.
	 
	The current definition of the "pktcMtaDevRealmOrgName" in the
draft-07 is as follows:
	 
	   pktcMtaDevRealmOrgName  OBJECT-TYPE 
	       SYNTAX      SnmpAdminString(SIZE (1..255)) 
	       MAX-ACCESS  read-create 
	       STATUS      current 
	       DESCRIPTION 
	           " This object contains the X.500 organization name
attribute  
	             as defined in the subject name of the service
provider  
	             certificate. The value of the organization name
includes 
	             the prefix 'O='." 
	       REFERENCE 
	           " PacketCable Security Specification." 
	       ::= { pktcMtaDevRealmEntry 5 } 

	 
	To address these two comments, co-authors are proposing the
following:

	    LongUtf8String  

	        " This object contains the X.500 organization name
attribute 
	 
	3. Add the following compliance statement to the MTA MIB
compliance section:

	 
	Regards,
	 
	Eugene Nechamkin.

---

From: "Woundy, Richard" <[email-masked]>
Date: Tue, 22 Nov 2005 09:14:44 -0500

Bert,
 
I agree.
 
But you also may want to update
http://www.ops.ietf.org/mib-common-tcs.html
<http://www.ops.ietf.org/mib-common-tcs.html>  as well. It also refers
to RFC2287 (instead of RFC3629) for the SYSAPPL-MIB. (That's the reason
why I referred to RFC2287 in my IPCDN meeting notes too, which is
something I should correct.)
 
Looking quickly at the rest of the TC webpage, you might also update
INET-ADDRESS-MIB (RFC4001 instead of RFC3291bis) and ENTITY-MIB (RFC4133
instead of RFC2737bis).
 
-- Rich

	-----Original Message-----
	From: [email-masked] [mailto:[email-masked]] On
Behalf Of Wijnen, Bert (Bert)
	Sent: Tuesday, November 22, 2005 9:00 AM
	To: Eugene Nechamkin; Ipcdn (E-mail)
	Cc: Jean-Francois Mule
	Subject: RE: [ipcdn] Comments on draft-ietf-ipcdn-pktc-mtamib-07
during the IETF-64 meeting

	RFC2279 has been obsoleted by RFC3629. So I suggest you refer to
	the newer RFC.
	 
	RFC2459 has been obsoleted by RFC3280. Probably better to refer
to
	the new RFC!?
	 
	Bert

		-----Original Message-----
		From: [email-masked]
[mailto:[email-masked]]On Behalf Of Eugene Nechamkin
		Sent: Monday, November 21, 2005 22:39
		To: Ipcdn (E-mail)
		Cc: Jean-Francois Mule
		Subject: [ipcdn] Comments on
draft-ietf-ipcdn-pktc-mtamib-07 during the IETF-64 meeting

		During the presentation of the
draft-ietf-ipcdn-pktc-mtamib-07 at IETF-64 meeting, there were the
following comments made on the presented material:
		 
		    - the max length of the "pktcMtaDevRealmOrgName"
currently defined as being 255 does not correspond to the actual number
of octets the MIB object may contain which is calculated as max number
of UTF-8 characters (64) each of which may consist of up to 6 octets.
		    - the value of the MIB object should not include the
prefix 'O=' in the Organization Name.
		 
		The current definition of the "pktcMtaDevRealmOrgName"
in the draft-07 is as follows:
		 
		   pktcMtaDevRealmOrgName  OBJECT-TYPE 
		       SYNTAX      SnmpAdminString(SIZE (1..255)) 
		       MAX-ACCESS  read-create 
		       STATUS      current 
		       DESCRIPTION 
		           " This object contains the X.500 organization
name attribute  
		             as defined in the subject name of the
service provider  
		             certificate. The value of the organization
name includes 
		             the prefix 'O='." 
		       REFERENCE 
		           " PacketCable Security Specification." 
		       ::= { pktcMtaDevRealmEntry 5 } 

		 
		To address these two comments, co-authors are proposing
the following:
		 
		1. Add the following to the IMPORTS section of the MTA
MIB:
		 
		    LongUtf8String  
		            FROM SYSAPPL-MIB                 --
[RFC2287]
		 
		2. Modify the definition of the pktcMtaDevRealmOrgName
to be the following:

		        " This object contains the X.500 organization
name attribute 

		    OBJECT pktcMtaDevRealmOrgName
		    SYNTAX LongUtf8String (SIZE (1..384))
		    DESCRIPTION
		        " Compliant devices are only required to support
		        pktcMtaDevRealmOrgName values of 64 UTF-8
encoded 
		        characters.
		        The Organization Name of the X.509 certificate
can
		        contain up to 64 UTF-8 encoded characters as 
		        specified in RFC 2459.
		        Given that, in UTF-8, characters are encoded
using
		        sequences of 1 to 6 octets (RFC 2279), compliant

		        devices must support a maximum size of 384
octets for 
		        pktcMtaDevRealmOrgName."

		Please feel free to provide comments on proposed
modifications.
		 
		Regards,
		 
		Eugene Nechamkin.