Subject: RE: [IPFIX] IPv6 care-of and home address

From: "Schmoll, Carsten" <[email-masked]>
Date: Thu, 30 Nov 2006 15:41:48 +0100

Dear all,

we are currently investigating on a prototype to send
accounted IP flow information in a mobile IPv6 environment.

For reasons of simplicity and speed we usually export the
care-of address (CoA) and the correspondent node's IP
address as sourceIPv6Address and destinationIPv6Address. 

In case of multiple users on one terminal however (or one
user making use of multiple of his identities) we'll have
to capture and export the home address (HoA) too. The HoA
is embedded in an IPv6 extension header of either type
Routing EH (43) or the Destination Options EH (60).

This would result then in a flow record with two IPv6 source
addresses. Even though repetition of the sourceIPv6 address
is legal I would like to propose additional IEs to avoid
ambiguity. These could be:

sourceIPv6CareOfAddress  
sourceIPv6HomeAddress
destinationIPv6CareOfAddress  
destinationIPv6HomeAddress

This would also cover the case where both endpoints of a 
communication are mobile nodes.

What do you think?

Best regards,
Carsten.

> -----Original Message-----
> From: Andrew Johnson [mailto:[email-masked]] 
> Sent: Tuesday, November 07, 2006 11:27 PM
> To: Juergen Quittek
> Cc: Schmoll, Carsten; [email-masked]
> Subject: Re: [IPFIX] IPv6 care-of and home address
> 
> Juergen Quittek wrote:
> > Carsten,
> > 
> > I do understand how these addresses are associated with
> > an interface.  But how do you think are they associated
> > with a certain flow?
> 
> That really depends on the common properties that define
> Carsten's flow.  Perhaps these different properties could
> part of an Option Template Record that provides information
> on an interface.
> 
> However, it seems that "The IPv6 source address in the IP
> packet header" is the wrong element to use these and new
> ones should be requested if there is an application in
> mind.
> 
> 
> regards
> 
> Andrew
> 
> 

_______________________________________________
IPFIX mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipfix

---

From: Andrew Johnson <[email-masked]>
Date: Thu, 30 Nov 2006 15:07:55 +0000

Hi Carsten

The Routing EH and Destination EH have the source and
destination Home Addresses in them, so new new fields
for them make sense.

The Care of Addresses are just from the IPv6 header, so
why do you need new types for them?

regards

Andrew

---

From: Andrew Johnson <[email-masked]>
Date: Thu, 30 Nov 2006 15:07:55 +0000

Hi Carsten

regards

Andrew