Subject: [IPFIX] [Technical Errata Reported] RFC5655 (2030)

From: RFC Errata System <[email-masked]>
Date: Mon, 1 Feb 2010 07:18:17 -0800 (PST)

The following errata report has been submitted for RFC5655,
"Specification of the IP Flow Information Export (IPFIX) File Format".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=5655&eid=2030

--------------------------------------
Type: Technical
Reported by: Andrei Rohau <[email-masked]>

Section: A.5, pg.56

Original Text
-------------
   144: D6 C7 58 BE 44 E6 60 06 4E 78 74 AE 7D 00 00 00

   176:|00 0A 00 50 47 0A B6 E5 00 00 00 01 00 00 00 01
      [^ second message header (length 80 bytes) -->
   192:|01 01 00 0E 00 47 0A B6 B9 47 0C 07 1B 00|01 02
      [^ time window rec -> [ session detail rec ^ -->
   208: 00 1C 00 C0 00 02 1E 0C 00 02 1F 80 01 12 83 84

   224: 0A 47 0A B6 E5 47 0C 07 48 00|01 03 00 18 00 3E
           [ message checksum record ^ -->
   240: 2B 37 08 CE B2 0E 30 11 32 12 4A 5F E3 AD DB 00

   256:|00 0A 05 10 47 0A B6 E5 00 00 00 06 00 00 00 01
      [^ third message header (length 1296 bytes) -->
   272:|01 00 04 E6|47 0A B6 B9 C0 00 02 02 C0 00 02 03
      [^ set hdr ][^ first data rec -->
   288: 80 02 00 50 06 00 00 46 50 00 00 00 41

Corrected Text
--------------
   144: D6 C7 58 BE 44 E6 60 06 4E 78 74 AE 7D 00 00 00

   160:|00 0A 00 50 47 0A B6 E5 00 00 00 01 00 00 00 01
      [^ second message header (length 80 bytes) -->
   176:|01 01 00 0E 00 47 0A B6 B9 47 0C 07 1B 00|01 02
      [^ time window rec -> [ session detail rec ^ -->
   192: 00 1C 00 C0 00 02 1E 0C 00 02 1F 80 01 12 83 84

   208: 0A 47 0A B6 E5 47 0C 07 48 00|01 03 00 18 00 3E
           [ message checksum record ^ -->
   224: 2B 37 08 CE B2 0E 30 11 32 12 4A 5F E3 AD DB 00

   240:|00 0A 05 10 47 0A B6 E5 00 00 00 06 00 00 00 01
      [^ third message header (length 1296 bytes) -->
   256:|01 00 04 E6|47 0A B6 B9 C0 00 02 02 C0 00 02 03
      [^ set hdr ][^ first data rec -->
   272: 80 02 00 50 06 00 00 46 50 00 00 00 41

Notes
-----
Should be pretty obvious as total size of the hex dump is only 285 bytes.

Please note that the whole Figure 10 is supposed to contain 317 bytes!

Instructions:
-------------
This errata is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party (IESG)
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC5655 (draft-ietf-ipfix-file-05)
--------------------------------------
Title               : Specification of the IP Flow Information Export (IPFIX) File Format
Publication Date    : October 2009
Author(s)           : B. Trammell, E. Boschi, L. Mark, T. Zseby, A. Wagner
Category            : PROPOSED STANDARD
Source              : IP Flow Information Export
Area                : Operations and Management
Stream              : IETF
Verifying Party     : IESG

---

From: Brian Trammell <[email-masked]>
Date: Mon, 1 Feb 2010 16:37:39 +0100

Two points on this erratum:

1. Byte offsets in figure 10 are indeed incorrect (160 is skipped in the sequence). Offsets from 176 (the 11th line in the dump) should have 16 subtracted from each offset. The content of the dump is unchanged. 

2. The introductory text has an incorrect byte count, as well, as it was calculated from the final offset; the correct value is 301.

OLD:

   Bringing together the examples above and adding message headers as
   appropriate, a hex dump of the first 317 bytes of the example File
   constructed above would appear as in the annotated Figure 10 below.

NEW:

   Bringing together the examples above and adding message headers as
   appropriate, a hex dump of the first 301 bytes of the example File
   constructed above would appear as in the annotated Figure 10 below.

On Feb 1, 2010, at 4:18 PM, RFC Errata System wrote:

> _______________________________________________
> IPFIX mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ipfix

---

From: Brian Trammell <[email-masked]>
Date: Mon, 1 Feb 2010 17:09:54 +0100

Replace point two as below.

2. The introductory text has an incorrect byte count, as well, as it was calculated from (an apparently older) final offset; the correct value is 285.

OLD:

NEW:

  Bringing together the examples above and adding message headers as
  appropriate, a hex dump of the first 285 bytes of the example File
  constructed above would appear as in the annotated Figure 10 below.

On Feb 1, 2010, at 5:05 PM, Andrei Rohau wrote:

> Brian,
> 
> Considering the section is supposed to provide a complete file example with all the headers added, either hex dump should be amended with missing bytes or the total count further reduced to the 285 bytes presented.
> 
> Please advise.
> 
> Best Regards,
> Andrei
> 
> On Mon, Feb 1, 2010 at 5:37 PM, Brian Trammell <[email-masked]> wrote:

---

From: Andrei Rohau <[email-masked]>
Date: Mon, 1 Feb 2010 18:05:29 +0200

Brian,

Considering the section is supposed to provide a complete file example with
all the headers added, either hex dump should be amended with missing bytes
or the total count further reduced to the 285 bytes presented.

Please advise.

Best Regards,
Andrei

On Mon, Feb 1, 2010 at 5:37 PM, Brian Trammell <[email-masked]>wrote:

> 1. Byte offsets in figure 10 are indeed incorrect (160 is skipped in the
> sequence). Offsets from 176 (the 11th line in the dump) should have 16
> subtracted from each offset. The content of the dump is unchanged.
>
> 2. The introductory text has an incorrect byte count, as well, as it was
> calculated from the final offset; the correct value is 301.
>
> OLD:
>