Subject: RE: IPv6 packets with unspecified source address

From: Richard Draves <[email-masked]>
Date: Wed, 26 Jul 2000 22:25:57 -0700

Another place where packets with an unspecified source address are
legitimately used is with MLD, when you are sending a Report before your
unicast addresses have finished DAD.

I think routers should check for the unspecified source address and not
forward such packets.

The other cases that you outline, I think can probably be left undefined.

Rich

> -----Original Message-----
> From: Jun-ichiro itojun Hagino [mailto:[email-masked]]
> Sent: Wednesday, July 26, 2000 7:45 PM
> To: [email-masked]
> Subject: IPv6 packets with unspecified source address
> 
> 
> 	This is kind of "host/router requirement" question...
> 
> 	IPv6 base specification allows (does not prohibit) use 
> of unspecified
> 	IPv6 address in source address.  The question we have is, how
> 	legitimate it is to use unspecified IPv6 address in 
> source address.
> 
> 	The only use we have in our document is:
> 	- neighbor solicitation with unspecified IPv6 source, for DAD
> 
> 	Please consider the following examples.  Are these 
> examples legal?
> 	- IPv6 ICMPv6 packet with unspecified source address, 
> which is DAD.
> 	  (this one should be legal, since it is documented in RFC2462)
> 
> 	- IPv6 ICMPv6 packet with unspecified source address, 
> which is NOT DAD.
> 
> 	- IPv6 TCP packet with unspecified source address.
> 	  this form of packet can be used to make a DoS attack. 
>  careless
> 	  implementation may create TCP control block with local
> 	  address = mine, and foreign address = unspecified, in 
> state SYN_RCVD.
> 	  this may disable wildcard listening TCP socket from 
> being contacted
> 
> 	- IPv6 UDP packet with unspecified source address.
> 
> 	- other upper layer protocol with unspecified source address.
> 
> 	- mobile-ip6 home address option with unspecified address.
> 
> 	- a router which forwards packets with unspecified 
> source address.
> 	  if we consider that DAD is the only legal use, we 
> should not forward.
> 
> itojun
> --------------------------------------------------------------------
> IETF IPng Working Group Mailing List
> IPng Home Page:                      http://playground.sun.com/ipng
> FTP archive:                      ftp://playground.sun.com/pub/ipng
> Direct all administrative requests to [email-masked]
> --------------------------------------------------------------------
> 
--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: Steve Deering <[email-masked]>
Date: Wed, 26 Jul 2000 22:50:15 -0700

>unicast addresses have finished DAD.

Ah yes, I forgot about that one.  That supports my own suggestions.

>The other cases that you outline, I think can probably be left undefined.

Now why couldn't I be that succinct?

Steve