Subject: RE: New idea for Router Sol/Adv and Mobility - NO new types

From: "Hesham Soliman (ERA)" <[email-masked]>
Date: Tue, 27 Feb 2001 21:13:42 +0100

> > > I suppose another option would be to add a
> > > "request aggregate prefix list" flag bit to
> > > the router solicitation message. Such a flag
> > > bit would be easier to implement in that
> > > it would only impact the part of the stack
> > > that deals with router solicitation/advertisement
> > > processing.
> > >
> > > What do others prefer?
> > 
> > I prefer this new RS type.
> > 
> > If the HA needs to know what home _link_ is in question, in case there
> > are more than one, it can use the destination address of the RS. Thus,
> > one fewer purpose for the home address option.
> > 
> 
> Let me play devil's advocate:
> 
> No new types are required! What we're sending is still a Router
> Solicitation/Advertisement. The fact that it is routed gives us more
> information:
> 
> 1. The TTL of RS is < 255, which tells the HA it is from off-link.
> 2. The HA knows that (1) means it is a mobile node and needs all
> prefixes on the link.
> 
> => I don't think that's a good assumption. There is no need to 
> guess when you can be sure of the purpose of the message.
> 
> 
> It makes more sense to think of these messages as router advertisements
> and solicitations -- that's really what they are, extended to handle
> mobility. If the goal of Mobile IP is to modify/enhance existing
> protocols as little as possible to support mobility, adding message
> types when it's not necessary is the wrong thing to do.
> 
> => I don't think having a new type is wrong. This is a "differentl"
> use of the rtr sol/adv messages and that's what a type means. 
> So I'm not sure that it is worth arguing against it, since it's 
> such a minor addition.
> 
> -- 
> T.J. Kniveton
> NOKIA Research Center
> 
> --------------------------------------------------------------------
> IETF IPng Working Group Mailing List
> IPng Home Page:                      http://playground.sun.com/ipng
> FTP archive:                      ftp://playground.sun.com/pub/ipng
> Direct all administrative requests to [email-masked]
> --------------------------------------------------------------------
--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: "Hesham Soliman (ERA)" <[email-masked]>
Date: Tue, 27 Feb 2001 21:13:42 +0100

---

From: "Hesham Soliman (ERA)" <[email-masked]>
Date: Tue, 27 Feb 2001 21:13:42 +0100