Subject: RE: another renumbering question

From: [email-masked]
Date: Wed, 7 Feb 2001 11:53:37 -0600

I disagree that we can assume any site will have two face DNS.  Thats a bad
assumption.  
/jim

> -----Original Message-----
> From: ext Brian E Carpenter [mailto:[email-masked]]
> Sent: Wednesday,February 07,2001 10:19 AM
> To: Robert Elz
> Cc: Paul Francis; [email-masked]
> Subject: Re: another renumbering question
> 
> 
> Once you *know* that a host has a site local address, the
> address selection draft tells you when to use it.  I've always
> assumed that they would be in the DNS along with global addresses.
> Presumably large sites will be running two-faced DNS anyway, so
> these addresses will never go outside.
> 
>    Brian
> 
> Robert Elz wrote:
> > 
> >     Date:        Tue, 6 Feb 2001 16:24:23 -0800
> >     From:        "Paul Francis" <[email-masked]>
> >     Message-ID:  <006b01c0909c$528dda60$1300a8c0@dellchan>
> > 
> >   | But I can't recall how it is a host decides when 
> another host can be reached
> >   | via a site-local address, nor can I find where I read that text.
> > 
> > This is still one of life's mysteries I think - several ideas have
> > been floated, but nothing yet committed to a draft that I'm 
> aware of.
> > 
> > The include placing the site locals in the DNS, and having clients
> > do a match on the global addresses to see if the site local should
> > refer to the same site (one that finds no attraction to me at all).
> > 
> > And having the client send from its site local addr (so the 
> packet cannot
> > leave the site) to the remote global addr an ICMP saying 
> "tell me your
> > addresses", and receiving a list that includes the site 
> locals for the
> > destination (or receiving an ICMP error indicating an 
> attempt to cross
> > the site boundary with a site local source addr).   (If the 
> source doesn't
> > have, or doesn't want to use, its site local addr, then 
> there's no point
> > doing any of this, may as well just use global addr of the 
> dest a well).
> > This one I like - it adds a small delay in communications 
> the first time
> > a connection is attempted to a new node (only for 
> connections initiated,
> > responses would never do this) but that is bounded by the 
> RTT to the edge
> > of the site, which is usually of the order of a couple of ms.
> > 
> > kre
> > 
> > --------------------------------------------------------------------
> > IETF IPng Working Group Mailing List
> > IPng Home Page:                      http://playground.sun.com/ipng
> > FTP archive:                      ftp://playground.sun.com/pub/ipng
> > Direct all administrative requests to [email-masked]
> > --------------------------------------------------------------------
> --------------------------------------------------------------------
> IETF IPng Working Group Mailing List
> IPng Home Page:                      http://playground.sun.com/ipng
> FTP archive:                      ftp://playground.sun.com/pub/ipng
> Direct all administrative requests to [email-masked]
> --------------------------------------------------------------------
> 
--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 07 Feb 2001 13:30:08 -0600

I didn't mean to say it is required. But I think it is so common these days that
it's fair to regard it as normal for large intranets.

   Brian