Subject: RE: Redirect ICMP and TAHI test?

From: Erik Nordmark <[email-masked]>
Date: Mon, 19 Feb 2001 17:50:05 +0100 (CET)

> You're supposed to accept Redirects even if there is no Destination
> Cache entry...

Where does it say so?

Or stated differently, this is already covered by rfc 2461 stating that
conceptually there is a destination cache entry for
all recently used destination addresses:

      Destination Cache
                   - A set of entries about destinations to which
                     traffic has been sent recently.  The Destination

  Erik

--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: "Richard Draves" <[email-masked]>
Date: Mon, 19 Feb 2001 08:25:44 -0800

> The idea behind the validity test is that a node should only accept
> a redirect from router R1 if the node very recently sent a packet
> to R1 that was for the destination.
> 
> In your implementation do you have something similar to a 
> "destination cache"
> which retains the next hop where you last sent packet?
> Or do you always do a lookup and find the default route(s)?

Rich

---

From: Erik Nordmark <[email-masked]>
Date: Mon, 19 Feb 2001 17:50:05 +0100 (CET)

Where does it say so?

      Destination Cache

  Erik

---

From: OKABE Nobuo <[email-masked]>
Date: Wed, 28 Feb 2001 17:41:49 +0900

I'm examining the subject.

From: Markku Savela <[email-masked]>
Subject: Redirect ICMP and TAHI test?
Date: Mon, 19 Feb 2001 14:38:06 +0200
> In TAHI Neighbor Discovery test 62, it introduces two routers, then
> sends a redirect from "one" of them, and expects the redirect to have
> an effect...

	He reported to me that his problem had come from
	not the tests but elsewhere.

	However, he also pointed out potential bugs of the tests:
		ncStateByRedirect4Nonce.seq
		ncStateByRedirect4Incomplete.seq
		ncStateByRedirect4Reachable.seq
		ncStateByRedirect4Stale.seq
		ncStateByRedirect4Probe.seq

	Those tests assumes that
		- a NUT does not have round-robin fashion
		  in the default router selection.
		- a NUT selects a same router as the default.
		- a NUT selects the router whose RA comes first
		  becomes the default router.

	In other word, some of the assumptions are broken,
	the tests may be failed.

From: "Richard Draves" <[email-masked]>
Subject: RE: Redirect ICMP and TAHI test?
Date: Mon, 19 Feb 2001 08:25:44 -0800
> Yes, the Redirect TAHI tests fail on the MS implementation, for the same
> reason. I think the test is broken.

	I guess that one of the above assumptions is broken
	in the case of MS implementation. This one always
	update the default router when accepting RA.

	I will be able to debug/fix the test
	if I have an implementation that behaves the same.

Thank you for your feedback, again.

--- nobuo