Subject: RE: Question on scopes involving IPv6 addresses

From: [email-masked]
Date: Thu, 8 Mar 2001 09:32:44 -0600

thanks Paul.  OK.  I would not use it to alter the boundaries imposed by
scoped site architecture which is a good set of boundaries.  I may have used
the hammer to avoid 2 faced DNS though.  Seems like now I should not do
that.

/jim

> -----Original Message-----
> From: ext Paul Francis [mailto:[email-masked]]
> Sent: Wednesday,March 07,2001 5:34 PM
> To: [email-masked]; [email-masked]
> Cc: [email-masked]; [email-masked]; [email-masked];
> [email-masked]; [email-masked]
> Subject: Re: Question on scopes involving IPv6 addresses 
> 
> 
> 
> 
> > I interpret the spec completely different than you and 
> discussing it now
> is
> > a waste of both our time and the mail list.  Also this 
> should have nothing
> > to do with link local.
> >
> > Paul can you shed some light on this conversation as Robert 
> and I see your
> > draft solving different problems :  thanks...........
> >
> 
> I don't undestand the first thing about scoped addresses.  Robert's
> interpretation is correct.  All my draft says is that a site 
> can reduce the
> probability of prefix collisions with other sites by 
> unilaterally sticking a
> random number in the "zeros" field.  In no way does it intend 
> to change the
> semantics or handling of the site local address (with the 
> exception that it
> reduces the frequency of renumbering events and/or allows two sites to
> interconnect more easily).
> 
> Having said that, it is a well-known fact that if an IETFian 
> finds a hammer
> lying on the gound, he/she will use it to do almost anything, 
> except perhaps
> hammer nails.  So I suppose there is some danger in making 
> site-locals near
> unique.
> 
> PF
> 
> ps.  Dupont's comments (can't call him Francis, can I...sort 
> of a scoping
> problem) that this is Christian's idea not mine is 100% true.
> 
--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: "Paul Francis" <[email-masked]>
Date: Thu, 8 Mar 2001 09:29:36 -0800

> the hammer to avoid 2 faced DNS though.  Seems like now I should not do

My comment about the hammer was stupid.  What I said about not knowing
anything about scoped addresses is true.  I don't know the issues there, so
I don't know whether trying to take extend near-uniques, or at least read
more into them than I meant, is a good idea or not.

But I do believe that trying to do make site-locals absolutely 100%
guarenteed unique is not practical, so any mechanisms that depend on that
have a big strike against them.

PF