Subject: Re: what is a site?

From: Tomohide Nagashima <[email-masked]>
Date: Wed, 28 Mar 2001 16:52:04 +0900

Hi,

At least, it is clear that "Site" is a set of links. But is the subset of Site 
the Site ? I begin to belive this answer is YES.If else, what do we call that ?
I belive this will be a key of definition of "Site".

I propose definition of "Site" as follows;
I also propose new word "Full-Site".

 (Definition of Site)
 A set of link "S" is a Site <==>
  "N" is a integer set  N = { n | n is integer , 0=< n =< 2^16 }. 
  For the "M" which is subset of N;
  There is a one-to-one projection from S to M.

 (Definition of Full-Site)
 Especially, We call that a Site with M=N is a Full-Site.

I think Full-Site has no reality , but this word is very useful.
Then we will have these theorem,

 (Theorem)
 1. |M| = |S| i.e. the number of M members is equal to the number of S members.
 2. Any subset of Site is Site.
 3. Full-Site is Site

  These are obvious.

Here is a example.

 (Example) There are three links in my network like this;
             Link 1        Link 2          
            -----+----   --+-------
                 |         |
               --+---------+---
                  Link 3

          We select projection as follows,
             Projection = {
                return 0x000a for Link 1
                return 0x000b for Link 2
                return 0x000c for Link 3
             }

          This is off-cause one-to-one projection from "S" to "M".
          M = { 0x000a, 0x000b, 0x000c } is subset of N
 
          So this "my network" is Site.

          If we select subnet ID as follows,
             subnet ID = 0x000a for Link 1
             subnet ID = 0x000b for Link 2
             subnet ID = 0x000c for Link 3

          then we can select Site-Local Address and Global Address as follows,
                       Site-Local         Global
             Link 1    fec0:0:0:a::/64    BLOB:A:L:a::/64
             Link 2    fec0:0:0:b::/64    BLOB:A:L:b::/64
             Link 3    fec0:0:0:c::/64    BLOB:A:L:c::/64
                 (BLOB:A:L::/48 is a prefix from upstream for this site.)

          If we add Link 4 with subnet ID = 0x000d , this new "my network"
          is also Site. We can add link until Site will became Full-Site.

 (Discussion)

 Let's think about following topology.
   [TLA1]      [TLA2]
      |           |
 <Network1>---<Network2>

 1) If administrator of Network1 and 2 regards that both Network1 and 2 should
    be in same Full-Site,
          ~~~~~~~~~~~~~~
    Projection for numbering of Site-Local Address and Aggregatable Global 
    Address for Network1 and Network2 are same projection ID(link_name). 

    Link "s1" in Network1 will be allocated
        fec0:0:0:ID(s1)::/64
          T:L:A1:ID(s1)::/64
    Link "s2" in Network2 will be allocated
        fec0:0:0:ID(s2)::/64
          T:L:A2:ID(s2)::/64
 
    Note that
     It is possible that "s2" will be allocated T:L:A1:ID(s2)::/64.
     It is possible that "s1" and "s2" connect with Site-Local address.

 2) If administrator of Network1 and 2 regards that Network1 and 2 should be
    in different Full-Sites,
       ~~~~~~~~~~~~~~~~~~~~
    Projection for numbering of Site-Local Address and Aggregatable Global 
    Address for Network1 and Network2 are differnt. Let's call 
     the projection which is used in Full-Site of Network1 is ID1(link_name)
     the projection which is used in Full-Site of Network2 is ID2(link_name)

    Link "s1" in Network1 will be allocated
        fec0:0:0:ID1(s1)::/64
          T:L:A1:ID1(s1)::/64
    Link "s2" in Network2 will be allocated
        fec0:0:0:ID2(s2)::/64
          T:L:A2:ID2(s2)::/64
 
    Note that
     It is impossible that "s2" will be allocated T:L:A1:ID1(s2)::/64.
     It is impossible that "s1" and "s2" connect with Site-Local address.

  Which way administrator will select is depends on policy.

  Another way of define "Site" is that we call that only "Full-Site" in 
  previous definition is "Site", and "Site" in previous is like ,,, 
  "Sub-Site". But "Full-Site" in prev is too ideal to use it as usual, 
  I belive we would define that as "Full-Site".

Give me your comment?

----
Tomohide Nagashima
[email-masked]
--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: "Joris Dobbelsteen" <[email-masked]>
Date: Thu, 29 Mar 2001 16:43:03 +0200

>-----Original Message-----
>From: [email-masked]
>[mailto:[email-masked]]On Behalf Of Tomohide Nagashima
>Sent: Wednesday, 28 March 2001 9:52
>To: [email-masked]; [email-masked]; [email-masked];
>[email-masked]
>Cc: [email-masked]
>Subject: Re: what is a site?
>
>
>Hi,
>
>the Site ?

This means that a site can be a part of another site....
At least, if I get this right...
Why would we make a site a part of a site?

You get something like this:

	Company-wide Network
	|- Sites
	   |- Sites
	   |  |- Links
         |  |- Sites
         |     |- ......
	   |- Links

You might benefit from this up to certain extend, but I tends to get a mess
of sites and 'sub'-sites. So what's what at the end? Or for site-local
addressing, who's local to me? You might get strange siturations:
A is in the same site as B and B is in the same site as C, but A isn't (form
his/her point of view) not in the same site as C. (However, C things A is in
the same site).

>I begin to believe this answer is YES.If else, what
>do we call that ?

So a site can be hierarchical and can a site also be a part of two (totally)
different sites?
Wouldn't this get quite messy...
>  "N" is a integer set  N = { n | n is integer , 0=< n =< 2^16 }.
                                                           ~~~~
Why an upper limit?
                     ... N = {n | n is integer, 0=<n }

>  There is a one-to-one projection from S to M.

I got lost here...

> (Example) There are three links in my network like this;

As long as Site-Local addresses are routable over Link 1, 2 and 3, this
would be OK for me...

> 2) If administrator of Network1 and 2 regards that Network1

I would fully agree....

>  I believe we would define that as "Full-Site".

>Give me your comment?

I don't see why we should use 'sub-sites'. From my point, this would be
quite a stupid move to use sub-sites, it can cause networks to get quite
messy. So actually, for me, the definition site, would be enough...

Link, in this case, would be a part that requires only a TTL value of 1.
This link-local is possible by sending a message with a TTL of 1.

>[email-masked]

- Joris