Subject: RE: PPP and Global Addresses

From: BINET David FTRD/DMI/CAE <[email-masked]>
Date: Fri, 15 Feb 2002 11:15:54 +0100

I did not attend the IPng meeting in May 2001 in Redmond and in the minutes
I do not see the reasons why DHCPv6 protocol is not appropriate for router
prefix delegation.
For several contexts, I think that we need some protocols or some extensions
to make the prefix router delegation possible, and as it has been proposed
by Ole, the new DHCP options can fit the needs. 
So, what are the reasons why DHCPv6 is not appropriate for such use ?

Thanks
David Binet  

-----Message d'origine-----
De : Ole Troan [mailto:[email-masked]]
Envoye : jeudi 14 fevrier 2002 20:34
A : Francis Dupont
Cc : Lilian Fernandes; [email-masked]; [email-masked]
Objet : Re: PPP and Global Addresses

>  In your previous mail you wrote:
>
>    >
http://playground.sun.com/pub/ipng/html/minutes/ipng-meeting-may2001.txt
>    > (search for Dialup Architecture, note this is my last attempt to find
>    > an usefulness to DHCPv6 :-).
>    
>    we're just about to suggest a couple of new DHCPv6 options for this
>    purpose.
>    
> => you may but don't forget the vote was 0 (zero) in favour of DHCPv6
> and at least Steve Deering is publicly strongly opposed to use DHCPv6
> for router configuration.

I'll let Steve speak for himself.

it turns out that router to router prefix delegation has a number of
conceptual similarities with statefull address assignment. instead of
making a new protocol evolve into DHCP under a different name, I
suggest we reconsider the use of DHCP.

/ot
--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: NOISETTE Yoann FTRD/DMI/CAE <[email-masked]>
Date: Fri, 15 Feb 2002 11:16:09 +0100

"PD (Automatic Prefix Delegation)" doesn't specify any means to set the
prefix pool the routers rely on for delegation, apart from a manual setting.
The DHCPv6 option could be used in this aim, and would be therefore
complementary to PD...
Moreover PD also deals with routing protocol negocation, and does then more
than just prefix delegation... This point is interesting in so far as the
reachability of the subnet(s) corresponding to the delegated prefix must be
achieved in a way or another...

Yoann

-----Message d'origine-----
De : Yamasaki Toshi [mailto:[email-masked]]
Envoyé : jeudi 14 février 2002 04:52
À : Lilian Fernandes; [email-masked]
Cc : [email-masked]
Objet : Re: PPP and Global Addresses

"PD (Automatic Prefix Delegation)" is one of the choices.

draft-haberman-ipngwg-auto-prefix-01.txt
http://search.ietf.org/internet-drafts/draft-haberman-ipngwg-auto-prefix-01.
txt

To solve all the configuration issues with DHCPv6 might be another good
choice, but I guess PD be a minimum requirement for those who want an
automatic prefix delegation mechanism for (for example) IPv6 access
services,  and DHCPv6 would be an option for those who want more.

---Toshi Yamasaki / NTT Communications

> Hi,
>
> I have a question about RFC2472 - "IP Version 6 over PPP". The RFC talks
> about the negotiation of the Interface-Identifier and specifies the
> Interface-Identifier Configuration Option. In this case the upper 64 bits
> are just fe80::
>
> It does not mention if there is any standard way to configure a
> global/site-local prefix on a point-to-point link i.e. are there
> configuration options to let one side tell the other about a global
> prefix?
>
> Or is it just left upto the users at both ends to decide on a prefix
> somehow and then configure it on each end?
>
> I'm sorry if there is an RFC about this that I missed...
>
> Thanks,
> Lilian
>
> _____________________________________________________________________
>
> Lilian Fernandes
> AIX TCP/IP Development - IBM Austin
> Tel: 512-838-7966 Fax: 512-838-3509
>
>

---

From: BINET David FTRD/DMI/CAE <[email-masked]>
Date: Fri, 15 Feb 2002 10:08:27 +0100

Thanks
David Binet  

-----Message d'origine-----
De : Ole Troan [mailto:[email-masked]]
Envoye : jeudi 14 fevrier 2002 20:34
A : Francis Dupont
Cc : Lilian Fernandes; [email-masked]; [email-masked]
Objet : Re: PPP and Global Addresses

/ot