Subject: I-D ACTION:draft-savola-ipv6-127-prefixlen-00.txt (fwd)

From: Pekka Savola <[email-masked]>
Date: Fri, 8 Feb 2002 22:50:30 +0200 (EET)

These issues have also come up in the addr/prefix discussion; the issue 
was originally discussed in November.

What do others think -- is this something worth noting?

-- 
Pekka Savola                 "Tell me of difficulties surmounted,
Netcore Oy                   not those you stumble over and fall"
Systems. Networks. Security.  -- Robert Jordan: A Crown of Swords

---------- Forwarded message ----------
Date: Tue, 05 Feb 2002 09:51:31 -0500
From: [email-masked]
To: IETF-Announce:  ;
Cc: [email-masked]
Subject: I-D ACTION:draft-savola-ipv6-127-prefixlen-00.txt

A New Internet-Draft is available from the on-line Internet-Drafts directories.

	Title		: Note about the Use of IPv6 /127 Prefix Length
	Author(s)	: P. Savola
	Filename	: draft-savola-ipv6-127-prefixlen-00.txt
	Pages		: 3
	Date		: 04-Feb-02
	
In some cases, the operational decision may be to use IPv6 /127
prefix lengths, especially on point-to-point links.  Under certain
situations, this may lead to one router claiming both addresses due
to subnet-router anycast being implemented.  This draft discusses the
issue and offers a couple of solutions to the problem.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-savola-ipv6-127-prefixlen-00.txt

To remove yourself from the IETF Announcement list, send a message to 
ietf-announce-request with the word unsubscribe in the body of the message.

Internet-Drafts are also available by anonymous FTP. Login with the username
"anonymous" and a password of your e-mail address. After logging in,
type "cd internet-drafts" and then
	"get draft-savola-ipv6-127-prefixlen-00.txt".

A list of Internet-Drafts directories can be found in
http://www.ietf.org/shadow.html 
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

Internet-Drafts can also be obtained by e-mail.

Send a message to:
	[email-masked].
In the body type:
	"FILE /internet-drafts/draft-savola-ipv6-127-prefixlen-00.txt".
	
NOTE:	The mail server at ietf.org can return the document in
	MIME-encoded form by using the "mpack" utility.  To use this
	feature, insert the command "ENCODING mime" before the "FILE"
	command.  To decode the response(s), you will need "munpack" or
	a MIME-compliant mail reader.  Different MIME-compliant mail readers
	exhibit different behavior, especially when dealing with
	"multipart" MIME messages (i.e. documents which have been split
	up into multiple messages), so check your local documentation on
	how to manipulate these messages.

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: Dan Lanciani <[email-masked]>
Date: Mon, 11 Feb 2002 20:37:33 -0500 (EST)

"Michel Py" <[email-masked]> wrote:

[much snipped]

|and I still fail to see a valid reason to subnet
|a /64 when one should have used a /48 and subnet using the SLA
|bits.

An obvious reason would be that the one who wishes to subnet the /64
is not the same one who should have used a /48, with the former one
having little control over the latter one.

				Dan Lanciani
				[email-masked]

---

From: "SESVOLD, DALE" <[email-masked]>
Date: Wed, 13 Feb 2002 07:11:24 -0600

This has been going on for quite and while.  And I keep asking myself --
Why not /60 for dialups?

Its on a nice nibble and gives a good handfull of subnets for the SOHO.

Dale Sesvold
Senior Engineer
MacAulay-Brown, Inc

-----Original Message-----
From: Dan Lanciani [mailto:[email-masked]] 
Sent: Monday, February 11, 2002 7:38 PM
To: [email-masked]
Subject: RE: I-D ACTION:draft-savola-ipv6-127-prefixlen-00.txt (fwd)

[much snipped]

|and I still fail to see a valid reason to subnet
|a /64 when one should have used a /48 and subnet using the SLA bits.

An obvious reason would be that the one who wishes to subnet the /64 is
not the same one who should have used a /48, with the former one having
little control over the latter one.

				Dan Lanciani
				[email-masked]

---

From: Dan Lanciani <[email-masked]>
Date: Tue, 12 Feb 2002 19:27:06 -0500 (EST)

Michel Py" <[email-masked]> wrote:

|> Dan Lanciani wrote:
|> An obvious reason would be that the one who wishes to subnet
|> the /64 is not the same one who should have used a /48, with
|> the former one having little control over the latter one.
|
|A dial-up connection gets a /48.....

It's not clear how you can make (let alone enforce) that generalization.
Consider multiple dial-up connections to a system whose connection to its
upstream provider is itself a dial-up connection.  Your definition is
self-contradictory in such a case.  You can't hand out multiple /48s if
all you have is one.

				Dan Lanciani
				ddl@danlan.*com