Subject: Ipv6 Arp

From: "Digambar Rasal" <[email-masked]>
Date: Wed, 13 Feb 2002 14:38:51 +0530

Hi,

We have presently a system in which we are using IPv4 and now  we are implementating IPv6 . But the problem i have come across is how we are going to change the ARP process. I mean can we use ARP with new 16 byte ipaddresses or we have to use some other process for address resolution?

Regards
Digambar

---

From: Pekka Savola <[email-masked]>
Date: Wed, 20 Feb 2002 23:20:49 +0200 (EET)

On Wed, 13 Feb 2002, Digambar Rasal wrote:
> We have presently a system in which we are using IPv4 and now we are
> implementating IPv6 . But the problem i have come across is how we are
> going to change the ARP process. I mean can we use ARP with new 16 byte
> ipaddresses or we have to use some other process for address resolution?

The core features of ARP are integrated in ICMPv6 protocol.  See RFC 2461.

-- 
Pekka Savola                 "Tell me of difficulties surmounted,
Netcore Oy                   not those you stumble over and fall"
Systems. Networks. Security.  -- Robert Jordan: A Crown of Swords

--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: Lilian Fernandes <[email-masked]>
Date: Wed, 20 Feb 2002 15:23:58 -0600 (CST)

IPV6 defines the Neighbor Discovery process to do this. See RFC2461.

Lilian

> We have presently a system in which we are using IPv4 and now  we are implementating IPv6 . But the problem i have come across is how we are going to change the ARP process. I mean can we use ARP w…

_____________________________________________________________________

Lilian Fernandes
AIX TCP/IP Development - IBM Austin
Tel: 512-838-7966	Fax: 512-838-3509