Subject: RE: Should IP Security be Optional? [Was RE:draft-ietf-ipv6-cellu lar-host-00.txt -> wg last call?]

From: [email-masked]
Date: Mon, 4 Mar 2002 10:20:33 -0000

> Therefore we feel that on size- and power-constrained
> devices one should select the implemented security
> mechanisms based on the requirements of the applications
> rather than a general rule. The general rules aren't
> very good if in the end the application RFC you were running
> would demand something else than the general rule, or if
> the deployment at the other end was something else.

This seems to presume that you can predict in advance all of the
applications that a user will wish to execute on a particular node. Can you
do that?

Also, please note well that the 'deployment at the other end' won't be
'something else' if we get IPsec in every IPv6 node. I thought that was the
whole point....

Regards,
Mat.
--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: Jari Arkko <[email-masked]>
Date: Mon, 04 Mar 2002 12:31:40 +0200

> applications that a user will wish to execute on a particular node. Can you

On a workstation you can't. On a tiny cellular device you
often can.

> 'something else' if we get IPsec in every IPv6 node. I thought that was the

Well, the other end could still require TLS if the RFC-for-app-X
required that. Regardless of what other RFC states something about
security at IP layer...

Jari

---

From: Keith Moore <[email-masked]>
Date: Mon, 04 Mar 2002 09:38:02 -0500

> On a workstation you can't. On a tiny cellular device you

only if the device doesn't have a data port.

Keith