Subject: RE: poposed changes to the scoping architecture draft

From: "Richard Draves" <[email-masked]>
Date: Wed, 20 Mar 2002 11:01:02 -0800

>    > Btw. what is the scope level of address "::"?  = 0?
>    
>    Hmm, good question.  I personally think "::" can be treated as a
>    global scope with regards to the scope architecture, 
> because it does
>    not cause ambiguity about the "zone".  And, in fact, our current
>    implementation treats "::" as a global address for 
> convenience, and it
>    works without anomaly.

I think the loopback address should be link-local scope (on a virtual
loopback link). It is obviously not global scope, since it does not
uniquely specify an interface.

Note that draft-ietf-ipv6-default-addr-select-07.txt section 2.4 also
refers to this issue.

Rich
--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: "Glenn Morrow"<[email-masked]>
Date: Wed, 20 Mar 2002 14:29:12 -0600

Yes,

I agree, this probably is the wrong ID to make the note in. I'll see if
such a note is in the current revision of the MIPv6 draft. That should be
sufficient.

> -----Original Message-----
> From: Francis Dupont [mailto:[email-masked]]
> Sent: Wednesday, March 20, 2002 10:48 AM
> To: JINMEI Tatuya / ????
> Cc: Morrow, Glenn [RICH2:C330:EXCH]; [email-masked]
> Subject: Re: poposed changes to the scoping architecture draft 
> 
> 
>  In your previous mail you wrote:
> 
>    >>>>> On Tue, 19 Mar 2002 22:53:22 -0600, 
>    >>>>> "Glenn Morrow" <[email-masked]> said:
>    
>    > Maybe I'm just paranoid but does anyone think that it 
> should be recommended
>    > that integrity protection of some sort be done when a 
> mobile uses a site
>    > local address as source when a packet is tunneled to the 
> home site?
>    
>    This can be an issue, but this is the case for all type of 
> tunneling,
>    that is, this is not specific to mobile IPv6.  At this 
> moment I don't
>    think we need an additional note on this issue, but if many other
>    people want to note this issue explicitly, I think we can 
> add a short
>    note in the Security Considerations section.
>    
> => I agree. In fact I can't see a reason to recommend 
> integrity protection
> only when the source is site-local (i.e tunnel == external).
> 
> Regards
> 
> [email-masked]
>