Subject: RE: PPP and Global Addresses

From: "Bound, Jim" <[email-masked]>
Date: Mon, 11 Mar 2002 12:49:59 -0500

Toshi-san,

> Jim and all,
> 
> > Differentiate the need for an Intranet vs an Internet.
> > Most DHC is deployed on Intranets.  Ralph has responded to you and I
> > concur.
> 
> I guess we are talking about "what is the best for ISP-to-Customer
> (PE-to-CPE) prefix delegation", correct?

I believe solving this one first is wise.  Then we can do what happens at leafs if required but my bias is that once we get a prefix to the edge router to a network then router renumbering should be used to propogate prefixes to routers.  I also believe dhcpv6 servers should have routing interface to hear the router renumbering prefix announcements for use for the stateful address configuration of nodes. I do not believe that a coporate Intranet will use all stateless for a very long time.  It will be mixed dhcpv6 and stateless.  For the home user it should be stateless but that does not mean that dhcpv6 cannot be used at the PE.  At least that is where I am at today.

> 
> Then, there seems three proposals shown below for this 
> purpose. What is your
> opinion for each proposed mechanism?

OK.  But I want to apply these to real deployment and can't do that on first read.  So my responses at this point are an architectural view not an implementation view which I will have by the IETF meeting I hope.

> 
> (APD) draft-haberman-ipngwg-auto-prefix-02.txt

This could be useful for LINK or Subnet Prefix delegation but not useful to give prefixes across multiple subnets or lets say more than one link as it relys on ND.  It could be useful also for Pt-to-Pt links as your slides below depict.

> (DHCPv6+PD option) draft-troan-dhcpv6-opt-prefix-delegation-00.txt

At this time in my view this is the most robust and most thought out draft of all of them.  It also permits the use of giving the router additional parameters with future extensions to this draft.  It also works across multiple links or over a network.

This work also permits one to transition the way the addresses are given to CPE via xDSL at the DSLAM points of entry to the ISP-PE.  The DHCPv6 server can perform many useful funcitons at the DSLAM location to kick-start IPv6 into the broadband market.  I will stop there but can go into great detail.   It also can be useful in a 3G (PP or P2) environment working in conjunction with AAA and HSS systems for location and authorization services.

The bottom line is stateless is fine on a link but not across a network IMO.

> (RA+PD option) draft-lutchann-ipv6-delegate-option-00.txt

I think some of the features and methods of this draft should be merged with APD.

So I can see having two approaches to solve the link or off line situations.  But the DHCP6+PD is more robust and can be used in all situations.  APD+RA+PD is the lightweight solution.

> 
> I believe everyone here agrees that zero-configuration 
> environment is very
> important for the deployment of IPv6, because we know IPv6 
> should realize an
> world where not only technical people but also much more non-technical
> people can enjoy the global address and always-on environment.

I agree.  But do so with a pragmatic view.

> 
> To achieve zero-configuration for "ISP-to-Customer (PE-to-CPE) prefix
> delegation", we had better have a global consensus about 
> which mechanism is
> minimally required for this purpose. Many mechnisms for the 
> same purpose
> will make it difficult to achieve zero-configuration 
> enviroment, because CPE
> should know which to use before runnning an 
> auto-configuration protocol
> among many choices.

I agree but I believe we can have a stateless and stateful solution for different needs.

> 
> My opinion is:
> 
> (APD) a good choice for a minimamlly required protocol for 
> prefix delegation

I concur.

> (DHCPv6+PD option) for those who want to more auto-configured 
> parameters
> other than site-prefix

I concur.

> (RA+PD option) can be used at only P-to-P enviroment and it is too
> restrictive

Yes but merge its attributes with APD is my suggestion to the authors.

> 
> P.S.
> 
> Here is an ppt presentation about the "temporally" conclusion of IPv6
> engineers mostly in Japan about this issue.
> http://www.apnic.net/meetings/13/sigs/docs/4.3_OSG_UNI.ppt
> It's a little old because there were no DHCPv6 nor RA 
> proposals for prefix
> delegation when we discussed, but comments and opinions are 
> very welcome.

This was very very good presentation.  I wish I had the time to do this for my work in the IETF in working groups it makes assumptions and ideas obvious.  Thank You.

Regards,
/jim

> 
> ---Toshi Yamasaki / NTT Communications
> 
> 
--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: "Yamasaki Toshi" <[email-masked]>
Date: Tue, 12 Mar 2002 19:08:48 +0900

Jim-san,

Thank you for your thoughtful opinions and advices. Again, I believe this
"ISP-to-Customer site-configuration" is one of the most urgent issues for
the WG, because no non-technical customers can join to IPv6 world unless we
provide any solution. This positive discussion will help us to solve the
issue.

> > purpose. What is your opinion for each proposed mechanism?
>
> OK.  But I want to apply these to real deployment and can't do that on
first read.  So my responses at this point are an architectural view not an
implementation view which I will have by the IETF meeting I hope.

Understand. FYI, some ISPs will (or want to) start IPv6/DSL services
hopefully in 2002, and we will see some working-in-commercial-services
implementations soon.

> So I can see having two approaches to solve the link or off line
situations.  But the DHCP6+PD is more robust and can be used in all
situations.  APD+RA+PD is the lightweight solution.

I agree with your opinion that APD is the minimally required lightweight
solution and DHCPv6 is the "FULL-SERVICE" solution.
It's not clear to me how you think the RA+PD proposal be merged into APD.
Could you kindly explain the details?

> I agree but I believe we can have a stateless and stateful solution for
different needs.

Absolutely.

--- Toshi Yamasaki / NTT Communications

---

From: Ole Troan <[email-masked]>
Date: Tue, 12 Mar 2002 14:33:50 +0000

Jim and all,

[...]

>> To achieve zero-configuration for "ISP-to-Customer (PE-to-CPE)
>> prefix delegation", we had better have a global consensus about
>> which mechanism is minimally required for this purpose. Many
>> mechnisms for the same purpose will make it difficult to achieve
>> zero-configuration enviroment, because CPE should know which to use
>> before runnning an auto-configuration protocol among many choices.
>

I think prefix delegation is inherently stateful. both DHCP PD and
ICMP PD are as such stateful protocols. that is, the delegating party
has to keep track of which prefixes are assigned where.

if anyone disagrees, please explain where the statelessness comes into
the picture.

/ot