Subject: RE: Applicability of draft-ietf-ipv6-cellular-host-00.txt

From: Phil Roberts <[email-masked]>
Date: Tue, 5 Mar 2002 12:54:07 -0500

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] 
> Sent: Tuesday, March 05, 2002 12:42 PM
> To: [email-masked]; [email-masked]
> Cc: [email-masked]
> Subject: RE: Applicability of draft-ietf-ipv6-cellular-host-00.txt
> 
> 
> Hi Phil,
>
> There will be many different types of devices, some will 
> support downloadable code, some will not.  Currently, I don't 
> know if the majority will be one sort or another.  Some folks 
> will want bells & wistles, some won't.  I prefer to turn java 
> off when I 
> browse the net ...

I agree.  But my uncle, who was the first person I knew to have a cellphone
doesn't know what java is, much less how to turn it off.

> > 
> > Hmmm (again).  I guess I'm wondering what is to prevent the 
> terminal 
> > from having a router in it.  3gpp has agreed to update the spec to 
> > assign a prefix, no?  What's to keep someone from running routing 
> > protocols over the link?
> 
> Again, we have never said that this won't happen, there are 
> then quite a few additional issues to be tackled.  We're 
> seperating the two functionalities.  For example, I don't
> think a general host requirement document should address 
> routing either.

I agree with that.  But I was just curious why you thought you couldn't
attach a router on the mobile device end of a GTP pipe?

> John
--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: "James Kempf" <[email-masked]>
Date: Tue, 5 Mar 2002 10:23:14 -0800

John,

I think some 90% of the new cellphones, even low end, now have Java on
them. Carriers like it.
But the last spec I saw for the Java MidP (the Java profile that runs on
a cell phone) did not have
a way to open a socket. You could only go through a URL. That may have
changed. So I think it is
likely that most cellphones will have Java on them, but it is not clear
whether they will be programmable to use IP at the
level most people do on other IP capable devices.

            jak

----- Original Message -----
From: "Phil Roberts" <[email-masked]>
To: <[email-masked]>; "Phil Roberts" <[email-masked]>;
<[email-masked]>
Cc: <[email-masked]>
Sent: Tuesday, March 05, 2002 9:54 AM
Subject: RE: Applicability of draft-ietf-ipv6-cellular-host-00.txt