Subject: Re: Should IP Security be Optional?[Was RE:draft-ietf-ipv6-cellu lar-host-00.txt -> wg last call?]

From: Keith Moore <[email-masked]>
Date: Mon, 04 Mar 2002 21:17:23 -0500

> > > > This seems to presume that you can predict in advance all of the
> > > > applications that a user will wish to execute on a particular node. Can you
> > > > do that?
> > >
> > > On a workstation you can't. On a tiny cellular device you
> > > often can.
> 
> > only if the device doesn't have a data port.
> 
> Actually then (especially in 3GPP devices) the IP stack will actually also 
> be behind that dataport, i.e. in the laptop. That is then a different story.

true enough.  but then you need the phone to act like an IPv6 router.

(it might be sufficient to have the phone act like a network interface -
if the network behind it provides a router and ND/RD etc. work normally)

Keith
--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: [email-masked]
Date: Mon, 4 Mar 2002 17:39:59 -0800

> only if the device doesn't have a data port.

Actually then (especially in 3GPP devices) the IP stack will actually also be behind that dataport, i.e. in the laptop. That is then a different story.

-Jonne.

--------
Jonne Soininen
Nokia

Tel. +1 650 864 6794
Cellular: +1 650 714 7733
Email: [email-masked]