Subject: RE: IPv6 working group agenda for Minneapolis IETF

From: "Bernie Volz (EUD)" <[email-masked]>
Date: Mon, 18 Mar 2002 11:08:16 -0600

So, change Ralph's text to SHOULD instead of MUST. The current text reads "should" and not "SHOULD". 

-----Original Message-----
From: Pekka Savola [mailto:[email-masked]]
Sent: Monday, March 18, 2002 12:02 PM
To: Ralph Droms
Cc: IPng List
Subject: Re: IPv6 working group agenda for Minneapolis IETF

On Mon, 18 Mar 2002, Ralph Droms wrote:
> So, RFC 2462 only uses RFC 2119 keywords to describe the behavior of a host 
> when the value of the 'O' flag remains unchanged.  The text in section 
> 5.5.3 needs to be updated to:
> 
>     If the value of OtherConfigFlag changes from FALSE to
>     TRUE, the host MUST invoke the stateful autoconfiguration
>     protocol [...]
> 
>     If the value of the OtherConfigFlag changes from TRUE
>     to FALSE, the host SHOULD continue running the stateful
>     address autoconfiguration protocol [...]

Strongly disagree.  This would make about every IPv6 implementation not
supporting stateful protocols non-compliant.

In my view 'O' is just a hint to the nodes that thay should try to use a 
stateful mechanism (as there is one in the specific network), if they have 
one.

-- 
Pekka Savola                 "Tell me of difficulties surmounted,
Netcore Oy                   not those you stumble over and fall"
Systems. Networks. Security.  -- Robert Jordan: A Crown of Swords

--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: Pekka Savola <[email-masked]>
Date: Mon, 18 Mar 2002 19:12:54 +0200 (EET)

> reads "should" and not "SHOULD".

With SHOULD I agree only if there's further specification like:

   If the value of OtherConfigFlag changes from FALSE to
   TRUE, the host SHOULD invoke the stateful autoconfiguration
   protocol, if one is available, [...]

.. I wouldn't make the support of stateful protocols even a SHOULD, but if 
there _is_ a supported stateful protocol, invoking it can be a SHOULD.