Subject: RE: Making Autoconfig Optional [Was RE: draft-ietf-ipv6-cellular-host-00.txt -> wg last call?]

From: [email-masked]
Date: Tue, 5 Mar 2002 11:23:02 +0200

Hi Markku,

> > This leads me to think that IPv6 MUST support either stateless or
> > stateful, but stateless is not mandatory.  
> 
> This seems quite warped, as stateless is much simpler than stateful
> (at least with PPP6, which can negotiate ID part). And probably every
> existing IPv6 stack has stateless supported, and stateful is an option
> that is supposed to be DHCP6, which nobody has...

OK, I'm just asking for clarification.  Sorting out what is required
and what is not required is actually rather difficult.  Believe me,
it took a lot of time to try to determine what are actually required
RFCs, what are optional, what are good to use, etc.

thanks,
John
--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: "Bound, Jim" <[email-masked]>
Date: Wed, 6 Mar 2002 11:59:36 -0500

Magaret,

We can't mandate stateless or anything for early implementation
deployment for 3G handsets its too much work.  I predict the winners
will have path to 2462 but the first step is make IPv6 work in the IMN
system.  To do that MAY is being used by the authors.

MAY in this context is not the same MAY we use for a spec like 2462.

The objective is to get this as guideline to 3G and its fine.  

I think your giving to much weight to the standard for real deployment
for handsets that are mostly not going to be e2e IPv6 for UMTS anyway.

Again for the 802.11 deployment that won't work.

And based on this conversation I will make sure they don't come here if
I can to discuss their IPv6 deployment requirements we will just ship
the product and deploy.

/jim

> -----Original Message-----
> From: Margaret Wasserman [mailto:[email-masked]]
> Sent: Monday, March 04, 2002 3:28 AM
> To: Hesham Soliman (ERA)
> Cc: [email-masked]; [email-masked]
> Subject: Making Autoconfig Optional [Was RE:
> draft-ietf-ipv6-cellular-host-00.txt -> wg last call?]
> 
> 
> 
> And the last issue that I raised in my message:
> 
> >   >          - Making IPv6 autoconfiguration optional on 
> hosts (rather
> >   >                  than mandatory on hosts and turned 
> on/off for the
> >   >                  link in router advertisements)
> >
> >=> You mean 2462 shoud be a SHOULD/MUST? 
> >That's possible for the generic cellular case, but for 3GPP, 
> >since there is a separate 'autoconfig' mechanism, 
> >this RFC is not needed. Would a SHOULD/MUST for the 
> >general case, and a 'not needed' for 3GPP 
> >be satisfactory?
> 
> My understanding is that the 3GPP group is actually migrating towards
> a more standard IPv6 configuration mechanism, using router 
> advertisements
> and allowing hosts to generate their own interface IDs.
> 
> Currently the cellular hosts draft says:
> 
> "IPv6 Stateless Address Autoconfiguration [RFC-2462] MAY be 
> supported."
> 
> However, I think that RFC 2462 should be a MUST for all IPv6 nodes.
> 
> There are probably other technical issues in the current draft that
> should be discussed, I've just listed what I consider to be the most
> pressing issues.
> 
> Margaret
> 
> 
> 
>      
>

---

From: "Bound, Jim" <[email-masked]>
Date: Wed, 6 Mar 2002 12:41:33 -0500

HP has DHCPv6.
/jim

> From: Markku Savela [mailto:[email-masked]]
> Sent: Tuesday, March 05, 2002 4:21 AM
> To: [email-masked]
> Cc: [email-masked]; [email-masked];
> [email-masked]; [email-masked]
> Subject: Re: Making Autoconfig Optional [Was RE:
> > X-Authentication-Warning: sunroof.eng.sun.com: majordomo 
> set sender to [email-masked] using -f
> > From: [email-masked]
> >