Subject: RE: Should IP Security be Optional? [Was RE: draft-ietf-ipv6-cel lular-host-00.txt -> wg last call?]

From: "Hesham Soliman (ERA)" <[email-masked]>
Date: Thu, 7 Mar 2002 19:31:30 +0100

But when you need IPsec, you
  > need it - and that you happen to be using a cellular link for some
  > particular communications is irrelevant.   

=> Hmm. That's a pretty big statement. If someone
decides to use IPsec for VoIP (an extreme example
I know) then is it still irrelevant whether
you are on a cellualr link or not?
I think it will, very quickly, become relevant
when you get your phone bill!

So the point is, and Jari has already highlighted
that, you have to be careful what kind of security
you use for what functions

Cheers,
Hesham

Whether to use IPsec or
  > not will depend upon the particular communications at any particular
  > instant, and needs to be able to be determined by the user 
  > - certainly
  > never by the implementor, who has no idea what environment 
  > (which includes
  > the remote end of communications) the equipment will be used in.
  > 
  > kre
  > 
  > --------------------------------------------------------------------
  > IETF IPng Working Group Mailing List
  > IPng Home Page:                      http://playground.sun.com/ipng
  > FTP archive:                      ftp://playground.sun.com/pub/ipng
  > Direct all administrative requests to [email-masked]
  > --------------------------------------------------------------------
  > 
--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: [email-masked]
Date: Fri, 8 Mar 2002 10:44:11 +0200

Hesham & Robert,

> you use for what functions

In summary, are we all saying: IPsec is manditory
to implement & optional to use?  I don't know if that
is anything new.  I do think we have tried to capture
in our document some pros & cons with regards to security
usage.

John