Subject: RE: poposed changes to the scoping architecture draft

From: "Glenn Morrow"<[email-masked]>
Date: Tue, 19 Mar 2002 22:53:22 -0600

Maybe I'm just paranoid but does anyone think that it should be recommended
that integrity protection of some sort be done when a mobile uses a site
local address as source when a packet is tunneled to the home site?

Regards,

Glenn

> -----Original Message-----
> From: Francis Dupont [mailto:[email-masked]]
> Sent: Tuesday, March 19, 2002 4:21 PM
> To: JINMEI Tatuya / ????
> Cc: [email-masked]
> Subject: Re: poposed changes to the scoping architecture draft 
> 
> 
>  In your previous mail you wrote:
> 
>    1. revise the mobility section to clarify issues about using
>       site-local addresses with mobile IPv6:
> 
> => I disagree with your solution because it takes more than a few line
> to describe it (:-).
> IMHO site-local addresses in a mobile IPv6 work well if only a
> bidirectional tunnel is used between the mobile and its home agent.
> Note there should be no penalty because by definition communications
> in the same site are local, so the only difference with routing
> optimization is the encapsulaion overhead.
> Another important point is an equivalent way to describe this solution
> is to say the bidirectional tunnel belongs to the home site.
> 
>      + thus, we recommend to use global home/care-of 
> addresses *whenever
>        possible*.
> 
> => I agree because this avoids to have a bi-sited node.
> (no further comment about multi-site support in some IPv6 stacks :-).
>    
>    2. revise the textual representation section 
> 
> => I agree if you still allow names (not ambiguous and mapped to
> the pair type/id in a local config file).
>    
> Regards
> 
> [email-masked]
> --------------------------------------------------------------------
> IETF IPng Working Group Mailing List
> IPng Home Page:                      http://playground.sun.com/ipng
> FTP archive:                      ftp://playground.sun.com/pub/ipng
> Direct all administrative requests to [email-masked]
> --------------------------------------------------------------------
>

---

From: JINMEI Tatuya / 神明達哉<[email-masked]>
Date: Wed, 20 Mar 2002 16:28:57 +0900

>>>>> On Tue, 19 Mar 2002 22:53:22 -0600, 
>>>>> "Glenn Morrow" <[email-masked]> said:

> local address as source when a packet is tunneled to the home site?

This can be an issue, but this is the case for all type of tunneling,
that is, this is not specific to mobile IPv6.  At this moment I don't
think we need an additional note on this issue, but if many other
people want to note this issue explicitly, I think we can add a short
note in the Security Considerations section.

					JINMEI, Tatuya
					Communication Platform Lab.
					Corporate R&D Center, Toshiba Corp.
					[email-masked]
--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: Francis Dupont <[email-masked]>
Date: Wed, 20 Mar 2002 17:47:34 +0100

=> I agree. In fact I can't see a reason to recommend integrity protection
only when the source is site-local (i.e tunnel == external).

Regards