Subject: Updating draft-ietf-ipv6-cellular-host-00.txt?

From: Margaret Wasserman <[email-masked]>
Date: Tue, 05 Mar 2002 10:45:31 -0500

Before folks go and do a lot of additional work to update
draft-ietf-ipv6-cellular-host-00.txt based on our discussions,
I think we have to answer a fundamental question:

Should the WG publish an informational RFC detailing the IPv6
requirements for cellular hosts?

If so, how can we prevent the two most likely bad outcomes:

	- 3GPP (or other) folks thinking that this document
		is an IETF standard?  [May be handled by
		a strongly worded disclaimer in the document?]
	- Everyone with an agenda attempting to publish a
		similar document for their "special"
		category of IPv6 host?  [Can we just say 'no'?]

I also think that we should start work on two standards-track 
documents, both of which would use the current draft as 
input:

	- An "IPv6 over <foo>" document for 3GPP links.
	- A general "IPv6 Node Requirements" document.

Margaret

--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: Brian Haberman <[email-masked]>
Date: Tue, 05 Mar 2002 11:17:26 -0500

Margaret,

> requirements for cellular hosts?

I don't think we should.  It just starts us down that slippery slope
of creating new "foo hosts" requirements docs.  Your following
arguments are reason enough to avoid this path.

>         - A general "IPv6 Node Requirements" document.

Definitely agree with this.

Brian

---

From: "Tony Hain" <[email-masked]>
Date: Tue, 5 Mar 2002 09:29:40 -0800

> 	- A general "IPv6 Node Requirements" document.

Thank you Margaret. You have made the point much more concisely than I
did, and translating this doc into IPv6 over foo is exactly what needs
to happen.

Tony

---

From: "Jari Arkko" <[email-masked]>
Date: Tue, 5 Mar 2002 20:04:00 +0200

Margaret,

> - A general "IPv6 Node Requirements" document.

I would very much like to have e.g. the general
node requirements document, and your approach
of splitting into two documents looks very clean. I have
already in the past announced my interest on working on
the general host document, so I would like to see it
happen, as soon as possible.

However, I do have a concern. Or at least
some issues, but perhaps you can suggest
how to deal with them. I think most of
us agree that a host requirements document is
something that we should have and is a necessary
one. If we had a general document I'm pretty sure
there'd be no need for any specific XXX host
requirements documents. Now, my concern is this:
how long do you think producing the general document
to an RFC will take? What should we say in the
meantime to folks who want to deploy IPv6 now?
If there are decisions as to what to do with ND/DAD/whatever,
should those be made by (a) IPv6 WG, (b) 3GPP, or (c)
vendors?

Jari

---

From: "Charles E. Perkins" <[email-masked]>
Date: Tue, 05 Mar 2002 10:33:25 -0800

> meantime to folks who want to deploy IPv6 now?

What if we make some revision to "draft-ietf-ipv6-cellular-host",
and run that as Informational?  Then we could have IPv6 Host
Requirements later on the standards track.  We could even
have a later IPv6-over-3GPP standards track document which
would obsolete the Informational document, if desirable.
Or, would that be IPv6-over-3.75G?

> should those be made by (a) IPv6 WG, (b) 3GPP, or (c)

Each of these groups will make decisions.  However, I think that
the IPv6 working group should have the responsibility to
determine protocol behavior for a general IPv6 node.
Clearly, in general, an IPv6 node has to be able to run
these protocols.  But there are times when the node should
be allowed to attach to a link without using them.

As an example, in the Mobile IPv6 working group, we have a
document that enables a mobile node to attach to a new link
without running DAD.  This is done only after assurance is
received, that no other node at the new point of attachment
could possibly have a conflicting address with the mobile
node.  A more general statement could be something like:
    "An IPv6 node MUST run DAD unless it already has assurance
     that there is no possible address conflict."
with some more wordsmithing.  One way to satisfy this would
be to have DAD run by some proxy agent -- again, the Mobile
IPv6 home agent has this responsibility at times.  Also,
note that in this case the mobile node is still presumed to
be able to run DAD, it just does not have always do DAD.

If all this has been said before, please just chalk it up
to my inability to keep up with enough mail lately.

Regards,
Charlie P.

---

From: Margaret Wasserman <[email-masked]>
Date: Tue, 05 Mar 2002 16:31:46 -0500

Hi Jari,

>I think most of
>requirements documents. 

I hope that we do have agreement about this.  Are
there others who disagree?

>Now, my concern is this:

This is a very good question... 

One answer is that I think that we could produce an "IPv6
over 3GPP PDP Contexts" document fairly quickly.  This 
document could address several of the issues raised in your 
document.

It _will_ take a while for the IPv6 WG to reach consensus 
on the minimal requirements for an IPv6 node.  

IMHO, reaching real consensus on these requirements will 
take a similar amount of time, whether we do it as part 
of a standards-based "node requirements" effort, or whether 
we do it for an informational "cellular host requirements"
document.  I don't believe that limiting the discussion
to "cellular hosts" will substantially reduce the amount
of effort, as cellular hosts span the spectrum from
low-end cell phones to high-end laptops.

I do not support publishing an informational document 
quickly that does not actually represent the consensus of 
the IPv6 WG regarding what the minimal requirements for an
IPv6 host actually are...  I think that such a document
could do more harm than good.

Margaret

---

From: Erik Nordmark <[email-masked]>
Date: Tue, 5 Mar 2002 23:12:36 +0100 (CET)

> 	- A general "IPv6 Node Requirements" document.

I think the above two documents make a lot of sense.

I wonder if there is utility in having a third document; 
an informational and non-prescriptive
document (i.e. no MUST, SHOULD, MAY language) which is more like a
document roadmap plus issues for hosts of category X (where X is a rather
narrowly defined subset of the 3g/cellular host).

For instance, listing the set of documents that implementors need to take
into account seems quite useful.

Also, discussing tradeoffs of what optional things to implement also sounds 
useful. And talking about how things fit together i.e. the relationship between
IPsec/IKE vs. TLS also sounds like useful information to implementors. But
"discussing issues" and not having any normative MUST, SHOULD, MAY language.

  Erik

---

From: Erik Nordmark <[email-masked]>
Date: Tue, 5 Mar 2002 23:09:02 +0100 (CET)

> should those be made by (a) IPv6 WG, (b) 3GPP, or (c)

Jari,

I think the ND/DAD type issues can be dealt with by the IPv6 over foo
document which should be a lot quicker to produce than the host requirements
document.

  Erik

---

From: Margaret Wasserman <[email-masked]>
Date: Tue, 05 Mar 2002 18:39:35 -0500

>should those be made by (a) IPv6 WG, (b) 3GPP, or (c)

This is a valid concern...

Many of the issues that are raised in your document
could be handled in an "IPv6 over 3GPP PDP Contexts" 
document.  I think that we should be able to produce
that document fairly quickly, probably quicker than
we will reach consensus on any requirements document,
even your informational one.

Margaret

---

From: Jari Arkko <[email-masked]>
Date: Wed, 06 Mar 2002 07:08:57 +0200

> document which should be a lot quicker to produce than the host requirements

True, but I guess I was more worried about the "whatever" part.
Looking at typical IPv6 over Foo documents, I would say ND, DAD,
PPP, and RFC 3041 issues fit those documents well. But what about
the rest?

Jari

---

From: NAKAJIMA Nobuyasu <[email-masked]>
Date: Thu, 07 Mar 2002 20:56:16 -0500 (EST)

Hello,

> 	- A general "IPv6 Node Requirements" document.

I think some documents or at least descriptions of requirements for
   - exemption from performing DAD
   - exemption from the exchange of packets related to ND or NUD
  (- any others?)
are also useful, for possible upcoming "IPv6 over <something>"
documents.

I am personally interested in DAD issue in particular, and I would
like general requirements for not performing DAD.

Regards
---
Nobuyasu Nakajima
Toshiba America Research, Inc.