Subject: RE: Making Autoconfig Optional [Was RE: draft-ietf-ipv6-cellular- host-00.txt -> wg last call?]

From: [email-masked]
Date: Wed, 6 Mar 2002 13:37:09 +0200

Hi Margaret,

> We should also update some of the base IPv6 specs to expect that
> certain portions of IPv6 behaviour (i.e. whether or not to use
> DAD) will be dependent on the link type, and defined in the
> "IPv6 over <foo>" documents for each link type.  Of course, we 
> then have to define this behaviour for each of the link types 
> that we've already specified (ethernet, PPP, etc.).
> 
> None of this is rocket science, but it will require some updates
> to existing standards currently at DS.  Is this something that
> we want to do at this point?

I think we should & we must. To be more specific, optimizations that
do not cause interoperability problems are extremely useful.  Updating
documents to reflect current reality is important.

Its a dirty job, but ...

John
--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: "Bound, Jim" <[email-masked]>
Date: Wed, 6 Mar 2002 12:16:00 -0500

Agree.  But they need not "use" ...is better than "do".
/jim

> -----Original Message-----
> From: Karim El-Malki (ERA) [mailto:[email-masked]]
> Sent: Monday, March 04, 2002 5:34 AM
> To: 'Francis Dupont'
> Cc: 'Margaret Wasserman'; Hesham Soliman (ERA); 
> [email-masked];
> [email-masked]
> Subject: RE: Making Autoconfig Optional [Was RE:
> draft-ietf-ipv6-cellular- host-00.txt -> wg last call?] 
> 
> 
>  > A way to solve your DAD/autoconf issue is to "delegate" the 
>  > /64 prefix
>  > and to keep only link-local addresses using link-layer negociated
>  > interface IDs (negociation is very simple and just checks 
>  > the interface
>  > IDs of the both ends are different). The link has to be 
>  > point-to-point
>  > but this is the only constraint (you can even use PPP if 
> you'd like).
> 
> That's exactly what we've pointed to in the 3gpp-advice draft and
> this is what 3GPP is following. Currently PPP is used. So I think we
> agree that 3gpp hosts need not do DAD, which explains the cellular
> hosts requirement.
> 
> /Karim

---

From: "Bound, Jim" <[email-masked]>
Date: Wed, 6 Mar 2002 12:19:26 -0500

Francis,

This is just an addendum to and for DAD.  It does not alter 2462 which
we should not do at this point for product and deployment reasons.

/jim

> From: Francis Dupont [mailto:[email-masked]]
> Sent: Monday, March 04, 2002 5:58 AM
> To: Karim El-Malki (ERA)
> Subject: Re: Making Autoconfig Optional [Was RE:
>  In your previous mail you wrote:
> 
>     > but this is the only constraint (you can even use PPP 
> if you'd like).
>    
> => so we agree. The only problem is we have to find a way to explain
> that in a standard track document and to get rough consensus not only
> for the idea but also for the way to specify it. I don't know
> if the agenda is already closed (it should not): does someone ask
> for a short slot in the next meeting agenda?
> 
> Regards
> 
> [email-masked]
> 
> PS: I'd like to get this (DAD considerations) for PPP in general.