Subject: RE: Dual stack routers

From: "Bound, Jim" <[email-masked]>
Date: Tue, 19 Mar 2002 02:32:09 -0500

Its really up to the engineering team for that implementation.  I would integrate v4 and v6 and duplicate as little as possible.  At least all data structures so the algorithm for update/replace/delete was the same function module and not duplicated once for tcp and once for udp and yet again for SCTP.  Then there is the emerging RDMA the router might want to use for storage.  Treating all addresses as 16bytes (v4 and v6) works and will perform.  Also all the traffic shaping, classification, et al on hardware would make the hardware engineers job a lot easier and thats a performance win too to support both address types.

regards,
/jim

> -----Original Message-----
> From: Murugan KAT [mailto:[email-masked]]
> Sent: Tuesday, March 19, 2002 2:15 AM
> To: 'IPng List'
> Subject: Dual stack routers
> 
> 
> 
> 
> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Murugan KAT
> Sent: Tuesday, 19 March 2002 12:07 AM
> To: 'IPng List'
> Subject: RE: Requirements for 'O' flag (was Re: IPv6 working group
> agendafor Minneapolis IETF)
> 
> 
> Hi,
> 
> Regarding Dual Stack Router implementation should a router maintain 2
> routing tables, one for V4 and other for V6. What about the 
> routing stacks?
> Should there be 2 instances of a routing protocol (BGP, OSPF etc.,) ?
> 
> What is the general approach?
> 
> 
> Thanks,
> KAT
> 
> 
> --------------------------------------------------------------------
> IETF IPng Working Group Mailing List
> IPng Home Page:                      http://playground.sun.com/ipng
> FTP archive:                      ftp://playground.sun.com/pub/ipng
> Direct all administrative requests to [email-masked]
> --------------------------------------------------------------------
> 
> --------------------------------------------------------------------
> IETF IPng Working Group Mailing List
> IPng Home Page:                      http://playground.sun.com/ipng
> FTP archive:                      ftp://playground.sun.com/pub/ipng
> Direct all administrative requests to [email-masked]
> --------------------------------------------------------------------
> 
--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: Brian Haberman <[email-masked]>
Date: Tue, 19 Mar 2002 08:21:42 -0500

Jim,
     I agree with your assessment.  It is essentially the way I have
integrated IPv6 into an IPv4 system.  One point to keep in mind though
is how to support site-scoped addresses in this model.  The route table
needs expansion in order to incorporate the zone IDs in the lookup.

Regards,
Brian