Subject: RE: Should DAD be optional? [Wasdraft-ietf-ipv6-cellular-host-00. txt -> wg last call?]

From: "Karim El-Malki (ERA)" <[email-masked]>
Date: Thu, 7 Mar 2002 13:28:18 +0100

I'd prefer dealing with what we have now first since I'd
like to see v6 deployed in 3g in the near term. 
We could discuss for a long time on how to improve a certain
cellular system and we probably all have our ideas
but that discussion would not belong here.

Regarding the DAD issue, it's the same thing that
can be done on any PPP link between a host and a router
with prefix delegation. DAD can be disabled there,
so no point of saying it can't be done in a cellular system
that is the same as that PPP link from the IPv6 point of view.

/Karim

 > -----Original Message-----
 > From: Charles E. Perkins [mailto:[email-masked]]
 > Sent: den 6 mars 2002 22:38
 > To: Karim El-Malki (ERA)
 > Cc: [email-masked]
 > Subject: Re: Should DAD be optional?
 > [Wasdraft-ietf-ipv6-cellular-host-00.txt -> wg last call?]
 > 
 > 
 > Hello Karim,
 > 
 > "Karim El-Malki (ERA)" wrote:
 > 
 > > I agree that it would be good to see some guidelines in an
 > > informational doc. However I disagree on the title change to
 > > IPv6 over cellular/3g. That is a different spec which we should
 > > also work on.
 > 
 > It is possible to design "cellular" systems where the
 > 3GPP/PDP address assignment is completely replaced by
 > localized, stateless methods.  The way that addresses
 > are assigned is not related to bandwidth, nor even to
 > essential authorization issues.  It's an artifact of
 > near-compatibility with existing 2.5G layouts.  GGSN
 > does not NECESSARILY need to control this process.
 > 
 > Thus, any document which recommends that DAD or Neighbor
 > Discovery might be executed rarely if ever, would not fit
 > such "cellular" systems as I would hope eventually do
 > come about.
 > 
 > Regards,
 > Charlie P.
 > 
--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: "Charles E. Perkins" <[email-masked]>
Date: Thu, 07 Mar 2002 09:13:33 -0800

Hello Karim,

I have no problem with the words in your note, but then you
have to rename the draft to be "IPv6-over-nearterm-3G", or
better, "IPv6-over-3GPPr5-PDP".  That gets the point across.

If it's "IPv6-over-cellular", then you have to write
the specification to apply to ALL cellular systems, current
and future.  That was the point in my note you quoted.

Regards,
Charlie P.