Subject: RE: Should DAD be optional? [Was draft-ietf-ipv6-cellular-host-00.txt -> wg last call?]

From: "Bound, Jim" <[email-masked]>
Date: Wed, 6 Mar 2002 14:41:59 -0500

Hi Keith,

No argument from me.  Your right.  But not all reqs are needed for all
devices. I do not believe for the current time-to-market needs of
vendors or users for cellular hosts has time to mess around here either.
I also don't think given all the protocol work we have to do that
documenting in our community what is and not needed for each device is a
high priority in fact because of your mail on our list of work or all
the specs the IESG has to read and parse.  Not saying it would not be
nice just two things:  one its not a priority to me, and two: the
authors spec for cellular hosts has time-to-market for IPv6 deployment
and no way are we or can we meet those needs (like right now) and they
should go to the public sector and publish this.

UNLESS: We go back to what informational means as Charlie and I believe
as it used to be?

I doubt that is possible.

/jim

> -----Original Message-----
> From: Keith Moore [mailto:[email-masked]]
> Sent: Wednesday, March 06, 2002 2:04 PM
> To: Bound, Jim
> Cc: Margaret Wasserman; Hesham Soliman (ERA); [email-masked]
> Subject: Re: Should DAD be optional? [Was
> draft-ietf-ipv6-cellular-host-00.txt -> wg last call?] 
> 
> 
> > The IETF specs are not like laws where they can really be enforced. 
> 
> I think most of us understand this already.  However, the IETF specs
> do establish widely-held assumptions for what is needed to allow
> products to interoperate.  Vendors who ship products that 
> violate those
> specs are risking that their products will not harm interoperability.
> Customers can hold those vendors liable for violating the 
> specifications,
> especially if they don't bother to document the violations 
> and/or problems 
> that result.  Admittedly this doesn't happen as often as it should.
> 
> Within IETF, the best we can do is to produce clear 
> guidelines for what
> is expected.  The harm that will result if the expectations 
> are violated 
> is not always possible to document in advance.  Just look at the level
> of denial that's still occuring about the harm that NATs cause.
> 
> Keith
> 
--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: "Charles E. Perkins" <[email-masked]>
Date: Wed, 06 Mar 2002 12:01:00 -0800

> I doubt that is possible.

Well, it's worth a shot, and the draft could include enough
text to make it obvious what is meant.  That would only make
a difference to people who bother to even glance at the document,
but anybody implementing the platform would be likely to see it,
and any marketing literature would probably not risk the black
eye of provably misconstruing the document.

Regards,
Charlie P.

---

From: Margaret Wasserman <[email-masked]>
Date: Wed, 06 Mar 2002 15:58:58 -0500

I'd be amenable some sort of "guidelines" document that offers
some guidance to 3GPP vendors on which portions of which IPv6
specifications should be implemented in cellular hosts.  With
the following characteristics:

         - The document should clearly state that it is not
                 a standard, and that it doesn't modify any
                 other standards.  I know that "informational"
                 status implies this, but I think it should
                 be explicit in the document.
         - The MUST, MAY, SHOULD... wording should be removed.
         - All conflicts with existing IPv6 standards should be
                 eliminated.
         - The document should be re-worked to focus more on
                 referring cellular implementers to the correct
                 IPv6 standards.
         - We should not recommend anything that we don't 
                 agree with -- for instance, if we think that
                 IP Sec should be included in all IPv6 hosts,
                 this document shouldn't say otherwise.

Margaret

---

From: "Charles E. Perkins" <[email-masked]>
Date: Wed, 06 Mar 2002 13:17:52 -0800

Hello Margaret,

Your proposal works very well for me.

I might suggest that the normative capitalization could
be changed to lower-case, along with an explanation that
the reason for doing so is to prevent the informational
recommendations from being construed as IETF IPv6 mandates.

I would also like the title to be changed to
"IPv6-over-3GPP-PDP", since I would like to eventually
see 3++G systems look a lot more like what we're used
to, instead of so many point-to-point tunnels.

Regards,
Charlie P.

---

From: Jari Arkko <[email-masked]>
Date: Thu, 07 Mar 2002 10:56:07 +0200

Margaret Wasserman wrote:

> specifications should be implemented in cellular hosts.

Interestingly, that was roughly in line what we were *trying* to
do. Could discuss exact title but still...

>          - All conflicts with existing IPv6 standards should be

This is almost right, but I would still allow for the *possibility*
that the WG now thinks something even if when it published something
else earlier. Conditional on WG consensus on the particular issue of
course, and there should be an explicit description in the document
that explains why there is a discrepancy.

>                  this document shouldn't say otherwise.

Again, this seems pretty obvious and has been our intent all
along. Naturally we have put some proposals on the table on
various recommendations as a starting point and presented our
reasoning, but like the work in all IETF WGs, the WG gets to
decide. And I see a lot of good discussion on the various
recommendations, so I'm hopeful some concensus will appear
on them.

Jari