Subject: RE: Updating draft-ietf-ipv6-cellular-host-00.txt?

From: Phil Roberts <[email-masked]>
Date: Tue, 5 Mar 2002 11:22:51 -0500

> 
> I don't think we should.  It just starts us down that 
> slippery slope of creating new "foo hosts" requirements docs. 
>  Your following arguments are reason enough to avoid this path.

Agree we shouldn't.

> 
> > 
> > If so, how can we prevent the two most likely bad outcomes:
> > 
> >         - 3GPP (or other) folks thinking that this document
> >                 is an IETF standard?  [May be handled by
> >                 a strongly worded disclaimer in the document?]
> >         - Everyone with an agenda attempting to publish a
> >                 similar document for their "special"
> >                 category of IPv6 host?  [Can we just say 'no'?]
> > 
> > I also think that we should start work on two standards-track 
> > documents, both of which would use the current draft as
> > input:
> > 
> >         - An "IPv6 over <foo>" document for 3GPP links.
> >         - A general "IPv6 Node Requirements" document.
> 
> Definitely agree with this.

I also agree.

> 
> Brian
> --------------------------------------------------------------------
> IETF IPng Working Group Mailing List
> IPng Home Page:                      http://playground.sun.com/ipng
> FTP archive:                      ftp://playground.sun.com/pub/ipng
> Direct all administrative requests to [email-masked]
> --------------------------------------------------------------------
> 
--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: [email-masked]
Date: Tue, 5 Mar 2002 19:50:43 +0200

Hi Phil,

> >  Your following arguments are reason enough to avoid this path.

If the discussion is that creating hosts requirements for every kind of
device is a bad idea, well, I think that you may have a point.  What
I think we have been trying to do in the draft is really discuss
the applicability of various IPv6 standards & features for a cellualr
host. In some cases, we go beyond what a general host requirements
would say.  So my question to the list, is what is contained in the
draft fundamentally flawed or not.

thanks,
John

---

From: Margaret Wasserman <[email-masked]>
Date: Tue, 05 Mar 2002 14:56:39 -0500

Hi John,

>I am having a hard time understanding what your objections
>to the document are.  You have raised some good technical
>points & we are looking at how to address them & revise
>the document.  However, you seem to be saying now that the
>technical issues are not important.

I don't believe that the technical issues that you have
raised are unimportant.  I think that they are very important -- 
important enough that they should be addressed in standards-track
documents.

But, I don't think that this document is in quite the right
form to move on to the standards track as written, and I don't
think that it makes sense to publish it as an informational 
document.  

Your document and your arguments have convinced me that we
should publish a standard definition of the minimal requirements
for an IPv6 node, an "IPv6 Node Requirements" document (or perhaps
two documents, one for hosts and one for routers?).  This should 
be a standards-track document, not an informational one, and I 
think that your document would serve as an excellent starting 
point for this work.

It is important that the minimal host requirements of IPv6 be
applicable to low-end systems, such as cell phones, and that 
should be reflected in our general IPv6 node requirements effort.  

However, I don't think that we want to have a fragmented set
of informational host requirements documents with different 
requirements for different IPv6 application spaces (cellular hosts
vs network appliances vs. home gateways vs. car infotainment 
equipment, etc.).  If I'm missing some reason why cellular
hosts are special, that explains why they would need an 
informational requirements document (when other applications
would not), please explain.

Most of the things that make the hosts you've discussed unique
are related to the fact that they run over a specific link
type.  In my opinion, these differences, and the behaviour that 
is required because of them, should be captured in a link-specific 
standards-track "IPv6 over <foo>" document, such as "IPv6
over 3GPP PDP Contexts".  This document could be based on
portions of your current document.
  
Of course, I don't personally get to decide what the IPv6
WG publishes.  I'm just voicing my opinion... 

>If the draft can go through the process of becoming an
>RFC, with work group consensus, etc. what is the problem?

Well, this is the process of trying to find that consensus. 
  
Consensus on publishing an RFC doesn't just mean that no one can
find any technical problems with the contents.  It also means 
getting the consensus of the WG and the IESG that a document is 
needed in this area, and that publishing that document would be 
useful.

I have voiced technical issues with the document AND reasons
why I thnk the WG may not want to publish this specific document as
an Informational RFC, even if the technical issues were addressed.  

>Of course, I do think that you are being very unfair in 
>this statement.  Most of the authors are IETF participants,
>not 3GPP participants.  We have no 'agenda' - or at
>least no more than your average IETF participant.  

I can see how you interpreted my comments this way, but this 
isn't what I meant...

I don't think that the authors of this draft have an  "agenda" 
(in the negative connotation sense) that runs contrary to the 
interests of the IETF, IPv6 or any related work.

I meant "agenda" more in the sense of "focus" or "area of 
interest".  

There are a lot of people involved in the IETF (myself included) 
who have a strong interest in making sure that IPv6 is applicable 
for certain types of uses.  This is a positive thing, because
we often have a lot of technical knowledge about those environments,
and we can add to the quality and wide applicability of IPv6 by
reviewing documents and representing our differing perspectives.

However, I don't think that the WG should publish a number of
different informational RFCs, representing all of these different
positions regarding what the minimal contents of IPv6 should be for
each type of application.  Instead, we should bring all of our
knowledge and skills together to write a single standards-
based "IPv6 Node Requirements" document that defines what the 
minimal requirements are for all IPv6 nodes.  

>This 
>is not 3GPP trying to push anything in the IETF.  Also,
>I really don't think that involving a more diverse set 
>of participants in the IETF is a bad thing.  I think
>we ought to encourage more direct participation in the
>IETF rather than less.  Do you feel it is a problem if
>folks from the FOO SDO starting participating in the IETF,
>and functioning under IETF rules?  I really could not
>find a problem with that.

No, I have no problem with that at all!  In fact, I'd like
to see even more of it.

Margaret

---

From: [email-masked]
Date: Wed, 6 Mar 2002 13:08:52 +0200

Hi Margaret,

> think that your document would serve as an excellent starting 

Point of clarification, I personally prefer splitting the host
requirements from the router requirements.  A host is a
node which does not forward packets on behalf of another node,
while a router does.  In creating the current document, this
seperation really helped in scoping it (perhaps it didn't
scope it enough, I'm sure a few of you are saying ...)

> should be reflected in our general IPv6 node requirements effort.  

Without a doubt.

> would not), please explain.

We don't want a fragmented market, that is why we've thought
that the work should be done here.  I think the reason why
we have been saying that they are special is because there
is urgent need for this kind of document and there is nothing
else out there.  

I don't think that anyone is going to argue on these 2 facts:
1) if we put out alot of IPv6 enabled cellular hosts,
   those hosts better behave well.
2) if we put out a lot of IPv6 enabled cellular hosts,
   IPv6 should work well over the cellular link.

I guess we are just differing on how best to achieve ensuring
the above. 

Oh, one additionally point, perhaps it is not as important since
it is an implementation issue, but the initial implementations
of IPv6 most likely will be in firmware, making tweaking extremely
difficult, which puts more pressure on making sure we get it right.

Does this make any sense?
John

---

From: "Karim El-Malki (ERA)" <[email-masked]>
Date: Wed, 6 Mar 2002 12:14:50 +0100

> Erik Nordmark wrote:
 > 
 > >>If there are decisions as to what to do with ND/DAD/whatever,
 > >>should those be made by (a) IPv6 WG, (b) 3GPP, or (c)
 > >>vendors?
 > >>
 > > 
 > > Jari,
 > > 
 > > I think the ND/DAD type issues can be dealt with by the 
 > IPv6 over foo
 > > document which should be a lot quicker to produce than the 
 > host requirements
 > > document.
 > 
 > 
 > True, but I guess I was more worried about the "whatever" part.
 > Looking at typical IPv6 over Foo documents, I would say ND, DAD,
 > PPP, and RFC 3041 issues fit those documents well. But what about
 > the rest?

I have a similar issue in mind.
If we have an "IPv6 over Cellular links" draft would that also include
some discussion on the rest e.g. security? That is, a security
section specifically for cellular links? For example, when you use IPsec,
IP header compression on the 3g link is not efficient and one of the
results is higher packet loss. I guess this is something that the
implementer should be told since it has to do with the specific link.
Just trying to figure out what the options are and what would go in an
eventual "IPv6 over Cellular links" draft.

/Karim

---

From: [email-masked]
Date: Wed, 6 Mar 2002 12:39:54 +0200

Hi Charlie,

> > how long do you think producing the general document
> > to an RFC will take? What should we say in the
> > meantime to folks who want to deploy IPv6 now?
> 
> What if we make some revision to "draft-ietf-ipv6-cellular-host",
> and run that as Informational?  Then we could have IPv6 Host
> Requirements later on the standards track.  We could even
> have a later IPv6-over-3GPP standards track document which
> would obsolete the Informational document, if desirable.
> Or, would that be IPv6-over-3.75G?

That could be one way forward.  What would the downside to this
be?  

I think that one of the current sticking points in our discussion
is that there is no IPv6 Host Requirements document.  If there
was, we wouldn't have this problem.  Additionally, I think
that a IPv6 Host Requirements document is extremely important,
I will gladly put effort into it, but I do think that it will
take some time to create a good document that will gain
consensus.  In the meantime, some companies will be putting
out more than a few IPv6 capable phones / PDAs / etc without
clear guidence.  This is what I worry about.

John

---

From: [email-masked]
Date: Wed, 6 Mar 2002 12:56:10 +0200

Hi Tony,

Hi Tony,

> Please don't take this as a personal attack, but you just 
> don't get it.

What I suspect is that we are actually looking at the same problems,
from a different direction & thinking that a different way forward
is what is needed.

I completely agree with you that we should (must) not change IPv6
to suit the immediate needs of the day.  Doing otherwise would
really kill the purpose of IPv6.

I think we both agree that one way to ensure this is to have an
IPv6 Host Requirement document, which is applicable to all of the
devices we see as potentially implementing IPv6.  Such a document
won't be turned out overnight, but that's the IETF.

Additionally, having IPv6 over Foo documents are always useful,
and in Salt Lake City, there was interest in having an
IPv6 over Cellular (or some variation of that theme).  I have discussed
with a number of folks writing such a document.  However, I think
even with the proper scoping, this document will take some time as well.

Now where we differ is what to do now.  In my opinion, some informational
document (that could / should be obsoleted when the general host document
is completed) is needed to assist in implementing & deploying IPv6
on small cellular hosts.  Most of these hosts will not be using a 
standard POSIX operating system, so information on doing this kind
of thing may be limited.  Of course, a document could be written
within 3GPP, 3GPP2, etc. but that would miss critical review that 
(in my opinion) is needed from the IPv6 WG - and potentially lead to 
different versions of IPv6 (3GPP's IPv6, 3GPP2's IPv6, IETF's IPv6).

I think the technical comments that Margaret has brought up
have been great & very useful.  Additionally, I think that the
entire discussion has been useful because it is clarifying
some things which are needed to be clarified.

If I am still not getting it, please let me know - I really do want
this discussion to be constructive and lead to a useful resolution.

best regards,
John

---

From: [email-masked]
Date: Wed, 6 Mar 2002 12:59:03 +0200

Hi Brian,

>      I don't think there is problem with the content.  

Thanks for the clarification - it hasn't always been entirely clear.  

> I believe
> the content needs to be separated.  One part to discuss IPv6
> operation over cellular links and one part to discuss the minimal
> IPv6 functionality for hosts.  The second part really belongs in
> a general host requirements document.

At the end of the day, this discussion is seeming to point to one 
fact - we NEED a general host requirements draft.

John

---

From: [email-masked]
Date: Wed, 6 Mar 2002 18:44:35 +0200

Hi Margaret,

> If we publish this document as "informational" now, I think we 
> all agree that the 3GPP community will treat this as a standard and
> implement to it.
> 
> This raises one serious, immediate problem.  This document 
> contradicts things in IPv6 standards track documents.  As a 
> result, we may end up with two subtly incompatible "camps" of 
> IPv6 nodes (cellular nodes and non-cellular nodes).

Right now, there is nothing for 3GPP community to implement
towards.  Divining the relationships between relevant IPv6
RFCs (and drafts which are updates to RFCs) is not at all clear.
Evaluating a number of commercial IPv6 stacks has shown that
a large number of them are not compliant to many of the 
standards we are listing in our document.

Our document does not intend to create any incompatibilities,
and we want to ensure that there are not.  I have already
been suggesting that we can adjust the requirements in the
document, so we don't introduce incompatibilities & this is
why we have been asking for comments on the document, so
that there are no incompatibilities.
 
> Why do you think that it will take more time to gain consensus
> on the minimal IPv6 host requirements for a standards-based "IPv6
> host requirements" effort, than it will to reach consensus on
> the minimal IPv6 host requirements for an informational "cellular
> hosts" effort?

Well, are we considering Minimum Host Requirements or Host Requirements
or Node Requirements?  We have been trying to scope our document,
however, there has been no scoping of what you have been proposing.
 
> Getting this right will take time, and I don't think that we
> should publish either document until we get it right.  If we
> are going to undertake this effort, wouldn't you rather emerge 
> with a standards-based host requirements document than with an 
> informational cellular-specific document?  

I've always thought that we could do both, perhaps I am
optimistic.
 
> Yes.  They will be doing it based on the IPv6 standards.
> We've worked on those standards for years, subjected them to
> multiple rounds of scrutiny, and they have been implemented by 
> many vendors.  None of us would say they are perfect, but
> they are the best information we have about how to build
> compatible, compliant IPv6 hosts.

I don't know who you have been discussing with - but most radio-heads
that I know (folks who have been implementing cellular stuff) are 
very unfamiliar with the IETF & standards.  I've gotten A LOT of 
feedback from many different groups based upon our draft on how
the ietf works, etc.  Remember, most phones do not use a POSIX
type of environment, and it will be a while before your average
consumer mobile host will have anything resembling a socket.  
Personally, I don't think that I want such a thing on my
general purpose phone.

> I _do_ think that we need to do an "IPv6 over <name the cellular
> link of your choice>" document.  This document should include 
> everything that is really special about building hosts that 
> talk on cellular links. 

We have agreed that this work would be started in Salt Lake City.
At least my understanding of the SLC Meeting was that our
draft would become a WG document, work should be started on
a general hosts document (I think I discussed with Ito-Jun and someone
else about starting that at the meeting) and I think Jonne Soininen
was interested in creating an "IPv6 over 3GPP" or something document.
Jonne mentioned to me that the current 3GPP specs have settled 
enough that such a document could be started.

John

---

From: "Karim El-Malki (ERA)" <[email-masked]>
Date: Wed, 6 Mar 2002 17:42:44 +0100

> everything that is really special about building hosts that 

I agree. If I remember correctly that was also one of the things
that came out of the IPv6-3gpp design team effort.

 > 
 > One question:  Are there enough differences between different
 > cellular link types that we will need more than one of these
 > documents?  Or is there, effectively, a single type of cellular
 > link, from an IPv6 perspective?

Well, several things are the same: low bandwidth, point-to-point,
lossy, needs header compression. I think that was the assumption
behind the cellular hosts draft.

/Karim

---

From: Phil Roberts <[email-masked]>
Date: Wed, 6 Mar 2002 12:05:26 -0500

> >That could be one way forward.  What would the downside to this be?
> 
> I've tried to explain this in other messages, but I don't
> think that my reasons are coming across...
> 
> all agree that the 3GPP community will treat this as a 
> standard and implement to it.
> 
> Since we know that this document will be treated as a 
> standard, giving it a cursory review and hurrying to publish 
> it as an "informational" document is irresponsible. 

I hear you and agree with you that this is a valid concern.

<snip>

> informational cellular-specific document? 

Also agree.
 
> 
> >In the meantime, some companies will be putting
> >out more than a few IPv6 capable phones / PDAs / etc without clear 
> >guidence.  This is what I worry about.
> 

Which raises a question - if all these vendors are capable
of building interoperable hosts and routers, what is the
big concern about the cellular handset vendors - other than
the subtle and specific differences of communicating over
specifically the 3gpp defined interfaces?  The danger seems
not that they will implement too much, but that they will
implement too little.  The doc seems to want to give
permission to skip required v6 features which is not something
this WG should bless.

> 
> I _do_ think that we need to do an "IPv6 over <name the 
> cellular link of your choice>" document.  This document 
> should include 
> documents?  Or is there, effectively, a single type of 
> cellular link, from an IPv6 perspective?

One big difference between the 3gpp architecture and the 3gpp2
architecture is that 3gpp2 uses Mobile IP for all mobility
management and 3gpp uses it for nothing really (although one
could do internetwork mobility with a second interface).

3gpp2 is not that far down the IP v6 path yet, I believe, to
be able to say much of significance about specific concerns
they may have.  At least that is my perception, perhaps someone
involved with that effort could clarify.

Phil

Phil

---

From: "Bound, Jim" <[email-masked]>
Date: Wed, 6 Mar 2002 12:44:54 -0500

I don't think we need a general nodes reqs document.  Isn't that what
standards are for?
If we cannot be reasonable to get specific node docs done quickly here
and shipped then we should not do them or do them and implementors will
go do them elsewhere.

/jim

> -----Original Message-----
> From: Margaret Wasserman [mailto:[email-masked]]
> Sent: Tuesday, March 05, 2002 10:46 AM
> To: [email-masked]
> Subject: Updating draft-ietf-ipv6-cellular-host-00.txt?
> 
> 
> 
> Before folks go and do a lot of additional work to update
> draft-ietf-ipv6-cellular-host-00.txt based on our discussions,
> I think we have to answer a fundamental question:
> 
> Should the WG publish an informational RFC detailing the IPv6
> requirements for cellular hosts?
>

---

From: "Bound, Jim" <[email-masked]>
Date: Wed, 6 Mar 2002 13:00:45 -0500

Info RFC is NOT a STANDARDS track doc.  So if its info do you still have
a problem.
/jim

> Sent: Tuesday, March 05, 2002 2:57 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: RE: Updating draft-ietf-ipv6-cellular-host-00.txt?
> 
> 
> 
> Hi John,
>

---

From: "Bound, Jim" <[email-masked]>
Date: Wed, 6 Mar 2002 13:04:07 -0500

Erik,

We can't possilbly to a standards ip over 3gpp its not possible.  It
also none of our business and could cause big liaison problem.

The other one needs to break down to different node types.

/jim

> From: Erik Nordmark [mailto:[email-masked]]
> Sent: Tuesday, March 05, 2002 5:13 PM
> To: Margaret Wasserman
> Subject: Re: Updating draft-ietf-ipv6-cellular-host-00.txt?
> 
> 
> 
> I think the above two documents make a lot of sense.
> 
> I wonder if there is utility in having a third document; 
> an informational and non-prescriptive
> document (i.e. no MUST, SHOULD, MAY language) which is more like a
> document roadmap plus issues for hosts of category X (where X 
> is a rather
> narrowly defined subset of the 3g/cellular host).
> 
> For instance, listing the set of documents that implementors 
> need to take
> into account seems quite useful.
> 
> Also, discussing tradeoffs of what optional things to 
> implement also sounds 
> useful. And talking about how things fit together i.e. the 
> relationship between
> IPsec/IKE vs. TLS also sounds like useful information to 
> implementors. But
> "discussing issues" and not having any normative MUST, 
> SHOULD, MAY language.
> 
>   Erik
>

---

From: "Bound, Jim" <[email-masked]>
Date: Wed, 6 Mar 2002 13:06:13 -0500

I don't agree on the expedite optimism.  We have important people in the
working group who are not even sure what a GGSN does technically.

PDP Context or 802.11 EAP with AAA will use IPv6.  Its like device
drivers.  They will be custom.

/jim

> Sent: Tuesday, March 05, 2002 6:40 PM
> To: Jari Arkko
> >Now, my concern is this:
> This is a valid concern...
> 
> Many of the issues that are raised in your document
> could be handled in an "IPv6 over 3GPP PDP Contexts" 
> document.  I think that we should be able to produce
> that document fairly quickly, probably quicker than
> we will reach consensus on any requirements document,
> even your informational one.
> 
> Margaret
> 
>

---

From: "Bound, Jim" <[email-masked]>
Date: Wed, 6 Mar 2002 13:32:15 -0500

Phil,

I don't agree with your view at all.  But below is important to the
decision IMO.

> permission to skip required v6 features which is not something

I have to agree if the doc is saying an IPv6 implementation should not
implement everything and it has an IETF RFC.

Not for technical reasons or I think it bad.  But because I am practical
and know our community.  This would not see the light of day politically
and that is just the way it is.

I strongly suggest we who care (again) just submit this to 3GPP and end
this IETF discussion.  

As to node reqs for IPv6.  Thats an important discussion but I will
argue I have all those reqs as a vendor and implementor currently in our
specs.  I will implement those that will be wanted by customers and for
the product set supporting them.

Thats what this is really all about and we may have headed down the
wrong path back at the seattle meeting.  The reason I say this is that
we cannot control IPv6 deployment in the IETF for any market and in
particular 3GPP.

Also as you stated 3GPP2 has different reqs than 3GPP.

regards,
/jim

---

From: "Bound, Jim" <[email-masked]>
Date: Wed, 6 Mar 2002 13:39:51 -0500

charlie,

the problem is that for a few years now people have begun to use info
rfc as political tool either to stop a good idea or abuse the info
status and then put its an RFC # in their marketing literature alluding
to that its a standard but not really doing so.

I agree with you info should be what it was a long time ago.  like just
info or fyi.

And like you I believe in caveat emptor (let the buyer beware) and if
someone is stupid enough to not check what mumbo jumbo rfc means and its
state and intention they deserve what happens to them.  we document
clearly what info means in our ietf community.  

but if folks won't treat info as it was intended and they are not in
most cases anymore we are wasting our fingers, mind, and a few other
things on this discussion and the authors should submit this to 3GPP and
we should submit different doc for 3GPP2 also and not even attempt info
rfc for this doc.   

time-to-market is to important in this case to mess around here for this
particular task for the next year.

/jim

> From: Charles E. Perkins [mailto:[email-masked]]
> Sent: Wednesday, March 06, 2002 12:21 PM
> To: Margaret Wasserman
> Cc: [email-masked]; [email-masked]
> Hello Margaret,
> Margaret Wasserman wrote:
> 
> I got that part of your message, and I think the problem is
> able to be avoided.  Maybe we should not have process discussions
> here, but generally I feel that if we can't use the Informational
> RFC mechanism as it was intended to be used, then something is
> wrong.
> 
> Then a good idea would be to make sure that the Informational
> document does NOT contradict IPv6 standards track documents.
> In my previous notes, I suggested some language that would be
> useful to ensure that result, partially motivated by work done
> elsewhere in the IETF.
> 
> > Since we know that this document will be treated as a standard,
> > giving it a cursory review and hurrying to publish it as an
> > "informational" document is irresponsible.
> 
> But on the other hand we can easily imagine giving the document
> thorough review and making responsible decisions about what belongs
> in it.
> 
> Then the Informational document should not be labeled "minimal".
> Maybe IPv6-over-3GPP-PDP is the right name.  The reason that
> it can be done faster, is because the discussion can be more
> focussed.  I agree with you, that such a document should
> not contain language contradicting the Draft Standard documents.
> Right now, I don't know any reason that would force this result.
> 
> > Either way, we need to reach consensus on the minimal set of
> > specifications and features that comprise IPv6, right?
> 
> Determining what is "minimal" will take longer
> than determining what is useful for 3GPP-over-PDP.
> 
> > should publish either document until we get it right.
> 
> Agreed -- but the time requirement for the focussed document
> can be a lot shorter than a general document.  And, a lot of
> work has already gone into it.
> 
> >                                                      If we
> All else being equal, yes.  But, not all things are equal here.
> 
> > Or are you suggesting that we should publish a "cellular host
> > requirements" draft without going through the effort to get
> > full consensus on the actual minimal requirements for IPv6
> > hosts?  How would that work, and still avoid the "two camps"
> > concern that I raised above?
> 
> That would be my suggestion.  It could work, because the Informational
> document would not be interpreted as an broadly applicable "minimal"
> draft.  In fact, by definition the "minimal" draft should have _fewer_
> features than the IPv6-over-3GPP-PDP draft.  I think this is able
> to be accomplished by (i) not contradicting IPv6 standards, and
> (ii) focussing exactly on what PDP needs.  I am not a crusader,
> nor even proponent, for PDP, since I think that was designed
> without much attention given to connectionless traffic.  But I
> am hopeful that we can get IPv6 deployed and functional ASAP;
> that will happen faster if we have a responsible, compatible
> story for 3GPP.
> 
> That could be the Informational document.
> 
> The similarities are more numerous than the differences, from
> the standpoint of IPv6, but I'm not sure whether there would be
> one, or perhaps a very small single-digit number of them (like, 2).
> Keep in mind that the total number of nodes conforming to either
> one of 2 such documents could easily outnumber the entire current
> IPv6 population.  Or, that the IPv6 implementation on such nodes
> could be poorly done without appropriate Informational guidance,
> giving IPv6 generally a bad name.  It could happen.
> 
> Regards,
> Charlie P.

---

From: [email-masked]
Date: Wed, 6 Mar 2002 05:24:57 -0800

[Karim wrote:]
>eventual "IPv6 over Cellular links" draft.

I have been in the process of writing an "IPv6 over PDP Context" or similar document. The 3GPP system has changed a bit in this aspect in the last few months, and that's why the document did not make it to this submission deadline. I try to better after IETF#53.
I think there might be some things from this document that can be copied to the IPv6-over-... doc, but not all of this should be there. In addition, I am of the opinion that this "minimum requirements" document in a form or another is really needed. I think that this quite extensive discussion in the mailing list already proves that to some extent. The issues is not quite clear, what you actually have to implement, and what not, if you try to make a minimal implementation. I think the cellular host (here meaning a host with very limited capacity, burned-in stack, and a single low-bandwidth link) has some special characteristics, and will be quite significant in numbers that it already justified its own document. 
It might be that some of the wordings in the document have to be changed, and maybe a disclaimer put that what assumptions have to be fulfilled, if you drop some functionality out. Basically for instance stating that if you do not DAD, you better know what you are doing, and you better be on a point-to-point link - alone.

Cheers,

Jonne.

--------
Jonne Soininen
Nokia

Tel. +1 650 864 6794
Cellular: +1 650 714 7733
Email: [email-masked]

---

From: "Bound, Jim" <[email-masked]>
Date: Sun, 10 Mar 2002 11:46:26 -0500

Jari,

I agree.  But if we cannot get consensus quickly then its time to move
on to the issues of use deployment elsewhere.

/jim

> From: Jari Arkko [mailto:[email-masked]]
> Sent: Thursday, March 07, 2002 7:30 AM
> To: Bound, Jim
> Cc: Brian Haberman; Margaret Wasserman; [email-masked]
> Bound, Jim wrote:
> > John et al.  Bag this lets go build a cellular host consortia with
> > vendors that want to ship and deploy IPv6 and build our use 
> requirements
> > out of here.
> > 
> > Or we will be hacking on this in January 2003.  It was a 
> good thing to
> > try but it might not work to do use / implementation reqs 
> in the IETF.
> > Thats fine though.
> 
> 
> Given that deployment starts this year and standards releases 
> are weeks
> or at most months away, I'm sure decisions *will* be made as 
> to what goes to the
> devices. The guestion is who will make the recommendations on what the
> devices do. My strong preference though is that this WG makes 
> them, because
> the expertise is here.
> 
> Jari
> 
> 
> 
>