Subject: RE: Should DAD be optional? [Wasdraft-ietf-ipv6-cellular-host-00. txt -> wg last call?]

From: "Hesham Soliman (ERA)" <[email-masked]>
Date: Thu, 7 Mar 2002 07:28:18 +0100

Andrew and all, 

  > 
  > This what is in current 3GPP specifications, is not 
  > necessarily the "right thing".

=> Let's keep this discussion within
the scope of 'what's relevant' to our work
and this WG.
Please note 2 points:

- We are NOT interested in fixing every SDOs
architecture. I can think of a dozen things that
would improve 3GPP/2's systems, but as far as this 
work and IETF in general are concerned, this is 
irrelevant. 

- We want to run IPv6 ASAP for obvious reasons. 
This would mean we take what's out there and
see how we can run IPv6 over it. 

  > 
  > Recommendation shall include the right network topology and 
  > IPv6 mechanism, not deal with system, which is only "half" right.

=> Getting the right architecture ...etc is not our
job in this WG. This is something for you and 
your 3GPP colleagues. So please try to provide
us with concrete technical comments on the draft.
All we want is to improve the work in a way that
makes it useful for implementors. 
I don't see a point in redesigning cellular systems
on this mailing list.

Hesham
--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: "Karim El-Malki (ERA)" <[email-masked]>
Date: Thu, 7 Mar 2002 14:26:52 +0100

>   | Can we keep 3gpp architecture discussions OFF this list?
 > 
 > As far as it goes, probably yes - but as long as you keep referring
 > to peculiarities of it, to justify other decisions, then no...

???
What does this have to do with cellular architectures?
We need to consider particulars of the link but that's a totally
different thing from the internal architecture of a cellular system
which belongs elsewhere.

 > 
 > The problem here is that there's no spec for IPv6 over those links.
 > Define one of those first, until that's done, attempting to define
 > host requirements for hosts connected to such a link is straight out
 > silly - how can anyone run IPv6 over any random link in any kind of
 > standardised way, when there's no existing spec on how to do that?
 > 
 > It is frightening to think that people seem to be 
 > contemplating actual
 > implementations of this, with no spec at all to base their 
 > implementation
 > on.   This needs to be fixed, and quickly.

3gpp has defined how the IPv6 behaviour over cellular links works with
IETF input in terms of 3gpp-advice. It's in a spec called 23.060.
So it's simply not true that people don't have a spec.

However it is important that we quickly get some form of minimum host
requirements spec which today just isn't there to guarantee host
compatibility. This could then be used by 3gpp implementers to ensure
compatibility but it needs to be done in a short time. In parallel we
could do the IPv6 over cellular spec which would give non-3gpp people
something to use. It's already been mentioned by Jonne that work has
started on this.

 > 
 >   | What we are talking about is an IPv6 host with a point-to-point
 >   | link to a router. They run PPP and the router delegates
 >   | a global prefix to the host. The router doesn't configure
 >   | any address on the delegated prefix and it supports NS/NAs.
 > 
 > It sounds as if what you're really describing is an 
 > "unnumbered" link.
 > (From the global point of view anyway) - the delegated 
 > prefix would be
 > for the host (terminal, phone, ...) to use as it sees fit?

Yes. Please read the previous emails on this.

 > 
 > Is that how it always *must* be done?   If so, that's what 
 > the IPv6 over
 > whatever doc should be saying (along with the appropriate 
 > justification).
 > 
 > But in any case, any link is going to have the link local 
 > prefix on it,
 > and on that one, the router is supposed to go and configure 
 > the "any routers"
 > anycast address, aside from a unicast address for itself 
 > usually - there's
 > absolutely no reason why it shouldn't - regardless of any 
 > prefix length
 > that might be used for a global prefix on the link (were 
 > there to be one),
 > the link local is always a /64 - so there really are plenty 
 > of addresses
 > there for there to be one for the host/terminal/phone/... 
 > and one for the
 > router.   Not allowing the router to have a link local address on the
 > link would need very good justification, as it would break 
 > all kinds of
 > assumptions made everywhere else.

Well, if you had read the previous emails you'd have realised
that 3gpp is using PPP to guarantee uniqueness of the router
and host's link-local. And no, once again, the router does not
configure any address on the delegated global prefix. It is a special
router. I'm starting to sound like a broken record :(

/Karim

---

From: "Hesham Soliman (ERA)" <[email-masked]>
Date: Thu, 7 Mar 2002 19:08:36 +0100

> I have no problem with the words in your note, but then you
  > have to rename the draft to be "IPv6-over-nearterm-3G", or
  > better, "IPv6-over-3GPPr5-PDP".  That gets the point across.
  > 
  > If it's "IPv6-over-cellular", then you have to write
  > the specification to apply to ALL cellular systems, current
  > and future.  That was the point in my note you quoted.

=> Basically we're saying similar things in different
ways. My note (hasn't made it to the list yet) 
said that we addressed both of the above in the 
draft. The secions titled 'X function in 3GPP'
address the specifics. 
It seems that there is some confusion about whether
cellular == 3GPP. That's certainly not the case
as it is explicitly stated in the draft. 
So I do see the case for 2 documents, but the important
issue right now is to have some agreement on 
the technical content, then decide if it should
be split into more than one document. 

Hesham

---

From: [email-masked]
Date: Fri, 8 Mar 2002 18:29:42 -0800

Hello Andrew again,

> necessarily the "right thing".

I think that what is in the 3GPP specs is the problem of 3GPP. Not us. Anyways, I rather would like to think that what 3GPP has is rather good, and (most important of all) it supports IPV6. That's enough for me. 

Cheers,

Jonne.

> -----Original Message-----
> From: ext Delecki Andrew-Y10658 [mailto:[email-masked]]
> Sent: Wednesday, March 06, 2002 4:11 PM
> To: 'Hesham Soliman (ERA)'; Perkins Charles (IPRG); Karim 
> El-Malki (ERA)
> Cc: [email-masked]
> Subject: RE: Should DAD be optional?
> [Wasdraft-ietf-ipv6-cellular-host-00. txt -> wg last call?]
> Importance: High
> 
> 
> Dear Hesham,
> 
> Andrew D.
> Motorola 
> -----Original Message-----
> From: Hesham Soliman (ERA) [mailto:[email-masked]]
> Sent: Wednesday, March 06, 2002 3:24 PM
> To: 'Charles E. Perkins'; Karim El-Malki (ERA)
> Cc: [email-masked]
> Subject: RE: Should DAD be optional?
> [Wasdraft-ietf-ipv6-cellular-host-00. txt -> wg last call?]
> 
> 
> Hi Charlie
> 
> I finally read the thread.
>   
>   > > I agree that it would be good to see some guidelines in an
>   > > informational doc. However I disagree on the title change to
>   > > IPv6 over cellular/3g. That is a different spec which we should
>   > > also work on.
>   > 
>   > It is possible to design "cellular" systems where the
>   > 3GPP/PDP address assignment is completely replaced by
>   > localized, stateless methods.  The way that addresses
>   > are assigned is not related to bandwidth, nor even to
>   > essential authorization issues.  It's an artifact of
>   > near-compatibility with existing 2.5G layouts.  GGSN
>   > does not NECESSARILY need to control this process.
>   > 
>  
> => That's fine, but we have to deal with what *is*
> right now and not what *may come*. 
> There are people that want to roll out systems with
> IPv6 support today, R&D will no doubt improve
> things, but in this draft we need to deal with
> the current specs.
> 
> 
> Hesham
>

---

From: Delecki Andrew-Y10658 <[email-masked]>
Date: Wed, 6 Mar 2002 16:11:26 -0800

Dear Hesham,

This what is in current 3GPP specifications, is not necessarily the "right thing".

Recommendation shall include the right network topology and IPv6 mechanism, not deal with system, which is only "half" right.

Andrew D.

Motorola 

-----Original Message-----
From: Hesham Soliman (ERA) [mailto:[email-masked]]
Sent: Wednesday, March 06, 2002 3:24 PM
To: 'Charles E. Perkins'; Karim El-Malki (ERA)
Cc: [email-masked]
Subject: RE: Should DAD be optional?

Hi Charlie

 

Hesham