Subject: SNMP for transport over IPv6

From: "MANDAVILLI,SWAMY J (HP-FtCollins,ex1)" <[email-masked]>
Date: Wed, 27 Mar 2002 09:09:49 -0800

Hi!

	For SNMP Transported over IPv6, is it
	a simple matter of modifying and compiling
	the Agents and Managers for v6 OR is there
	a standard for SNMP v6/ng?

	Is there a need to define "var-binds" for
	v6 addresses?  Does it require versioning
	of SNMP for v6/ng?

	If so, is there standard and/or a working-group
	for this?

	Thanks in advance.

Regards,
Swamy
--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: Margaret Wasserman <[email-masked]>
Date: Wed, 27 Mar 2002 15:12:37 -0500

Hi Swamy,

There are a few different issues involved in getting
an existing UDP/IPv4 SNMP agent to run over IPv6.

First, you need to make changes to the part of the
agent that sends/receives packets to allow it 
receive requests and send responses over IPv6.

If you want to support SNMPv3 security over an
IPv6 transport, you also need to make some changes
to your TAddress/TDomain definitions.  There is 
an Internet-Draft available that describes one set
of possible changes, and we are working to get that
draft (or a modified version of that draft) accepted
by the IETF.  This work is happening in the OPS
area, outside of any WG.

It is also likely that you will want to support
some IPv6 MIBs for your TCP/IP stack, at least.
Those MIBs are under development in the IPv6
WG.  They are very similar to the IPv4 versions,
except that they include address types that are
capable of holding an IPv6 address.

Margaret