Subject: Re: Stateless DNS discovery draft

From: Ralph Droms <[email-masked]>
Date: Thu, 04 Apr 2002 10:45:40 -0500

I think the third scenario is likely to be problematic.

My understanding is that your third scenario would
require that the customers' networks all be part of
the same site as the ISP network - at least as far in
as a DNS server somewhere. I imagine some ISPs
might want to draw a site boundary somewhere
between the ISP edge and the CPE; either in the
CPE or in the ISP edge device or by declaring the
CPE-PE link to be not in either site...

- Ralph

At 05:36 PM 4/4/2002 +0200, Hesham Soliman (ERA) wrote:
>Hi,
>
>During the last meeting a question was raised
>on whether the scenarios for which the stateless
>DNS discovery draft can be used, were clear to
>everyone.
>I think that on a very high level we could basically
>say that this draft is useful when a host desires
>to discover a DNS located in the same site for the
>purpose of address resolution.
>
>Examples of where this can be useful:
>
>- Corporate networks
>- Cellular networks: 3GPP is one case where this
>   would be useful for all those who complain
>   about how small the devices are and that the
>   less code the better ;)
>
>- ISPs which host a DNS server for customers
>   connected via DSL for example. Of course in
>   this case they would have to define a site
>   accordingly.
>
>Any other scenarios ? I think there is a reasonable
>case for this draft based on the scenarios
>above.
>
>Comments?
>
>Cheers,
>Hesham
>
>--------------------------------------------------------------------
>IETF IPng Working Group Mailing List
>IPng Home Page:                      http://playground.sun.com/ipng
>FTP archive:                      ftp://playground.sun.com/pub/ipng
>Direct all administrative requests to [email-masked]
>--------------------------------------------------------------------

--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: [email-masked]
Date: Fri, 05 Apr 2002 11:25:54 +0900

>CPE-PE link to be not in either site...

	if CPE can become dual-sited (participate into ISP's site and
	customer's site) it can relay DNS query requests/responses between
	clients in customer's site to DNS server in the ISP.

itojun

---

From: Ralph Droms <[email-masked]>
Date: Thu, 04 Apr 2002 21:40:06 -0500

Either the CPE or the provider edge device could perform a
relay function.  The relay function is not described as
part of draft-ietf-ipv6-dns-discovery-04.txt.  How, exactly
would it work?

In my opinion, the relay function defeats the "zero
configuration" goal of the DNS Discovery mechanism, as
it requires configuration - either in the CPE or the
PE device - to select that DNS forwarding should be enabled
across sites and how that forwarding should take place.

- Ralph

---

From: Alain Durand <[email-masked]>
Date: Fri, 12 Apr 2002 18:03:44 -0700

> CPE-PE link to be not in either site...

This is the very reason why I suggested to use a well-known
global Ipv6 address instead of a site local one.
This address would have to be taken out of a reserved prefix
that will not/should not be announced in BGP peerings.

But in such a scenario, if prefix delegation from PE to CPE
is done using DHCPv6, it would make sense to piggyback
the address of the DNS server in this dialog and the CPE
could act itself as a lightweight DHCPv6 server and pass the information
to any internal node requesting the DNSserver IP address using DHCPv6...

So, the question to ask is:
In such a scenario, will it make sense to ask internal IPv6 nodes to 
implement
a minimal DHCPv6 client or will they rather like to use a pre-configured
well known address in their /etc/resolv.conf file?

	- Alain.