Subject: RE: Proposed IPv6 DNS Discovery Requirements

From: Ralph Droms <[email-masked]>
Date: Tue, 30 Apr 2002 10:16:12 -0400

Are the MLD extensions for anycast written up somewhere?

- Ralph

At 03:56 PM 4/30/2002 +0200, Hesham Soliman (ERA) wrote:
>
>   > >> b) What's the security model by which the router decides
>   > whether to
>   > >>    accept routing updates from the DNS server?
>   > >
>   > > The same model that is used between routers in the network.
>   >
>   > Right, so this approach adds a whole new set of boxes that
>   > can mess up
>   > your routing system.  This does not strike me as a good thing.
>
>=> Which boxes does it add? I really don't see any more
>boxes here. Note, I'm not advocating this particular
>approach (injecting routes from the DNS) but I don't
>agree with your claim above, and I think it can work.
>
>I think something like MLD extensions would be much cleaner.
>
>   > > That's up to your implementation.  The DNS is the only
>   > server using
>   > > this address, so you can tie them together.
>   >
>   > Sure.  One can do the same kind of thing with the DHCP approach (use
>   > SO_REUSEPORT or whatever and tie the DHCP mini server to the DNS
>   > server).
>
>=> I believe you :), in fact, since you read the draft
>(twice now ;) ) you would have seen that DHCP messages
>were also considered for the 'content' part of the
>discovery.
>
>   > The point was just that exactly the same considerations apply to the
>   > anycast proposal as apply to other proposals.
>
>=> I think you're mixing the 'content' of the message
>used for discovery and the method used for transporting
>that message to the right server. Anycast does the latter.
>So I don't know why you're comparing anycast with DHCP.
>DHCP can also use anycast in theory, I never tried
>it.
>
>Hesham
>--------------------------------------------------------------------
>IETF IPng Working Group Mailing List
>IPng Home Page:                      http://playground.sun.com/ipng
>FTP archive:                      ftp://playground.sun.com/pub/ipng
>Direct all administrative requests to [email-masked]
>--------------------------------------------------------------------

--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: Brian Haberman <[email-masked]>
Date: Tue, 30 Apr 2002 10:42:38 -0400

The original anycast extensions draft was incorporated into the
MLDv2 draft (draft-vida-mld-v2-02.txt) which is a MAGMA WG
document.

Regards,
Brian