Subject: RE: DAD vs. DIID

From: "Bound, Jim" <[email-masked]>
Date: Mon, 12 Aug 2002 22:37:59 -0400

Hi Margaret,

> -----Original Message-----
> From: Margaret Wasserman [mailto:[email-masked]]
> Sent: Friday, August 09, 2002 12:05 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: Re: DAD vs. DIID
> 
> 
> 
> Hi Robert,
> 
> >Though, it is not entirely clear to me why
> >the /subnet IID uniqueness rather than the /link
> >uniqueness makes the case of privacy addresses easier.
> 
> To ensure IID uniqueness on a link, a node that implements
> privacy addresses would need to generate a link-local 
> address for each randomly generated IID (in addition to the
> global address generated for privacy), perform DAD on
> that address, and maintain that address for the lifetime
> of the privacy address in order to respond to other nodes'
> DAD messages.
> 
> If we only require IIDs to be unique within a subnet, 
> a node that implements privacy addresses will only need
> to generate the single privacy address and perform
> DAD for that address.
> 
> As currently document (prior to the discussed changes)
> the privacy document is incompatible, in this minor way,
> with the addressing architecture and the autoconfiguration
> documents.  We had two options for what to change:
> 
>          - Relax the uniqueness restriction in the 
>                  addressing architecture, and make
>                  a corresponding change to the 
>                  autoconfiguration document.
>          -OR-
>          - Modify the privacy address document to 
>                  require the creation and maintenance of
>                  link-local addresses, as described above.
> 
> We had a consensus within the room in Yokohama to choose
> the first option, and we are currently checking that
> consenus with the list.

We had no such consensus.  In fact it was stated we had to take this to the mail list.

Many of us were concerned that we wanted to know what problem we are trying to solve. That has been stated by your mail now and that is good.

But now we need to discuss the ramifications on this list and if it is warranted.

regards,
/jim

> 
> Margaret
> 
> 
> 
> 
> --------------------------------------------------------------------
> IETF IPng Working Group Mailing List
> IPng Home Page:                      http://playground.sun.com/ipng
> FTP archive:                      ftp://playground.sun.com/pub/ipng
> Direct all administrative requests to [email-masked]
> --------------------------------------------------------------------
> 

--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: Robert Elz <[email-masked]>
Date: Tue, 13 Aug 2002 21:52:27 +0700

Date:        Mon, 12 Aug 2002 22:37:59 -0400
    From:        "Bound, Jim" <[email-masked]>
    Message-ID:  <[email-masked]>

  | We had no such consensus.

Yes, in the room, there was very clear support for this.  Margaret
was correct.

  | In fact it was stated we had to take this to the mail list.

Of course it was - all WG decisions get made on the list, so everything
"decided" in the room has to be taken to the list.

That is what is happening now...

kre