Subject: Proposal: DAD Optimization using Multicast Listener Discovery

From: Greg Daley <[email-masked]>
Date: Tue, 27 Aug 2002 16:47:20 +1000

Hi Everyone,

I've been thinking about how we can use MLD to
determine if anyone else is defending an address using DAD.

The MLD RFC indicates that a node's link-scope multicast
addresses except all-nodes link-scope must be joined
using MLD.

Since the router receives MLD reports from all devices it
knows whether a multicast group is active on the subnet
(or should that be link(s)?) for which it is the Querier.

If there are no listeners for the solicited-node multicast
of the tentative address, then no-one may be DAD
defending the address(es) associated with this multicast group.
Therefore no-one may have one of these addresses.

This means that a node which is aware that it is the first
to join this group does not have to complete DAD, because
there are can be no other devices which have this address
configured.

The mechanism I propose to do this for a host to send an
extension of an MLD query message, specifying the group
which the host wishes to join.

The Router which holds a list of all the multicast groups
sends back a UNKNOWN_GROUP indication in a (modified)
MLD report message if the address is unknown.

Reception this message may be used to finish DAD early.

If the group is currently active at the Router (and the
router responds with an ACTIVE_GROUP message), or if
the router does not respond within the timeout period,
DAD must be completed in accordance with RFC 2462.

In all cases (on timeout, or reception of a response from
the Router) an MLD Report is sent from the host to join the
multicast group.

Backoff mechanisms to prevent DoS on the nodes and Router
are being considered.

Our team will try to have a draft for discussion within
a couple of days.

Greg Daley
Centre for Telecommunications and Information Engineering
Monash University

--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: "Dave Thaler" <[email-masked]>
Date: Wed, 28 Aug 2002 11:27:02 -0700

> From: Robert Elz [mailto:[email-masked]] 
[...]
> | I don't understand how not doing DAD relates to DIID.  I thought
> | (possibly mistakenly) that the proposal that Steve Deering presented
was
> | to do with eliminating the delay introduced DAD for addresses that
are
> | unlikely to conflict with others, allowing faster aquisition of new
> | addresses (helpful for mobile nodes).
>
> Yes, it did all that.   But it turns out that to make DIID really
work,
> it would be close to essential to do this.   Just why is no longer
really
> relevant (Steve can explain if he feels inclined).

I agree with Brett.  I still strongly support Steve's proposal
with DAD.  It reduces the startup delay in most scenarios.

-Dave