Subject: RE: need clarification of "deprecated" address [multihomed case]

From: "Bound, Jim" <[email-masked]>
Date: Mon, 26 Aug 2002 13:52:47 -0400

this would all have to be done out of band just like tcp from addr conf like daemon that listens to the RAs and/or timers.

/jim

> -----Original Message-----
> From: Bill Sommerfeld [mailto:[email-masked]]
> Sent: Tuesday, August 20, 2002 7:09 PM
> To: Peter Lei
> Cc: [email-masked]
> Subject: Re: need clarification of "deprecated" address [multihomed
> case] 
> 
> 
> > However, should any new connections (SCTP associations) 
> FROM this host to
> > a peer list the deprecated address as part of the 
> association?  Given the
> > existing text and this discussion, it seems that it should 
> not, as other
> > preferred address(es) are available.  Of course unless as 
> qualified by the
> > proposed text below-- that it is the only address available 
> (eg. the host
> > is single homed/has a single valid address which happens to 
> be a deprecated
> > address).
> 
> Does SCTP provide some way to describe a preferred order over the
> addresses, or is the address set inherently unordered?  Does it
> provide a way to delete an address from an active connection?
> 
> If there is an ordering, pushing deprecateds to the bottom of the
> barrel (and deleting them when they expire) sounds most robust and in
> keeping with the rest of the discussion on this thread.
> 
> 					- Bill
> 
> --------------------------------------------------------------------
> IETF IPng Working Group Mailing List
> IPng Home Page:                      http://playground.sun.com/ipng
> FTP archive:                      ftp://playground.sun.com/pub/ipng
> Direct all administrative requests to [email-masked]
> --------------------------------------------------------------------
> 

--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: "Bound, Jim" <[email-masked]>
Date: Mon, 26 Aug 2002 13:53:19 -0400

which ID is this?
thanks
/jim

> From: Peter Lei [mailto:[email-masked]]
> Sent: Wednesday, August 21, 2002 12:14 AM
> To: [email-masked]
> > > existing text and this discussion, it seems that it 
> should not, as other
> > > proposed text below-- that it is the only address 
> available (eg. the host
> > > is single homed/has a single valid address which happens 
> to be a deprecated
> > > address).
> > 
> I agree, but the address list is unordered (there is no 
> implied preference
> order), hence my thought that they should probably not be 
> included in the
> list.
> 
> And yes, there is a way to delete an address from an active 
> association,
> but that is currently an I-D and not part of RFC 2960; hence, 
> for existing
> association(s) that have addresses that become deprecated, 
> then expire,
> there is a mechanism to delete them from the association(s).
> 
> --peter