Subject: RE: Anycast address - How to find the "nearest" router?

From: "Sivaramakrishnan A" <[email-masked]>
Date: Thu, 15 May 2003 15:06:50 +0530

Hi,

I accept that the route table organisation can help to find the
nearness of any router. So (In this case) do you mean, both R1 
and R2 should agree upon themselves, that who should process 
the packet anycast addressed packet ? If yes, how could this be
achieved?

How can NS-NA exchange help us resolve who should receive the packet?

thanks,
Sivaramakrishnan. A 

-----Original Message-----
From: Suvidh Mathur [mailto:[email-masked]]
Sent: Thursday, 15 May 2003 1:51 PM
To: [email-masked]
Subject: Re: Anycast address - How to find the "nearest" router?

Hi,

What exactly do you mean by "nearest"?

As per the RFC, nearest should be based on the routing protocols' notion of
distance. Thus if R1 is nearer then R2, then the packet should reach R1
alone.
If R1 and R2 are equi-distant, then either the routing table organization
(at the sending nore and / or the intermediate routers) or NS - NA exchange
(in case of R1 and R2 being onlink) should ensure that the packet is sent
only to one of the routers.

Hope this helps,

Regards,
Suvidh

Thursday, 15 May, 2003 12:39 PM
To: <[email-masked]>
cc:
From: "Sivaramakrishnan A" <[email-masked]>
Subject: Anycast address - How to find the "nearest" router?

Hi,
I have 2 Routers  ( R1 and R2) in a link who are configured the same
ANYCAST
address.
A packet is addressed to that anycast address. According to [ADDR-ARCH] the
"nearest"
one shoule receive this packet. Assume R1 is the "nearest" one here. But
how
does R1 know
that "I'm the nearest, and I should process this packet?" . If  Suppose if
R1 is nearer, how is
R2 restricted from processing the packet?
thanks and regards,
Sivaramakrishnan. A

***************************************************************************
This message is proprietary to Future Software Limited (FSL) 
and is intended solely for the use of the individual to whom it
is addressed. It may contain  privileged or confidential information 
and should not be circulated or used for any purpose other than for 
what it is intended. 

If you have received this message in error, please notify the
originator immediately. If you are not the intended recipient,
you are notified that you are strictly prohibited from using,
copying, altering, or disclosing the contents of this message. 
FSL accepts no responsibility for loss or damage arising from 
the use of the information transmitted by this email including
damage from virus.
***************************************************************************
--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: "Sha Liu" <[email-masked]>
Date: Thu, 15 May 2003 21:43:44 +0800

Hello,
    I believe properly set the Override bit in NA message on that link can reach what you call agreement.
    E.g., R1's NAs for the anycast address set the Override bit to 1, while R2's NAs set it to 0.

---

From: "Sha Liu" <[email-masked]>
Date: Sun, 18 May 2003 21:37:05 +0800

Hi,
    In RFC2461:
    "7.2.4. Sending Solicited Neighbor Advertisements
    If the Target Address is either an anycast address or a unicast address for which the node is providing proxy service, or the Target Link-Layer Address option is not included, the Override flag SHOULD be set to zero. Otherwise, the Override flag SHOULD be set to one. Proper setting of the Override flag ensures that nodes give preference to non-proxy advertisements, even when received after proxy advertisements, and also ensures that the first advertisement for an anycast address "wins"."

---

From: "Sivaramakrishnan A" <[email-masked]>
Date: Mon, 19 May 2003 10:36:54 +0530

Hi,

When sending NA for anycast address, the Override Bit should always be set
to 0. So the
Neighbour Cache of the node receiving this NA is updated from the First
advertisement!
All other nodes sending NA for that anycast address, would also send with O
bit set to
0 which will have no effect on the Neighbour cache of the receiving Node.
Hence, as you
specified "the first advertisement for an anycast address 'wins' "!

regards,
Sivaramakrishnan. A

-----Original Message-----
From: Sha Liu [mailto:[email-masked]]
Sent: Sunday, 18 May 2003 7:07 PM
To: [email-masked]
Cc: [email-masked]
Subject: Re: Anycast address - How to find the "nearest" router?

Hi,
    In RFC2461:
    "7.2.4. Sending Solicited Neighbor Advertisements
    If the Target Address is either an anycast address or a unicast address
for which the node is providing proxy service, or the Target Link-Layer
Address option is not included, the Override flag SHOULD be set to zero.
Otherwise, the Override flag SHOULD be set to one. Proper setting of the
Override flag ensures that nodes give preference to non-proxy
advertisements, even when received after proxy advertisements, and also
ensures that the first advertisement for an anycast address "wins"."