Subject: RE: Draft on Globally Unique IPv6 Local Unicast Addresses

From: "Bound, Jim" <[email-masked]>
Date: Fri, 16 May 2003 18:39:02 -0400

This is transparent to applications completely.
/jim

> -----Original Message-----
> From: Alain Durand [mailto:[email-masked]] 
> Sent: Wednesday, May 14, 2003 5:47 PM
> To: Pekka Savola
> Cc: Bob Hinden; Margaret Wasserman; [email-masked]
> Subject: Re: Draft on Globally Unique IPv6 Local Unicast Addresses
> 
> 
> 
> On Tuesday, May 13, 2003, at 10:58  AM, Pekka Savola wrote:
> 
> > On Tue, 13 May 2003, Bob Hinden wrote:
> >>> Bob's proposal explicitly defines a type of addresses 
> that are not 
> >>> expected to be routed throughout the Internet.  So, these 
> addresses 
> >>> are local, not globally routable.
> >>>
> >>> However, Bob's proposal defines addresses that are unique 
> throughout 
> >>> the Internet.  No single address identifies one node when used 
> >>> within one "scope" and another node when used in another 
> "scope".  
> >>> So, these are not "scoped addresses", as defined in the 
> IPv6 Scoped 
> >>> Addressing Architecture.
> >>>
> >>> I *think* that Bob and I are using the same definition 
> for the term 
> >>> "scoped", but I hope he'll correct me if I'm wrong.
> >>
> >> I tried hard to not define the term "scoped address".  I only used
> >> the word
> >> "scope" once in the draft and that referred to global scope 
> >> addresses.  I
> >> may remove that use in the next version :-)
> >>
> >> The globally unique IPv6 local unicast addresses are not limited in
> >> their
> >> use to any scope less than global by their design because they have
> >> prefixes that are globally unique.  By comparison site-local 
> >> addresses were
> >> limited to a limited scope by their design because they had 
> >> non-globally
> >> unique prefixes.
> >>
> >> So yes, I think we agree.
> >
> > What would you propose to do with default address selection, if any?
> >
> > Should a preference in it be given to truly global or 
> globally unique 
> > local addresses, or should these be indistinguishable from 
> the point 
> > of view?
> >
> > This "addresses tried first" ordering is of some importance -- which
> > one
> > reason for having this "scope" concept.
> 
> Pekka is right. The real question behind Bob's proposal is 
> not so much to know if it creates scopes or not, but what is 
> the impact on the 
> applications.
> 
> If applications need to be aware of those addresses and take 
> different 
> actions
> if/when different combination of "bob's" or "regular" 
> addresses exist, 
> we
> end up with much of the issues we had with Site Local, ambiguity 
> excepted.
> This needs to be clarified.
> 
> 	- Alain.
> 
> 
> --------------------------------------------------------------------
> IETF IPng Working Group Mailing List
> IPng Home Page:                      http://playground.sun.com/ipng
> FTP archive:                      ftp://playground.sun.com/pub/ipng
> Direct all administrative requests to [email-masked]
> --------------------------------------------------------------------
> 

--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: Pekka Savola <[email-masked]>
Date: Sat, 17 May 2003 08:28:05 +0300 (EEST)

> This is transparent to applications completely.

And to the operating system?  Can in distinguish between the addresses?

> > -----Original Message----- From: Alain Durand
> > [mailto:[email-masked]] Sent: Wednesday, May 14, 2003 5:47 PM
> > To: Pekka Savola Cc: Bob Hinden; Margaret Wasserman;
> > [email-masked] Subject: Re: Draft on Globally Unique IPv6
> > Local Unicast Addresses
> > 
> > 
> > 

-- 
Pekka Savola                 "You each name yourselves king, yet the
Netcore Oy                    kingdom bleeds."
Systems. Networks. Security. -- George R.R. Martin: A Clash of Kings