Subject: RE: Avoiding interface failure upon DAD failure

From: Hesham Soliman <[email-masked]>
Date: Wed, 7 May 2003 10:28:50 -0400

> Did anyone ever notice a problem with selecting a new 
 > link-local address?
 > Isn't this what happens if a device tries to use a 3041 
 > address which has a
 > conflict?

=> I would like to add that this is also needed for 
the global care-of address (i.e. pick another address
if DAD fails according to RFC 3041). 

Hesham

--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: Vladislav Yasevich <[email-masked]>
Date: Wed, 07 May 2003 11:04:56 -0400

Hesham

> if DAD fails according to RFC 3041). 

I don't think so.  The global COA is usually formed with
the same ID as link local.  So, if the link-local was
gnerated using 3041 (as the mobile spec suggests), the
global whould simply re-use the ID generated for the link-local
address.  So no special cases is needed.

-vlad

-- 
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
Vladislav Yasevich		Tru64 UNIX Network Group
Hewlett Packard 		Tel: (603) 884-1079
Nashua, NH 03062		ZKO3-3/T07