Subject: RE: Avoiding interface failure upon DAD failure

From: [email-masked]
Date: Fri, 9 May 2003 15:13:41 +0300

Hi Mika,

> On Thu, 2003-05-08 at 23:34, Jari Arkko wrote:
> > Anyway, what should we do with the probabilities? Are you
> > saying that everything with a smaller probability than
> > radio problems should not be pursued?
> 
> It's part of the cost-benefit analysis. If the probability of collision
> is low enough not to be a significant factor in the total failure rate,
> the user is not going to see any difference one way or the other. If
> this is the case, the added implementation complexity is not 
> warranted.
> 
> > Perhaps the argument is that the probability is neglible.
> > It is, I agree. Still, shouldn't we do the right thing
> > even if the probability of the bad thing happening is
> > very small?
> 
> Only if the cost-benefit analysis makes sense.

I agree with you in principle, but part of the cost-benefit analysis
should also consider the 'predictability' of failure.  What
I mean is that if the DAD failure happened everytime that you tried
to connect to a specific access point, then the cost would be
very high (in my opinion). However, if the DAD failure is
fairly random and does not measurably increase the total rate of
failure of connecting, then I would think that adding complexity
to the specification is not warrented.

Has anyone come-up with cases where DAD would fail? 

thanks,
John

--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: Francis Dupont <[email-masked]>
Date: Fri, 09 May 2003 14:33:56 +0200

In your previous mail you wrote:

=> real case: manual setup of a router (so without autoconf) with
a manual IID (common if you need to know it, 1 is easier than
260:5cff:fef4:90f :-) copied without care to another router.
IMHO DAD failures are far more frequent when not automatical config
is used, i.e., for routers and boxes running some services like DNS.

Thanks

[email-masked]