Subject: [Call for Feedback] Applicability Statement for IPv6 DAD

From: Soohong Daniel Park <[email-masked]>
Date: Fri, 11 Jul 2003 14:22:47 +0900

Dear folks

Once I discussed a DAD related issue "IPv6 DAD Consideration for 802.11"
in IPv6 mailing list, I received some feedback and request to make a
document
like above subject.

Recently, some drafts are trying to contribute optimized and expanded
IPv6 DAD
for various environments but we can not find out any references.
So I have written very rough document right now, and I would like to
listen more feedback from many experts in IPv6 WG.

http://home.megapass.co.kr/~natpp00/ApplicabilityStatementforIPv6DAD.txt

I think this would be useful contribution to IPv6 wg as working item.

Please let me know your view on this with your feedback and comment.

Daniel (Soohong Daniel Park)
Mobile Platform Lab,SAMSUNG Electronics

--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: Greg Daley <[email-masked]>
Date: Tue, 22 Jul 2003 10:21:33 +1000

Hi Daniel,

It looks like there are three largely unrelated
sections in the draft (or only related in that
DAD is involved).

Firstly, there are the issues of MAC address
duplication and source address filtering
for DAD packets.

Secondly there are descriptions of
existing DAD optimizations.

Thirdly, there are references to some protocols
which use NS (DAD) packets to do some
additional configuration.

At this stage, (I know it is a -00 draft),
my guess is that the description of the issues
with MAC duplication and filtering aren't
of great interest to many in IPv6
standardization.   (Since for those
intimate with Neighbor Discovery, the
statements are {believed to be} reasonably
well understood).

Even though I say that, it is likely that
people who run the networks (as opposed to
standardizing them) may gain something
from explicitly stating these issues in a
document.

If this is the case, though, I wouldn't
put that work into a document with any
other data (not even the optimization work).

The survey and comparison of the existing
DAD schemes is good to have, but maybe not
in IPv6 at this time.  The DNA BoF showed
interest at the meeting on Friday to look
into DAD optimization schemes.  Maybe
this is where that section should be
targeted at this stage (maybe as a separate
document).

I'm not sure what to do about the third
section (DNA configuration using DAD).

Greg