Subject: doubt in IPv6 Default address selection

From: Jayabharathi <[email-masked]>
Date: Mon, 14 Jul 2003 10:52:13 +0530

Hi ,

I got a doubt while reading rfc 3484(Default Address Selection for Internet protocol version 6).

The deafult policy table is given as follows,

Prefix        Precedence Label
      ::1/128               50     0
      ::/0                      40     1
      2002::/16           30     2
      ::/96                    20     3
      ::ffff:0:0/96         10     4

If a destination address which is not mapping to any of the listed prefixes in the policy table, what should be the precedence value to be used.

For example, a destination address prefix 3ffe::/16 is given, what should be the precedence used in this case???

One more doubt,

Each and every prefix presented in the default policy table maps to an unique address type,
Can't we make it as address type, instead of Prefix while implementing the same.

Pls clarify 

regds
Jaya

---

From: "Dave Thaler" <[email-masked]>
Date: Tue, 15 Jul 2003 12:21:29 -0700

Jaya, 
Since the default route (::/0) is in the table you list below, every destination address will match an entry in the table.  The address in your example matches the second row, so the precedence would be 40.
 
Also, prefixes are more general than address types so you can express more granular policies.
 
Hope this helps,
-Dave

________________________________

From: [email-masked] on behalf of Jayabharathi
Sent: Sun 7/13/2003 10:22 PM
To: [email-masked]
Subject: doubt in IPv6 Default address selection

Hi ,

 
Prefix        Precedence Label
      ::1/128               50     0
      ::/0                      40     1
      2002::/16           30     2
      ::/96                    20     3
      ::ffff:0:0/96         10     4

 
One more doubt,

Pls clarify 
 
regds
Jaya

--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------