Subject: Is 2001:250:5400:: a valid IPv6 address?

From: "Liusand" <[email-masked]>
Date: Tue, 15 Jul 2003 18:28:10 +0800

I failed to configure it as a gateway for 2000::/3 route on both usagi-linux24-stable-20030214 and usagi-linux24-s20030609, the command, "ip -6 route add 2000::/3 via 2001:250:5400:: dev eth0"  reported "RTNETLINK answers: Invalid argument". But I made it the "default" gateway easily on both Linux 2.4.18 kernel and Red Hat 2.4.20-8 kernel.

--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: Pekka Savola <[email-masked]>
Date: Tue, 15 Jul 2003 13:54:31 +0300 (EEST)

On Tue, 15 Jul 2003, Liusand wrote:
>   I failed to configure it as a gateway for 2000::/3 route on both
> usagi-linux24-stable-20030214 and usagi-linux24-s20030609, the command,
> "ip -6 route add 2000::/3 via 2001:250:5400:: dev eth0"  reported
> "RTNETLINK answers: Invalid argument". But I made it the "default"
> gateway easily on both Linux 2.4.18 kernel and Red Hat 2.4.20-8 kernel.

You're running your system as a router, and 2001:250:5400:: (subnet router
anycast address) points to the loopback, I suspect.

But in any case, this is not the right place to ask such questions.  
Use USAGI mailing lists.

-- 
Pekka Savola                 "You each name yourselves king, yet the
Netcore Oy                    kingdom bleeds."
Systems. Networks. Security. -- George R.R. Martin: A Clash of Kings