Subject: Re: Re: [I-D] IPv6 DAD Consideration for 802.11 Environment

From: 박수홍 <[email-masked]>
Date: Sat, 05 Jul 2003 17:05:20 +0900

>The purpose of DAD is not to detect MAC address duplication, but IP 
>address duplication.

Generally, MAC (IEEE 802 48bit) duplication occurs IP address duplication
with same Interface ID.
Also I didn't mention that the purpose of DAD was to detect MAC duplication in this draft.
The intent of this approach is that we can not detect the same MAC and IP address in 802.11 environment
with existing DAD procedure.

>Perhaps this would speak for some form of applicability statement for DAD, 
>to be clear what it is meant to solve and what it isn't.

So far there is not any applicability statement for DAD without
802.11 environment.

Daniel (Soohong Daniel Park)
Mobile Platform Lab. Samsung Electronics
TEL:+82-31-200-4508  FAX:+82-31-200-3147
mailto:[email-masked]

--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: Pekka Savola <[email-masked]>
Date: Sat, 5 Jul 2003 13:55:46 +0300 (EEST)

> with existing DAD procedure.

DAD does not detect (or rather, is not meant to detect) MAC duplication in 
regular wired Ethernet.

Then why not being able to detect it in 802.11 is a problem?

Note that DAD as specified still works in 802.11 perfectly, AFAICS.

> So far there is not any applicability statement for DAD without

Which was my point: one should be created :-)

-- 
Pekka Savola                 "You each name yourselves king, yet the
Netcore Oy                    kingdom bleeds."
Systems. Networks. Security. -- George R.R. Martin: A Clash of Kings

---

From: Syam Madanapalli <[email-masked]>
Date: Mon, 07 Jul 2003 15:18:44 +0530

Hello Pekka,

----- Original Message -----
From: "Pekka Savola" <[email-masked]>
To: "???" <[email-masked]>
Cc: "Bob Hinden & Margaret Wasserman" <[email-masked]>;
<[email-masked]>; <[email-masked]>
Sent: Saturday, July 05, 2003 4:25 PM
Subject: Re: Re: [I-D] IPv6 DAD Consideration for 802.11 Environment

> DAD does not detect (or rather, is not meant to detect) MAC duplication in

When MAC is duplicated and the node filters the frames based
on Source MAC, DAD is no good. This is true even if the IPv6 address
is being constructed using random interface identifier.

And if MAC is unique and IID is being derived from MAC address,
then also DAD is no good. In this case, DAD is useful, if IID is a random
identifier.

> Then why not being able to detect it in 802.11 is a problem?

If the wired ethernet also does the source filtering based on MAC
address, then it is a problem with both of them (Wired and Wirelss).