Subject: RE: avoiding NAT with IPv6

From: <[email-masked]>
Date: Thu, 17 Jul 2003 12:11:45 +0300

Hi Jordi,

> If we include, for example, in the node-requirements, that 
> one of the IPv6 node requirements is to "avoid" the support of NAT or any
> other kind of address translation mechanism (I'm not 
> suggesting exactly this way to say it), any vendor that do that, can be
> "banned" by the community and the Interop/Conformance test, 
> because he is not complying with the specs.
>
> Some still will do that, but we can then tell the network 
> managers and users, that the product is NOT IETF complaint.

I feel ambigious about this - avoiding NATs is a good thing, however
IETF is not a protocol enforcement agency.  Interop & conformance
testing happens outside of the IETF, so I am not sure this is
in scope for the IETF.

Additionally, the WG chairs chartered the Node Requirements work
to document existing requirements, and I actually don't think
we have any IPv6 RFCs that have any related statements like
'You MUST NOT NAT IPv6' ... so I am unsure how to procede on
this subject.  

That noted, there are well known RFCs published already on
the dangers of NATing, so I'm not sure what good it would do
to put something in the Node Requirements document.

Finally, I actually don't know what a reasonable requirement
would be to add to cover this.  If you think you have good text,
please send it on the mailing list.

John

--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: "JORDI PALET MARTINEZ" <[email-masked]>
Date: Thu, 17 Jul 2003 11:24:37 +0200

Hi John,

I know this is a difficult topic, and we don't enforce the vendors, but we do "de facto".

I mean, if a vendor don't pass a given RFC in a conformance/interoperability, because they do NAT, then a lot of customers (ISPs,
Telcos) will not purchase it, because that's what the market do most of the time. And this is a "market" enforcement ...

What about something like:

IPv6 has enough addressing space that allows avoid the need of any kind of address translation, that is considered harmful according
[RFCxxxx]. Consequently, IPv6 nodes MUST NOT support any kind of address translation.

Regards,
Jordi

----- Original Message ----- 
From: <[email-masked]>
To: <[email-masked]>; <[email-masked]>
Sent: Thursday, July 17, 2003 11:11 AM
Subject: RE: avoiding NAT with IPv6

Hi Jordi,

John

*****************************
Madrid 2003 Global IPv6 Summit
Presentations and videos on-line at:
http://www.ipv6-es.com

---

From: Leif Johansson <[email-masked]>
Date: Thu, 17 Jul 2003 11:27:26 +0200

>please send it on the mailing list.
I think you answered the question already. There are enough widely
deployed applications (sip for instance) which don't really work over
NAT. Given this it would be unfortunate if we didn't take every
oportunity to ensure that those applications won't break in ipv6.

       Cheers Leif

---

From: Hans Kruse <[email-masked]>
Date: Thu, 17 Jul 2003 09:51:20 -0400

But, as has been pointed out many times, getting the address space 
allocated is not always possible/affordable/practical (which is where site 
locals came from).

I would much prefer the approach mentioned before -- create an addressing 
infrastructure that solves known issues better than NAT.  I think the 
current draft(s) being discussed are getting close.

--On Thursday, July 17, 2003 11:24 +0200 JORDI PALET MARTINEZ 
<[email-masked]> wrote:

> IPv6 has enough addressing space that allows avoid the need of any kind
> of address translation, that is considered harmful according [RFCxxxx].
> Consequently, IPv6 nodes MUST NOT support any kind of address translation.
>

Hans Kruse, Associate Professor
J. Warren McClure School of Communication Systems Management
Adjunct Associate Professor of Electrical Engineering and Computer Science
Ohio University, Athens, OH, 45701
740-593-4891 voice, 740-593-4889 fax
--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: "JORDI PALET MARTINEZ" <[email-masked]>
Date: Thu, 17 Jul 2003 16:41:05 +0200

Agree, but doing both things (address space and avoid NAT) will be more useful than just one.

Regards,
Jordi