Subject: site-local observations from the outside

From: "Todd T. Fries" <[email-masked]>
Date: Mon, 4 Aug 2003 11:38:27 -0500

While I do not pretend to be the most versed in all of the IPv6 related RFC's,
I am questioning what the goals of site-local or a similar replacement
would be.

Either you have link-local addresses, or you have global routable addresses.

Any attempt at providing something that is site local suggests to me that
you open the doors wide for something like NAT, which of course none of
us wants.

There is enough address space in the global table, why can we not have some
sort of free reservation system (the free tunnel brokers would suggest it
is economically feasible) for sites that want local addresses but do not
intend on globally routing them.

Should these sites want connectivity to the global internet, they would then
get an allocation from their ISP as necessary.

I expect I'm missing something, but perhaps not.
-- 
Todd Fries .. [email-masked]

Free Daemon Consulting, LLC                    Land: 405-748-4596
http://FreeDaemonConsulting.com              Mobile: 405-203-6124
"..in support of free software solutions."

Key fingerprint: 37E7 D3EB 74D0 8D66 A68D  B866 0326 204E 3F42 004A
            Key: http://todd.fries.net/pgp.txt

(last updated 2003/03/13 07:14:10)

--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: "JORDI PALET MARTINEZ" <[email-masked]>
Date: Mon, 4 Aug 2003 18:58:30 +0200

Hi Todd,

I feel that we will have NAT-like situation in both cases (with/without site-local).

If we don't provide a "site-local" kind of address space (I prefer to say limited-range), the people will use any global prefix,
trying to filter it, and sometimes creating global routing problems/conflicts.

Take a look at http://www.ietf.org/internet-drafts/draft-hain-templin-ipv6-limitedrange-00.txt.

Regards,
Jordi

----- Original Message ----- 
From: "Todd T. Fries" <[email-masked]>
To: <[email-masked]>
Sent: Monday, August 04, 2003 6:38 PM
Subject: site-local observations from the outside

> I expect I'm missing something, but perhaps not.

*****************************
Madrid 2003 Global IPv6 Summit
Presentations and videos on-line at:
http://www.ipv6-es.com