Subject: RE: Moving forward on Site-Local and Local Addressing

From: "Christian Huitema" <[email-masked]>
Date: Sun, 10 Aug 2003 11:37:02 -0700

> Actually, I believe we do not have a birthday paradox issue in this case.
> The birthday paradox would exist only if ALL 1.2 million self-drawn prefixes would see each other.
> However, in our scenario, the merging of two enterprises, only the two local prefixes may collide with each other.
> They can not collide with the other 1.2 million or any other number of prefixes out there.
> Thus, the probability remains 2^-40.

The individual probability of two domains colliding is x=2^-40, but the global result on the Internet is a somewhat larger. If we have N domains, and each peers with M other domains, then the probability of absence of collision for each domain is:
          p1 = (1-x)^M
The probability that no collision will be observed in the whole Internet is
          p2 = (1-x)^MN
I believe we can easily find a value of N (say 10 billion) and M (say 100) where p2 is close to 1, i.e. some poor guy somewhere is going to get stuck.
 
Which means that we should build an escape hatch: easy renumbering & number registration come to mind.
 
-- Christian Huitema

--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: "Nir Arad" <[email-masked]>
Date: Sun, 10 Aug 2003 22:52:21 +0200

10 billion organizations, each merging with 100 other, distinct organizations?

When Mathematicians talk about "0 probability events", I think that's what they mean... ;-)

Surely, even taken the 2^-40 probability, some poor guy can get stuck - I agree with that.
(I can imagine him thinking, "I should not have ignored this MD5 part...")

Regards,

-- Nir Arad

----- Original Message ----- 
From: "Christian Huitema" <[email-masked]>
To: "Nir Arad" <[email-masked]>; <[email-masked]>
Sent: Sunday, August 10, 2003 8:37 PM
Subject: RE: Moving forward on Site-Local and Local Addressing

> The individual probability of two domains colliding is x=2^-40, but the global result on the Internet is a somewhat
larger. If we have N domains, and each peers with M other domains, then the probability of absence of collision for each