Subject: RE: I-D ACTION:draft-hinden-ipv6-global-local-addr-01.txt

From: "Peter Barany" <[email-masked]>
Date: Wed, 6 Aug 2003 14:34:58 -0500

Hi,

Two questions about this I-D:

(1) In Section 3.2.3 "Sample Code for Pseudo-Random Global ID Algorithm",
step (1) of the algorithm states:
"Obtain the current time of day in 64-bit NTP format (NTP)"
Question: Would it be possible to have the I-D specify that "how the current
time of day is obtained is beyond the scope of this document"?
(2) In Section 7.0 "DNS Issues", the last paragraph states:
"For future study names with logically unique IPv6 local addresses may be
resolved inside of the site using dynamic naming systems such as Multicast
DNS".
Question: Are you referring to <draft-ietf-dnsext-mdns-22.txt>?

Regards,

Pete

-----Original Message-----
From: Bob Hinden [mailto:[email-masked]]
Sent: Friday, June 13, 2003 4:25 PM
To: [email-masked]
Subject: Fwd: I-D ACTION:draft-hinden-ipv6-global-local-addr-01.txt

FYI.  Changes include:

       o Added section on scope definition and updated application
         requirement section.
       o Clarified that, by default, the scope of these addresses is
         global.
       o Renumbered sections and general text improvements
       o Removed reserved global ID values
       o Split Global ID values into centrally assigned and local
         assignments and added text to describe local assignments
       o Added pseudo code for local allocation submitted by Brian
         Haberman and added him as an author.

The draft continues the use of the FC00::/7 prefix as I didn't see (as the 
author) a clear consensus to change it.

Bob

>To: IETF-Announce: ;
>From: [email-masked]
>Reply-to: [email-masked]
>Subject: I-D ACTION:draft-hinden-ipv6-global-local-addr-01.txt
>Date: Fri, 13 Jun 2003 07:51:35 -0400
>
>A New Internet-Draft is available from the on-line Internet-Drafts 
>directories.
>
>
>         Title           : Globally Unique IPv6 Local Unicast Addresses
>         Author(s)       : R. Hinden
>         Filename        : draft-hinden-ipv6-global-local-addr-01.txt
>         Pages           : 13
>         Date            : 2003-6-12
>
>This document defines an unicast address format that is globally
>unique and is intended for local communications, usually inside of a
>site.  They are not expected to be routable on the global Internet
>given current routing technology.
>
>A URL for this Internet-Draft is:
>http://www.ietf.org/internet-drafts/draft-hinden-ipv6-global-local-addr-01.
txt
>
>To remove yourself from the IETF Announcement list, send a message to
>ietf-announce-request with the word unsubscribe in the body of the message.
>
>Internet-Drafts are also available by anonymous FTP. Login with the
username
>"anonymous" and a password of your e-mail address. After logging in,
>type "cd internet-drafts" and then
>         "get draft-hinden-ipv6-global-local-addr-01.txt".
>
>A list of Internet-Drafts directories can be found in
>http://www.ietf.org/shadow.html
>or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
>
>
>Internet-Drafts can also be obtained by e-mail.
>
>Send a message to:
>         [email-masked].
>In the body type:
>         "FILE
/internet-drafts/draft-hinden-ipv6-global-local-addr-01.txt".
>
>NOTE:   The mail server at ietf.org can return the document in
>         MIME-encoded form by using the "mpack" utility.  To use this
>         feature, insert the command "ENCODING mime" before the "FILE"
>         command.  To decode the response(s), you will need "munpack" or
>         a MIME-compliant mail reader.  Different MIME-compliant mail
readers
>         exhibit different behavior, especially when dealing with
>         "multipart" MIME messages (i.e. documents which have been split
>         up into multiple messages), so check your local documentation on
>         how to manipulate these messages.
>
>
>Below is the data which will enable a MIME compliant mail reader
>implementation to automatically retrieve the ASCII version of the
>Internet-Draft.
>Content-Type: text/plain
>Content-ID:     <[email-masked]>
>
>ENCODING mime
>FILE /internet-drafts/draft-hinden-ipv6-global-local-addr-01.txt
>
><ftp://ftp.ietf.org/internet-drafts/draft-hinden-ipv6-global-local-addr-01.
txt>

--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 07 Aug 2003 14:01:27 +0200

> Peter Barany wrote:
> (1) In Section 3.2.3 "Sample Code for Pseudo-Random Global ID Algorithm", step (1) of the algorithm states:
> Question: Would it be possible to have the I-D specify that "how the current time of day is obtained is beyond the scope of
> this document"?

What is specified is the format, not the source. It's necessary to specify 
a format in order to specify an algorithm.

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Brian E Carpenter 
Distinguished Engineer, Internet Standards & Technology, IBM 

NEW ADDRESS <[email-masked]> PLEASE UPDATE ADDRESS BOOK