Subject: RE: AD response to Site-Local Appeal

From: "Michel Py" <[email-masked]>
Date: Fri, 1 Aug 2003 16:26:47 -0700

Steve,

> Steven M. Bellovin wrote:
> Tony -- to make life easier for all concerned, please state
> explicitly what recourse you're asking for from the IESG.
> As things stand now, even if we agreed with everything you say,
> we wouldn't know exactly what you want us to do.  

IMHO the ultimate goal is to handle the deprecation situation by having
the IESG make a decision that will lead the ipv6 WG into taking the
appropriate path towards it.

IMHO, this path is:

1. The WG will publish a document describing the requirements to replace
site-local addresses.

2. The WG will publish one and possibly/preferably more than one
document(s) describing solutions to replace site-locals that meet the
requirements (it could be a good idea to merge close-enough drafts at
some point).

3. The WG will publish a deprecation proposal document. This document
will mostly propose to deprecate existing site-locals and develop one of
solutions issued from 2.

THEN, having provided enough time to review the deprecation proposal and
the merits of the proposed replacement(s) the WG will be able to make an
educated decision whether or not deprecating site-locals in appropriate
(one criteria being that the proposed replacement has less problems than
the current site-locals), and if yes which one(s) of the proposed
replacement(s) is to be developed.

Michel.

--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: "Michel Py" <[email-masked]>
Date: Mon, 4 Aug 2003 07:42:15 -0700

Brian,

> Brian E Carpenter wrote:
> Personally, I'd advise customers who believe they need local
> addresses to continue using FEC0 until the addressing
> architecture is revised and products catch up.

Customers don't like incertitude when designing networks and will delay
IPv6 deployment until this is settled.

Michel.

---

From: "Michel Py" <[email-masked]>
Date: Mon, 4 Aug 2003 08:42:07 -0700

Brian,

> architecture is revised and products catch up.

Oops I goofed. s/incertitude/uncertainty

Customers don't like uncertainty when designing networks and will delay
IPv6 deployment until this is settled.

Michel.

---

From: "Bound, Jim" <[email-masked]>
Date: Sat, 9 Aug 2003 09:46:18 -0400

I support what Brian stated and the ADs please lets move on here.
/jim

> -----Original Message-----
> From: Brian E Carpenter [mailto:[email-masked]] 
> Sent: Monday, August 04, 2003 10:21 AM
> To: [email-masked]
> Cc: [email-masked]
> Subject: Re: FW: AD response to Site-Local Appeal
> 
> 
> Scott Bradner wrote:
> > 
> > fwiw - I fully agree with kre
> > (that has happened before in case anyone wondered)
> 
> fwiw, I don't (and I have both agreed and disagreed with kre 
> and sob in the past).
> 
> I really think this is a distraction. Objectively, the WG is 
> getting on with the three things that need to be done 
> (requirements, an alternative proposal, and a draft 
> deprecation document). To me there was manifestly rough 
> consensus for this course of action: what else could 
> "deprecate site local" mean to anyone who had been reading 
> the mailing list for the previous several months? The details 
> naturally depend on those three documents, which will have to 
> be taken through due process. There was certainly not 
> unanimity, or a detailed proposal, when choosing this course of 
> action, but that's no ground for overruling the chairs.
> 
>    Brian
> 
> - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - 
> - - Brian E Carpenter 
> Distinguished Engineer, Internet Standards & Technology, IBM 
> 
> NEW ADDRESS <[email-masked]> PLEASE UPDATE ADDRESS BOOK

---

From: "Bound, Jim" <[email-masked]>
Date: Sat, 9 Aug 2003 09:47:31 -0400

Unfortuneately Michel is 100% correct.  This is an issue already I see
in real deployment analysis.

/jim

> From: Michel Py [mailto:[email-masked]] 
> Sent: Monday, August 04, 2003 10:42 AM
> To: Brian E Carpenter; [email-masked]
> Cc: [email-masked]
> Subject: RE: AD response to Site-Local Appeal
> 
> 
> Brian,
> 
> > Brian E Carpenter wrote:
> > Personally, I'd advise customers who believe they need 
> local addresses 
> > to continue using FEC0 until the addressing architecture is revised 
> > and products catch up.
> 
> Customers don't like incertitude when designing networks and 
> will delay IPv6 deployment until this is settled.
> 
> Michel.
> 
>