Subject: set the flow-label field in ipv6 header

From: Yudi <[email-masked]>
Date: Fri, 24 Dec 2004 07:58:30 -0800 (PST)

I'm student whose doing final project about QoS in
IPv6.
I would like to asked some question 
 
How to set the flow-label field in ipv6 header ?
I read that someone already asked it in mailing list a few
year ago (1998) , here are the site :
http://mailman.isi.edu/pipermail/6bone/1998-May/001583.html
but maybe now, there is a way to set the flow label header.
I try to setup it with sysctl (in freeBSD) with this syntag :
net.inet6.ip6.auto_flowlabel=0 (for deactivate)
and
net.inet6.ip6.auto_flowlabel=1 (for activate)
But I saw with ethereal, the header still no different.
 
nb : I'm using freebsd v 4.9 and v5.3 

Thanks before,
Best Regard

Suyudiana
Student at Electricall Engineering
University of Indonesia

---------------------------------
Do you Yahoo!?
 Yahoo! Mail - 250MB free storage. Do more. Manage less.

--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

---

From: David Malone <[email-masked]>
Date: Tue, 4 Jan 2005 09:58:49 +0000

> But I saw with ethereal, the header still no different.

The auto_flowlabel stuff in FreeBSD only works for TCP connections,
and there was a bug that resulted in it only being set for one side
of the connection. This bug is fixed in 5.3.

(There was also an interesting issue about setting the flowlabel
consistently in the syncookie case, where the kernel needs to
generate the flowlabel from the syncookie if the label on the SYN|ACK
packet is to be the same as on the rest of the flow.)

	David.