Subject: RE: Request to Advance: <draft-ietf-ipv6-ndproxy-00.txt> [RESEND]

From: "Soliman, Hesham" <[email-masked]>
Date: Fri, 28 Jan 2005 15:23:13 -0500

> Alain Durand wrote:
 > ...
 > > The argument that NDproxy will only be used in a certain 
 > environments
 > > where SEND is not needed is clearly bogus, The IETF is not about
 > > defining standards for special cases but for the whole Internet. 
 > 
 > I disagree as a matter of principle. It is perfectly OK to have
 > specs that are incompatible with each other as long as they are
 > never implemented on the same network. It isn't OK to do that without
 > documenting the incompatibility.
 > 
 > It's clear that this argument doesn't apply to end to end
 > protocols, but strictly to things that have topologically limited
 > scope.
 > 
 > Actually we have plenty of examples of this; they are called routing
 > protocols.

=> I don't think this is the right comparison though. Routing protocols
are performing similar functions and are alternatives to each other.
What's being discussed here is two unrelated functions: Security and 
"bridging" that are not compatible. This is quite different.

FWIW I don't have a problem with ndproxy being published while incompatible
with SeND. There are other examples of completely insecure experimental
RFCs, e.g. Fast handoffs. It's essential to make the document consistent though.

Hesham

 > 
 > That doesn't settle the issue of whether SEND and NDproxy are or
 > are not incompatible, but I have no problem with the concept that
 > a given (bridged) LAN can only run one of them.
 > 
 >     Brian
 > 
 > 
 > --------------------------------------------------------------------
 > IETF IPv6 working group mailing list
 > [email-masked]
 > Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
 > --------------------------------------------------------------------
 > 

===========================================================
This email may contain confidential and privileged material for the sole use
 of the intended recipient.  Any review or distribution by others is strictly
 prohibited.  If you are not the intended recipient please contact the sender
 and delete all copies.
===========================================================

--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

---

From: Vijay Devarapalli <[email-masked]>
Date: Fri, 28 Jan 2005 19:46:45 -0800

> RFCs, e.g. Fast handoffs. It's essential to make the document consistent though.

what is being discussed is incompatibility between two
protocols. not insecure experimental protocols. FWIW,
draft-kempf-mobopts-handover-key-00.txt is tring to define
how SEND can be used to create keys for fast handoffs.

Vijay