Subject: RE: PID --- a new option for Stateless Address Auto-Configuration

From: "CTO WEN Haibo" <[email-masked]>
Date: Wed, 7 Jun 2006 10:45:30 +0800

Once the BRAS receives a RS from some special subscriber network, then it can 
periodically send unsolicit RA with Prefix infomraiton opiton and PID option.
In fact, prefix will not be allocated to a subscriber network until it has successful 
passed the authentication in access network. So at the very beginning, BRAS will 
not send RA with prefix information to unauthenticated subscriber networks.
Without this mechanism, hosts in unauthenticated subscriber network can enjoy 
Internet services.

> -----Original Message-----
> From: Lawrence Zou [mailto:[email-masked]]
> Sent: 2006年6月7日 10:12
> To: CTO WEN Haibo; 'IPv6 WG'
> Cc: 'Jari Arkko'; 'Brian Haberman'; 'Bob Hinden'
> Subject: RE: PID --- a new option for Stateless Address
> Auto-Configuration
> 
> 
> I noticed that in your document,the PID is created by the AN and AN
> insert the PID into the RS,
> the BRAS do not know the PID until it received the RS. so at the
> beginning ,the BRAS just only can
> send unsolicit  RA without the PID option,that means maybe all
> subscriber will receive this "general " RA if
> the layer2 AN can forward it.
> 
> >-----Original Message-----
> >From: CTO WEN Haibo [mailto:[email-masked]] 
> >Sent: Wednesday, June 07, 2006 10:00 AM
> >To: Lawrence Zou; IPv6 WG
> >Cc: Jari Arkko; Brian Haberman; Bob Hinden
> >Subject: RE: PID --- a new option for Stateless Address 
> >Auto-Configuration
> >
> >
> >Considering that the prefix allocation of "one prefix per subscriber 
> >network" will be deployed in access network and one prefix 
> will not be 
> >shared by multiple subscriber network, BRAS/router will send the 
> >periodically unsolicit RA to subscriber networks with the <Prefix 
> >Infomration option, PID option> pair.
> >Without PID option, access node doesn't know how to forward 
> the RA to 
> >the correct subscriber network.
> >
> >-Haibo
> >
> >> -----Original Message-----
> >> From: Lawrence Zou [mailto:[email-masked]]
> >> Sent: 2006年6月6日 19:14
> >> To: CTO WEN Haibo; 'IPv6 WG'
> >> Cc: 'Jari Arkko'; 'Brian Haberman'; 'Bob Hinden'
> >> Subject: RE: PID --- a new option for Stateless Address 
> >> Auto-Configuration
> >> 
> >> 
> >> I think the idea in this draft is very good. I only have a 
> question:
> >> 
> >> Does the BRAS/router still send normal unsolict RA that not 
> >along with 
> >> the PID option to the subscriber network?
> >> 
> >> >-----Original Message-----
> >> >From: CTO WEN Haibo [mailto:[email-masked]]
> >> >Sent: Tuesday, June 06, 2006 1:58 PM
> >> >To: IPv6 WG
> >> >Cc: Jari Arkko; Brian Haberman; Bob Hinden
> >> >Subject: PID --- a new option for Stateless Address 
> >> Auto-Configuration
> >> >
> >> >
> >> >Dear all,
> >> >
> >> >With the more and more mature of IPv6 technology, IPv6 will
> >> >sure be deployed in access network. Considering most part of 
> >> >existing network devices in access networks are layer2 
> >> >devices, operators would like to deploy IPv6 services on 
> >> >existing infrastructure as much as possible. 
> >> >Less network devices upgrading to layer3 devices are more 
> favorable.
> >> >
> >> >Draft-wen-ipv6-rsra-opt-pid-00.txt is considering help
> >> >implement IPv6 Stateless Address Auto-Configuration in access 
> >> >network without upgrading access node and CPE to be layer3 
> >> >devices. This option doesn't change 
> >> >the standard IPv6 mechanism, while it adds more availability 
> >> to IPv6.
> >> >Because PID option can co-exist with existing options in SAAC.
> >> >
> >> >FAQ summary is also presented below. Please check it.
> >> >Hope everyone could give some comments on this proposal.
> >> >Thanks in advance.
> >> >
> >> >Best regards,
> >> >
> >> >Haibo
> >> >
> >> >
> >> >A New Internet-Draft is available from the on-line
> >> >Internet-Drafts directories.
> >> >
> >> >	Title		: Port Identifier option for RS/RA 
> >> >messages in IPv6 access network
> >> >	Author(s)	: H. Wen
> >> >	Filename	: draft-wen-ipv6-rsra-opt-pid-00.txt
> >> >	Pages		: 11
> >> >	Date		: 2006-4-4
> >> >	
> >> >This document makes an extension to stateless address auto-
> >> >configuration (SAAC) mechanism by defining Port Identifier 
> >> >option for RS/RA messages in IPv6 access network. This option 
> >> >can make SAAC 
> >> >possible without upgrading access node and CPE to be layer 
> >3 devices.
> >> >
> >> >A URL for this Internet-Draft is:
> >> >http://www.ietf.org/internet-drafts/draft-wen-ipv6-rsra-opt-p
> >id-00.txt
> >> >
> >> >
> >> >================= FAQ summary ===================
> >> >
> >> >/1. co-existence of two scenarios
> >> >
> >> >In future IPv6 access network, the following two scenarios
> >> >will co-exist as the figure shows.
> >> >(1) there is a router in the subscriber network
> >> >(2) there is no router in the subscriber network, and only L2 
> >> >CPE and L2 AN exist.
> >> >
> >> >+--------+    +---------+ A    B +--+------+    +--------------+
> >> >| host1  |----| router1 |--------| L2 AN   |----|  BRAS/router |
> >> >+--------+    +---------+        +---+-----+    +--------------+
> >> >                                C|   |
> >> >                                 |   |
> >> >        +--------+       +-------+-+ |
> >> >        |  host2 |-------| L2 CPE  | |
> >> >        +--------+       +---------+ |
> >> >                                    D|
> >> >           +--------+       +--------++ 
> >> >           |  host3 |-------| L2 CPE  |
> >> >           +--------+       +---------+
> >> >                            /
> >> >                    +------/ 
> >> >                    | host |
> >> >                    +------+
> >> >
> >> >
> >> >/2. motivation of this proposal
> >> >
> >> >Nowadays, operators like to run their access networks as
> >> >simple as possilbe: access node (i.e., AN) is a layer2 device, 
> >> >no routed CPE in the subscriber network. Our goal is to 
> >> >implement Stateless Address Auto-Configuration (SAAC) in 
> >> >access network without 
> >> >upgrading existing devices to be layer3 devices, thus we can 
> >> >protect existing investment. That is to say, our proposal is 
> >> >used for the second scenario in the above section (/1.).
> >> >
> >> >
> >> >/3. The policy for IPv6 prefix allocation
> >> >
> >> >One prefix per subscriber network is deployed. why?
> >> >(1) Many devices in the subscriber network (e.g., PCs, TVs,
> >> >camera, and electrical applicances) will be connected to the 
> >> >Internet. And each device will have an IPv6 global address. 
> >> >(2) That one prefix is shared by multiple subscriber networks in 
> >> >SAAC environment will lead to security issues and also 
> >> >complicated implementation of access node.
> >> >(3) There are so many /64 prefixes, which are adequate for 
> >> >assigning a prefix to each subscriber network.
> >> >
> >> >
> >> >/4. directly customer-to-customer communication.
> >> >
> >> >Directly customer-to-customer communication is not allowed in
> >> >L2 access network by operators. All traffic should firstly go to 
> >> >BRAS/router. In L2 access node, user segregation (or subscriber 
> >> >network segregation) is done on the AN. The traffic from one 
> >> >subscriber network is not allowed to directly enter other 
> >> >subscriber networks(i.e., layer2 segregation).All the packets 
> >> >should go to the BRAS/ router first, then be routed to the 
> >> >appropriate subnet. Current operator 
> >> >has implemented this functionality.
> >> >
> >> >
> >> >/5. The objective of PID
> >> >
> >> >In L2 access network, the subscriber network is connected to
> >> >an AN through subscriber line (i.e., user port of the AN). And 
> >> >the user 
> >> >port information is terminated at the AN. That's why DHCP relay 
> >> >agent option (option 82) for DHCP in IPv4 and PPPoE+ are defined. 
> >> >It's the same for SAAC in access network. When an RS is forwarded 
> >> >by AN to BRAS/router. There is no any information that helps 
> >> >BRAS/ router know the exact origination, then BRAS/router 
> >don't know 
> >> >which prefix should assign to this RS. PID opiton is defined for 
> >> >this purpose.
> >> >
> >> >
> >> >/6. How to use PID option?
> >> >
> >> >Once the L2 AN receives RS message from subscriber network, it
> >> >will insert this PID option with appropriate PID information, 
> >> >and forward to BRAS/router. When the BRAS/router receives this 
> >> >RS, it will advertise a RA message with correct Prefix 
> Information 
> >> >option and PID option. The AN removes the PID option from RA and 
> >> >forward the RA to the appropriate subscriber network.
> >> >
> >> >
> >> >/7. what kind of subscriber network will generate RS 
> message to AN?
> >> >
> >> >Only L2 subscriber network will generate RS to AN.
> >> >RS/RA messages are used to help hosts/terminals to discovery
> >> >prefixes and default router. RS/RA is running between hosts/ 
> >> >terminals and routers.
> >> >(1) When there is a router in the subscriber network as gateway 
> >> >(as shown in the figure above), obviously the RS 
> generated by host 
> >> >(host1) is bounded within the subscriber network.
> >> >The interface of the home router (i.e., the interface A of 
> >> >router1) will not send RS message to access node (i.e., L2 
> >> >AN), then to the 
> >> >BRAS/router. Does the RS/RA message exisit on the 
> >> >point-to-point link of two routers? If the interface A will  
> >> >send RS message, 
> >> >what's the purpose of this RS message. Route information is 
> >> >delivered by routing protocol with link-local addresses. I 
> >> >*don't* think the interface A of router1will send RS message 
> >> >to BRAS/router.
> >> >(2) The RS generated by host 2 will be forwarded by L2 CPE to L2 
> >> >AN, then this L2 AN will add PID option.
> >> >
> >> >In a word, the router in the subscriber network will not send RS
> >> >message to the AN, only the L2 subscriber network will send RS 
> >> >message to access node.
> >> >
> >> >
> >> >/8. the impact of the proposal
> >> >
> >> >The softwares of AN and BRAS/router should support PID option.
> >> >PID option doesn't have any negative impact on existing IPv6 
> >> >mechanism. This proposal aims at implementing SAAC in 
> >> >currently deloyed access network without requesting the 
> >> >replace of exisint devices. It can coexist with the scenario 
> >> >that there is a router in the subscriber network.
> >> >
> >> >---------------------------------
> >> >
> >> 
> >--------------------------------------------------------------------
> >> >IETF IPv6 working group mailing list
> >> >[email-masked]
> >> >Administrative Requests: 
> https://www1.ietf.org/mailman/listinfo/ipv6
> >> 
> >--------------------------------------------------------------------
> >> >
> >> 
> >> 
> >> 
> >
> 
> 
> 

--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

---

From: Lawrence Zou <[email-masked]>
Date: Wed, 07 Jun 2006 11:34:14 +0800

>Sent: Wednesday, June 07, 2006 10:46 AM
so you restrict the BRAS to send unsolict -RA only when it know the PID
after it receive RS from some  special subscriber.

>In fact, prefix will not be allocated to a 
>subscriber network until it has successful 
>not send RA with prefix information to unauthenticated 
>subscriber networks. Without this mechanism, hosts in 
>unauthenticated subscriber network can enjoy 
>Internet services.

i think it is no matter  with whether of not the subscriber have passed
the authentication.
hosts can get address befor they pass the authentication( I myself  are
not saticified with this,
 i also think it will be better that the host first pass the
authentication then get address).The NAS 
will decide whether or not allow the user to access to the internet
according to the  authentication state of user.
>> insert the PID into the RS, the BRAS do not know the PID until it 
>> received the RS. so at the beginning ,the BRAS just only can
>> >> >With the more and more mature of IPv6 technology, IPv6 will sure 
>> >> >be deployed in access network. Considering most part of existing 
>> >> >network devices in access networks are layer2 devices, operators 
>> >> >would like to deploy IPv6 services on existing infrastructure as 
>> >> >much as possible. Less network devices upgrading to 
>layer3 devices 
>> >> >are more
>> favorable.
>> >> >
>> >> >Draft-wen-ipv6-rsra-opt-pid-00.txt is considering help implement 
>> >> >IPv6 Stateless Address Auto-Configuration in access network 
>> >> >without upgrading access node and CPE to be layer3 devices. This 
>> >> >option doesn't change the standard IPv6 mechanism, while it adds 
>> >> >more availability
>> >> to IPv6.
>> >> >FAQ summary is also presented below. Please check it. Hope 
>> >> >everyone could give some comments on this proposal. Thanks in 
>> >> >advance.
>> >> >
>> >> >Best regards,
>> >> >
>> >> >Haibo
>> >> >
>> >> >
>> >> >configuration (SAAC) mechanism by defining Port 
>Identifier option 
>> >> >for RS/RA messages in IPv6 access network. This option can make 
>> >> >SAAC possible without upgrading access node and CPE to be layer
>> >3 devices.
>> >> >