Subject: RFC 4113: Is udpEndpointInstance persistent?

From: Anders Persson <[email-masked]>
Date: Mon, 05 Jun 2006 15:26:25 -0700

Dear Authors,

I was reading through RFC 4113 and one thing that is not clear to me is
the expected behavior of udpEndpointInstance. In particular, is the
instance persistent (i.e. does an endpoint have to be associated with a
particular instance throughout its lifetime)?

My understanding of the "instance" object is just as a facility to allow 
information from multiple identical endpoints to be extracted, and not 
as a way of identifying endpoints. If that is the case, then I assume 
there should no problem if the instance of a particular endpoint change 
over time?

/Anders

--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Tue, 6 Jun 2006 00:37:12 +0200

> there should no problem if the instance of a particular endpoint change 

The udpEndpointInstance object is part of the INDEX. Since a row in
the udpEndpointTable represents a particular endpoint, I would say
this object like all other INDEX objects serves to "identify" an
endpoint.

/js

-- 
Juergen Schoenwaelder		    International University Bremen
<http://www.eecs.iu-bremen.de/>	    P.O. Box 750 561, 28725 Bremen, Germany

---

From: Anders Persson <[email-masked]>
Date: Mon, 05 Jun 2006 17:02:33 -0700

> this object like all other INDEX objects serves to "identify" an

So what would be the situation be if the endpoint is terminated, and a 
new identical endpoint start? If the goal is to identify an endpoint, 
then I suppose that "instance" values should not be "recycled".

Thanks,
Anders

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Tue, 6 Jun 2006 07:43:20 +0200

> then I suppose that "instance" values should not be "recycled".

I am less sure about the answer to this question.

My naive understanding was that as long as an endpoint exists, the
value of udpEndpointInstance should remain the same. I am less sure
about the reuse of udpEndpointInstance for the same four tuple. On the
manager side, I kind of would prefer if udpEndpointInstance values for
the same four tuple are not reused too frequently.

I agree that this should be clarified.

/js

---

From: Kristine Adamson <[email-masked]>
Date: Tue, 6 Jun 2006 07:39:48 -0600

Hello,
   Just wanted to add that in our TCP/IP implementation, the instance 
identifies an endpoint to a network management application.  We created a 
proprietary SNMP table that augments udpEndpointEntry, so we could provide 
counter statistics (datagrams, octets) for the endpoints.  So if a 
management app is polling the UDP endpoint information, it uses the 
instance to recognize updated counters for an endpoint.  We increment the 
instance value for each new endpoint.

Juergen Schoenwaelder <[email-masked]> wrote on 06/06/2006 

> I agree that this should be clarified.

---

Kristine Adamson
IBM z/OS Communications Server: TCP/IP Development
Internet e-mail:[email-masked]

---

From: Bill Fenner <[email-masked]>
Date: Tue, 6 Jun 2006 08:16:16 -0700

My off-the-cuff answer is that the udpEndpointInstance
exists in order to distinguish between multiple UDP Endpoints
that are otherwise identical, so its specific value doesn't
matter at all (otherwise than that it's unique, which is
required by the fact that it's in the INDEX).  One imagined
implementation is to use the [low-order bits of] the address
of the kernel data structure (e.g., see BSD's "netstat -A"
output).

  Bill

---

From: Pars Mutaf <[email-masked]>
Date: Thu, 08 Jun 2006 13:35:13 +0200

Hello, 

Is there a standard way of constructing 
an interface ID from human name?

I would like to configure an interface ID
hash(ParsMutaf| 1) and if it collides
hash(ParsMutaf| 2) etc..

You can try reach or locate me 
by sending a packet to (please do not
hesitate):

subnetprefix | hash(ParsMutaf| 1) or 
subnetprefix | hash(ParsMutaf| 2)

Is there a standard way of doing this?
For example there should be space between
first and last name? etc.

Any comments? Pointers? Thank you.

Regards,

Pars Mutaf

---

From: Pars Mutaf <[email-masked]>
Date: Fri, 09 Jun 2006 17:20:47 +0200

Hello, 

Please find the following Internet Draft 
on generating an IPv6 interface id from a human name.
The main idea is that human name is easy to remember,
and consequently I can construct your IPv6 address
if I know you, and I can reach you (in some cases). 

http://www.freewebs.com/pmutaf/draft-mutaf-ipv6humid-00.txt

I would very much appreciate your comments, if any.

Regards,

Pars Mutaf

---

From: Ruri Hiromi <[email-masked]>
Date: Mon, 12 Jun 2006 17:18:26 +0900

Hi Pars,

I got it, I can imagine what you want to do.
SIP has similar mechanism that you want, I suppose, so that what is  
the merit on this?
Sorry for my primitive question.

Regards,

On 2006/06/12, at 17:00, Pars Mutaf wrote:

> On Mon, 2006-06-12 at 15:35 +0900, Ruri Hiromi wrote:
>> I am sorry this question might be OFF-TOPIC but I just wonder.
>>
>> Is this idea used for a specific aim? In my company we just consider
>> about how to connect sensors and sensors seem to be have no such
>> human names currently.
>
> Hi,
> I was thinking about cellular phones in fact.
> In this case, a host (phone) is associated with a
> human.
>
> If everything goes wrong I can try to contact my
> friend using his name.
>
> pars
>
>
>>
>> On 2006/06/10, at 0:20, Pars Mutaf wrote:
>>
>>>
>>> Hello,
>>>
>>>> Administrative Requests: https://www1m [IPv6:::1] (localhost [127.0.0.1])
	by inc.inetcore.com (Postfix) with ESMTP id 92BBBD52DF8;
	Mon, 12 Jun 2006 17:18:28 +0900 (JST)
From: Ruri Hiromi <[email-masked]>
Date: Mon, 12 Jun 2006 17:18:26 +0900
To: [email-masked],
 [email-masked]
Cc: 
Subject: Re: interface ID from human name how to?

This is an OpenPGP/MIME signed message (RFC 2440 and 3156)

Hi Pars,

I got it, I can imagine what you want to do.
SIP has similar mechanism that you want, I suppose, so that what is  
the merit on this?
Sorry for my primitive question.

Regards,

On 2006/06/12, at 17:00, Pars Mutaf wrote:

> On Mon, 2006-06-12 at 15:35 +0900, Ruri Hiromi wrote:
>> I am sorry this question might be OFF-TOPIC but I just wonder.
>>
>> Is this idea used for a specific aim? In my company we just consider
>> about how to connect sensors and sensors seem to be have no such
>> human names currently.
>
> Hi,
> I was thinking about cellular phones in fact.
> In this case, a host (phone) is associated with a
> human.
>
> If everything goes wrong I can try to contact my
> friend using his name.
>
> pars
>
>
>>
>> On 2006/06/10, at 0:20, Pars Mutaf wrote:
>>
>>>
>>> Hello,
>>>
>> -------------------------------
>> Ruri Hiromi
>> [email-masked]
>>
>>
>>
>

-------------------------------
Ruri Hiromi
[email-masked]

---

From: Pars Mutaf <[email-masked]>
Date: Mon, 12 Jun 2006 10:35:04 +0200

Hi, 

> Sorry for my primitive question.

No it is a good question. 

The idea is that when the DNS is down (or unreachable), 
and/or Mobile IPv6 home agent is down etc, and there is no way 
to locate and reach the destination host, then I can try to 
use this technique.

Imagine an earthquake scenario. In Turkey in 1999 
cellular phones saved lives. Imagine you are trying to call
someone, but you can't get his address because
of some infrastructure failures. etc..

You know his name, then using hash(firstname lastname) you can
construct his interface ID. This might be helpful. You can 
try to reach him at its human Ipv6 address. Hopefully his phone
configured a human Ipv6 address.

This makes sense?

pars

---

From: Ruri Hiromi <[email-masked]>
Date: Tue, 13 Jun 2006 23:35:18 +0900

Thanks Pars,

now it goes more clear to me.  But I still wonder that this must be  
solved/proposed in ecrit-wg. Anyway, I will read it through.

On 2006/06/12, at 17:35, Pars Mutaf wrote:

>>>>>> ----------------------------------------------------------------- 
>>>>>> --
>>>>>> -
>>>>>> ----------------------------------------------------------------- 
>>>>>> --
>>>>>> -
>>>>>
>>>>>

---

From: Pars Mutaf <[email-masked]>
Date: Thu, 15 Jun 2006 10:08:35 +0200

> solved/proposed in ecrit-wg. Anyway, I will read it through.

Ok thanks.
But my earthquake example was an example.
I think this is a networking topic, similarly 
to MANET.

How to encode a human name into an IPv6 address?
This kind of name resolution is interesting
because it is truly stateless and end-to-end.
(and impossible with IPv4)

Thank you.

pars

---

From: Bob Hinden <[email-masked]>
Date: Fri, 23 Jun 2006 15:11:35 -0700

Hi,

> an interface ID from human name?

Ignoring for now if this is good or bad idea, but you might look at

   http://www.ietf.org/internet-drafts/draft-ietf-ipngwg-icmp-name- 
lookups-15.txt

There is a mechanism there to create multicast addresses based on a  
host name that might be a starting point.

> subnetprefix | hash(ParsMutaf| 2)

The big usage problem here is that without knowing your "subnetprfix"  
it won't be very useful.  That leads me to wonder how useful it would  
be to find you.

> configured a human Ipv6 address.

Also, see the above referenced ID.  It's not too hard to do this on a  
single link, but trying to scale this to the Internet gets very hard  
very fast.  It is probably better for the earthquake scenario you  
describe to do this at a higher level (e.g., have a website called "i- 
am-alive.org" and make it easy for people to leave messages and for  
people to search people they are trying to find out about).

Doing it on a single link might be useful in some adhoc scenarios.

Bob