Subject: A question about MLD

From: Jason Wang <[email-masked]>
Date: Wed, 16 Aug 2006 15:58:13 +0800

Hi,folks.

I have a question about MLD protocol. The router sends a query message to
find if there are any nodes are concerned about particular multicast group,
then a node will send a response to show it's interest to a multicast group.
The router will last know this. But for the node,how could it ensure it has
joined into a certain multicast group?

Best regrads,

Jason

--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

---

From: "Manfredi, Albert E" <[email-masked]>
Date: Wed, 16 Aug 2006 10:08:29 -0400

> -----Original Message-----
> From: Jason Wang [mailto:[email-masked]] 
> Sent: Wednesday, August 16, 2006 2:58 AM
> To: [email-masked]
> Subject: A question about MLD
> 
> Hi,folks.
> 

As in IGMP, the listener knows because it begins receiving the multicast
packets.

Bert

---

From: Jason Wang <[email-masked]>
Date: Thu, 17 Aug 2006 09:18:43 +0800

Thread-index: AcbBCbjshBpLx5nxQMenxrx8OCQtegAM6B7wABcBNzA=

Thanks ever for your reply.So as you said, the multicast source should send
multicast packets continuously so that the listeners could receive packets
at any time. There is a delay between the MLD report and the first arrived
multicast packet.

Jason

> From: Manfredi, Albert E [mailto:[email-masked]] 
> Sent: Wednesday, August 16, 2006 10:08 PM
> To: Jason Wang; [email-masked]
> Subject: RE: A question about MLD
> 
> > I have a question about MLD protocol. The router sends a 
> query message 
> > to find if there are any nodes are concerned about particular 
> > multicast group, then a node will send a response to show it's 
> > interest to a multicast group.
> > The router will last know this. But for the node,how could 
> it ensure 
> > it has joined into a certain multicast group?
> 
> As in IGMP, the listener knows because it begins receiving 
> the multicast packets.
> 
> Bert
>

---

From: Gopakumar Kurup <[email-masked]>
Date: Thu, 17 Aug 2006 10:37:37 +0800

----- Original Message -----
From: Jason Wang <[email-masked]>
Date: Wednesday, August 16, 2006 4:06 pm
Subject: A question about MLD
To: [email-masked]

> joined into a certain multicast group?

My understanding of MLD is, the node has joined the group when it adopts
the group address on its listening interface and sends the appropriate
reports towards the multicast router. The node assumes the router has
processed its report and taken the necessary steps to forward multicast
data onto the link. MLD does not provide a functionality for the node to
determine whether it is actually receiving the data. Some other
mechanism is required for that purpose.
gopi.

---

From: Jason Wang <[email-masked]>
Date: Thu, 17 Aug 2006 14:13:00 +0800

Thanks.I do agree with you. When the listener must determine whether it has

joined the group successfully as soon as possible,there may be a need of
other
notification mechanism.

Jason

> From: Gopakumar Kurup [mailto:[email-masked]] 
> Sent: Thursday, August 17, 2006 10:38 AM
> To: Jason Wang
> Cc: [email-masked]
> Subject: Re: A question about MLD
> 
> 
> 
> My understanding of MLD is, the node has joined the group 
> when it adopts the group address on its listening interface 
> and sends the appropriate reports towards the multicast 
> router. The node assumes the router has processed its report 
> and taken the necessary steps to forward multicast data onto 
> the link. MLD does not provide a functionality for the node 
> to determine whether it is actually receiving the data. Some 
> other mechanism is required for that purpose.
> gopi.
> 
> 
>