Subject: RE: Prefix Delegation using ICMPv6

From: "Bernie Volz \(volz\)" <[email-masked]>
Date: Thu, 24 Aug 2006 11:21:43 -0400

>If we're to compare, I'd compare the ICMPv6-PD effort with the RA
option
>to carry DNS Server effort.  If things are to evolve quicker then we
>could skip some intermediary steps. 

Exactly. Why have two ways to the same thing! That's another effort that
should be terminated.

Gee, why don't we just encapsulate DHCPv6 options in RA/RS? Then, we'd
solve all of these problems and be able to get rid of "DHCPv6".

- Bernie

-----Original Message-----
From: Alexandru Petrescu [mailto:[email-masked]] 
Sent: Thursday, August 24, 2006 8:39 AM
To: [email-masked]
Cc: IETF IPv6 Mailing List; Ralph Droms (rdroms)
Subject: Re: Prefix Delegation using ICMPv6

[email-masked] wrote:
>> We do not create alternative ways to >do the same thing, because 
>> doing so will burden >implementors with additional complexity and 
>> reduces >the likelihood that nodes can communicate >successfully. 
>> Picking a common way to do something is >the fundamental idea 
>> behind standards.
> 
> In general that is true. However, for things such as IPv6 node 
> addressing we have DHCPv6 and SLAAC. The point is THAT there is >1 
> way to do something (in this  case IPv6 node addressing).

It's not because there may exist several ways to skin a cat that there
should also be several ways to skin a dog.

If we're to compare, I'd compare the ICMPv6-PD effort with the RA option
to carry DNS Server effort.  If things are to evolve quicker then we
could skip some intermediary steps.

Alex

--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

---

From: Alexandru Petrescu <[email-masked]>
Date: Thu, 24 Aug 2006 17:51:26 +0200

Bernie Volz (volz) wrote:
>> to carry DNS Server effort.  If things are to evolve quicker then
>> we could skip some intermediary steps.
> 
> Exactly. Why have two ways to the same thing! That's another effort
> that should be terminated.
> 
> Gee, why don't we just encapsulate DHCPv6 options in RA/RS? Then,
> we'd solve all of these problems and be able to get rid of "DHCPv6".

Right, encapsulating DHCPv6 options in RA/RS would transform RA/RS into 
DHCPv6 itself.  RS/RA is the first thing people see when they come to 
IPv6.  It's so magic that it seems to be able to solve many problems. 
It's a common temptation to add stuff into RA.  That said.

We could try to document what are the current options to convey a prefix 
to a terminal such that it can reuse that prefix for itself and for others.

Alex

---

From: "Ralph Droms \(rdroms\)" <[email-masked]>
Date: Thu, 24 Aug 2006 11:54:35 -0400

Alexandru - you've used a phrase that I still don't understand.  What
does it mean for a node to have a prefix that "it can reuse [...] for itself
and for others"?

- Ralph

-----Original Message-----
From: Alexandru Petrescu [mailto:[email-masked]]
Sent: Thu 8/24/2006 11:51 AM
To: Bernie Volz (volz)
Cc: IETF IPv6 Mailing List; Ralph Droms (rdroms)
Subject: Re: Prefix Delegation using ICMPv6

Alex

---

From: Alexandru Petrescu <[email-masked]>
Date: Thu, 24 Aug 2006 18:04:06 +0200

Ralph Droms (rdroms) wrote:
>  does it mean for a node to have a prefix that "it can reuse [...] 
> for itself and for others"?

Ralph, thanks for asking.  "A node having a prefix it can reuse for
itself and for others" means that the node derives shorter prefixes from
the one that is delegated and it eventually RAs them into a network for
which is responsible.  Something like a router at home connected to ADSL
needs a whole prefix for the other PCs in house.

This is a potential use of prefix delegation.  I'm not sure whether the
ICMPv6-PD authors think the same about what's PD needed for.  They would
clarify, I hope.

Alex

---

From: "Rao Satyanarayana-W60007" <[email-masked]>
Date: Thu, 24 Aug 2006 12:33:39 -0400

Thanks, Alex.
We too think the same about the use of PD - to be able subnet further
and RA downstream.

- Satya Rao
Mobile Devices Technology Office
Motorola
Tel: 512-996-6781
Email: [email-masked]

> From: Petrescu Alexandru-AAP021 
> Sent: Thursday, August 24, 2006 11:04 AM
> To: Ralph Droms (rdroms)
> Cc: IETF IPv6 Mailing List; Bernie Volz (volz)
> > does it mean for a node to have a prefix that "it can reuse 
> [...] for 
> > itself and for others"?
> 
> Ralph, thanks for asking.  "A node having a prefix it can 
> reuse for itself and for others" means that the node derives 
> shorter prefixes from the one that is delegated and it 
> eventually RAs them into a network for which is responsible.  
> Something like a router at home connected to ADSL needs a 
> whole prefix for the other PCs in house.
> 
> This is a potential use of prefix delegation.  I'm not sure 
> whether the ICMPv6-PD authors think the same about what's PD 
> needed for.  They would clarify, I hope.
> 
> Alex
>

---

From: "Ralph Droms \(rdroms\)" <[email-masked]>
Date: Thu, 24 Aug 2006 12:43:05 -0400

Alex - thanks, that clarification helps.  I wasn't sure if PD using ICMPv6
was using the phrase "prefix delegation" as you defined it, or to assign
a prefix between the requesting node and the assigning node (to
simulate a point-to-point link), or both.

- Ralph

-----Original Message-----
From: Rao Satyanarayana-W60007 [mailto:[email-masked]]
Sent: Thu 8/24/2006 12:33 PM
To: Petrescu Alexandru-AAP021; Ralph Droms (rdroms)
Cc: IETF IPv6 Mailing List; Bernie Volz (volz)
Subject: RE: Prefix Delegation using ICMPv6
 
Thanks, Alex.

- Satya Rao

---

From: Alexandru Petrescu <[email-masked]>
Date: Thu, 24 Aug 2006 20:31:02 +0200

> We too think the same about the use of PD - to be able subnet further

So one would need prefix delegation for a DSL-like deployment, or for a 
mobile router deployment, but not for a netlmm deployment.  Right?

Alex