Subject: Re: Closure of IPv6 WG and creation of IPv6 Maintenance WG

From: Tim Enos <[email-masked]>
Date: Thu, 26 Jul 2007 14:35:09 -0500 (CDT)

All,

>Alain,
>
>Durand, Alain wrote:
>>  
>>> The working group's work items are as follows:
>>>
>>>     o Shepherd completion of standardization of RA Flags Option
>>>     o Shepherd completion of standardization of the RH0 Deprecation
>> document
>>>     o Complete documentation/standardization of IPv6 over PPP
>> Compression Negotiation
>>>     o Complete work on Centrally Allocated Unique Local Addresses
>> (ULA-C)
>> 
>> Considering ULA as a core IPv6 protocol is a hard sell.
>> 
>
>I personally am not considering ULA a core protocol.  However, the work
>on ULA (whatever the outcome) needs a home.

I agree that ULA-C "needs a home" but disagree the IPv6 Maintenance WG is it, given:

* the first paragraph of the proposed charter:

"The sole purpose of this group is in the maintenance of the core
IPv6 protocol specifications and *not* in the development of new
solutions or changes to the specifications.."

&& at least one of the group chairs doesn't consider it to be a core protocol,

&& at least one of the group chairs doesn't see group consensus on ULA-C,

&& there are other group members who don't see group consensus on ULA-C,

&& we haven't heard from any group members who do see group consensus on ULA-C,

&& "Complete work" is meant to be predicated upon group consensus

I'd say it should be removed from the charter.

>Regards,
>Brian

Best Regards,

Tim Enos
Rom 8:28
>
>
>--------------------------------------------------------------------
>IETF IPv6 working group mailing list
>[email-masked]
>Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
>--------------------------------------------------------------------

--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

---

From: Roger Jorgensen <[email-masked]>
Date: Thu, 26 Jul 2007 21:55:02 +0200 (CEST)

On Thu, 26 Jul 2007, Tim Enos wrote:
<snip>
> && at least one of the group chairs doesn't consider it to be a core protocol,

It probably isnt a core protocol, it is a set of IP addresses out of the 
IPv6 address scope. I guess the right question is:

- who should in the future decide on usage of other sub-set of the IPv6 
address scope?

> && we haven't heard from any group members who do see group consensus on ULA-C,

well I wouldn't claim there are any consensus right now but there are two 
draft out there and the merge between them has been ignored for a month... 
do people just wish the entire discussion to die away and ignore it? 
(sorry for the hard wordings of that sentence)

> I'd say it should be removed from the charter.

why... it is a open discussion with two suggested draft as said above and 
it is moving in the direction of some sort of consensus.

-- 

------------------------------
Roger Jorgensen              | - ROJO9-RIPE  - RJ85P-NORID
[email-masked]           | - IPv6 is The Key!
-------------------------------------------------------

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 26 Jul 2007 23:32:58 +0200

> On Thu, 26 Jul 2007, Tim Enos wrote:

...
> - who should in the future decide on usage of other sub-set of the IPv6 

6man, and tweak the charter to cover address architecture maintenance,
IMHO.
...

> why... it is a open discussion with two suggested draft as said above 
> and it is moving in the direction of some sort of consensus.

Exactly.

    Brian

---

From: Jari Arkko <[email-masked]>
Date: Thu, 26 Jul 2007 16:51:48 -0500

Tim,

> I'd say it should be removed from the charter.

What we really want to achieve is to have a forum where we
can talk about maintenance issues of the IPv6 protocol set,
but we also need to carry over the work that remains from
IPv6 WG. I am not creating another working group to
just talk about ULA, so we have a practical question of
where we will finish the work. (And by "finish" I might
mean that we decide to abandon the work at the end --
but NOT before a discussion.)

Please be assured that we will not move the ULA work forward
if the current non-consensus situation does not change.

> 6man, and tweak the charter to cover address architecture maintenance, 

This would be my take too.

Jari

---

From: Roger Jorgensen <[email-masked]>
Date: Fri, 27 Jul 2007 08:23:29 +0200 (CEST)

> This would be my take too.

so you will issue a new version of the charter with some of the other 
changes people have mention?

--