Subject: Re: Re: [dhcwg] DHCPv6 Proxy Agent

From: Joseph Hyunwook Cha <[email-masked]>
Date: Tue, 04 Nov 2008 05:45:05 +0000 (GMT)

Hello, Ted.

Thank you for your reply.
My comments are below.

2008/11/4 Ted Lemon <[email-masked]>:
> On Nov 3, 2008, at 6:40 PM, Joseph Hyunwook Cha wrote:
>>
>>  However, if the service provider provides DHCPv6 service for the internet
>> connectivity of customer's hosts and is willing to give only /128 addresses
>> without delegating prefixes, there are no other feasible solutions than 6to6
>> NAPT for of local hosts to share the Internet connection. To address this
>> problem, new element called DHCPv6 proxy agent is suggested, which supports
>> message transactions between hosts in the LAN and remote server in the
>> provider network using IAID demultiplexing.
>
> I don't see how this would help.   If the provider is only willing to
> provide a /128, what makes you think that (a) the routing will work for more
> than one /128, and (b) that the provider will be willing to give you a
> second or subsequent /128 after you've acquired the first?
>
I am assuming that (b) is supported by the provider. With this assumption, packets destined to extra addresses can reach actual destination hosts configured with these addresses via the ND proxy. 

> Also, why do you need to define additional protocol to make this happen?  
> It seems to me that you can already do this by using multiple IAIDs, so
> there's no need for an additional draft.
>

I also agree that DHCPv6 client can obtain multiple addresses by using multiple IAIDs. One reason why I propose the DHCPv6 proxy agent is that it is more preferable to let internal hosts obtain global addreses from remote server in provider network without user's intervention. According to the RFC3315, DHCPv6 client can not request addresses on behalf of other clients. If it obtains multiple addresses with multiple IA configurations, all addresses are just used for the interface on which the client is running. This means that user should remove extra addresses from the
interface manually. Then extra addresses may be assigned to the internal hosts manually or through DHCPv6 local server. In addition, I think that it is more desirable for internal hosts to be able to create and maintain bindings of the remote server directly. 

Joseph

> Personally, I think that if ISPs in general start giving out /128s, we have
> pretty much wasted the effort of creating IPv6, because we'll effectively
> have an IPv4 network, only with substantially bigger protocol headers.
>
> --------------------------------------------------------------------
> IETF IPv6 working group mailing list
> [email-masked]
> Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
> --------------------------------------------------------------------
>

--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

---

From: Ted Lemon <[email-masked]>
Date: Mon, 3 Nov 2008 23:53:51 -0700

On Nov 3, 2008, at 10:45 PM, Joseph Hyunwook Cha wrote:
> I am assuming that (b) is supported by the provider. With this  
> assumption, packets destined to extra addresses can reach actual  
> destination hosts configured with these addresses via the ND proxy.

Yes, but this seems like an extraordinarily unlikely assumption.   If  
the ISP is being stingy with addresses, surely they are not going to  
hand them out just because you ask for more.

In any case, I think this is a solution in search of a problem.    
Let's wait and see what actual problems crop up in the field and  
*then* solve them.