Subject: Node Req: Issue 6: Support for RFC 5121: IP version 6 over WiMAX

From: <[email-masked]>
Date: Thu, 13 Nov 2008 15:34:43 -0600

Daniel Park sent this issue in:

I'd request one more requirement for this bis. It is about 16ng
deliverable for IPv6 transmission over IPv6CS networks as RFC 5121. Due
to Convergence Sublayer characteristics of WiMAX networks, the below
requirement must be included in the Node Requirement. (For example:
globally unique prefix must be assigned to the WiMAX node, DAD
considerations, ND features, and etc described in RFC 5121)

4.X IP version 6 over WiMAX - RFC 5121

Nodes supporting IPv6 over WiMAX networks MUST implement 

"Transmission of IPv6 via the IPv6 Convergence Sublayer
over IEEE 802.16 Networks" [RFC 5121].

--> I think this seems like a reasonable thing to add.

John
--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

---

From: "Daniel Park" <[email-masked]>
Date: Fri, 14 Nov 2008 18:19:51 +0900

John,

I would make a minor change according to the valuable comments from the
WiMAX expert:

There are two ways to transfer IPv6 over WiMAX:
- IPv6 over WiMAX using IPCS: RFC5121
- IPv6 over Ethernet carried over WiMAX: AD Evaluation (ID Status)

So.

Nodes supporting IPv6 via IPCS over WiMAX networks MUST implement

"Transmission of IPv6 via the IPv6 Convergence Sublayer over IEEE 802.16
Networks" [RFC 5121].

Thanks,

Daniel

---

From: <[email-masked]>
Date: Fri, 14 Nov 2008 17:22:25 -0600

Daniel,
 
Could you explain what the IPCS abbreviation stands for?
 
thanks,
John

________________________________

	From: ext Daniel Park [mailto:[email-masked]] 
	Sent: 14 November, 2008 01:20
	To: Loughney John (Nokia-D/MtView)
	Cc: [email-masked]
	Subject: Re: Node Req: Issue 6: Support for RFC 5121: IP version
6 over WiMAX

	John, 
	
	I would make a minor change according to the valuable comments
from the WiMAX expert:

	There are two ways to transfer IPv6 over WiMAX:
	- IPv6 over WiMAX using IPCS: RFC5121
	- IPv6 over Ethernet carried over WiMAX: AD Evaluation (ID
Status)

	So.

	Nodes supporting IPv6 via IPCS over WiMAX networks MUST
implement
	
	"Transmission of IPv6 via the IPv6 Convergence Sublayer over
IEEE 802.16 Networks" [RFC 5121].

	
	Thanks, 
	
	Daniel

	On Fri, Nov 14, 2008 at 6:34 AM, <[email-masked]>
wrote:

		I'd request one more requirement for this bis. It is
about 16ng
		deliverable for IPv6 transmission over IPv6CS networks
as RFC 5121. Due
		to Convergence Sublayer characteristics of WiMAX
networks, the below
		requirement must be included in the Node Requirement.
(For example:
		globally unique prefix must be assigned to the WiMAX
node, DAD
		considerations, ND features, and etc described in RFC
5121)

		

		John
	
--------------------------------------------------------------------
		IETF IPv6 working group mailing list
		[email-masked]
		Administrative Requests:
https://www.ietf.org/mailman/listinfo/ipv6

---

From: Basavaraj Patil <[email-masked]>
Date: Fri, 14 Nov 2008 17:29:37 -0600

IPCS= IP Convergence Sublayer

On 11/14/08 5:22 PM, "John Loughney" <[email-masked]> wrote:

>> Subject: Re: Node Req: Issue 6: Support for RFC 5121:  IP version 6 over
>> WiMAX
>> 
>>  
>> John, 
>>

---

From: <[email-masked]>
Date: Fri, 14 Nov 2008 17:37:42 -0600

Thanks. This seems like a reasonable addition.
 
John

	From: [email-masked] [mailto:[email-masked]] On
Behalf Of ext Basavaraj Patil
	Sent: 14 November, 2008 15:30
	To: Loughney John (Nokia-D/MtView); Daniel Soohong Park
	Cc: [email-masked]
	Subject: Re: Node Req: Issue 6: Support for RFC 5121: IP version
6 over WiMAX

	On 11/14/08 5:22 PM, "John Loughney" <[email-masked]>
wrote:

		Daniel,

		thanks,
		John

			From: ext Daniel Park
[mailto:[email-masked]] 
			Sent: 14 November, 2008  01:20
			To: Loughney John (Nokia-D/MtView)
			Cc:  [email-masked]
			Subject: Re: Node Req: Issue 6: Support for RFC
5121:  IP version 6 over WiMAX

			John, 
			
			I would make a minor change according to the
valuable  comments from the WiMAX expert:

			
			- IPv6 over Ethernet carried over  WiMAX: AD
Evaluation (ID Status)
			
			So.

			Nodes supporting IPv6 via IPCS over WiMAX
networks MUST  implement
			
			"Transmission of IPv6 via the IPv6 Convergence
Sublayer over  IEEE 802.16 Networks" [RFC 5121].

			
			Thanks,  
			
			Daniel

			On Fri, Nov 14, 2008 at 6:34 AM,
<[email-masked]>  wrote:

				I'd request one more requirement for
this  bis. It is about 16ng
				deliverable for IPv6 transmission over
IPv6CS  networks as RFC 5121. Due
				to Convergence Sublayer characteristics
of  WiMAX networks, the below
				requirement must be included in the Node
Requirement. (For example:
				globally unique prefix must be assigned
to the  WiMAX node, DAD
				considerations, ND features, and etc
described in RFC  5121)

				Nodes supporting  IPv6 over WiMAX
networks MUST implement
				
				"Transmission of IPv6 via the  IPv6
Convergence Sublayer
				over IEEE 802.16 Networks" [RFC  5121].
				
				--> I think this seems like a reasonable
thing to  add.
				
				John

---

From: Pekka Savola <[email-masked]>
Date: Sat, 15 Nov 2008 15:12:17 +0200 (EET)

On Fri, 14 Nov 2008, Daniel Park wrote:
> I would make a minor change according to the valuable comments from 
> the WiMAX expert:
> 
> "Transmission of IPv6 via the IPv6 Convergence Sublayer over IEEE 
> 802.16 Networks" [RFC 5121].

This is almost like a tautology.  What use is having this kind of 
statements in an RFC?  If someone needs to implement IPv6 using IP 
convergence Sublayer on a WIMAX network and already knows of RFCs, 
(s)he can certainly find the RFC without such a reference here.

A statement is much more useful if it actually conveys some new 
information.  Such as providing guidance (or links to guidance) on 
when one should choose WiMAX using IPCS or Ethernet-adapation, or 
possibly some third (or fourth) option.

I'll note that while the current node requirements lists some IPv6 L2 
adaptation mechanisms, the list is not complete, and I don't think it 
needs to be complete.

-- 
Pekka Savola                 "You each name yourselves king, yet the
Netcore Oy                    kingdom bleeds."
Systems. Networks. Security. -- George R.R. Martin: A Clash of Kings
--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

---

From: Brian E Carpenter <[email-masked]>
Date: Mon, 17 Nov 2008 16:12:33 +1300

Daniel,

> - IPv6 over Ethernet carried over WiMAX: AD Evaluation (ID Status)

Where does your suggested preference for the IPv6 CS come from?
Does 16ng have a consensus on this preference?

Since I can't imagine anyone *not* implementing the Ethernet CS,
doesn't this make extra work for all implementors, compared
with preferring the Ethernet CS for both IP versions?

    Brian

> ------------------------------------------------------------------------
>

---

From: <[email-masked]>
Date: Mon, 17 Nov 2008 09:10:06 -0600

Hi Pekka,

>This is almost like a tautology.  What use is having this kind 
>of statements in an RFC?  If someone needs to implement IPv6 
>using IP convergence Sublayer on a WIMAX network and already 
>knows of RFCs, (s)he can certainly find the RFC without such a 
>reference here.
>
>A statement is much more useful if it actually conveys some 
>new information.  Such as providing guidance (or links to 
>guidance) on when one should choose WiMAX using IPCS or 
>Ethernet-adapation, or possibly some third (or fourth) option.

That makes sense, we should add more text to provide more guidence here.

>I'll note that while the current node requirements lists some 
>IPv6 L2 adaptation mechanisms, the list is not complete, and I 
>don't think it needs to be complete.

I agree it does not make sense, we should list support for major L2s
that the working group is interested in.  

That being said, does the working group consider IPCS support an
important
consideration for IPv6?

thanks,
John

---

From: Basavaraj Patil <[email-masked]>
Date: Mon, 17 Nov 2008 10:44:22 -0600

Hi John,

> That makes sense, we should add more text to provide more guidence here.

WiMAX forum specifications and documents provide sufficient information
about when to use IPCS or Eth CS. Mobile WiMAX networks in general rely on
IPCS. I don't think that this document should be providing guidance on when
to use IPCS vs Eth CS vs GPCS. It is better to simply provide the
appropriate reference to WMF documents.

> important consideration for IPv6?

I don't know if the IPv6 WG would care too much about IPCS. After all IPCS
is specified by IEEE 802.16. The point is that in Mobile WiMAX IPCS is used
for IPv4 and IPv6. Having a reference to Mobile WiMAX and the use of IPCS
for IPv6 transmission in those networks is useful.

-Raj

---

From: <[email-masked]>
Date: Mon, 17 Nov 2008 19:44:09 +0200

Hi Brian,

My recollection on this is that Ethernet CS is intended for CPE
("wireless DSL") use cases and IP CSes more for handhelds. In this
regard IP CSes correspond very closely on 3GPP IPv4/IPv6 PDP contexts.

Furthermore, Ethernet CS is optional feature while support for IP CSes
is mandatory.

In future I'm sure there will be a lot more devices using IPv6 over IPv6
CS/IPv6 PDP context/IPv6 EPS bearers than PPP.

Best regards,

	Teemu

>-----Original Message-----
>Behalf Of ext Brian E Carpenter
>Sent: 16 November, 2008 21:13
>To: Daniel Park
>Cc: Loughney John (Nokia-D/MtView); [email-masked]
>Subject: Re: Node Req: Issue 6: Support for RFC 5121: IP 
>version 6 over WiMAX
>
>Daniel,
>
>Since I can't imagine anyone *not* implementing the Ethernet 
>CS, doesn't this make extra work for all implementors, 
>compared with preferring the Ethernet CS for both IP versions?
>
>    Brian
>
>> 
>> So.
>> 
>>> deliverable for IPv6 transmission over IPv6CS networks as RFC 5121. 
>>> Due to Convergence Sublayer characteristics of WiMAX networks, the 
>>> below requirement must be included in the Node Requirement. 
>(For example:

---

From: "Daniel Park" <[email-masked]>
Date: Tue, 18 Nov 2008 04:47:26 +0900

John,

> appropriate reference to WMF documents.

Agreed, I think we don't need more text for CS in Node-Req. If anyone want
to know about CS more, they can refer to RFC 5121 as well as WiMAX
specification which is already in the list of references of RFC 5121.

Daniel

<snip>

---

From: "Daniel Park" <[email-masked]>
Date: Tue, 18 Nov 2008 05:03:11 +0900

Brian (ccing 16ng list)

> with preferring the Ethernet CS for both IP versions?

We had long discussion on that before..:-) Yes, IPv6CS (RFC5121) comes from
16ng WG. And EthernetCS is too. Prebably, the consensus you mentioned above
means which CS is a mandatory or optional for IPv6 implementation or
both. Well, 16ng WG just leaves them to the business choice in WiMAX
networks since that is beyond scope of 16ng. As of today, obviously mobile
biz wants to implement IPv6CS only, and wired biz (looks like DSL) wants to
implemt EthernetCS. But, no one knows what happens tomorrow in WiMAX
networks.

Daniel

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 18 Nov 2008 09:06:52 +1300

Teemu,

Well, I'd like to see a definitive statement of what the
consensus of 16ng is on this point, and then IMHO
the node requirements should exactly reflect that consensus.

   Brian

---

From: Basavaraj Patil <[email-masked]>
Date: Mon, 17 Nov 2008 14:15:12 -0600

As Daniel has also mentioned in another email, I do not believe that 16NG
can make a recommendation about when to use a specific CS for IPv6
transport. It depends on the deployment models and operators.

-Raj

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 18 Nov 2008 09:20:16 +1300

> implemt EthernetCS. But, no one knows what happens tomorrow in WiMAX

Then it seems to me there is no useful statement to be made
in the node requirements document. If 16ng has no recommendation,
I don't see how 6man can decide.

Thanks

   Brian

---

From: "Daniel Park" <[email-masked]>
Date: Tue, 18 Nov 2008 06:35:44 +0900

Confusing...definitely RFC5121 must be implemented for IPv6 over WiMAX
network. EthernetCS must be too. No need to decide which CS must be used for
WiMAX by 6man...?

Daniel

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 18 Nov 2008 10:49:03 +1300

> network. EthernetCS must be too. No need to decide which CS must be used for

My understanding is that in the IETF we try to avoid situations where
two ways of doing the same thing MUST be implemented. I hope that 16ng will
produce an applicability statement, but I don't see what we can usefully
say in the node requirements.

    Brian

---

From: <[email-masked]>
Date: Tue, 18 Nov 2008 05:23:47 +0200

Brian,

I think it's best to view Ethernet CS and IPv6 CS as different foos,
even if both are for WiMAX. Thus they are not two solutions for the same
thing.

So RFC5121 is needed by hosts supporting IPv6 CS foo and
draft-ietf-16ng-ip-over-ethernet-over-802.16 for host supporting
Ethernet CS foo.

Best regards,

	Teemu

>From: ext Brian E Carpenter [mailto:[email-masked]] 
>Sent: 17 November, 2008 14:07
>To: Savolainen Teemu (Nokia-D-MSW/Tampere)
>Cc: [email-masked]; Loughney John (Nokia-D/MtView); [email-masked]
>consensus of 16ng is on this point, and then IMHO the node 
>requirements should exactly reflect that consensus.
>
>   Brian
>
>>> From: [email-masked] [mailto:[email-masked]] 
>On Behalf 
>>> Of ext Brian E Carpenter
>>> Subject: Re: Node Req: Issue 6: Support for RFC 5121: IP version 6 
>>> over WiMAX
>>>
>>> Daniel,
>>>
>>> doesn't this make extra work for all implementors, compared with 
>>> preferring the Ethernet CS for both IP versions?
>>>
>>>    Brian
>>>
>>>> So.
>>>>
>-------------------------------------------------------------------
>>>>> - IETF IPv6 working group mailing list [email-masked] 
>Administrative 
>>>>> Requests: https://www.ietf.org/mailman/listinfo/ipv6
>>>>> 
>---------------------------------------------------------------------
>>> -
>>>> --
>>>>
>>>> 
>>>> IETF IPv6 working group mailing list [email-masked] Administrative 
>>>> Requests: https://www.ietf.org/mailman/listinfo/ipv6
>>>>