Subject: RE: IPORPR Update Presentation to 802.17 Sept Interim

From: "Dawkins, Spencer" <[email-masked]>
Date: Tue, 4 Sep 2001 09:34:20 -0500

Done...

Spencer

-----Original Message-----
From: RJ Atkinson [mailto:[email-masked]]
Sent: Sunday, September 02, 2001 11:34 AM
To: Albert Herrera
Cc: [email-masked]'
Subject: Re: IPORPR Update Presentation to 802.17 Sept Interim

At 11:43 02/09/01, Albert Herrera wrote:
>I have an update slide to present at the
>upcoming IEEE 802.17 WG Interim the week of
>Sept 10. Any comments are welcome.

        Please resend in a non-proprietary file format, 
perhaps PDF or standards-compliant HTML (as different
from various proprietary HTML formats) or such like.

        Not everyone here has or uses Windows or Microsoft
Office applications.  IETF rules are that things MUST be
be accessible to ALL participants on an equal basis.

Thanks,

Ran
[email-masked]

---

From: RJ Atkinson <[email-masked]>
Date: Tue, 04 Sep 2001 11:47:22 -0400

>Spencer

Thanks.

I think the viewgraph should specifically note these points:
        - IETF IPoRPR WG currently does NOT have rough consensus
          on the contents of the Framework draft.
        - Hence, IETF IPoRPR WG does not currently have ANY opinion
          as a WG about any of the proposals before IEEE 802.17.
        - IETF IPoRPR WG would like to explore possible joint
          development with 802.17 of SNMP MIBs for IP over 802.17,
          at an appropriate future point after 802.17 has settled
          on a basic concept and has a stable working draft.
          Those MIBs then could be openly published as RFCs
          (and also optionally published by IEEE if desired by IEEE),
          so they are available widely on a no-cost basis to
          both implementers and users.

Ran
[email-masked]

---

From: "Kastenholz, Frank" <[email-masked]>
Date: Tue, 04 Sep 2001 12:37:43 -0400

Speaking as co-chair...

>          on the contents of the Framework draft.

I beg to differ here. 

>          as a WG about any of the proposals before IEEE 802.17.

We are not supposed to have any opinion about any of the 
proposals before 802.17. Saying so in the slides would
help ensure that no institutional toes get stepped on
and that no turf war starts up.  

Albert, could you add a statement like this someplace?

>          both implementers and users.

I would claim that the "IP over 802.17" MIB is
strictly for the IETF to develop. The "802.17
Interface MIB" is different -- it is certainly 
something that could be done jointly between the
IETF and IEEE. But regardless, neither is something
to do until 802.17 gets further along and the IETF
group recharters itself to actually develop the 
"IP over RPR" standard.

On a slightly separate note, we probably should start
thinking sometime over the remainder of this year 
about what exactly we'll need to do to define 
"IP over RPR" -- sort of a high-level list of things
which, when the time comes, we'll put in the charter.
I envision the list might be something like
- MIBs
    - Interface MIB (done in conjunction with IEEE?)
    - IP/MPLS-over-RPR MIB 
    - ?
- Encapsulation
    - IPv4
    - IPv6
    - MPLS
    - ?
- Address Resolution
- Multicast

etc. I do not see a need for us to rush on this
and, of course, the exact work items will depend
on the output of 802.17

Frank Kastenholz
Co-Chair, IPoRPR

---

From: RJ Atkinson <[email-masked]>
Date: Tue, 04 Sep 2001 13:43:16 -0400

>>          on the contents of the Framework draft.

        Based on which mailing list discussion ?  Consensus is
supposed to be measured on the WG mailing list.  There have
been a lot of objections to the contents of the current I-D
in email from several people to this list.  Now we could
achieve consensus on the Framework draft, but I don't see 
any data to support that right now as I examine list archives.
Note well that I'm not claiming there is consensus against
the Framework I-D, just lack of consensus either way right now.

        If the WG Chairs believe we have rough consensus, then
why isn't the Framework I-D up for WG Last Call ?

>IETF and IEEE. 

        Terribly sorry, used the wrong phrase.  Meant
"802.17 Interface MIB"...

>But regardless, neither is something to do until 802.17 
>gets further along and the IETF group recharters itself 
>to actually develop the "IP over RPR" standard.

        To start writing a MIB now, fully agree.  However, 
it seems reasonable for us to open a dialogue with 802.17 
on MIB cooperation between IETF and IEEE, particularly given 
apparent WG interest and AD interest in that topic.  

        I'm particularly concerned that we avoid the sad
outcome of 802.11, which defined its own Interface MIB, 
but then made that 802.11 Interface MIB spec only available 
in paper IEEE documents that cost real money.  The result
has been that users/operators have no deployable 802.11
Interface MIB.  By opening dialogue with 802.17 about this
right now, we can likely work out some setup agreeable 
to both IETF and IEEE in advance.

>    - Interface MIB (done in conjunction with IEEE?)

        No objection to any MIBs.  Not sure what the
"IP/MPLS/RPR MIB" looks like though.  No doubt I'll
learn later on.

>-Multicast

        Iff each isn't just a matter of re-using existing
encapsulations and existing ARP and such like.  As you say, 
we'll need to see what happens in 802.17 before we can see
what needs to be done here beyond MIBs.

Ran
[email-masked]

---

From: "Kastenholz, Frank" <[email-masked]>
Date: Tue, 04 Sep 2001 16:08:02 -0400

At 01:43 PM 9/4/01 -0400, RJ Atkinson wrote:
>in email from several people to this list.  

Ran, I have read through the archive of the mailing list.
The only objection that I could see was yours saying that
        "As I said at the last IETF meeting, I think the current 
        Framework draft is essentially misguided and isn't solving 
        any real problem, whether technical or procedural."
and then later you suggest that we should rework the document to 
concentrate on MIBs and framing of IP over RPR. There were, I think, 
two or three people who more-or-less agreed with your position.

I have, several times, pointed out that our charter is to produce
a framework right now, not a set of specs for doing MIBs and 
framing.  So, what you are in effect saying is that you do not want 
the working group to be doing what it has been chartered to do. Right?

One may argue that the IETF is not about frameworks and requirement,
that it's about running code and all that. That may well be. But
the IESG (and IAB -- are you still involved in chartering?)
chartered this working group to do a framework.  So it seems
that your disagreement is more properly with their decision
to charter the working group and I humbly suggest that
you send them some email. 

>Now we could

As was stated in the minutes of the London meeting, which
I posted to the list on 13 August
        "The current framework will stay an internet draft, allowing the
         working group to change it quickly, as needed."

>apparent WG interest and AD interest in that topic.  

First, the AD has not told me of his interest, nor
has he told Albert, as far as I am aware. Second, we
have a charter that does not have the tri-graph MIB
in it at all.

>"IP/MPLS/RPR MIB" looks like though.  No doubt I'll

If memory serves, there are some MIBs that deal with
foo-over-l2 types of issues -- such as address mappings.
The answer for RPR may well be the NULL set.

>what needs to be done here beyond MIBs.

May well be. But I expect the charter to say something like
"the wg must examine all of these issues and pick-n-chose
what is appropriate given what pops out of 802.17" (rephrased
in appropriate charter-ese

Frank Kastenholz
Co-chair, IPoRPR