Subject: RE: IPORPR Update Presentation to 802.17 Sept Interim

From: "Dawkins, Spencer" <[email-masked]>
Date: Tue, 4 Sep 2001 11:41:06 -0500

I agree with Ran's comment about SNMP MIBs. 

I'm not disputing Ran's diagnosis of "NOT rough consensus" on the contents of the Framework draft, but I'm wondering if there is a subset of the document that we COULD come to rough consensus on.

Quoting from the WGCHAIRS presentation (http://www.ietf.org/wgchair/sld017.htm), "May have to discard parts to get consensus on rest" - but I would like to see some guidance given to IEEE 802.17, because we don't get to comment on subnetwork protocols before they're designed (and deployed) very often. The PILC WG has, I believe, reached rough consensus on the Advice to Internet Subnetwork Designers I-D (except for a merry-go-round on the Security Considerations section), available as http://www.ietf.org/internet-drafts/draft-ietf-pilc-link-design-06.txt. Is this the best advice that IETF has for IEEE 802.17? 

Any thoughts?

Spencer Dawkins,
PILC co-chair

-----Original Message-----
From: RJ Atkinson [mailto:[email-masked]]
Sent: Tuesday, September 04, 2001 10:47 AM
To: Dawkins, Spencer
Cc: [email-masked]'
Subject: RE: IPORPR Update Presentation to 802.17 Sept Interim

At 10:34 04/09/01, Dawkins, Spencer wrote:
>Done...
>Spencer

Thanks.

I think the viewgraph should specifically note these points:
        - IETF IPoRPR WG currently does NOT have rough consensus
          on the contents of the Framework draft.
        - Hence, IETF IPoRPR WG does not currently have ANY opinion
          as a WG about any of the proposals before IEEE 802.17.
        - IETF IPoRPR WG would like to explore possible joint
          development with 802.17 of SNMP MIBs for IP over 802.17,
          at an appropriate future point after 802.17 has settled
          on a basic concept and has a stable working draft.
          Those MIBs then could be openly published as RFCs
          (and also optionally published by IEEE if desired by IEEE),
          so they are available widely on a no-cost basis to
          both implementers and users.

Ran
[email-masked]

---

From: "Kastenholz, Frank" <[email-masked]>
Date: Tue, 04 Sep 2001 13:00:06 -0400

>I agree with Ran's comment about SNMP MIBs.

See my response to Ran.

>I'm not disputing Ran's diagnosis of "NOT rough consensus" on the contents of the Framework draft, but I'm wondering if there is a subset of the document that we COULD come to rough consensus on.

Simple statements of "there is no consensus" are not
useful. Please identify the things you do not like about
the current draft, wherever possible submitting new text.

Frank Kastenholz
co-chair, IPoRPR

---

From: RJ Atkinson <[email-masked]>
Date: Tue, 04 Sep 2001 14:02:11 -0400

>I'm not disputing Ran's diagnosis of "NOT rough consensus" on the contents of the Framework draft, but I'm wondering if there is a subset of the document that we COULD come to rough consensus on.

A worthwhile goal.  I suspect that is possible if we work at it.

>...I would like to see some guidance given to IEEE 802.17, 
>because we don't get to comment on subnetwork protocols 
>before they're designed (and deployed) very often. 

        I'm not sure whether or not we agree.  

        I'm not averse to feedback to 802.17 about aspects that directly 
impact IPvN, after 802.17 has some specific chosen working draft for us 
to comment upon.

        However, I think it is both premature and impolite for us to be 
guiding them in how to design a MAC protocol at this stage, where they
haven't converged to a single design/architecture for 802.17.

> Is this the best advice that IETF has for IEEE 802.17? 

        I don't see the current Framework draft as offering any
advice to 802.17 -- certainly it isn't rough consensus advice
from this WG, maybe it is the authors' personal advice though...

Ran
[email-masked]

---

From: RJ Atkinson <[email-masked]>
Date: Tue, 04 Sep 2001 14:09:35 -0400

At 13:00 04/09/01, Kastenholz, Frank wrote:
>Simple statements of "there is no consensus" are not useful. 

        Disagree.  

        In the context of a presentation to IEEE 802.17 that references 
a given I-D, it is USEFUL and IMPORTANT to make it clear in that 
presentation to 802.17 that the draft does NOT represent 
IETF rough consensus *at this time*.  

        Otherwise, someone in 802.17 is likely to erroneously assume 
the draft only contains items about which we have rough consensus 
as an IETF WG.  This HAS happened in the past with this WG and 802.17. 
I'd really like to avoid repeating the problem as we move forwards.

>Please identify the things you do not like about

        My proposed new text is mostly the DELETE key.  In the past,
I've identified several things that I do not like.  

Clarification question:
        Would you like everyone to reproduce their full laundry list 
of issues/objections to the Framework draft again ?

Ran

---

From: "Kastenholz, Frank" <[email-masked]>
Date: Tue, 04 Sep 2001 16:23:45 -0400

>I'd really like to avoid repeating the problem as we move forwards.

While I disagree about consensus, as the document is remaining 
an ID for a while, and we have not done any last-calls (either 
WG or IETF-wide), it would be fair to refer to it as a work-in-
progress.

Albert, would you update your slide accordingly?

>of issues/objections to the Framework draft again ?

Comments, issues, objections, etc, are always welcome.

Just remember, our charter is fairly specific. Things which you
have talked about in the past are, I believe, out of scope of that
charter and as such are not appropriate topics to bring up. Claims
that the draft does not say "foo", when "foo" is out of scope in
the current charter are irrelevancies and won't "count".

Frank Kastenholz
co-chair, IPoRPR

---

From: "Kastenholz, Frank" <[email-masked]>
Date: Tue, 04 Sep 2001 16:35:16 -0400

>haven't converged to a single design/architecture for 802.17.

I agree with Ran here. The charter says
        "The WG will not address issues that are clearly within the 
        MAC Layer"

Frank Kastenholz
Co-chair, IPoRPR