Subject: RE: IPORPR Update Presentation to 802.17 Sept Interim

From: "Dawkins, Spencer" <[email-masked]>
Date: Tue, 4 Sep 2001 14:32:32 -0500

Ran,

I think we're talking about two different things (and we could probably agree on each of them if we shared context).

The PILC working group has as a deliverable a document that "guides" MAC designers - not about MAC protocol design, but about how MACs get used by higher-level protocols on the Internet. Most frequently, the questions sound like "how persistent should my MAC protocol be, when losses are detected?" or "does it matter if I reorder packets as they cross the subnetwork?".

The reason I asked about http://www.ietf.org/internet-drafts/draft-ietf-pilc-link-design-06.txt is because many of the topics discussed there are general in nature, and I'm interested in hearing about subnetwork/transport protocol interactions on internets that include one or more RPR subnetworks.

When I asked "Is this the best advice that IETF has for IEEE 802.17?". I meant "is the mostly-transport-level PILC LINK I-D everything that IETF needs to tell 802.17?". PILC is strongly TCP-oriented, and I keep hearing 802.17 conversations about non-TCP-based applications as well.

 I wasn't suggesting anything about the IPORPR Framework draft. Sorry for the confusion.

Spencer

-----Original Message-----
From: RJ Atkinson [mailto:[email-masked]]
Sent: Tuesday, September 04, 2001 1:02 PM
To: [email-masked]
Subject: RE: IPORPR Update Presentation to 802.17 Sept Interim

At 12:41 04/09/01, Dawkins, Spencer wrote:

>...I would like to see some guidance given to IEEE 802.17, 
>because we don't get to comment on subnetwork protocols 
>before they're designed (and deployed) very often. 

        I'm not sure whether or not we agree.  

        I'm not averse to feedback to 802.17 about aspects that directly 
impact IPvN, after 802.17 has some specific chosen working draft for us 
to comment upon.

        However, I think it is both premature and impolite for us to be 
guiding them in how to design a MAC protocol at this stage, where they
haven't converged to a single design/architecture for 802.17.

> Is this the best advice that IETF has for IEEE 802.17? 

        I don't see the current Framework draft as offering any
advice to 802.17 -- certainly it isn't rough consensus advice
from this WG, maybe it is the authors' personal advice though...

Ran
[email-masked]

---

From: "Green, Scott" <[email-masked]>
Date: Tue, 4 Sep 2001 16:49:05 -0400

Please remove me from the distribution list.

Thanks.

Scott
[email-masked]
[email-masked]

-----Original Message-----
From: Kastenholz, Frank [mailto:[email-masked]]
Sent: Tuesday, September 04, 2001 4:35 PM
To: RJ Atkinson; [email-masked]
Subject: RE: IPORPR Update Presentation to 802.17 Sept Interim

At 02:02 PM 9/4/01 -0400, RJ Atkinson wrote:
>>I'm not disputing Ran's diagnosis of "NOT rough consensus" on the contents
of the Framework draft, but I'm wondering if there is a subset of the
document that we COULD come to rough consensus on.
>
>A worthwhile goal.  I suspect that is possible if we work at it.

>haven't converged to a single design/architecture for 802.17.

I agree with Ran here. The charter says
        "The WG will not address issues that are clearly within the 
        MAC Layer"

Frank Kastenholz
Co-chair, IPoRPR

---

From: "Wijnen, Bert (Bert)" <[email-masked]>
Date: Wed, 5 Sep 2001 14:46:09 +0200

Inline

> Sent: dinsdag 4 september 2001 22:08
> To: RJ Atkinson
> Cc: [email-masked]
> At 01:43 PM 9/4/01 -0400, RJ Atkinson wrote:

> >
> >        To start writing a MIB now, fully agree.  However, 
> >it seems reasonable for us to open a dialogue with 802.17 
> >on MIB cooperation between IETF and IEEE, particularly given 
> >apparent WG interest and AD interest in that topic.  
> 
> First, the AD has not told me of his interest, nor
> has he told Albert, as far as I am aware. Second, we
> have a charter that does not have the tri-graph MIB
> in it at all.
> 
I guess that Ran knows that I am an SNMP/MIB person, so he
probably assumed (correctly) that I do have a genuine interest
in MIB work.

There is nothing about a MIB in your current charter, so in
that sense Frank is right.
What Ran brings up IS a valid point: people who are
active in IEEE can try to seed the idea that we want to be
involved when any MIB work gets started. So mentioning that
in a slide to the IEEE 802.17 might be a good starting point.

I would think that this is doable without an explicit WG
milestone, no? 

Bert

---

From: "Kastenholz, Frank" <[email-masked]>
Date: Wed, 05 Sep 2001 09:20:21 -0400

>I would think that this is doable without an explicit WG

First, the last two sentences of the "Description of Working Group"
in our charter say:
        No formal liaison with the IEEE is anticipated. It is 
        expected that individuals will participate directly 
        in both groups. 
So, as far as I am concerned, that limits any IEEE/IETF "cooperation" 
to individuals who feel that they have something useful to contribute.
If the draft we're working on says something like "the IEEE and the IETF
will work together on a common MIB" that seems to me to be a "formal
liason", or at least the beginnings of one. On the other hand, if someone
wants to wander over to the IEEE and say "I think that ...", there's
nothing wrong with that.

Second, I have seen many working groups wander off into the weeds
and become nothing more than excuses to accumulate airline miles
because they had poor, vague, charters or their chairs chose to
ignore their charters, or their chairs did not resist members of
the working group who also want their protocol to solve world hunger.
So when I chair (or co-chair) a working group I insist on close,
strict, adherence to the charter. If that is unacceptable to
you than please let me know.

Third, as you are an SNMP/MIB person, I'm sure you're very familiar
with the history of the Ethernet MIB. While it would be nice for
the official 802.17-mib to be "good" with regard to our needs
(including availability), we can always repeat the process
used for the Ethernet MIB. (For those unfamiliar with history,
the IEEE had their Ethernet MIB.  I wanted to get some understanding
of the SNMP SMI/etc so I rewrote it in "IETF/SMI"-speak and
posted it to the SNMP mailing list to get some feedback.
It was picked up by others and eventually became "our"
Ethernet MIB. History has shown which MIB is more widely
deployed and used... This all happened in 1989/1990.)

Frank Kastenholz
co-chair, IPoRPR

---

From: "Wijnen, Bert (Bert)" <[email-masked]>
Date: Thu, 6 Sep 2001 13:55:57 +0200

Inline
> Sent: woensdag 5 september 2001 15:20
> To: Wijnen, Bert (Bert)
And I think that is exactly what I suggested above, is it not?

> liason", or at least the beginnings of one. 
>
I did not say that we should put something in the draft.
Rather I suggest the following, which you seem to agree with.

> On the other hand, if someone
I am sorry for your bad experience, I was not around in IETF at that
time... so I can't comment much if anything. I am just trying to see
if individuals at the technical level can try early to talk about
these types of things, so that we/they can create a MIB from a
common understanding.

Bert

---

From: Albert Herrera <[email-masked]>
Date: Fri, 7 Sep 2001 13:02:44 -0400

Further modifications. Presentation attached.
Mike, please include with other 802.17 presentations 
for upload.

Thanks.

Albert Herrera
Co-Chair - IPORPR WG

> From: Albert Herrera [mailto:[email-masked]]
> Sent: Wednesday, September 05, 2001 3:31 PM
> Cc: 'Kastenholz, Frank'
> Modified presentation attached.
> 
> Albert Herrera
> Co-Chair - IPORPR WG
> 
>

---

From: "Wijnen, Bert (Bert)" <[email-masked]>
Date: Fri, 7 Sep 2001 22:02:42 +0200

Albert, it is probably best if:

- You make it clear that you happen to be an IPORPR WG co-chair,
  but that you are not a formal liason or spokesperson for IETF
  or the WG. This is important so that people understand that
  we do not have a formal representation at IEEE.
- the 5th point on your 2nd page, should probably be reworded
  to something like:
  - to eleaborate on the previous point... some participants 
    of the IPORPR WG really would like to explore cooperation
    with IEEE 802.17 on possible future (joint) development 
    of an SNMP MIB for the 802.17 Interface type

Bert 

> Sent: vrijdag 7 september 2001 19:03
> Cc: 'Kastenholz, Frank'; [email-masked]'

---

From: Albert Herrera <[email-masked]>
Date: Fri, 7 Sep 2001 18:39:59 -0400

I'll make this clear when I present the material.

Thanks for the feedback.

Albert

> From: Wijnen, Bert (Bert) [mailto:[email-masked]]
> Sent: Friday, September 07, 2001 4:03 PM
> To: Albert Herrera; [email-masked]
> Cc: 'Kastenholz, Frank'; [email-masked]'; Scott Bradner

---

From: Raj Sharma <[email-masked]>
Date: Fri, 7 Sep 2001 21:36:54 -0700

My thoughts before the games begin on Monday.

The second bullet on slide 2 will be somewhat
confusing for the IEEE WGers. If November is
indeed a cut off point for all technical
proposals than by November there should be 
fair degree of philosophical consensus. After this
The nitty gritty works will start - However, that
is when the IPORPR group goes into Hibernation !!
November being the cut-off point looks unlikely
at this point - this is my personal opinion.

Also, you state the re-emergence of IPORPR will be triggered
by "substantial specs". This threshold is vague and also will
confuse people since by the time "substantial specs"
get put in place IPORPR may have very little wiggle
room.

The question lingers - What is the purpose for
IPORPR? Since, this is a very popular questions I will 
also raise this as a "class-question" on the IEEE meeting 
floor when these slides are presented. Or, Albert, you
can elaborate the rationale at the meeting even before 
I ask it.

Raj

-----Original Message-----
From: Albert Herrera [mailto:[email-masked]]
Sent: Wednesday, September 05, 2001 12:31 PM
To: [email-masked]
Cc: 'Kastenholz, Frank'
Subject: RE: IPORPR Update Presentation to 802.17 Sept Interim

Albert Herrera
Co-Chair - IPORPR WG

---

From: RJ Atkinson <[email-masked]>
Date: Sat, 08 Sep 2001 10:22:06 -0400

At 00:36 08/09/01, Raj Sharma wrote:
>The question lingers - What is the purpose for IPORPR? 

        I think IPoRPR exists primarily to make sure that a suitable
802.17 Interface MIB appears as a freely distributable RFC, 
just as IETF HUBMIB WG handles (cooperatively with IEEE 802.3)
the widely implemented Ethernet MIB.  

        As Frank K will point out, that perspective is NOT entirely 
consistent with the current IPoRPR charter.

        Secondarily, in the (unlikely IMHO) event that 802.17 designs 
layer-2 such that existing LAN protocol mapping techniques (e.g.: ARP, 
IPv6 ND, multicast address mapping L3--L2) break, then IPoRPR would 
likely be the place where IETF would figure out how to perform those
functions over the 802.17 link layer.

        Now a very good reason (IMHO) for going dormant in November 
(or even as soon as right now) is that neither of the above items can
start until AFTER 802.17 has a stable draft specification (where
stable draft specification != final specification; common sense has
worked just fine in the past for determining "stable draft" so we
do NOT need a more formal definition).

Regards,

Ran
[email-masked]

---

From: Albert Herrera <[email-masked]>
Date: Sat, 8 Sep 2001 15:11:06 -0400

> From: Raj Sharma [mailto:[email-masked]]
> Sent: Saturday, September 08, 2001 12:37 AM
As per the IPORPR Charter, we are providing input 
same as all other proposals to-date; and it's up 
to 802.17 to take this or leave it. If the November 
cut-off is a soft date, it's not a matter for IPORPR.
As per the last bullet/note on the slide, IPORPR
has no opinion on proposals, etc. re: MAC development
so when the nitty gritty MAC work actually starts
it might be best for IPORPR to go into Hibernation. 
 
> get put in place IPORPR may have very little wiggle
Once 802.17 sorts out all proposals and establishes a
first draft, then a re-emergence might be in order.
 
> can elaborate the rationale at the meeting even before 
The purpose is as per the Charter: to provide input.
If 802.17 deems the input to be useless or irrelevant,
they can simply ignore it. There are no formal liaisons
but I think the intentions are good.

---

From: "Kastenholz, Frank" <[email-masked]>
Date: Mon, 10 Sep 2001 09:07:27 -0400

Raj

As I understand things, the november date is
when the IEEE cuts off all submissions. We
(the IETF RPR working group) can certainly continue
to discuss things, provide information that IEEE
folks may want, provide a forum for individual IETF-
ers to work out what they wish to say in the IEEE
working group, and so on.

>get put in place IPORPR may have very little wiggle

Our intent on the re-emergence of IPoRPR is that
at that time, the IEEE work should be far enough
along and solid enough so that we can start serious
work on defining exactly how to run IP over 802.17.
Until IEEE starts converging, it makes no sense for us
to start defining IP-over-RPR.  The mailing list will
be available so that the individual people on IPoRPR
can start early discussions and explorations.

>can elaborate the rationale at the meeting even before 

The primary gaol, now, is to wait for 802.17 to 
get well enough defined so that we can define how
to run IP over it. 

Frank Kastenholz