Subject: RE: [Ipoverib] I-D ACTION:draft-ietf-ipoib-ibif-mib-00.txt

From: "Arvind Murching" <[email-masked]>
Date: Tue, 13 Nov 2001 09:39:50 -0800

Sean/Bill, I am wrong in stating there is a unique GUID/GID per SWITCH
port.

However, since this I-D presumably applies to IP nodes on an IB fabric,
each node must be located on a port that has a unique GUID and GID
assigned to it (otherwise it cannot participate in the IP network).

Note that an IP link may (if not now, in the future) span multiple IB
subnets, in which case the LID cannot be used as the ifPhysAddress.

In fact, the ifPhysAddress of an IP node should probably be identical to
the hardware address that it uses in an ARP reply. 

- Arvind

-----Original Message-----
From: Bill Anderson [mailto:[email-masked]] 
Sent: Monday, October 22, 2001 7:41 AM
To: Arvind Murching
Cc: [email-masked]
Subject: RE: [Ipoverib] I-D ACTION:draft-ietf-ipoib-ibif-mib-00.txt

Arvind
  Are you saying there is a unique GUID/GID per switch port?
I thought that a switch would have a minimum of one GUID for the
management
interface
but could also have additional GUIDs assigned to the mgmt interface by
the
Subnet Mgr (which
GUID would show up in ifphyaddress).  Also I dont think there is a IBA
requirement that the GUIDs be the same through a reboot of the switch
(but
in practice they probably are same).
I believe the GUID and GID info you are seeking is available from the
SMA
MIB which came out a few weeks ago. If a device had the SMA MIB
implemented
would that solve the problem your tring to solve?  Id hate to lose the
LID
info.

[Arvind] <snip>
Regards
Bill

-----Original Message-----
From: Arvind Murching [mailto:[email-masked]]
Sent: Friday, October 19, 2001 3:40 PM
To: [email-masked]
Subject: RE: [Ipoverib] I-D ACTION:draft-ietf-ipoib-ibif-mib-00.txt

Bill,

It seems that each port (router, CA, switch) does have a port GUID
assigned to it.

Since a LID is used in the LRH, it is doubly important that the MIB not
report a "temporally valid" value. The LID is also valid only within an
IB subnet, so this would preclude IP subnets that span multiple IB
subnets.

I agree that the current mapping of GID/GUIDs to LIDs is useful
information, but that need not necessarily be obtained directly from
ifPhysAddress.

Thanks
Arvind

-----Original Message-----
From: Bill Anderson [mailto:[email-masked]]
Sent: Wednesday, October 17, 2001 4:18 AM
To: Arvind Murching
Subject: RE: [Ipoverib] I-D ACTION:draft-ietf-ipoib-ibif-mib-00.txt

Hi Arvind,
  As I recall I chose to use the base LID over the GID since it appeared
to
me to be the only port based address choice that was available across
routers, CAs and switches. I don't believe the assignment of a  GID to a
switch port is done.  I also liked the fact that it allowed good
visibility
into whether or not the Subnet Mgr had configured the link yet.  Lastly
the
use of the Link Layer address carried in the LRH just seemed like the
closest we could come to a "physical Address"
  I hope this answers your question sufficiently.
-Bill

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf
Of Arvind Murching
Sent: Tuesday, October 16, 2001 5:22 PM
To: [email-masked]
Subject: RE: [Ipoverib] I-D ACTION:draft-ietf-ipoib-ibif-mib-00.txt

Bill,

Can you explain why the base LID is chosen as the value for
ifPhysAddress? Since the LID is subject to change, it would seem that
the port GID/GUID would have been a more appropriate choice. For
example, an entity that obtained the ifPhysAddress (or for that matter
ifRcvAddressTable) would reasonably expect to send packets using that
ifPhysAddress such that it reaches the desired node. If a LID is chosen,
it is not possible to cater to any such expectations.

Thanks
Arvind Murching

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Friday, October 12, 2001 4:10 AM
Cc: [email-masked]
Subject: [Ipoverib] I-D ACTION:draft-ietf-ipoib-ibif-mib-00.txt

A New Internet-Draft is available from the on-line Internet-Drafts
directories.
This draft is a work item of the IP over InfiniBand Working Group of the
IETF.

	Title		: Definitions of Managed Objects Infiniband
Interface
                          Type
	Author(s)	: B. Anderson
	Filename	: draft-ietf-ipoib-ibif-mib-00.txt
	Pages		: 21
	Date		: 11-Oct-01

InfiniBand Architecture (IBA) specifies a high speed, channel
based, switched fabric architecture to deliver scalable
performance in data centers.
This memo defines a portion of Management Information Base (MIB)
for use with network management protocols in TCP/IP-based internets.
In particular, it defines objects for managing IBA defined
Infiniband interfaces.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-ipoib-ibif-mib-00.txt

To remove yourself from the IETF Announcement list, send a message to
ietf-announce-request with the word unsubscribe in the body of the
message.

Internet-Drafts are also available by anonymous FTP. Login with the
username
"anonymous" and a password of your e-mail address. After logging in,
type "cd internet-drafts" and then
	"get draft-ietf-ipoib-ibif-mib-00.txt".

A list of Internet-Drafts directories can be found in
http://www.ietf.org/shadow.html
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

Internet-Drafts can also be obtained by e-mail.

Send a message to:
	[email-masked].
In the body type:
	"FILE /internet-drafts/draft-ietf-ipoib-ibif-mib-00.txt".

NOTE:	The mail server at ietf.org can return the document in
	MIME-encoded form by using the "mpack" utility.  To use this
	feature, insert the command "ENCODING mime" before the "FILE"
	command.  To decode the response(s), you will need "munpack" or
	a MIME-compliant mail reader.  Different MIME-compliant mail
readers
	exhibit different behavior, especially when dealing with
	"multipart" MIME messages (i.e. documents which have been split
	up into multiple messages), so check your local documentation on
	how to manipulate these messages.

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

_______________________________________________
IPoverIB mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/ipoverib

_______________________________________________
IPoverIB mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/ipoverib

---

From: "Bill Swortwood" <[email-masked]>
Date: Tue, 13 Nov 2001 10:17:02 -0800

All -

 Port and Node GUIDs are assigned to by the HW vendor. This is expected
 to be persistent, as opposed to LIDs, which may change from reboot
 of the subnet - per spec below:

pg 85, volume 1.0a

Each channel adapter has a Globally Unique Identifier (GUID) called the
Node GUID assigned by the channel adapter vendor. Each of its ports has
a Port GUID also assigned by the channel adapter vendor. The Port GUID
combined with the local subnet prefix becomes a port's default GID.

Subnet administration provides a GUID to LID/GID resolution service.
Thus a node can persistently identify another node by remembering a
Node or Port GUID.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf
Of Arvind Murching
Sent: Tuesday, November 13, 2001 9:40 AM
To: [email-masked]; [email-masked]
Subject: RE: [Ipoverib] I-D ACTION:draft-ietf-ipoib-ibif-mib-00.txt

- Arvind

-----Original Message-----
From: Bill Anderson [mailto:[email-masked]] 
Sent: Monday, October 22, 2001 7:41 AM
To: Arvind Murching
Cc: [email-masked]
Subject: RE: [Ipoverib] I-D ACTION:draft-ietf-ipoib-ibif-mib-00.txt

Arvind

[Arvind] <snip>
Regards
Bill

-----Original Message-----
From: Arvind Murching [mailto:[email-masked]]
Sent: Friday, October 19, 2001 3:40 PM
To: [email-masked]
Subject: RE: [Ipoverib] I-D ACTION:draft-ietf-ipoib-ibif-mib-00.txt

Bill,

Thanks
Arvind

-----Original Message-----
From: Bill Anderson [mailto:[email-masked]]
Sent: Wednesday, October 17, 2001 4:18 AM
To: Arvind Murching
Subject: RE: [Ipoverib] I-D ACTION:draft-ietf-ipoib-ibif-mib-00.txt

Hi Arvind,

-----Original Message-----

Bill,

Thanks
Arvind Murching

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Friday, October 12, 2001 4:10 AM
Cc: [email-masked]
Subject: [Ipoverib] I-D ACTION:draft-ietf-ipoib-ibif-mib-00.txt

Send a message to:
	[email-masked].
In the body type:

---

From: "Bill Strahm" <[email-masked]>
Date: Tue, 13 Nov 2001 10:07:52 -0800

Well this ID applies to all IB interfaces regardless of which L3 is running
on top of it.  I would like to hear from some other IB folks, but I believe
that a single port can only participate in a single IB fabric.  Is it
possible that I put a port into multiple fabrics (maybe like I can put an
ethernet card into multiple collision domains using VLANs with VLAN
tagging).  I do not think that is possible with IB, at best you can be in
multiple partitions in a single fabric, but then you have the same LID.

Bill

-----Original Message-----

- Arvind

-----Original Message-----
From: Bill Anderson [mailto:[email-masked]]
Sent: Monday, October 22, 2001 7:41 AM
To: Arvind Murching
Cc: [email-masked]
Subject: RE: [Ipoverib] I-D ACTION:draft-ietf-ipoib-ibif-mib-00.txt

Arvind

[Arvind] <snip>
Regards
Bill

-----Original Message-----
From: Arvind Murching [mailto:[email-masked]]
Sent: Friday, October 19, 2001 3:40 PM
To: [email-masked]
Subject: RE: [Ipoverib] I-D ACTION:draft-ietf-ipoib-ibif-mib-00.txt

Bill,

Thanks
Arvind

-----Original Message-----
From: Bill Anderson [mailto:[email-masked]]
Sent: Wednesday, October 17, 2001 4:18 AM
To: Arvind Murching
Subject: RE: [Ipoverib] I-D ACTION:draft-ietf-ipoib-ibif-mib-00.txt

Hi Arvind,

-----Original Message-----

Bill,

Thanks
Arvind Murching

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Friday, October 12, 2001 4:10 AM
Cc: [email-masked]
Subject: [Ipoverib] I-D ACTION:draft-ietf-ipoib-ibif-mib-00.txt

Send a message to:
	[email-masked].
In the body type:

---

From: "Bill Swortwood" <[email-masked]>
Date: Tue, 13 Nov 2001 10:32:09 -0800

Sorry for the length of time in getting these out, hopefully some
of this is helpful:

1) Overall, the MIB assumes that the management of the subnet is
   largely done by SM class communications, and misses objects in the
   SA class, which actually is the interface class to the SM. Some objects
   desirable in this MIB might be:

   a) ServiceRecords
   b) McMemberRecords
   c) RangeRecords
   d) LinkRecords

2) The MIB borrowed from a stale initial pass of the subnet management
   agent MIB, and carries with it some of the initial SNMP modeling errors.
   This is the common 'copied homework' syndrome. We will have this happen
   a number more times, for certain.

3) The recording of path records in the MIB might be a bit unwieldly.
PathRecords
themselves were thought to be in the IBTA a derived data set rather than a
static
information repository. In simpler subnet implementations this modeling
might work,  but may not in all.

4) The author should also be aware that there are some changes in some of
the SA
objects forthcoming, and might want to look at the current MGTWG work here.

5) For any given InfiniBand port, there may be N number of GUIDs assigned
beyond the PortGUID, as indicated in smPortGUIDCap. The alias GUIDS should
be modeled.

Again, hope this helps --

---------------------------
Bill Swortwood
Sanera Systems
Oregon Design Center
(w) 503 601 0261
[email-masked]
---------------------------

---

From: "Bill Swortwood" <[email-masked]>
Date: Tue, 13 Nov 2001 13:05:32 -0800

Another clarification:

 An InfiniBand switch address, or GID, is the address of the management
 entity port -- the only end port or termination port for an IB swith.
 The other switch ports, or through ports, are not directly addressable,
 except through the management port. There is no 'through port' LID or
 GID or GUIDs, just to the end ports of the switch or the CA.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf
Of Bill Swortwood
Sent: Tuesday, November 13, 2001 10:17 AM
To: Arvind Murching; [email-masked]; [email-masked]
Subject: RE: [Ipoverib] I-D ACTION:draft-ietf-ipoib-ibif-mib-00.txt

All -

pg 85, volume 1.0a

-----Original Message-----

- Arvind

-----Original Message-----
From: Bill Anderson [mailto:[email-masked]] 
Sent: Monday, October 22, 2001 7:41 AM
To: Arvind Murching
Cc: [email-masked]
Subject: RE: [Ipoverib] I-D ACTION:draft-ietf-ipoib-ibif-mib-00.txt

Arvind

[Arvind] <snip>
Regards
Bill

-----Original Message-----
From: Arvind Murching [mailto:[email-masked]]
Sent: Friday, October 19, 2001 3:40 PM
To: [email-masked]
Subject: RE: [Ipoverib] I-D ACTION:draft-ietf-ipoib-ibif-mib-00.txt

Bill,

Thanks
Arvind

-----Original Message-----
From: Bill Anderson [mailto:[email-masked]]
Sent: Wednesday, October 17, 2001 4:18 AM
To: Arvind Murching
Subject: RE: [Ipoverib] I-D ACTION:draft-ietf-ipoib-ibif-mib-00.txt

Hi Arvind,

-----Original Message-----

Bill,

Thanks
Arvind Murching

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Friday, October 12, 2001 4:10 AM
Cc: [email-masked]
Subject: [Ipoverib] I-D ACTION:draft-ietf-ipoib-ibif-mib-00.txt

Send a message to:
	[email-masked].
In the body type:

---

From: Michael Krause <[email-masked]>
Date: Thu, 15 Nov 2001 09:21:09 -0800

>multiple partitions in a single fabric, but then you have the same LID.

You have the same set of LIDs per endnode (CA or IB router) port (port 0 
for a switch).  A endnode port may only be in one IB subnet at a time 
through a CA (and router by definition) may have multiple ports with each 
port in a separate subnet if desired.  IB partitions in many respects are 
similar to 802.1Q VLAN tags which allow an Ethernet port to participate in 
multiple VLANs.  It should also be noted that one may carve up an IB fabric 
(irrespective of IB subnets) into different partition management domains 
thereby allowing IB partitions to span any range in terms of number of 
endnodes within a partition unlike VLANs which are constrained within a 
single layer 2 fabric.

Mike