Subject: [Ipoverib] Additions to IPOVERIB Textual Conventions MIB

From: "Harnedy, Sean" <[email-masked]>
Date: Tue, 13 Nov 2001 10:47:25 -0500

I have gone over all of the current MIBs and have found 3 Textual
Conventions that should be added to the IPOVERIB Textual Conventions
MIB:

New IB-TC-MIB TC Definitions:

(IBUlidTC from InfiniBand Subnet Management Agent MIB)
IbUnicastLid ::= TEXTUAL-CONVENTION 
   DISPLAY-HINT "d" 
   STATUS      current 
   DESCRIPTION 
      "Identifies a unicast LID. Value is stored in IBA defined bit

       order, that is, the High Order Bit of the Local Identifier 
       byte 0 is positioned as the high-order bit of the first byte 
       of octet string.  " 
   SYNTAX       Integer32 (1..49152) 
    
(IBMlidTC from InfiniBand Subnet Management Agent MIB) 
IbMulticastLid ::= TEXTUAL-CONVENTION 
   DISPLAY-HINT "d" 
   STATUS      current 
   DESCRIPTION 
      "Identifies a Multicast LID. Value is stored in IBA defined 
       bit order, that is, the High Order Bit of the Local 
       Identifier byte 0 is positioned as the high-order bit of the 
       first byte of octet string.  " 
   SYNTAX       Integer32 (49153..65535)

(SmPortList from InfiniBand Subnet Management MIB) 
IbSmPortList ::= TEXTUAL-CONVENTION 
   STATUS       current 
   DESCRIPTION 
      "Each octet within this value specifies a port 
       in an IB device.  A port can have a number from 
       0 to 255.  The port number is unique only within 
       the scope of an IB device." 
   SYNTAX       OCTET STRING (SIZE(32)) 

I believe all of the current TC definitions are covered so far in the
proposed TC ID. Please forward all suggestions, comments, etc. on
including new TCs, etc. As a general naming convention I believe we
should maintain consistency and begin each TC with Ib<Tc name>. I also
don't think the TC suffix is necessary as each TC begins with an upper
case character.

Thanks,

Sean Harnedy
Principal Software Engineer
InfiniSwitch Corporation.
134 Flanders Road
Westborough, MA 01581
1-508-599-6388
http://www.infiniswitch.com

_______________________________________________
IPoverIB mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/ipoverib

---

From: "Bill Swortwood" <[email-masked]>
Date: Tue, 13 Nov 2001 10:32:09 -0800

Looks good to me.
I like the new naming conventions better than mine.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf
Of Harnedy, Sean
Sent: Tuesday, November 13, 2001 7:47 AM
To: [email-masked]
Subject: [Ipoverib] Additions to IPOVERIB Textual Conventions MIB

    

Thanks,

Sean Harnedy