Subject: Re: [Ipoverib] Is InfiniBand a Layer 2 or Layer 3 Protocol ?

From: "Jim Fleming" <[email-masked]>
Date: Wed, 5 Dec 2001 16:39:38 -0600

OK, given InfiniBand is going to be used to route IPv4 around.

How does one obtain routable InfiniBand address blocks ?

Jim Fleming
http://www.IPv8.info
IPv16....One Better !!

----- Original Message ----- 
From: "H.K. Jerry Chu" <[email-masked]>
To: <[email-masked]>
Cc: <[email-masked]>
Sent: Wednesday, December 05, 2001 4:17 PM
Subject: Re: [Ipoverib] Is InfiniBand a Layer 2 or Layer 3 Protocol ?

> I'm not sure I understand your question. InfiniBand has its own layering
> defintions covering layer 1 - 4 according to the OSI 7-layer model.
> It also defines its owning addressing and naming scheme and management
> functions. Although it borrows many ideas from IPv6 in its layer-3
> definition, it's best to treat IB as a link-layer for IPoIB purpose, at
> least initially. This way it causes the least disruption to existing IP
> stacks and infrastructure. E.g. DNS can work as is on top of IP/IB.
> 
> Jerry
> 
> >From: "Jim Fleming" <[email-masked]>
> >To: "H.K. Jerry Chu" <[email-masked]>
> >Cc: <[email-masked]>
> >Subject: Re: [Ipoverib] Is InfiniBand a Layer 2 or Layer 3 Protocol ?
> >Date: Wed, 5 Dec 2001 16:03:40 -0600
> >MIME-Version: 1.0
> >Content-Transfer-Encoding: 7bit
> >X-Priority: 3
> >X-MSMail-Priority: Normal
> >X-MimeOLE: Produced By Microsoft MimeOLE V5.50.4133.2400
> >
> >Since InfiniBand will be the outer wrapper, is there an
> >InfiniBand Address Plan defined ?
> >
> >....in other words....mappings from DNS A and AAAA records....
> >
> >....or, does InfiniBand use the DNS A6 format, like IPv6 does ?
> >
> >
> >
> >Jim Fleming
> >http://www.dot-biz.com/IPv4/Tutorial/
> >http://www.IPv8.info
> >IPv16....One Better !!
> >
> >----- Original Message ----- 
> >From: "H.K. Jerry Chu" <[email-masked]>
> >To: <[email-masked]>
> >Cc: <[email-masked]>
> >Sent: Wednesday, December 05, 2001 2:55 PM
> >Subject: Re: [Ipoverib] Is InfiniBand a Layer 2 or Layer 3 Protocol ?
> >
> >
> >> >Is InfiniBand's Layer 2, documented separate from the other layers ?
> >> 
> >> No. See the IBTA web site for the latest IB spec.
> >> 
> >> >
> >> >For IPv4 over InfiniBand, is just the InfiniBand Layer 2 involved ?
> >> >
> >> 
> >> I'd say it's infeasible (or impractical) due to the above. (S/W has no
> >> direct access to IB layer 2 only.)
> >> 
> >> I'd also like to suggest that basic IB-related questions be moved
> >> somewhere else so we can have a better focus on IPoIB here.
> >> 
> >> Jerry
> >> 
> >> >
> >> >Jim Fleming
> >> >http://www.DOT-BIZ.com
> >> >http://www.Register-BIZ.com
> >> >http://www.BIZ-Registry.com
> >> >
> >> >
> >> >
> >> >----- Original Message ----- 
> >> >From: "Grun, Paul" <[email-masked]>
> >> >To: "'Jim Fleming'" <[email-masked]>; <[email-masked]>
> >> >Sent: Wednesday, December 05, 2001 11:49 AM
> >> >Subject: RE: [Ipoverib] Is InfiniBand a Layer 2 or Layer 3 Protocol ?
> >> >
> >> >
> >> >> InfiniBand includes layers 1, 2, 3 and 4.  There is nothing to preclude
> >> >> someone from mapping other layer 3/4 protocols on top of IBA's layer 2 or
> >> >> layer 3.  As I understand it, that is what IPoverIB WG is doing.
> >> >> -paul
> >> >> 
> >> >> > -----Original Message-----
> >> >> > From: Jim Fleming [mailto:[email-masked]]
> >> >> > Sent: Wednesday, December 05, 2001 9:56 AM
> >> >> > To: Bill Strahm; [email-masked]
> >> >> > Subject: [Ipoverib] Is InfiniBand a Layer 2 or Layer 3 Protocol ?
> >> >> > 
> >> >> > 
> >> >> > Is InfiniBand a Layer 2 or Layer 3 Protocol ?
> >> >> > 
> >> >> > http://www.infinibandta.org
> >> >> > 
> >> >> > 
> >> >> > Jim Fleming
> >> >> > http://www.IPv8.info
> >> >> > IPv16....One Better !!
> >> >> > 
> >> >> > 
> >> >> > ----- Original Message ----- 
> >> >> > From: "Bill Strahm" <[email-masked]>
> >> >> > To: "Jim Fleming" <[email-masked]>; <[email-masked]>
> >> >> > Sent: Wednesday, December 05, 2001 11:43 AM
> >> >> > Subject: RE: [Ipoverib] Is InfiniBand a "private protocol" ?
> >> >> > 
> >> >> > 
> >> >> > > Funny, you are the one that brought up "private protocol" 
> >> >> > and you don't have
> >> >> > > a definition for it...
> >> >> > > 
> >> >> > > For a layer 2 protocol to work, there needs to be a few 
> >> >> > documents in each
> >> >> > > layer 3 protocol that tell you how to hook up addressing 
> >> >> > and encapsulation.
> >> >> > > These documents exist for Ethernet, Token Ring, Cable Data 
> >> >> > Networks, and
> >> >> > > many many others...
> >> >> > > 
> >> >> > > The IETF is interested in having IPv4 and IPv6 run over 
> >> >> > Infiniband, therefor
> >> >> > > this WG is chartered with producing those documents...
> >> >> > > 
> >> >> > > Bill
> >> >> > > 
> >> >> > > -----Original Message-----
> >> >> > > From: [email-masked] 
> >> >> > [mailto:[email-masked]]On Behalf
> >> >> > > Of Jim Fleming
> >> >> > > Sent: Wednesday, December 05, 2001 9:40 AM
> >> >> > > To: [email-masked]; Vivek Kashyap; [email-masked]
> >> >> > > Subject: Re: [Ipoverib] Is InfiniBand a "private protocol" ?
> >> >> > > 
> >> >> > > 
> >> >> > > How does one define a "private protocol" ?
> >> >> > > 
> >> >> > > Also, it seems that InfiniBand over IPv4 would be more in 
> >> >> > tune with the
> >> >> > > IETF.
> >> >> > > Is that part of your plan ?
> >> >> > > 
> >> >> > > 
> >> >> > > Jim Fleming
> >> >> > > http://www.IPv8.info
> >> >> > > IPv16....One Better !!
> >> >> > > 
> >> >> > > ----- Original Message -----
> >> >> > > From: "Ashwin Kamath" <[email-masked]>
> >> >> > > To: "Vivek Kashyap" <[email-masked]>; <[email-masked]>; "Jim
> >> >> > > Fleming" <[email-masked]>
> >> >> > > Sent: Wednesday, December 05, 2001 9:10 AM
> >> >> > > Subject: Re: [Ipoverib] Is InfiniBand a "private protocol" ?
> >> >> > > 
> >> >> > > 
> >> >> > > > No, Infiniband is not a private protocol.
> >> >> > > > The trade associations website is located at 
> >> >> > http://www.infinibandta.org
> >> >> > > >
> >> >> > > >
> >> >> > > > ---------- Original Message ----------------------------------
> >> >> > > > From: "Jim Fleming" <[email-masked]>
> >> >> > > > Date:  Wed, 5 Dec 2001 02:47:06 -0600
> >> >> > > >
> >> >> > > > >----- Original Message -----
> >> >> > > > >From: "Vivek Kashyap" <[email-masked]>
> >> >> > > > >>
> >> >> > > > >> > Note that IPv4 has a lot of mileage left in it. IPv5 
> >> >> > and IPv7 can
> >> >> > > > >> > still use the IPv4 version number and pass through 
> >> >> > the "standard
> >> >> > > > >>
> >> >> > > > >>         ??? IPv5/v7 ....no such thing. If these are 
> >> >> > private protocols
> >> >> > > > >>         they are certainly not being considered. If 
> >> >> > they can pass for
> >> >> > > > >>         IPv4 I am sure you will be able to map your 
> >> >> > implementations
> >> >> > > > >>         like you have done for other media. Anyway that doesn't
> >> >> > > > >>         concern this WG. ???
> >> >> > > > >>
> >> >> > > > >
> >> >> > > > >Is InfiniBand a "private protocol" ?
> >> >> > > > >
> >> >> > > > >
> >> >> > > > >Jim Fleming
> >> >> > > > >http://www.IN-ADDR.info
> >> >> > > > >http://www.unir.com/images/architech.gif
> >> >> > > > >http://www.unir.com/images/headers.gif
> >> >> > > > >http://www.unir.com/images/address.gif
> >> >> > > > >
> >> >> > > > >
> >> >> > > > >
> >> >> > > > >_______________________________________________
> >> >> > > > >IPoverIB mailing list
> >> >> > > > >[email-masked]
> >> >> > > > >http://www.ietf.org/mailman/listinfo/ipoverib
> >> >> > > > >
> >> >> > > >
> >> >> > > >
> >> >> > > > _______________________________________________
> >> >> > > > IPoverIB mailing list
> >> >> > > > [email-masked]
> >> >> > > > http://www.ietf.org/mailman/listinfo/ipoverib
> >> >> > > >
> >> >> > > 
> >> >> > > 
> >> >> > > _______________________________________________
> >> >> > > IPoverIB mailing list
> >> >> > > [email-masked]
> >> >> > > http://www.ietf.org/mailman/listinfo/ipoverib
> >> >> > > 
> >> >> > > 
> >> >> > 
> >> >> > 
> >> >> > _______________________________________________
> >> >> > IPoverIB mailing list
> >> >> > [email-masked]
> >> >> > http://www.ietf.org/mailman/listinfo/ipoverib
> >> >> > 
> >> >> 
> >> >> _______________________________________________
> >> >> IPoverIB mailing list
> >> >> [email-masked]
> >> >> http://www.ietf.org/mailman/listinfo/ipoverib
> >> >> 
> >> >
> >> >
> >> >_______________________________________________
> >> >IPoverIB mailing list
> >> >[email-masked]
> >> >http://www.ietf.org/mailman/listinfo/ipoverib
> >> 
> >> 
> >> _______________________________________________
> >> IPoverIB mailing list
> >> [email-masked]
> >> http://www.ietf.org/mailman/listinfo/ipoverib
> >> 
> >
> 
> 

_______________________________________________
IPoverIB mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/ipoverib

---

From: "H.K. Jerry Chu" <[email-masked]>
Date: Wed, 5 Dec 2001 14:17:05 -0800 (PST)

Jerry