Subject: RE: [Ipoverib] Is InfiniBand a Layer 2 or Layer 3 Protocol ?

From: "Grun, Paul" <[email-masked]>
Date: Wed, 5 Dec 2001 09:49:37 -0800

InfiniBand includes layers 1, 2, 3 and 4.  There is nothing to preclude
someone from mapping other layer 3/4 protocols on top of IBA's layer 2 or
layer 3.  As I understand it, that is what IPoverIB WG is doing.
-paul

> -----Original Message-----
> From: Jim Fleming [mailto:[email-masked]]
> Sent: Wednesday, December 05, 2001 9:56 AM
> To: Bill Strahm; [email-masked]
> Subject: [Ipoverib] Is InfiniBand a Layer 2 or Layer 3 Protocol ?
> 
> 
> Is InfiniBand a Layer 2 or Layer 3 Protocol ?
> 
> http://www.infinibandta.org
> 
> 
> Jim Fleming
> http://www.IPv8.info
> IPv16....One Better !!
> 
> 
> ----- Original Message ----- 
> From: "Bill Strahm" <[email-masked]>
> To: "Jim Fleming" <[email-masked]>; <[email-masked]>
> Sent: Wednesday, December 05, 2001 11:43 AM
> Subject: RE: [Ipoverib] Is InfiniBand a "private protocol" ?
> 
> 
> > Funny, you are the one that brought up "private protocol" 
> and you don't have
> > a definition for it...
> > 
> > For a layer 2 protocol to work, there needs to be a few 
> documents in each
> > layer 3 protocol that tell you how to hook up addressing 
> and encapsulation.
> > These documents exist for Ethernet, Token Ring, Cable Data 
> Networks, and
> > many many others...
> > 
> > The IETF is interested in having IPv4 and IPv6 run over 
> Infiniband, therefor
> > this WG is chartered with producing those documents...
> > 
> > Bill
> > 
> > -----Original Message-----
> > From: [email-masked] 
> [mailto:[email-masked]]On Behalf
> > Of Jim Fleming
> > Sent: Wednesday, December 05, 2001 9:40 AM
> > To: [email-masked]; Vivek Kashyap; [email-masked]
> > Subject: Re: [Ipoverib] Is InfiniBand a "private protocol" ?
> > 
> > 
> > How does one define a "private protocol" ?
> > 
> > Also, it seems that InfiniBand over IPv4 would be more in 
> tune with the
> > IETF.
> > Is that part of your plan ?
> > 
> > 
> > Jim Fleming
> > http://www.IPv8.info
> > IPv16....One Better !!
> > 
> > ----- Original Message -----
> > From: "Ashwin Kamath" <[email-masked]>
> > To: "Vivek Kashyap" <[email-masked]>; <[email-masked]>; "Jim
> > Fleming" <[email-masked]>
> > Sent: Wednesday, December 05, 2001 9:10 AM
> > Subject: Re: [Ipoverib] Is InfiniBand a "private protocol" ?
> > 
> > 
> > > No, Infiniband is not a private protocol.
> > > The trade associations website is located at 
> http://www.infinibandta.org
> > >
> > >
> > > ---------- Original Message ----------------------------------
> > > From: "Jim Fleming" <[email-masked]>
> > > Date:  Wed, 5 Dec 2001 02:47:06 -0600
> > >
> > > >----- Original Message -----
> > > >From: "Vivek Kashyap" <[email-masked]>
> > > >>
> > > >> > Note that IPv4 has a lot of mileage left in it. IPv5 
> and IPv7 can
> > > >> > still use the IPv4 version number and pass through 
> the "standard
> > > >>
> > > >>         ??? IPv5/v7 ....no such thing. If these are 
> private protocols
> > > >>         they are certainly not being considered. If 
> they can pass for
> > > >>         IPv4 I am sure you will be able to map your 
> implementations
> > > >>         like you have done for other media. Anyway that doesn't
> > > >>         concern this WG. ???
> > > >>
> > > >
> > > >Is InfiniBand a "private protocol" ?
> > > >
> > > >
> > > >Jim Fleming
> > > >http://www.IN-ADDR.info
> > > >http://www.unir.com/images/architech.gif
> > > >http://www.unir.com/images/headers.gif
> > > >http://www.unir.com/images/address.gif
> > > >
> > > >
> > > >
> > > >_______________________________________________
> > > >IPoverIB mailing list
> > > >[email-masked]
> > > >http://www.ietf.org/mailman/listinfo/ipoverib
> > > >
> > >
> > >
> > > _______________________________________________
> > > IPoverIB mailing list
> > > [email-masked]
> > > http://www.ietf.org/mailman/listinfo/ipoverib
> > >
> > 
> > 
> > _______________________________________________
> > IPoverIB mailing list
> > [email-masked]
> > http://www.ietf.org/mailman/listinfo/ipoverib
> > 
> > 
> 
> 
> _______________________________________________
> IPoverIB mailing list
> [email-masked]
> http://www.ietf.org/mailman/listinfo/ipoverib
> 

_______________________________________________
IPoverIB mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/ipoverib

---

From: "Jim Fleming" <[email-masked]>
Date: Wed, 5 Dec 2001 12:14:06 -0600

Is InfiniBand's Layer 2, documented separate from the other layers ?

For IPv4 over InfiniBand, is just the InfiniBand Layer 2 involved ?

Jim Fleming
http://www.DOT-BIZ.com
http://www.Register-BIZ.com
http://www.BIZ-Registry.com