Subject: IPP> Face-to-face meeting minutes posted

From: "Whittle, Craig" <[email-masked]>
Date: Wed, 20 Aug 2008 15:29:40 -0700

All:

The minutes from the IPPv2 Camas, WA face-to-face meeting can be found
at:

ftp://ftp.pwg.org/pub/pwg/ipp/ippv2-minutes/08AUG-Camas-IPPv2-face-to-fa
ce.pdf. 

Best regards,

**CW

---

From: Michael Sweet <[email-masked]>
Date: Wed, 20 Aug 2008 16:18:40 -0700

Whittle, Craig wrote:
> 
> 
> All:
> 
>  
> 
> The minutes from the IPPv2 Camas, WA face-to-face meeting can be found at:
> 
> ftp://ftp.pwg.org/pub/pwg/ipp/ippv2-minutes/08AUG-Camas-IPPv2-face-to-face.pdf 

Feedback on meeting notes:

1. Just to be clear, the consensus was to remove the
    document-format requirements entirely?

2. WRT XPS, it is patent-encumbered and not covered by any
    existing ISO, IETF, PWG, or W3C standards.  It may make a
    fine high-level PDL, but IMHO it isn't a good fit for a
    required document-format.

3. WRT BMLinkS, this is the first I have heard of it.  The
    web site indicates modest adoption by Japanese vendors,
    and as best as I can tell from the documentation
    everything is passed as TIFF files, which are a nightmare
    to support thanks to the thousands of possible varients
    you'll run into...

4. CUPS doesn't define required formats, but it does implement
    a lot of them.  I'm more than happy to write up a spec
    for this, though...

-- 
______________________________________________________________________
Michael R Sweet                        Senior Printing System Engineer

---

From: "Ira McDonald" <[email-masked]>
Date: Wed, 20 Aug 2008 22:51:45 -0400

Hi,

XPS - I agree with Mike that it's not appropriate as a required document
format for IPP right now.  But it *is* being formally standardized in ECMA
Technical Committee 46:

  http://www.ecma-international.org/memento/TC46.htm

And their current draft 1.2 is much improved from the earlier drafts
- worth watching.

Cheers,
- Ira

-- 
Ira McDonald (Musician / Software Architect)
Chair - Linux Foundation Open Printing WG
Blue Roof Music/High North Inc
email: [email-masked]
winter:
 579 Park Place Saline, MI 48176
 734-944-0094
summer:
 PO Box 221 Grand Marais, MI 49839
 906-494-2434

---

From: Michael Sweet <[email-masked]>
Date: Wed, 20 Aug 2008 20:35:01 -0700

> And their current draft 1.2 is much improved from the earlier drafts

Unless the patent stuff is resolved to allow for open source/free
software implementations, I would be opposed to adding it even if
it gets an ECMA stamp of approval.

---

From: "Ira McDonald" <[email-masked]>
Date: Wed, 20 Aug 2008 23:44:18 -0400

Hi Mike,

I agree - the PWG hasn't ever standardized encumbered technology
and it shouldn't ever start doing so.

Cheers,
- Ira