Subject: [IPP] IPP Agenda - 4pm EDT Monday 17 May 2010

From: Ira McDonald <[email-masked]>
Date: Fri, 14 May 2010 16:51:39 -0400

Hi,

[watch for update with Live Meeting link if Pete Zehler can set up]

Reminder of our next IPP WG call:

 Monday 17 May - 1-2pm PDT / 4-5pm EDT

 Call-in toll-free number (US/Canada): 1-866-469-3239
 Call-in toll number (US/Canada): 1-650-429-3300 (Primary)
 Call-in toll number (US/Canada): 1-408-856-9570 (Backup)

 Attendee Access Code: *******#
 Attendee ID Code: # (empty)

If you need the Attendee Access code, please email me a request.

*** Main Objectives - finish up IPP JPS2, continue IPP/2.0 SE ***

Agenda:

(1) PWG IP Policy and Minute Taker
 - Mike?

(2) Approve IPP minutes from 10 May teleconference
 - ftp://ftp.pwg.org/pub/pwg/ipp/minutes/ippv2-concall-minutes-20100510.pdf

(3) Review of IPP Job and Printer Operations Set2 (Tom)
 - ftp://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippjobprinterext10-v26-20100509-rev.pdf
 <or later draft, if available>

(4) Review of IPP Version 2.0 Second Edition (Ira)
 - ftp://ftp.pwg.org/pub/pwg/ipp/wd/wd-ipp20-20100512-rev.pdf

(5) Status of PWG Last Call on IPP Everywhere Charter (Mike/Ira)
 - ftp://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippeverywhere-charter-20100417.pdf

(6) Next Steps
 - Next IPP WG Call - Monday 24 May - 4-5pm US EDT
 - IPP Everywhere Last Call - ends Friday 28 May
 - PWG F2F IPP Everywhere - Thursday 10 June - 2-3pm US EDT
 - PWG F2F IPP WG - Thursday 10 June - 3-5pm US EDT

Cheers,
- Ira (IPP co-editor)

Ira McDonald (Musician / Software Architect)
Chair - Linux Foundation Open Printing WG
Co-Chair - TCG Hardcopy WG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music/High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto:[email-masked]
winter:
  579 Park Place  Saline, MI  48176
  734-944-0094
summer:
  PO Box 221  Grand Marais, MI 49839
  906-494-2434

-- 
This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: "Tom Hastings" <[email-masked]>
Date: Mon, 17 May 2010 02:22:08 -0700

I've uploaded v27 of JPS2 for Monday's IPP concall:

ftp://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippjobprinterext10-v27-20100516-rev.doc
ftp://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippjobprinterext10-v27-20100516-rev.pdf

Error Log:
18.1	16 May 2010 (v27)
1.	Section 7.4 job-delay-output-until (type3 keyword | name(MAX)) and
7.5 job-delay-output-until-time (dateTime): Only Set-Job-Attributes can get
a job out of a indefinitely delay-output condition; Resume-Job and
Release-Job cannot be used for this.
2.	Section 7.6 job-hold-until-time  (dateTime):  Tightened up the error
response to the bad request with both "job-hold-until" and
"job-hold-until-time" specified in a job creation operation, so that the
Printer MUST reject the operation and return
'client-error-conflicting-attributes' status code.
3.	Figure 4 - Time Sequence Diagram for 1 Hold, 2 Delay Output, and 4
normal Jobs: Made arrows more horizontal.
4.	Added Section 8 Additional semantics for existing operations with
subsections: 8.1 Additional attribute for use with the Hold-Job operation
and 8.2 Additional attributes for use with the Set-Job-Attributes operation

Tom

-----Original Message-----
From: Ira McDonald [mailto:[email-masked]] 
Sent: Friday, May 14, 2010 13:52
To: [email-masked]; Tom Hastings; Michael R Sweet; Paul Tykodi; Ira McDonald
Subject: IPP Agenda - 4pm EDT Monday 17 May 2010

Hi,

Agenda:

(3) Review of IPP Job and Printer Operations Set2 (Tom)
 -
ftp://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippjobprinterext10-v26-20100509-rev.pdf
 <or later draft, if available>

(6) Next Steps

Cheers,
- Ira (IPP co-editor)