Subject: RE: [Pwg-Announce] Call for Review of langPDF/PS/PCL variants for IANAPrinter MIB (30 April 2010)

From: "George Liu" <[email-masked]>
Date: Mon, 3 May 2010 09:50:42 -0700

Unlike PDF, which is a document format, Postscript and PCL/PCL-XL are PDL, which means printer-device specific.

A Tray-1 PCL command for HP printer means Bypass Tray, but means the first tray under the printer engine for Ricoh printer.
Also, in Postscript, there are many vendor specific Postscript setpagedevice commands. 

How will the new command set definition handles this case?

Are we only taking about the graphics drawing part not the device control part?
Or are we making "langPCL5e" only for a specific vender?

George

 -----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Ira McDonald
Sent: Friday, April 30, 2010 7:56 AM
To: [email-masked]; Michael R Sweet; Ira McDonald
Subject: [Pwg-Announce] Call for Review of langPDF/PS/PCL variants for IANAPrinter MIB (30 April 2010)

Hi,

This call for review will end on Friday 14 May 2010.

ftp://ftp.pwg.org/pub/pwg/pmp/iana/langpdf-20100414.txt
- full text also below in my previous note

Before registering these PDF, PostScript, and PCL printer
language variants with IANA, your IETF Designated Experts
(Mike Sweet and Ira McDonald) would like to solicit any last
comments or additions from the larger PWG community.

The two major use cases for these language variants are:

(1) Driver installation based on 1284 Device ID strings
      - i.e., selecting appropriate device drivers during
      local or network printer installation

(2) Content generation based on 1284 Device ID strings
      - i.e., generating the correct subset of a language in
      an intelligent application generating print-ready output

Please take a few minutes to review and comment.

Cheers,
- Ira (IETF Designated Expert for IANA Printer MIB)

Ira McDonald (Musician / Software Architect)
Chair - Linux Foundation Open Printing WG
Co-Chair - TCG Hardcopy WG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music/High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto:[email-masked]
winter:
  579 Park Place  Saline, MI  48176
  734-944-0094
summer:
  PO Box 221  Grand Marais, MI 49839
  906-494-2434

On Wed, Apr 14, 2010 at 4:50 PM, Ira McDonald <[email-masked]> wrote:
> Hi,
>
> [For review at WIMS WG teleconference on 19 April 2010]
>
>
> Added PCL3GUI in this second draft, per Mike Sweet's comment.
>
> Per requests from Linux Foundation Open Printing WG and Jerry
> Thrasher (Lexmark), I just posted proposed text for new values of
> PrtInterpreterLangFamilyTC in the IANA Printer MIB at:
>
>  ftp://ftp.pwg.org/pub/pwg/pmp/iana/langpdf-20100414.txt
>
> These values specify variants of the PDF, PostScript, and PCL
> printer languages, for machine-readable clarity (since the other
> version fields in prtInterpreterTable in IETF Printer MIB are NOT
> standardized and are therefore NOT reliably machine-readable).
>
> Full text is also included below (hint - view in a fixed width font).
>
> Cheers,
> - Ira (IETF Designated Expert for IANA Printer MIB)
>
> ------------------------------------------
> Permanent enumerated name/value registrations for IANA Printer MIB
>
> In PrtInterpreterLangFamilyTC, delete comma after 'langXHTMLPrint(71)'
> and add the following:
>
>       langPDFis(72),       -- Not in RFC 3805
>                            -- PWG PDF Image-Streamable (PWG 5102.3)
>                            -- ftp://pwg.org/pub/pwg/candidates/
>                            --   cs-ifxpdfis10-20040315-5102.3.pdf
>                            -- See also 'langPDF'
>       langPDF13(73),       -- Not in RFC 3805
>                            -- Adobe Portable Document Format v1.3
>                            -- http://www.adobe.com/devnet/
>                            --   pdf/pdfs/PDFReference13.pdf
>                            -- See also 'langPDF'
>       langPDF14(74),       -- Not in RFC 3805
>                            -- Adobe Portable Document Format v1.4
>                            -- http://www.adobe.com/devnet/
>                            --   pdf/pdfs/PDFReference.pdf
>                            -- See also 'langPDF'
>       langPDF15(75),       -- Not in RFC 3805
>                            -- Adobe Portable Document Format v1.5
>                            -- http://www.adobe.com/devnet/
>                            --   pdf/pdfs/PDFReference15_v5.pdf
>                            -- See also 'langPDF'
>       langPDF16(76),       -- Not in RFC 3805
>                            -- Adobe Portable Document Format v1.6
>                            -- http://www.adobe.com/devnet/
>                            --   pdf/pdfs/PDFReference16.pdf
>                            -- See also 'langPDF'
>       langPDF17(77),       -- Not in RFC 3805
>                            -- Adobe Portable Document Format v1.7
>                            -- http://www.adobe.com/devnet/
>                            --   acrobat/pdfs/pdf_reference_1-7.pdf
>                            -- Equivalent to ISO 32000-1:2008
>                            -- See also 'langPDF'
>       langPS2(78),         -- Not in RFC 3805
>                            -- Adobe PostScript Second Edition
>                            -- http://partners.adobe.com/public/
>                            --   developer/en/ps/psrefman.pdf
>                            -- See also 'langPS'
>       langPS3(79),         -- Not in RFC 3805
>                            -- Adobe PostScript Third Edition
>                            -- http://www.adobe.com/products/
>                            --   postscript/pdfs/PLRM.pdf
>                            -- See also 'langPS'
>       langPCL3(80),        -- Not in RFC 3805
>                            -- HP Printer Command Language 3
>                            -- No technical reference manual online
>                            -- See also 'langPCL'
>       langPCL3GUI(81),     -- Not in RFC 3805
>                            -- HP Printer Command Language 3 GUI
>                            -- No technical reference manual online
>                            -- See also 'langPCL'
>       langPCL5e(82),       -- Not in RFC 3805
>                            -- HP Printer Command Language 5 Enhanced
>                            -- http://h20000.www2.hp.com/bc/docs/
>                            --   support/SupportManual/bpl13210/
>                            --   bpl13210.pdf
>                            -- See also 'langPCL'
>       langPCL5c(83)        -- Not in RFC 3805
>                            -- HP Printer Command Language 5 Color
>                            -- http://h20000.www2.hp.com/bc/docs/
>                            --   support/SupportManual/bpl13212/
>                            --   bpl13212.pdf
>                            -- See also 'langPCL'
>
> Proposed: Ira McDonald (High North) and Jerry Thrasher (Lexmark)
> Reviewed: Email discussion on Printer MIB mailing list
> Approved: <TBD>
> By:       Ira McDonald (IETF Designated Expert for IANA Printer MIB)
> Email:    [email-masked]
>

-- 
This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.

_______________________________________________
pwg-announce mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/pwg-announce

-- 
This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.

_______________________________________________
pwg-announce mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/pwg-announce

---

From: Ira McDonald <[email-masked]>
Date: Mon, 3 May 2010 13:47:11 -0400

Hi George,

Right - we're only talking about the graphics drawing aspect
of these printer languages.

The IEEE 1284 Device ID format only supports a list of
printer languages - it cannot be extended (interoperably)
for these other device-specific aspects.

The PWG cannot actually extend the capabilities keywords
or their syntax in the base IEEE 1284 spec.

So the scope of comments we're requesting is only to identify
any other common variants of PCL (for example) that should
be registered with IANA.

All of these are enumerated values in the single Printer MIB
integer object prtInterpreterLangFamily.  Other objects such
as prtInterpreterLangLevel and prtInterpreterDescription can
be used by vendors to distinguish vendor-unique features.

Cheers,
- Ira

---

From: "George Liu" <[email-masked]>
Date: Mon, 3 May 2010 11:10:46 -0700

Has PCL-XL been left out intentionally?

There're PCL-XL 1.1, 2.0, 3.0, etc. Microsoft GPD based mini drivers is
able to generate PCL-XL.

George

-----Original Message-----
From: Ira McDonald [mailto:[email-masked]] 
Sent: Monday, May 03, 2010 10:47 AM
To: George Liu; Ira McDonald
Cc: [email-masked]; Michael R Sweet
Subject: Re: [Pwg-Announce] Call for Review of langPDF/PS/PCL variants
for IANAPrinter MIB (30 April 2010)

Hi George,

Cheers,
- Ira

On Mon, May 3, 2010 at 12:50 PM, George Liu <[email-masked]>
wrote:
> Unlike PDF, which is a document format, Postscript and PCL/PCL-XL are
PDL, which means printer-device specific.
>
> A Tray-1 PCL command for HP printer means Bypass Tray, but means the
first tray under the printer engine for Ricoh printer.

---

From: Michael Sweet <[email-masked]>
Date: Mon, 3 May 2010 10:59:35 -0700

> Unlike PDF, which is a document format, Postscript and PCL/PCL-XL are PDL, which means printer-device specific.

PostScript and PCL *can* be device-independent as long as you stay away from obvious device-specific commands or settings. In all cases (even for PDF!) you have to make certain assumptions about supported media, margins, resolutions, and color spaces, or gather this information from other sources - see below.

> Or are we making "langPCL5e" only for a specific vender?

I think we are stuck treating these as languages/language families. Device-specific capability or feature information (tray numbers, etc.) has to be looked up separately. Today this means using the 1284 device ID to look up an appropriate printer driver, and for some devices this means (for example) picking between the PostScript, PCL 6, or PCL 5e driver depending on what the customer purchased.

This is one of the problems that IPP Everywhere is trying to solve, BTW...

>  579 Park Place  Saline, MI  48176

________________________________________________________________________
Michael Sweet, Senior Printing System Engineer, PWG Chair

---

From: Michael Sweet <[email-masked]>
Date: Mon, 3 May 2010 11:15:56 -0700

> Has PCL-XL been left out intentionally?

Yes, because it is already registered in RFC 3805:

        langPCLXL(47),       -- Not in RFC 1759
                             -- Printer Control Language. Extended
                             -- language features for printing, and
                             -- printer control.
                             -- Tammy Ferguson (HP)
                             -- and Binnur Al-Kazily (HP)
                             -- Technical reference manual: None
                             -- Hewlett-Packard Co.

---

From: "George Liu" <[email-masked]>
Date: Mon, 3 May 2010 13:49:44 -0700

> I think we are stuck treating these as languages/language families. 

I'd like to suggest change the description for langPCL3, langPCL3GUI, langPCL5e, langPCL5c. Rename "HP Printer Command Language xxx" to "Printer Command Language xxx"

George

---

From: Michael Sweet <[email-masked]>
Date: Mon, 3 May 2010 13:46:41 -0700

That's probably appropriate; Ira, let's normalize the PCL and PostScript descriptions to match the format of the current registrations:

        langPCL(3),          -- PCL.  Starting with PCL version 5,
                             -- HP-GL/2 is included as part of the
                             -- PCL language.
                             -- PCL and HP-GL/2 are registered
                             -- trademarks of Hewlett-Packard
                             -- Company.
        langPS(6),           -- PostScript (tm) Language
                             -- Postscript - a trademark of Adobe
                             -- Systems Incorporated which may be
                             -- registered in certain jurisdictions
Looks like the existing langPDF and the new langPDF* definitions are already using the same conventions, so just the new PCL and PS descriptions need updating.

---

From: Ira McDonald <[email-masked]>
Date: Mon, 3 May 2010 17:21:32 -0400

Hi George and Mike,

I *strongly* disagree with dropping "HP" and "Adobe" from the
ASN.1 comments for these new registrations.

Ever since RFC 1759, the company that defined each printer
language has been named explicitly in all ASN.1 comments.
This is *very* important in order to distinguish from (possible
future) registrations of other vendor-extended variants.

Look at all of our recent XPS, OpenXPS, JDF, JMF, PPML, etc.
IANA registrations as well as the Printer MIB v1/v2 legacy.

If Ricoh wishes, they can request registration of vendor variants
of PCL (that include "Ricoh" in both the enum tags and ASN.1
comments).

Cheers,
- Ira

On Mon, May 3, 2010 at 4:46 PM, Michael Sweet <[email-masked]> wrote:
> That's probably appropriate; Ira, let's normalize the PCL and PostScript
> descriptions to match the format of the current registrations:
>
> Looks like the existing langPDF and the new langPDF* definitions are already
> using the same conventions, so just the new PCL and PS descriptions need
> updating.
> I'd like to suggest change the description for langPCL3, langPCL3GUI,
> langPCL5e, langPCL5c. Rename "HP Printer Command Language xxx" to "Printer
> Command Language xxx"
>
> George
>

---

From: Michael Sweet <[email-masked]>
Date: Mon, 3 May 2010 15:02:31 -0700

> ASN.1 comments for these new registrations.

Ira, I'm not suggesting that we drop "HP" or "Adobe", just that we adopt the format used by the current entries (which puts the vendor name *after* the format name) for consistency. I absolutely agree that we need to still have the vendor listed since HP and Adobe control/own the corresponding formats.

---

From: Ira McDonald <[email-masked]>
Date: Mon, 3 May 2010 18:14:32 -0400

Hi Mike,

Ah - I think I understand what you mean now.

In most Printer MIB v1/v2 entries as well as *all*
of the PDF/PS/PCL proposed entries, the vendor
name is BEFORE the name of the language in the
ASN.1 comments - that's where it belongs.

And there is no IANA procedure for changing the
comments on an *already* registered value (such as
you suggested for the base PS and PCL values).

I want to avoid changing Printer MIB v1 registrations,
for stability - unless they're seriously defective - there's
deployed software out there that displays these ASN.1
comments in a "more info" tab/button.

Cheers,
- Ira

---

From: "George Liu" <[email-masked]>
Date: Tue, 4 May 2010 09:54:50 -0700

Ira,

You mentioned in your previous posting the following MIB field:
prtInterpreterLangFamily, prtInterpreterLangLevel and prtInterpreterDescription.

Is the newly defined PDL values for any of the fields?
It looks like it's pretty hard to divide "langPDFis" into interpreter family field and language level field programmatically.

George

-----Original Message-----
From: Ira McDonald [mailto:[email-masked]] 
Sent: Monday, May 03, 2010 3:15 PM
To: Michael Sweet; Ira McDonald
Cc: George Liu; [email-masked]
Subject: Re: [Pwg-Announce] Call for Review of langPDF/PS/PCL variants for IANAPrinter MIB (30 April 2010)

Hi Mike,

Cheers,
- Ira

---

From: Ira McDonald <[email-masked]>
Date: Tue, 4 May 2010 13:03:37 -0400

Hi George,

These language variant tags are *all* for addition to the textual
convention PrtInterpreterLangFamilyTC in the IANA Printer MIB
(original version in RFC 3805) for use in prtInterpreterLangFamily
object.

When the PWG PDF/is variant is registered, there will be no need
to qualify it in prtInterpreterLangLevel - it's independent.

Cheers,
- Ira