Subject: [IPP] Canon's feedback to NODRIVER v2 - 6.4.1 client-info

From: Steven Young via ipp <[email-masked]>
Date: Fri, 17 Dec 2021 21:01:54 +0000

[Background]
As you know, the attribute "client-info" in NODRIVER v2 spec was recommended by Smith Kennedy that IHV printer can identify what OS client IPP is sending to printer.
6.4.1 client-info
6.1.1.1<https://nam12.safelinks.protection.outlook.com/?url=http%3A%2F%2F6.1.1.1%2F&data=04%7C01%7Csyoung%40cusa.canon.com%7C0e14357ae4334eda1d2c08d9c19dda6a%7C5132013a1c8d4f879f4d43110f5bc07b%7C0%7C0%7C637753705998607912%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=UgVAeQqvJyF4APgnjW1pVGwKKpFZo77zT2K%2F06ebZd0%3D&reserved=0> client-key (type2 keyword)
6.1.1.2<https://nam12.safelinks.protection.outlook.com/?url=http%3A%2F%2F6.1.1.2%2F&data=04%7C01%7Csyoung%40cusa.canon.com%7C0e14357ae4334eda1d2c08d9c19dda6a%7C5132013a1c8d4f879f4d43110f5bc07b%7C0%7C0%7C637753705998607912%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=AOgmoXyQboxdScVgY8ZcUfQmDvZAHKDcrA706L7uj4k%3D&reserved=0> client-name (name(MAX))
6.1.1.5<https://nam12.safelinks.protection.outlook.com/?url=http%3A%2F%2F6.1.1.5%2F&data=04%7C01%7Csyoung%40cusa.canon.com%7C0e14357ae4334eda1d2c08d9c19dda6a%7C5132013a1c8d4f879f4d43110f5bc07b%7C0%7C0%7C637753705998607912%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=cGRvGGF5McJ7jM2g6qtwcDoElqo05AT4u5Z3lwUcVEA%3D&reserved=0> client-version (octetString(64))

[Feedback (Request) from Canon]
Our goal of using this is to clearly identify the existing OSs. For example, the following major OSs should be identified separately at lease:
Windows 10, 11, 11SE, Mac OS, iOS, Android OS, Chrome OS, etc.
Therefore, Canon would want PWG IPP WG to define the key values in this spec doc before it is published.

Regards,

Steven

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: "Kennedy, Smith \(Wireless & IPP Standards\) via ipp" <[email-masked]>
Date: Fri, 17 Dec 2021 21:27:14 +0000

Hi Steven,

I completely agree with this feedback and I will work to incorporate a listing of keywords into the next draft of IPP Driverless Printing Extensions v2.0.

Happy holidays!

Cheers,
Smith
---
Smith Kennedy
[email-masked]

On Dec 17, 2021, at 2:02 PM, Steven Young via ipp <[email-masked]> wrote:

[Background]
As you know, the attribute “client-info” in NODRIVER v2 spec was recommended by Smith Kennedy that IHV printer can identify what OS client IPP is sending to printer.
6.4.1 client-info
6.1.1.1<https://nam12.safelinks.protection.outlook.com/?url=http%3A%2F%2F6.1.1.1%2F&data=04%7C01%7Csyoung%40cusa.canon.com%7C0e14357ae4334eda1d2c08d9c19dda6a%7C5132013a1c8d4f879f4d43110f5bc07b%7C0%7C0%7C637753705998607912%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=UgVAeQqvJyF4APgnjW1pVGwKKpFZo77zT2K%2F06ebZd0%3D&reserved=0> client-key (type2 keyword)
6.1.1.2<https://nam12.safelinks.protection.outlook.com/?url=http%3A%2F%2F6.1.1.2%2F&data=04%7C01%7Csyoung%40cusa.canon.com%7C0e14357ae4334eda1d2c08d9c19dda6a%7C5132013a1c8d4f879f4d43110f5bc07b%7C0%7C0%7C637753705998607912%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=AOgmoXyQboxdScVgY8ZcUfQmDvZAHKDcrA706L7uj4k%3D&reserved=0> client-name (name(MAX))
6.1.1.5<https://nam12.safelinks.protection.outlook.com/?url=http%3A%2F%2F6.1.1.5%2F&data=04%7C01%7Csyoung%40cusa.canon.com%7C0e14357ae4334eda1d2c08d9c19dda6a%7C5132013a1c8d4f879f4d43110f5bc07b%7C0%7C0%7C637753705998607912%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=cGRvGGF5McJ7jM2g6qtwcDoElqo05AT4u5Z3lwUcVEA%3D&reserved=0> client-version (octetString(64))

Regards,

Steven