Subject: Re: [ippm] A question about IPPM!Please help me!

From: [email-masked]
Date: Mon, 20 Mar 2006 15:51:54 -0500

It maybe of help if you would elaborate what you mean by relation between
metrics and how thyey  relates in your view to the network performance - in
other word what do you mean when you say network performance..
If you are looking for some composite index that is a function of latency,
jitter and p loss the shortest way is to look at service type metrics
like MOS a sthey do factor in network performance into one measure but in a
specific way for a specific purpose with some other non network type
parameters.
In general these three metrics are reported independently, but as I said
there are attempts to define QoE indexes for specific services
that are kind of synthetic measures. There is some body of work on QoE
indexes but mostly in presos and informal. internal documents.
roman

------------------------------------------------------------------------------

Roman Krzanowski
PMTS- VTO
500 Westchester Ave
White Plains, NY
10604
(of) 914-644-2395
(fax) 914-644-2301
[email-masked]

                      "天玉 王"                                                                                                  
                      <borlandfox@yahoo        To:       [email-masked]                                                           
                      .com.cn>                 cc:                                                                               
                                               Subject:  [ippm] A question about IPPM!Please help me!                            
                      03/19/2006 09:21                                                                                           
                      PM                                                                                                         

Dear IPPM WorkGroup,
        I am a college student.Now I am researching how to evaluate the
performance of the network based on the current network performance metrics
such as delay,throughput,loss.But how to get the relation between each two
metrics?I have searched on Internet but I could get little material about
this question.Could you help me give me some material or some advices.

Thanks a lot!
2006.3.20
Tianyu Wang

雅虎1G免费邮箱百分百防垃圾信
雅虎助手-搜索、杀毒、防骚扰 _______________________________________________
ippm mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ippm

_______________________________________________
ippm mailing list
[email-masked] 
https://www1.ietf.org/mailman/listinfo/ippm

---

From: "Geib, Ruediger" <[email-masked]>
Date: Tue, 21 Mar 2006 08:17:57 +0100

Joel Sommers, Nick Duffield et al. published on active 
measurements considering delay variation and packet 
loss to estimate the duration and frequency of loss 
events:

http://www.sigcomm.org/sigcomm2005/paper-SomBar.pdf

Regards,

Ruediger

|> I'm a little bit puzzled what you want.  The metrics
|> have been defined to be orthogonal, i.e. delay is 
|> independent of loss, so there is no direct relation.
|
|IMHO, e2e delay could be represent as:
|
|e2e-delay=transmission_delay+propagation_delay+queueing_delay
|
|among the three factors, queueing_delay is the one
|which represent congestion status e2e routing path. Is
|the link is congested, queueing delay should increase
|and packet loss possibility increase too.
|
|So, maybe there is statistical relationship between
|varation of e2e delay and variation of packet loss. 

Ruediger Geib

T-Systems Enterprise Services GmbH
Senior Expert
Systems Integration 
Technologiezentrum
Engineering Networks, Products & Services
Packet based Carrier Transport Networks
Deutsche-Telekom-Allee 7, D-64295 Darmstadt
Fon: +49 6151 937-2138
http://www.t-systems.com

---

From: <[email-masked]>
Date: Tue, 21 Mar 2006 11:37:02 -0000

Regarding the packet loss happened in the delay measurement, it will cause infinite delay and should be ignored. Therefore, the delay measured might have nothing to do with packet loss situation. Whether packets wait in a long queue or short queue, it has no deterministic reflection on congestion or packets drop as long as the packet observed provide a valid delay value. 
 
Cheers,
Lei

________________________________

From: Jing Shen [mailto:[email-masked]]
Sent: Tue 21/03/2006 2:05
To: Henk Uijterwaal; ??" "?; [email-masked]
Subject: Re: Re: [ippm] A question about IPPM!Please help me!

>
> I'm a little bit puzzled what you want.  The metrics
> have been defined
> to be orthogonal, i.e. delay is independent of loss,
> so there is no
> direct relation.

IMHO, e2e delay could be represent as:

e2e-delay=transmission_delay+propagation_delay+queueing_delay

among the three factors, queueing_delay is the one
which represent congestion status e2e routing path. Is
the link is congested, queueing delay should increase
and packet loss possibility increase too.

So, maybe there is statistical relationship between
varation of e2e delay and variation of packet loss.

>
> Of course, one can simply measure two (or more
> quantities) and try to see
> if they are related.  (This has been done in the
> past, and the answer was
> no, in general there is no relation).

The factor, which could not be removed from
measurement packet loss rate, is administrative packet
dropping on routers. Usually, ACL or shaping/policing
is done on access router/switch for special purpose;
so it should be speical condition in e2e performance
measurement statistics.

regards

Jing Shen

___________________________________________________________
??1G???????????
http://cn.mail.yahoo.com/