Subject: [ippm] A question about IPPM!Please help me!

From: 天玉 王 <[email-masked]>
Date: Mon, 20 Mar 2006 10:21:02 +0800 (CST)

Dear IPPM WorkGroup,
          I am a college student.Now I am researching how to evaluate the performance of the network based on the current network performance metrics such as delay,throughput,loss.But how to get the relation between each two metrics?I have searched on Internet but I could get little material about this question.Could you help me give me some material or some advices.
   
  Thanks a lot!
                                                                                       2006.3.20
                                                                                       Tianyu Wang

---------------------------------
 雅虎1G免费邮箱百分百防垃圾信
 雅虎助手-搜索、杀毒、防骚扰  

_______________________________________________
ippm mailing list
[email-masked] 
https://www1.ietf.org/mailman/listinfo/ippm

---

From: Henk Uijterwaal <[email-masked]>
Date: Mon, 20 Mar 2006 18:16:07 +0100

Hi Tianyu,

>         I am a college student.Now I am researching how to evaluate 
> the performance of the network based on the current network 
> performance metrics such as delay,throughput,loss.But how to get 
> the relation between each two metrics?I have searched on Internet 
> but I could get little material about this question.Could you help 
> me give me some material or some advices.

I'm a little bit puzzled what you want.  The metrics have been defined
to be orthogonal, i.e. delay is independent of loss, so there is no
direct relation.

Of course, one can simply measure two (or more quantities) and try to see
if they are related.  (This has been done in the past, and the answer was
no, in general there is no relation).

Henk

------------------------------------------------------------------------------
Henk Uijterwaal                           Email: henk.uijterwaal(at)ripe.net
RIPE Network Coordination Centre          http://www.amsterdamned.org/~henk
P.O.Box 10096          Singel 258         Phone: +31.20.5354414
1001 EB Amsterdam      1016 AB Amsterdam  Fax: +31.20.5354445
The Netherlands        The Netherlands    Mobile: +31.6.55861746
------------------------------------------------------------------------------

1160438400. Watch this space...

---

From: Jing Shen <[email-masked]>
Date: Tue, 21 Mar 2006 10:05:46 +0800 (CST)

> to be orthogonal, i.e. delay is independent of loss,

IMHO, e2e delay could be represent as:

e2e-delay=transmission_delay+propagation_delay+queueing_delay

among the three factors, queueing_delay is the one
which represent congestion status e2e routing path. Is
the link is congested, queueing delay should increase
and packet loss possibility increase too.

So, maybe there is statistical relationship between
varation of e2e delay and variation of packet loss. 

> no, in general there is no relation).

The factor, which could not be removed from
measurement packet loss rate, is administrative packet
dropping on routers. Usually, ACL or shaping/policing
is done on access router/switch for special purpose;
so it should be speical condition in e2e performance
measurement statistics.

regards

Jing Shen

___________________________________________________________ 
雅虎1G免费邮箱百分百防垃圾信 
http://cn.mail.yahoo.com/