Subject: RE: [ippm] Comments on draft-ietf-ippm-framework-compagg-00

From: "Fardid, Reza" <[email-masked]>
Date: Wed, 22 Mar 2006 16:40:54 -0800

Anura,

Can you please quantify small and large inter-packet gaps, in the
context of delay?
Do you consider 20 msec, the frame length of typical VoIP packets,
small?

Regards,
Reza Fardid
Covad Communications

-----Original Message-----
From: Anura Jayasumana [mailto:[email-masked]] 
Sent: Tuesday, March 21, 2006 6:45 PM
To: Philip F. Chimento Jr.
Cc: ippm
Subject: RE: [ippm] Comments on draft-ietf-ippm-framework-compagg-00

>===== Original Message From "Philip F. Chimento Jr."
<[email-masked]> 
=====
>Hi Anura:
>You can add means, whether the relevant RVs are dependent or not, so
>average delays add.
>Higher order statistics, as you point out, do not add simply.
>Convolution ASSUMES that the RVs are independent.
>
>
>Regards,
>Phil Chimento

Phil,
Yes, you are right.  Based on very limited results we have for delay, it
looks 
like the delays are independent if the inter-packet gaps of the stream
is 
large; when ipg is small, such as with a burst, the delays appear to be
highly 
correlated. This is when convolution breaks down. 
Cheers!
AJ

>
>On Mar 21, 2006, at 12:31, Anura Jayasumana wrote:
>
>>
>>
>> Henk Uijterwaal wrote:
>>> Phil,
>>>
>>> The problem that I have with this section is that it doesn't give me
>>> very strong or concrete reasons for why I want to combine metrics.
>>>
>>> Suppose I have a path A-B-C.  I'm interested in the delays between
>>> them.
>>> Now, I can measure all 3 (A-B, B-C and A-B-C) separately.
>>> However, if
>>> there is a way to add up the delays between A-B and B-C, and get the
>>> overall delay, then i can see myself some work and diskspace.  In
>>> general,
>>> I'd be interested in the minimum set of measurements that still
gives
>>> me information about the entire network.
>>>
>>>  Section 5.1: The problem here is that piece-wise measurements do
>>> not necessarily combine. IPDV and re-ordering are examples where one
>>> subsection of a network can "undo" what a previous one has done.
>>> Putting these together in a straightforward way doesn't give you the
>>> right answer.
>>
>> With delays,  if the packet delays in the two networks are not
>> correlated, it is still possible to measure statistics of  delays
>> of segments and combine them to provide end-to-end delay
>> statistics.  When delays are correlated, it becomes necessary to
>> measure correlation as well.... which would be more complex.
>> Reordering is somewhat of a harder problem. But, when  captured
>> using RD (reorder density), you can combine the reordering in
>> different segments and still come up with end-to-end reordering.
>> Combination is done using
>> convolution, which would be the case for delay also.  One thing
>> going for RD is the fact that reordering in two network segments
>> are less likely to be correlated compared to delay.  We have
>> carried out many mesurements on Internet, planet-lab, simulations,
>> etc., and are yet to see a case where it did not work - for
>> reordering.
>> (See http://www.cnrl.colostate.edu/packet_reorder.html )
>> Cheers!
>> AJ
>>
>>>
>>> I agree but can't we just say so?
>>>
>>> Henk
>>>
>>>
>>>
---------------------------------------------------------------------
>>> ---------
>>> Henk Uijterwaal                           Email: henk.uijterwaal
>>> (at)ripe.net
>>> RIPE Network Coordination Centre          http://
>>> www.amsterdamned.org/~henk
>>> P.O.Box 10096          Singel 258         Phone: +31.20.5354414
>>> 1001 EB Amsterdam      1016 AB Amsterdam  Fax: +31.20.5354445
>>> The Netherlands        The Netherlands    Mobile: +31.6.55861746
>>>
---------------------------------------------------------------------
>>> ---------
>>>
>>> 1160438400. Watch this space...
>>>
>>> _______________________________________________
>>> ippm mailing list
>>> [email-masked] https://www1.ietf.org/mailman/listinfo/ippm
>>
>> Anura P. Jayasumana
>> Professor, Electrical & Computer Engineering
>>                            and Computer Science
>> Department of Electrical and Computer Engineering
>> Colorado State University
>> Fort Collins, CO 80523
>> Phone: (970) 491-7855
>> Fax: (970) 491-2249
>> Email: <[email-masked]>
>
>
>_______________________________________________
>ippm mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/ippm

_______________________________________________
ippm mailing list
[email-masked] 
https://www1.ietf.org/mailman/listinfo/ippm

_______________________________________________
ippm mailing list
[email-masked] 
https://www1.ietf.org/mailman/listinfo/ippm

---

From: Anura Jayasumana <[email-masked]>
Date: Thu, 23 Mar 2006 10:29:48 -0700

Hi Reza,
You hit the key point I  tried to avoid as the answer is not simple.
The value is relative,  and depends on intermediate link speeds, current 
congestion etc. 
20 ms would be small in a slow bit-rate network, or if going through
a narrow bottleneck, while it may be high in a fast network - say a 
100Mbps LAN.   
One of the main causes of correlation is due to later packets of a 
stream having to wait (e.g. in a queue) while prior packets in the same 
stream are being processed.  

Although we were not directly addressing the issue being disussed,  a 
paper at ICON 2004 -  
http://www.engr.colostate.edu/ece/faculty/jayasumana/pdf/conferences/icon_04_np.pdf
contains measurements and a discussion illustrating  this problem.

Cheers!
Anura

Fardid, Reza wrote:

>-

Anura P. Jayasumana <http://www.engr.colostate.edu/%7Eanura>