Subject: RE: [ippm] On draft-niccolini-ippm-storetraceroutes

From: "Saverio Niccolini" <[email-masked]>
Date: Wed, 22 Mar 2006 19:12:04 +0100

Hi Henk, 

> -----Original Message-----
> From: Henk Uijterwaal [mailto:[email-masked]] 
> Posted At: Tuesday, March 21, 2006 6:13 PM
> Posted To: ippm
> Conversation: [ippm] On draft-niccolini-ippm-storetraceroutes
> Subject: [ippm] On draft-niccolini-ippm-storetraceroutes
> 
> 
> Saverio et al,
> 
> While reading up for this afternoon's meeting:
> 
> - I don't really understand the last paragraph of 6.2.  I thought the
>    idea was to make this uniform between IPPM and GGF.  Why 
> use different
>    names for the same things then?

I am sorry this was my fault, in the rush of updating the 
draft for IETF 65 I forgot to update this paragraph. :-(

> - In 7, I think we should use the metrics in RFC 2679... for RTT's,
>    the RTT's with a traceroute are very rough measurements

I do not understand what you mean by:
"we should use the metrics in RFC 2679"
are you referring to one way delay metric?

traceroute RTT is not conformant to RFC 2679
I think there is no way to store metrics as defined in RFC 2679
as an output of a traceroute measurement.

Maybe I did not understand your question, can you clarify it?

> - 11, open issues: YES, there should be a field for storing the AS.
>    (In a lot of cases, it doesn't really matter if you go through
>     router A or router B inside AS1 (load balancing and such), but it
>     does make a huge difference if you go through AS1 or AS2.

ok, we will add this to next release.

>    We should probably also have a way to specify who the IP to AS
>    mapping was done.

I can investigate this further, I have no ideas coming to my mind
right now but I will address this.

Thank you for the comments,
Saverio

> Henk
> 
> 
> 
> --------------------------------------------------------------
> ----------------
> Henk Uijterwaal                           Email: 
> henk.uijterwaal(at)ripe.net
> RIPE Network Coordination Centre          
> http://www.amsterdamned.org/~henk
> P.O.Box 10096          Singel 258         Phone: +31.20.5354414
> 1001 EB Amsterdam      1016 AB Amsterdam  Fax: +31.20.5354445
> The Netherlands        The Netherlands    Mobile: +31.6.55861746
> --------------------------------------------------------------
> ----------------
> 
> 1160438400. Watch this space... 
> 
> 
> _______________________________________________
> ippm mailing list
> [email-masked] 
> https://www1.ietf.org/mailman/listinfo/ippm
> 

_______________________________________________
ippm mailing list
[email-masked] 
https://www1.ietf.org/mailman/listinfo/ippm

---

From: Henk Uijterwaal <[email-masked]>
Date: Wed, 22 Mar 2006 23:56:07 +0100

Hi Saverio,

>as an output of a traceroute measurement.

The RTT results from the various traceroute implementations are
somewhat unreliable, and certainly do not follow the metrics that
the group has defined.  So, we may store the numbers from the
traceroute printout but we should encourage people to use the
RFC2679-2682 metrics.

>right now but I will address this.

There are various tricks one can do: look at a router RIB, look
at Internet registries, etc.  These produce slightly different
results.

Henk

>Thank you for the comments,

------------------------------------------------------------------------------
Henk Uijterwaal                           Email: henk.uijterwaal(at)ripe.net
RIPE Network Coordination Centre          http://www.amsterdamned.org/~henk
P.O.Box 10096          Singel 258         Phone: +31.20.5354414
1001 EB Amsterdam      1016 AB Amsterdam  Fax: +31.20.5354445
The Netherlands        The Netherlands    Mobile: +31.6.55861746
------------------------------------------------------------------------------