Subject: [ippm] FW: Draft http://tools.ietf.org/wg/ippm/draft-morton-ippm-delay-var-as-04.txt

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Mon, 11 Feb 2008 18:04:57 +0100

If the question that is being asked is 'do you believe that the
document' is in good shape to become an IPPM WG work item?', my answer
is 'yes'.

Dan

-----Original Message-----
From: Henk Uijterwaal [mailto:[email-masked]] 
Sent: Monday, February 11, 2008 12:26 PM
Subject: Draft
http://tools.ietf.org/wg/ippm/draft-morton-ippm-delay-var-as-04.txt

Hi

Last year, you expressed interest in

   http://tools.ietf.org/wg/ippm/draft-morton-ippm-delay-var-as-04.txt

and supported it as an IPPM WG document.  Did you read the latest
version of the document and if so, can you please post comments to the
[email-masked] list.  Even a "yes, I've read it and it is fine" is
already very helpful.

Thanks!

Henk
_______________________________________________
ippm mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/ippm

---

From: Henk Uijterwaal <[email-masked]>
Date: Mon, 11 Feb 2008 20:22:46 +0100

> document' is in good shape to become an IPPM WG work item?', my answer

We already asked that one, the next question is: do you agree with the
contents, what should be added/changed/removed?

Henk

-- 
------------------------------------------------------------------------------
Henk Uijterwaal                           Email: henk.uijterwaal(at)ripe.net
RIPE Network Coordination Centre          http://www.amsterdamned.org/~henk
P.O.Box 10096          Singel 258         Phone: +31.20.5354414
1001 EB Amsterdam      1016 AB Amsterdam  Fax: +31.20.5354445
The Netherlands        The Netherlands    Mobile: +31.6.55861746
------------------------------------------------------------------------------

Is one of the choices leaving the office open?
                                       Alan Greenspan on the next elections
_______________________________________________
ippm mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/ippm

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Mon, 11 Feb 2008 20:34:25 +0100

IMO section 5 and most of section 6 should probably go away. I am not
sure that section 8 is within the 'traditional' scope of IPPM. 

Dan

> Sent: Monday, February 11, 2008 9:23 PM
> To: Romascanu, Dan (Dan)
> Cc: IETF IPPM WG
> Subject: Re: [ippm] FW: Draft 
> We already asked that one, the next question is: do you agree 
> with the contents, what should be added/changed/removed?
> 
> Henk
> 
> 
> > 
> > Dan
> > 
> > 
> > 
> >  
> > 
> This email was protected during delivery to Avaya with TLS encryption
> 
>

---

From: Benoit Claise <[email-masked]>
Date: Tue, 12 Feb 2008 01:04:59 +0100

Dan,

While I "could" understand your point about section 5, I don't 
understand the arguments about removing section 6.
I thought it gave some useful comparison between IPDV and PDV when 
looking at parameters packet loss, path changes, clocks, composition.
- "In conclusion, the PDV results are affected by the packet loss ratio.
   The IPDV results are affected by both the packet loss ratio and the
   packet loss distribution.  In the extreme case of loss of every other
   packet, IPDV doesn't provide any results."
   is an important conclusion (just to reference one) for the selection 
of the DV method
- For example, do we NTP for one-way delay and delay variation is a 
typical question I receive from customers.
- Same thing for "how do I combine DV?"

Again for section 8, I have to explain to customers/partners
- "You want Poisson because it's random. But it's sometimes better to 
get a random start with fixed intervals..."
- "With PDV, it is sufficient to specify the upper percentile (e.g.,  
99.9%), while it's different with IPDV"
- How long should I measure etc...

Considering that this draft is there as an entry point for delay 
variation explanations + a series of guidelines (at least this was my 
intention) I spent quite some time on these sections. Specifically, if 
section 5 is removed, we need to list somewhere the conclusions of the 
published papers referenced in section 5. The place would then be the 
current section 6. Unless you have a different view?

Regards, Benoit.

>>> document' is in good shape to become an IPPM WG work 
>>>       
>> item?', my answer 
>>     
>>> is 'yes'.
>>>       
>>> version of the document and if so, can you please post 
>>>       
>> comments to the 
>>

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Tue, 12 Feb 2008 12:00:37 +0100

Benoit,
 
Let me say that I am finding this discussion to happen a little bit too
early, but I was answering to the challenge coming from Henk. Usually
such discussions happen when the document became a work item, or even at
WGLC. 
 
Section 5 includes A LOT of history which seems to me not relevant and
usually is not included in IETF documents. Maybe a short summary should
be part of Section 6 but not all the details. In section 6 I do not see
the point of 6.5 and 6.6, and have doubts about 6.8, but maybe I should
read this one again to make sure that I understand the issues. 
 
The issue with section 8 is that it goes into some details about
measurement methods and devices, rather than metrics. It would be
interested to hear the opinion of other IPPM folks. 
 
Dan

________________________________

	From: Benoit Claise [mailto:[email-masked]] 
	Sent: Tuesday, February 12, 2008 2:05 AM
	To: Romascanu, Dan (Dan)
	Cc: Henk Uijterwaal; IETF IPPM WG
	Subject: Re: [ippm] FW:
http://tools.ietf.org/wg/ippm/draft-morton-ippm-delay-var-as-04.txt

	Dan,
	
	While I "could" understand your point about section 5, I don't
understand the arguments about removing section 6.
	I thought it gave some useful comparison between IPDV and PDV
when looking at parameters packet loss, path changes, clocks,
composition.
	- "In conclusion, the PDV results are affected by the packet
loss ratio.
	   The IPDV results are affected by both the packet loss ratio
and the
	   packet loss distribution.  In the extreme case of loss of
every other
	   packet, IPDV doesn't provide any results." 
	   is an important conclusion (just to reference one) for the
selection of the DV method
	- For example, do we NTP for one-way delay and delay variation
is a typical question I receive from customers.
	- Same thing for "how do I combine DV?"
	
	Again for section 8, I have to explain to customers/partners
	- "You want Poisson because it's random. But it's sometimes
better to get a random start with fixed intervals..."
	- "With PDV, it is sufficient to specify the upper percentile
(e.g.,  99.9%), while it's different with IPDV"
	- How long should I measure etc...

	Regards, Benoit.

		IMO section 5 and most of section 6 should probably go
away. I am not
		sure that section 8 is within the 'traditional' scope of
IPPM. 
		
		Dan

		  

			-----Original Message-----
			From: Henk Uijterwaal [mailto:[email-masked]] 
			Sent: Monday, February 11, 2008 9:23 PM
			To: Romascanu, Dan (Dan)
			Cc: IETF IPPM WG
			Subject: Re: [ippm] FW: Draft 

				 If the question that is being asked is
'do you believe that the 
				document' is in good shape to become an
IPPM WG work 

			item?', my answer 

				is 'yes'.

			We already asked that one, the next question is:
do you agree 
			with the contents, what should be
added/changed/removed?
			
			Henk

				Dan

				-----Original Message-----
				From: Henk Uijterwaal
[mailto:[email-masked]]

				Hi

				      

				and supported it as an IPPM WG document.
Did you read the latest 
				version of the document and if so, can
you please post 

			comments to the 

				[email-masked] list.  Even a "yes, I've
read it and it is fine" is 
				already very helpful.
				
				Thanks!
				
				Henk

			--
	
--------------------------------------------------------------
			----------------
			Henk Uijterwaal                           Email:

			henk.uijterwaal(at)ripe.net
			RIPE Network Coordination Centre          
			http://www.amsterdamned.org/~henk
			P.O.Box 10096          Singel 258         Phone:
+31.20.5354414
			1001 EB Amsterdam      1016 AB Amsterdam  Fax:
+31.20.5354445
			The Netherlands        The Netherlands
Mobile: +31.6.55861746
	
--------------------------------------------------------------
			----------------
			
			                                       Alan
Greenspan on the 
			next elections
			
			This email was protected during delivery to
Avaya with TLS encryption

---

From: Henk Uijterwaal <[email-masked]>
Date: Tue, 12 Feb 2008 12:26:00 +0100

Dan,

> */Let me say that I am finding this discussion to happen a little bit 
> too early, but I was answering to the challenge coming from Henk. 
> Usually such discussions happen when the document became a work item, or 
> even at WGLC. /*

The document has been accepted as a WG item last year.  Al/Benoit haven't
submitted a version with a draft-ietf-ippm-... filename but I understand
that this will be done before the Philly cut-off date.

Anyway, we can/should discuss the content!

Henk

> *//* 
> */Section 5 includes A LOT of history which seems to me not relevant and 
> read this one again to make sure that I understand the issues. /*
> *//* 
> */The issue with section 8 is that it goes into some details about 
> interested to hear the opinion of other IPPM folks. /*
> *//* 
> */Dan/*
> *//* 
>  
>  
> 
>     ------------------------------------------------------------------------
>     *From:* Benoit Claise [mailto:[email-masked]]
>     *Sent:* Tuesday, February 12, 2008 2:05 AM
>     *To:* Romascanu, Dan (Dan)
>     *Cc:* Henk Uijterwaal; IETF IPPM WG
>     *Subject:* Re: [ippm] FW:
>     - "You want Poisson because it's random. But it's sometimes better
>     to get a random start with fixed intervals..."
>     variation explanations + a series of guidelines (at least this was
>     my intention) I spent quite some time on these sections.
>     Specifically, if section 5 is removed, we need to list somewhere the
>     conclusions of the published papers referenced in section 5. The
>     place would then be the current section 6. Unless you have a
>     different view?
> 
>     Regards, Benoit.
> 
> ------------------------------------------------------------------------
>

---

From: Al Morton <[email-masked]>
Date: Thu, 14 Feb 2008 15:31:32 -0500

Dan,

Just to weigh-in with my view:

I've given this paper to many people, and most do not

participate in IETF activities.  The feedback has been

entirely positive - this is a successful entry-level memo.

Section 5 performs a useful service for the reader: it condenses

comparisons from several sources (some which are not readily
available)

into several pages of relevant info, and brings the comparisons

up to date where necessary. Perhaps it could move to an Appendix,

but it will disturb the flow:

intro - tasks - definitions - background - new comparisons -
conclusions

Section 6 performs the analyses that support the new conclusions

in section 7.  In theory, we could just present the table in
section

7.4 as the "Applicability Statement", but it would leave room
for

much interpretation and confusion.  The purpose of this memo is
to

put to rest as much controversy as possible, and the supporting
detail

is needed to do that.

That said, I too am interested in comments of others, since

all comments up till now have asked to expand the details

included in this memo.

regards,

Al

At 06:00 AM 2/12/2008, you wrote:

Content-class:
urn:content-classes:message

Content-Type: multipart/alternative;

boundary="----_=_NextPart_001_01C86D66.8009E61C"

Benoit,

Let me say
that I am finding this discussion to happen a little bit too early, but I
was answering to the challenge coming from Henk. Usually such discussions
happen when the document became a work item, or even at WGLC.

Section 5
includes A LOT of history which seems to me not relevant and usually is
not included in IETF documents. Maybe a short summary should be part of
Section 6 but not all the details. In section 6 I do not see the point of
6.5 and 6.6, and have doubts about 6.8, but maybe I should read this one
again to make sure that I understand the issues.

The issue with
section 8 is that it goes into some details about measurement methods and
devices, rather than metrics. It would be interested to hear the opinion
of other IPPM folks.

Dan

---

From: Al Morton <[email-masked]>
Date: Thu, 14 Feb 2008 15:43:29 -0500

At 03:31 PM 2/14/2008, Al wrote:
>...the table in section 7.4

make that 7.3