Subject: [ippm] Raw material for tomorrow's charter discussion

From: Brian Trammell <[email-masked]>
Date: Thu, 14 Mar 2013 18:13:38 -0400

Greetings, all,

We've worked on editing the text of the IPPM charter to reflect what we see as the union of work items which could fit under the new charter of the working group, based on today's meeting, as well as past discussions both on- and off-list. This is NOT a proposed new charter; rather, it's a starting point for tomorrow's charter text discussion, presented to allow participants to prepare.

A proposed charter resulting from tomorrow's meeting will be circulated thereafter.

Cheers,

Bill and Brian

[begin charter discussion text]

The IP Performance Metrics (IPPM) Working Group develops and maintains standard metrics that can be applied to the quality, performance, and reliability of Internet data delivery services and applications. It also develops and maintains protocols for the measurement of these metrics. These metrics are designed such that they can be performed by network operators, end users, or independent testing groups. Metrics developed by the IPPM WG are intended to provide unbiased quantitative performance measurements and not a value judgement, such as “good” or “bad” performance.

The IPPM WG has produced documents that define specific metrics and procedures for accurately measuring and documenting these metrics. The working group will continue advancing these metrics along the standards track, along the guidelines stated in RFC 6576.

In addition, the WG will develop new metrics which more accurately model the network path(s) under test and/or the behavior of transport and application layer protocols on these path(s), whether based on previously-defined or newly-defined fundamental metrics. In addition, the WG will define methods for the composition and comparison of these metrics, as well as passive and hybrid measurement methods for these metrics, as appropriate. The WG may update its core framework RFC 2330 as necessary to accommodate these activities.

The WG has produced protocols to enable communication among test equipment that implements the one- and two-way metrics (OWAMP and TWAMP respectively). OWAMP and TWAMP will be advanced along the standards track. Further development of these protocols will also be done inside the WG.

The interoperability of metric definitions is crucial to accurate, comparable measurement. The WG will define and maintain a registry of metric definitions to this end. The WG encourages work which compares IPPM metrics with metrics developed elsewhere, particularly in regards to interoperability, similarity and functionality. The WG also encourages work which improves interoperability of IPPM protocols with other protocols for measuring similar metrics.

The IPPM WG seeks cooperation with other appropriate standards bodies and forums (such as ATIS IIF, ITU-T SG 12, 13 and 15, MEF, BBF, etc.) to promote consistent approaches and metrics. Within the IETF process, IPPM metrics definitions will be subject to as rigorous a scrutiny for usefulness, clarity, and accuracy as other protocol standards. The IPPM WG will interact with other areas of IETF activity whose scope intersects with the requirement of these specific metrics. The WG will, on request, provide input to other IETF working groups on the use and implementation of these metrics.

[end charter discussion text]

---

From: Greg Mirsky <[email-masked]>
Date: Fri, 15 Mar 2013 09:19:47 -0700

Dear Brian, et al.,
I think that the following phrase
"In addition, the WG will define methods for the composition and comparison
of these metrics, as well as passive and hybrid measurement methods for
these metrics, as appropriate."
implies that active measurement method is the main technique being
considered and researched at IPPM WG. I think that all measurement methods
are equally in scope of the WG and propose the following change:
"In addition, the WG will define methods for the composition, comparison of
these metrics, as well as active, passive, and hybrid measurement methods
for these metrics, as appropriate."

Regards,
Greg

On Thu, Mar 14, 2013 at 3:13 PM, Brian Trammell <[email-masked]>wrote:

> Greetings, all,
>
> We've worked on editing the text of the IPPM charter to reflect what we
> see as the union of work items which could fit under the new charter of the
> working group, based on today's meeting , as well as past discussions both
> on- and off-list. This is NOT a proposed new charter; rather, it's a
> starting point for tomorrow's charter text discussion, presented to allow
> participants to prepare.
>
> The IP Performance Metrics (IPPM) Working Group develops and maintains
> standard metrics that can be applied to the quality, performance, and
> reliability of Internet data delivery services and applications. It also
> develops and maintains protocols for the measurement of these metrics.
> These metrics are designed such that they can be performed by network
> operators, end users, or independent testing groups. Metrics developed by
> the IPPM WG are intended to provide unbiased quantitative performance
> measurements and not a value judgement, such as “good” or “bad” performance.
>
> The IPPM WG has produced documents that define specific metrics and
> procedures for accurately measuring and documenting these metrics. The
> working group will continue advancing these metrics along the standards
> track, along the guidelines stated in RFC 6576.
>
> In addition, the WG will develop new metrics which more accurately model
> the network path(s) under test and/or the behavior of transport and
> application layer protocols on these path(s), whether based on
> previously-defined or newly-defined fundamental metrics. In addition, the
> WG will define methods for the composition and comparison of these metrics,
> as well as passive and hybrid measurement methods for these metrics, as
> appropriate. The WG may update its core framework RFC 2330 as necessary to
> accommodate these activities.
>
> The WG has produced protocols to enable communication among test equipment
> that implements the one- and two-way metrics (OWAMP and TWAMP
> respectively). OWAMP and TWAMP will be advanced along the standards track.
> Further development of these protocols will also be done inside the WG.
>
> The interoperability of metric definitions is crucial to accurate,
> comparable measurement. The WG will define and maintain a registry of
> metric definitions to this end. The WG encourages work which compares IPPM
> metrics with metrics developed elsewhere, particularly in regards to
> interoperability, similarity and functionality. The WG also encourages work
> which improves interoperability of IPPM protocols with other protocols for
> measuring similar metrics.
>
> The IPPM WG seeks cooperation with other appropriate standards bodies and
> forums (such as ATIS IIF, ITU-T SG 12, 13 and 15, MEF, BBF, etc.) to
> promote consistent approaches and metrics. Within the IETF process, IPPM
> metrics definitions will be subject to as rigorous a scrutiny for
> usefulness, clarity, and accuracy as other protocol standards. The IPPM WG
> will interact with other areas of IETF activity whose scope intersects with
> the requirement of these specific metrics. The WG will, on request, provide
> input to other IETF working groups on the use and implementation of these
> metrics.
>
> _______________________________________________
> ippm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ippm
>