Subject: Re: [ippm] Genart last call review of draft-ietf-ippm-2330-ipv6-04

From: Spencer Dawkins at IETF <[email-masked]>
Date: Tue, 8 May 2018 12:19:56 -0500

Hi, draft-ietf-ippm-2330-ipv6.all,

On Fri, Apr 27, 2018 at 2:43 AM, Francesca Palombini <
[email-masked]> wrote:

> > [acm]
> > We can add the pre-5378 disclaimer as a catch-all, but I doubt the
> original
> > authors would make any fuss about the small amount of common text with
> > 2330.
> > Almes, Paxson, Mahdavi and Mathis are all gentlemen and the best of their
> > time.
> >
>
> I'm sure they are :) Just relaying what the id-nits told me.
>

If I might make an observation - the discontinuity between pre-5379 and
post-5370 copyright grants isn't going to get better (until all pre-5370
RFCs are Historic), and we already have some running code from pre-5370 RFC
authors becoming unreachable (in extreme cases, because they died).

If you folks can contact the original authors and ask if they have any
objections to use of the updated copyright boilerplate now, that may come
in handy the next time IPPM needs to update 2330.

If you can't, it's probably best to update the copyright disclaimer now.

Thanks!

Spencer

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Wed, 9 May 2018 06:23:23 +0000

Spencer wrote:
If you folks can contact the original authors and ask if they have any objections to use of the updated copyright boilerplate now, that may come in handy the next time IPPM needs to update 2330.

[acm] I updated the disclaimer in the working version.
I think there are a few more editorial comments to resolve.
Al

From: Spencer Dawkins at IETF [mailto:[email-masked]]
Sent: Tuesday, May 8, 2018 1:20 PM
To: Francesca Palombini <[email-masked]>
Cc: MORTON, ALFRED C (AL) <[email-masked]>; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: Re: Genart last call review of draft-ietf-ippm-2330-ipv6-04

On Fri, Apr 27, 2018 at 2:43 AM, Francesca Palombini <[email-masked]<mailto:[email-masked]>> wrote:
> [acm]
> We can add the pre-5378 disclaimer as a catch-all, but I doubt the original

If I might make an observation - the discontinuity between pre-5379 and post-5370 copyright grants isn't going to get better (until all pre-5370 RFCs are Historic), and we already have some running code from pre-5370 RFC authors becoming unreachable (in extreme cases, because they died).

If you folks can contact the original authors and ask if they have any objections to use of the updated copyright boilerplate now, that may come in handy the next time IPPM needs to update 2330.

Thanks!

Spencer

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Tue, 22 May 2018 10:01:33 -0500

Hi, Al,

> I think there are a few more editorial comments to resolve.

I think we're just waiting for a fairly small -05 revision to put this on a
telechat, is that the way it looks to you?

Spencer

> Al
>
>
>
> *From:* Spencer Dawkins at IETF [mailto:[email-masked]]
> *Sent:* Tuesday, May 8, 2018 1:20 PM
> *To:* Francesca Palombini <[email-masked]>
> *Cc:* MORTON, ALFRED C (AL) <[email-masked]>; [email-masked];
> [email-masked]; [email-masked]; [email-masked]
> *Subject:* Re: Genart last call review of draft-ietf-ippm-2330-ipv6-04
>
>
>

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Wed, 23 May 2018 12:10:10 +0000

Hi Spencer,

If co-authors are satisfied with the version I sent
on May 9th, then we are ready to go.

FYI – I’m taking a few days off, so replies will be
delayed, like this one.

regards,
Al

From: Spencer Dawkins at IETF [mailto:[email-masked]]
Sent: Tuesday, May 22, 2018 11:02 AM
To: MORTON, ALFRED C (AL) <[email-masked]>
Cc: Francesca Palombini <[email-masked]>; gen-art <[email-masked]>; [email-masked]; [email-masked]
Subject: Re: Genart last call review of draft-ietf-ippm-2330-ipv6-04

Hi, Al,
On Wed, May 9, 2018 at 1:23 AM MORTON, ALFRED C (AL) <[email-masked]<mailto:[email-masked]>> wrote:
Spencer wrote:
If you folks can contact the original authors and ask if they have any objections to use of the updated copyright boilerplate now, that may come in handy the next time IPPM needs to update 2330.

I think we're just waiting for a fairly small -05 revision to put this on a telechat, is that the way it looks to you?

Spencer

Al

From: Spencer Dawkins at IETF [mailto:[email-masked]<mailto:[email-masked]>]
Sent: Tuesday, May 8, 2018 1:20 PM
To: Francesca Palombini <[email-masked]<mailto:[email-masked]>>
Cc: MORTON, ALFRED C (AL) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: Genart last call review of draft-ietf-ippm-2330-ipv6-04

Thanks!

Spencer

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Wed, 23 May 2018 07:54:06 -0500

On May 23, 2018 7:10 AM, "MORTON, ALFRED C (AL)" <[email-masked]>
wrote:

Hi Spencer,

I'll give the authors a day to object, and then get this draft placed on a
telechat agenda ...

Spencer

delayed, like this one.

regards,

Al

*From:* Spencer Dawkins at IETF [mailto:[email-masked]]
*Sent:* Tuesday, May 22, 2018 11:02 AM
*To:* MORTON, ALFRED C (AL) <[email-masked]>
*Cc:* Francesca Palombini <[email-masked]>; gen-art <
[email-masked]>; [email-masked]; [email-masked]

Hi, Al,

Spencer wrote:

Spencer

Al

original

Thanks!

Spencer

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Wed, 23 May 2018 13:39:16 +0000

Hi Francesca,
one last item to resolve, we should be good now.
see below,
Al

> -----Original Message-----
> From: Francesca Palombini [mailto:[email-masked]]
> Sent: Friday, April 27, 2018 3:44 AM
> To: MORTON, ALFRED C (AL) <[email-masked]>; [email-masked]
> Cc: [email-masked]; [email-masked]; [email-masked]
> Subject: RE: Genart last call review of draft-ietf-ippm-2330-ipv6-04
> 
> Hi Al,
> 
> Thanks for your reply.
> I cut selected parts of the email to detail some of my comments, see
> inline.
> 
> Francesca
> 
...snip...
> > > To be consistent with the first bullet of the list above ("It includes
> > > a valid IP header: see below for version-specific criteria."), I would
> > > rephrase the text above with something on the lines of:
> > >
> > > "For an IPvX (...) packet to be standard-formed, the IPvX-specific
> > > criteria for a valid IP header are:"
> > [acm]
> > Your wording suggestion dropped the clear indication of a requirement.
> > We are using the RFC2119 terms consistently for requirements.
> >
> 
> I was trying to point out that the first part of the section (first bullet
> list) does not use RFC2119 terms. I read the second bullet list as a "sub-
> list" of the first one, which is why I was suggesting removing the
> REQUIRED term. Or you could rephrase the first list to use REQUIRED too.
> Anyway, this is nit-picking. Feel free to disregard.
> 
[acm]
I see your point now, and I changed the sentence introducing the 
initial (IP version-agnostic list) to read:

A packet is standard-formed if it meets all of the following REQUIRED criteria:

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Wed, 23 May 2018 13:50:51 +0000

Thanks Spencer.

I have just now addressed the remaining comment
(on a parallel thread).  I have a version 05 draft
ready to submit tomorrow.

Al

Sent: Wednesday, May 23, 2018 8:54 AM

On May 23, 2018 7:10 AM, "MORTON, ALFRED C (AL)" <[email-masked]<mailto:[email-masked]>> wrote:
Hi Spencer,

I'll give the authors a day to object, and then get this draft placed on a telechat agenda ...

Spencer

regards,
Al

From: Spencer Dawkins at IETF [mailto:[email-masked]<mailto:[email-masked]>]
Sent: Tuesday, May 22, 2018 11:02 AM
To: MORTON, ALFRED C (AL) <[email-masked]<mailto:[email-masked]>>
Cc: Francesca Palombini <[email-masked]<mailto:[email-masked]>>; gen-art <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>

Hi, Al,

Spencer

Al

Thanks!

Spencer

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Thu, 24 May 2018 14:08:30 +0000

There were no last-chance comments, so I have
just submitted version 05 and it is available for
an IESG telechat agenda.

thanks,
Al

From: MORTON, ALFRED C (AL)
Sent: Wednesday, May 23, 2018 9:51 AM
To: 'Spencer Dawkins at IETF' <[email-masked]>
Cc: Francesca Palombini <[email-masked]>; gen-art <[email-masked]>; [email-masked]; [email-masked]
Subject: RE: Genart last call review of draft-ietf-ippm-2330-ipv6-04

Thanks Spencer.

Al

Spencer

regards,
Al

Hi, Al,

Spencer

Al

Thanks!

Spencer

---

From: Francesca Palombini <[email-masked]>
Date: Fri, 25 May 2018 08:24:12 +0000

Hi Al,

Thanks for addressing my comments, it looks good.

Francesca

> From: MORTON, ALFRED C (AL) <[email-masked]>
> Sent: den 23 maj 2018 15:39
> To: Francesca Palombini <[email-masked]>; gen-
> [email-masked]
> > > > To be consistent with the first bullet of the list above ("It
> > > > includes a valid IP header: see below for version-specific
> > > > criteria."), I would rephrase the text above with something on the lines
> of:
> > > >
> > list) does not use RFC2119 terms. I read the second bullet list as a
> > "sub- list" of the first one, which is why I was suggesting removing
> > the REQUIRED term. Or you could rephrase the first list to use REQUIRED
> too.
> I see your point now, and I changed the sentence introducing the initial (IP
> version-agnostic list) to read:
>