Subject: [ippm] I-D Action: draft-ietf-ippm-metric-registry-19.txt

From: [email-masked]
Date: Fri, 29 Mar 2019 04:45:53 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the IP Performance Measurement WG of the IETF.

        Title           : Registry for Performance Metrics
        Authors         : Marcelo Bagnulo
                          Benoit Claise
                          Philip Eardley
                          Al Morton
                          Aamer Akhter
	Filename        : draft-ietf-ippm-metric-registry-19.txt
	Pages           : 35
	Date            : 2019-03-29

Abstract:
   This document defines the format for the IANA Performance Metrics
   Registry.  This document also gives a set of guidelines for
   Registered Performance Metric requesters and reviewers.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-ippm-metric-registry/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-ippm-metric-registry-19
https://datatracker.ietf.org/doc/html/draft-ietf-ippm-metric-registry-19

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-ippm-metric-registry-19

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Fri, 29 Mar 2019 11:55:02 +0000

Hi IPPM, Mirja, Michelle, and Brian,

I have addressed the last of the WGLC comments in the 
latest versions. The changes include:

- No more URNs! (acm)

- Unbounded Identifier  (Brian)

- Group Name specified in the Draft (Tom and Dale)

- Mirja's comment pertaining to the RFC number in the name:
  Some more detail on this one:

After re-reading the section on revising Registered Metrics (8.2),
it became clear that we can leave the Name unchanged 
(including the RFC number in the name) when the proposed change
is backward compatible (and we define the conditions when a revision
is backward-compatible).

When a registered metric is changed in a significant way, and 
not backward compatible, then the new metric will use the 
new RFC number in the Name, and the "old" metric will be deprecated
(not deleted as I said at the mic on Monday!  Sorry!).

I also gave Michelle and Amanda an update at the IANA desk,
including progress and next steps (AD Review...).

regards,
Al

> -----Original Message-----
> From: I-D-Announce [mailto:[email-masked]] On Behalf Of
> [email-masked]
> Sent: Friday, March 29, 2019 7:46 AM
> To: [email-masked]
> Cc: [email-masked]
> Subject: I-D Action: draft-ietf-ippm-metric-registry-19.txt
> 
> 
> https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__datatracker.ietf.org_doc_draft-2Dietf-2Dippm-2Dmetric-
> 2Dregistry_&d=DwICAg&c=LFYZ-
> o9_HUMeMTSQicvjIg&r=OfsSu8kTIltVyD1oL72cBw&m=9i6uWWLhXFTw_EszwsA17sBBbWJh8
> A12HGSHA33TZMo&s=48PhX0Oyak9lC2FVFh4R1wQSbgK5J95CG5iTL2Vcni4&e=
> 
> https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__tools.ietf.org_html_draft-2Dietf-2Dippm-2Dmetric-2Dregistry-
> 2D19&d=DwICAg&c=LFYZ-
> o9_HUMeMTSQicvjIg&r=OfsSu8kTIltVyD1oL72cBw&m=9i6uWWLhXFTw_EszwsA17sBBbWJh8
> A12HGSHA33TZMo&s=--MUJARhgSFvjD-l9C5QON4UW-nzuvXx78f9psrqz9Y&e=
> https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__datatracker.ietf.org_doc_html_draft-2Dietf-2Dippm-2Dmetric-2Dregistry-
> 2D19&d=DwICAg&c=LFYZ-
> o9_HUMeMTSQicvjIg&r=OfsSu8kTIltVyD1oL72cBw&m=9i6uWWLhXFTw_EszwsA17sBBbWJh8
> A12HGSHA33TZMo&s=Bmc34Y34K86OTaJXv4wti7-1Fa9gjKVi0ckjpXBQUUQ&e=
> 
> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_rfcdiff-
> 3Furl2-3Ddraft-2Dietf-2Dippm-2Dmetric-2Dregistry-2D19&d=DwICAg&c=LFYZ-
> o9_HUMeMTSQicvjIg&r=OfsSu8kTIltVyD1oL72cBw&m=9i6uWWLhXFTw_EszwsA17sBBbWJh8
> A12HGSHA33TZMo&s=RoEw-q2miyybBT6eJH2VUvK6bgsnAQF9at5yTwha3mY&e=
> 
> 
> https://urldefense.proofpoint.com/v2/url?u=ftp-3A__ftp.ietf.org_internet-
> 2Ddrafts_&d=DwICAg&c=LFYZ-
> o9_HUMeMTSQicvjIg&r=OfsSu8kTIltVyD1oL72cBw&m=9i6uWWLhXFTw_EszwsA17sBBbWJh8
> A12HGSHA33TZMo&s=N7PPF-HL8lQw-W-gq6wBUtv48fpwqD9x8I-_oHm1KxY&e=
> 
> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__www.ietf.org_mailman_listinfo_i-2Dd-2Dannounce&d=DwICAg&c=LFYZ-
> o9_HUMeMTSQicvjIg&r=OfsSu8kTIltVyD1oL72cBw&m=9i6uWWLhXFTw_EszwsA17sBBbWJh8
> A12HGSHA33TZMo&s=YzKEkKEKSHv2MPiM3V0mQMRzhVQblpWweYZ0sLAfpJI&e=
> Internet-Draft directories:
> https://urldefense.proofpoint.com/v2/url?u=http-
> 3A__www.ietf.org_shadow.html&d=DwICAg&c=LFYZ-
> o9_HUMeMTSQicvjIg&r=OfsSu8kTIltVyD1oL72cBw&m=9i6uWWLhXFTw_EszwsA17sBBbWJh8
> A12HGSHA33TZMo&s=XmLToD2MM58SdF9XK79ex3nPSUnorVjuVBXE-_AG7zE&e=
> or https://urldefense.proofpoint.com/v2/url?u=ftp-
> 3A__ftp.ietf.org_ietf_1shadow-2Dsites.txt&d=DwICAg&c=LFYZ-
> o9_HUMeMTSQicvjIg&r=OfsSu8kTIltVyD1oL72cBw&m=9i6uWWLhXFTw_EszwsA17sBBbWJh8
> A12HGSHA33TZMo&s=LyIcYjAHvFWlz32ugKG3dE3ZIZiVdaX8zKEpTaVbbtU&e=