Subject: [ippm] Comments on draft-song-ippm-postcard-based-telemetry

From: Greg Mirsky <[email-masked]>
Date: Mon, 11 Mar 2019 11:00:50 -0700

Dear Authors,
I've read your draft with a great deal of interest. Thank you for sharing
your ideas, work in a clear and concise manner. In turn, I'd like to offer
my comments below:

   - you might know that "in-band OAM" is not the clearest term. Any OAM,
   active or hybrid, should be in-band with the monitored data flow.
   Otherwise, an observer, an operator will receive inaccurate information
   about the service conditions. I suggest using "on-path telemetry
   collection" for OAM like the postcard-based.
   - comparing solutions may be tricky if there is no commonly accepted,
   agreed upon criteria. I think that a document that lists the requirements
   of the on-path telemetry collection will be useful and helpful. As a start,
   we can combine the requirements
   from draft-song-ippm-postcard-based-telemetry and
   draft-mirsky-ippm-hybrid-two-step.
   - as the postcard-based mechanism of collecting telemetry data is to
   provide information about a flow, discussion of how the flow in different
   network layer may be defined will benefit the document. More details shall
   be provided in layer-specific documents on what characteristic information
   to be included in identifying the flow in the postcard, but some general
   discussion can be added to the document.

Regards,
Greg

---

From: Haoyu song <[email-masked]>
Date: Mon, 11 Mar 2019 18:17:18 +0000

Hi Greg,

Thanks for the comments! Below please see my response inline.

Best,
Haoyu

From: Greg Mirsky [mailto:[email-masked]]
Sent: Monday, March 11, 2019 11:01 AM
To: [email-masked]; IETF IPPM WG <[email-masked]>
Subject: Comments on draft-song-ippm-postcard-based-telemetry

Dear Authors,
I've read your draft with a great deal of interest. Thank you for sharing your ideas, work in a clear and concise manner. In turn, I'd like to offer my comments below:

  *   you might know that "in-band OAM" is not the clearest term. Any OAM, active or hybrid, should be in-band with the monitored data flow. Otherwise, an observer, an operator will receive inaccurate information about the service conditions. I suggest using "on-path telemetry collection" for OAM like the postcard-based.
HS> Agree. Although in industry, the term INT is widely used and accepted, in SDO we need to be more accurate. We’ll make the change in the future revisions.

  *   comparing solutions may be tricky if there is no commonly accepted, agreed upon criteria. I think that a document that lists the requirements of the on-path telemetry collection will be useful and helpful. As a start, we can combine the requirements from draft-song-ippm-postcard-based-telemetry and draft-mirsky-ippm-hybrid-two-step.
HS> This is possible. I think there is not a universal set of requirements that all the implementations need to obey. Instead, different application scenarios may have different requirements. Therefore, I believe each variation of the on-path telemetry techniques should be a tool in a tool box and will find its position somewhere. Also, to avoid make the field messy, we should also try the best to consolidate the schemes to the minimum.

  *   as the postcard-based mechanism of collecting telemetry data is to provide information about a flow, discussion of how the flow in different network layer may be defined will benefit the document. More details shall be provided in layer-specific documents on what characteristic information to be included in identifying the flow in the postcard, but some general discussion can be added to the document.
HS> Yes this can be discussed more. The flow definition can be very flexible, up to the configuration at path head. Such flow identity is retained even through tunnels.
Regards,
Greg