Subject: [ippm] About path congestion metric, welcome to discuss

From: Dangjuanna <[email-masked]>
Date: Mon, 4 Mar 2019 09:38:25 +0000

Hi everyone,
I have submit a new individual draft named A One-Path Congestion Metric for IPPM.
Welcome to discuss.
Best wishes,

Joanna Dang

===============================================

A new version of I-D, draft-dang-ippm-congestion-00.txt has been successfully submitted by Joanna Dang and posted to the IETF repository.

Name:               draft-dang-ippm-congestion

Revision:  00

Title:                  A One-Path Congestion Metric for IPPM

Document date:       2019-03-04

Group:               Individual Submission

Pages:               10

URL:            https://www.ietf.org/internet-drafts/draft-dang-ippm-congestion-00.txt

Status:         https://datatracker.ietf.org/doc/draft-dang-ippm-congestion/

Htmlized:       https://tools.ietf.org/html/draft-dang-ippm-congestion-00

Htmlized:       https://datatracker.ietf.org/doc/html/draft-dang-ippm-congestion

Abstract:

   This memo defines a metric for one path congestion across Internet

   paths.  The traditional mode evaluates network congestion based on

   the bandwidth utilization of the link.  However, there is a lack of

   E2E path congestion that is truly service oriented.  So A Path

   Congestion Metric is required.

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Greg Mirsky <[email-masked]>
Date: Mon, 4 Mar 2019 11:53:17 -0800

Hi Joanna,
thank you for sharing this work. I have a couple of questions on the
proposed calculation of the e2e path congestion metric:

   - I couldn't find the explanation of 'tp' parameter in the short-term
   measurement (I assume that the first equation is for the short-term
   measurement);
   - the long-term measurement, as I understand, equates the e2e path
   congestion with the packet loss ratio as (SrcCountp - DstCountp)/DstCountp
   is the formula to calculate the packet loss ratio.

Much appreciate your consideration.

Regards,
Greg

On Mon, Mar 4, 2019 at 1:38 AM Dangjuanna <[email-masked]> wrote:

> A new version of I-D, draft-dang-ippm-congestion-00.txt has been
> successfully submitted by Joanna Dang and posted to the IETF repository.
>
>
>
> URL:
> https://www.ietf.org/internet-drafts/draft-dang-ippm-congestion-00.txt
>
> Status:
> https://datatracker.ietf.org/doc/draft-dang-ippm-congestion/
>
> Htmlized:
> https://datatracker.ietf.org/doc/html/draft-dang-ippm-congestion
>
>
>
>
>
> Abstract:
>
> Please note that it may take a couple of minutes from the time of
> submission until the htmlized version and diff are available at
> tools.ietf.org.
>
>
>
> The IETF Secretariat
>
>
>
>
> _______________________________________________
> ippm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ippm
>

---

From: Dangjuanna <[email-masked]>
Date: Tue, 5 Mar 2019 11:08:04 +0000

Hi Greg,
Thank you for your reply.

I  carefully read your question and try to give  the  response.
I1, i2, i3 is the time.
Q1: I couldn't find the explanation of 'tp' parameter in the short-term measurement (I assume that the first equation is for the short-term measurement);
Tp is dpt which is transmission period of a measurement. For example, a measurement is trigged once dpt (such as 3.3 milliseconds).  If the path is no congestion,  the test message sent by Src at (I1+dpt) should be received  by Dst at (I2+dpt).

As the following figure is shown,  in long-term measurement  we focus on one complete measurement.
So  c = (( I3 - I2) / dpt ) -1
Q2: the long-term measurement, as I understand, equates the e2e path congestion with the packet loss ratio as (SrcCountp - DstCountp)/DstCountp is the formula to calculate the packet loss ratio.
This formula is for short-term measurement. In this mode we focus on one cycle (that is one dpr).
For example, in one cycle, Src send 6 packets (there are p1, p2,p3,p4,p5,p6).
The path has the congestion and then Dst only receive 5 packet(there are p1, p2,p3,p4,p5). After (I2+dpt) Dst just receive P6.
So c =  (SrcCountp / DstCountp)-1
As a result,

1.       If c is 0, the path is no congestion.

2.       If c is more than 0, the path has the congestion. C is greater while the path congestion is serious.

The above is my reply.

Best wishes,
Joanna

发件人: Greg Mirsky [mailto:[email-masked]]
发送时间: 2019年3月5日 3:53
收件人: Dangjuanna <[email-masked]>
抄送: [email-masked]
主题: Re: [ippm] About path congestion metric, welcome to discuss

Hi Joanna,
thank you for sharing this work. I have a couple of questions on the proposed calculation of the e2e path congestion metric:

  *   I couldn't find the explanation of 'tp' parameter in the short-term measurement (I assume that the first equation is for the short-term measurement);
  *   the long-term measurement, as I understand, equates the e2e path congestion with the packet loss ratio as (SrcCountp - DstCountp)/DstCountp is the formula to calculate the packet loss ratio.
Much appreciate your consideration.

Regards,
Greg

On Mon, Mar 4, 2019 at 1:38 AM Dangjuanna <[email-masked]<mailto:[email-masked]>> wrote:
Hi everyone,
I have submit a new individual draft named A One-Path Congestion Metric for IPPM.
Welcome to discuss.
Best wishes,

Joanna Dang

Revision:  00

Pages:               10

Abstract:

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org<http://tools.ietf.org>.

The IETF Secretariat

_______________________________________________
ippm mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ippm