Subject: [ippm] Comments on draft-mirsky-ippm-stamp-option-tlv

From: "[email-masked]" <[email-masked]>
Date: Fri, 1 Mar 2019 15:59:52 +0800

Dear Authors,

I've been following the work on the STAMP protocol and support its progress. I've read draft-mirsky-ippm-stamp-option-tlv and would like to share my thoughts, ask some questions.

1.OWAMP/TWAMP use the Padding field to control the size of a test packet. The draft proposes the use of Padding TLV. Are these two mechanisms expected to coexist?
2.What is the meaning of fields in the Timestamp TLV? Is one pair of the parameters sufficient to draw any useful conclusion of the accuracy of timestamps?

Thanks

Liu Chang
China Unicom
Email: [email-masked]
Phone: +8618601102572
Tel: 010-68799999-7294

---

From: Greg Mirsky <[email-masked]>
Date: Sat, 2 Mar 2019 15:36:11 -0800

Dear Liu Chang,
thank you for your kind words and thoughtful questions on the STAMP Options
draft. Please find my answers below tagged GIM>>.
Much appreciate your consideration and welcome further questions, comments.

Best regards,
Greg

On Fri, Mar 1, 2019 at 12:00 AM [email-masked] <
[email-masked]> wrote:

> Dear Authors,
>
> I've been following the work on the STAMP protocol and support its
> progress. I've read draft-mirsky-ippm-stamp-option-tlv and would like to
> share my thoughts, ask some questions.
>
> 1.OWAMP/TWAMP use the Padding field to control the size of a test packet.
> The draft proposes the use of Padding TLV. Are these two mechanisms
> expected to coexist?
>
GIM>> Yes, you're correct pointing that the Padding field defined in *WAMP
protocols and the Padding TLV serve the same purpose. Our intention is to
limit the use of the Padding field to have the basic Session-Sender's test
packet match the length of the Session-Reflector's test packet.  Padding
TLV should be used to create larger test packets.

> 2.What is the meaning of fields in the Timestamp TLV? Is one pair of the
> parameters sufficient to draw any useful conclusion of the accuracy of
> timestamps?
>
GIM>> Synchronization Source is to characterize the method of clock
synchronization. We consider the following:

   - Network Time Protocol
   -  Precision Time Protocol
   - Synchronization Supply Unit or Building Integrated Timing Supply
   -  Global Positioning System, Global Orbiting Navigation Satellite
   System, and Long Range Navigation System Version C
   - free-running clock

Timestamping Method is to characterize the method used to obtain the value
of the wall clock and write it into the packet. We see these cases:

   - hardware-assisted
   - software API (local)
   - from a remote server, e.g., RPC. We refer to this as a control plane
   based.

> Thanks
>
> ------------------------------
>
> Liu Chang
> China Unicom
> _______________________________________________
> ippm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ippm
>