Subject: [ippm] use of flag bit in IOAM

From: Tianran Zhou <[email-masked]>
Date: Thu, 21 Mar 2019 01:30:52 +0000

Hi Barak,

I think we have all understand the postcard based telemetry draft based on the previous discussion, why it is useful, how it is designed, and why IOAM existing options cannot achieve.
I have also well examined the IOAM data draft. Here are some questions I want to discuss with you and the working group.

1.  Could you please give more introduction on the use case that the “identifier” is enough in tracing mode? Is this the common or significant use case?

2.  How could E2E mode + the immediate export flag help to achieve the postcard?

3.  Why don’t you make PBT as a separate option, but to extend existing trace and e2e? This will break their own semantic, and make the mass. And when PBT could be an independent usage, why split it into two options?

4.  Why you insist using the very limited “flag” for postcard, while it can be achieved by other way? I think the flag has a more useful usage to support the “important data indication” I proposed in the mailing list.

https://mailarchive.ietf.org/arch/msg/ippm/H_d6ArjpD5izt5kg4cOERu2kR4w

5.  Finally, why not support our PBT proposal when there is already well thinking document there?

Thanks,
Tianran

From: Barak Gafni [mailto:[email-masked]]
Sent: Thursday, March 21, 2019 8:21 AM
To: Jai Kumar <[email-masked]>; Haoyu song <[email-masked]>; Frank Brockners (fbrockne) <[email-masked]>; Tianran Zhou <[email-masked]>; Tommy Pauly <tpauly=[email-masked]>
Cc: IETF IPPM WG <[email-masked]>
Subject: RE: [ippm] Draft agenda for IETF 104

Jai,
Thanks for the comments.
Please take a look at the new IPv4 options draft, where we did started the discussion about fragmentation, see https://tools.ietf.org/html/draft-gafni-ippm-ioam-ipv4-options-00#section-3.1.5. As a side note, this discussion for the same use case started in RFC 791 chapter 3.1, which we refer to as well. We should continue this discussion and enhance it, appreciate your comments.
For the flow tracking: There are implementations that don’t need this identifier, for them this marking should be enough. For the ones who need it, as part of the discussion on Immediate Export at 05 we suggested to use e2e which can include these indicators, and plan to extend this discussion in the next draft.

Thanks,
Barak

From: Jai Kumar <[email-masked]<mailto:[email-masked]>>
Sent: Wednesday, March 20, 2019 5:08 PM
To: Barak Gafni <[email-masked]<mailto:[email-masked]>>; Haoyu song <[email-masked]<mailto:[email-masked]>>; Frank Brockners (fbrockne) <[email-masked]<mailto:[email-masked]>>; Tianran Zhou <[email-masked]<mailto:[email-masked]>>; Tommy Pauly <tpauly=[email-masked]<mailto:tpauly=[email-masked]>>
Cc: IETF IPPM WG <[email-masked]<mailto:[email-masked]>>
Subject: Re: [ippm] Draft agenda for IETF 104

Barak,

Please take a look at the IFA draft ver 01.
https://datatracker.ietf.org/doc/draft-kumar-ippm-ifa/<https://eur03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-kumar-ippm-ifa%2F&data=02%7C01%7Cgbarak%40mellanox.com%7Cbdb809a6dba045a9671a08d6ad913d00%7Ca652971c7d2e4d9ba6a4d149256f461b%7C0%7C0%7C636887236676327324&sdata=0dThk870RrTXTBR34KSUgs7zA6jCsXUYyJFrEBK3D9E%3D&reserved=0>

You do not need to add a separate flag. Currently IOAM doesn’t take care of fragmentation (don’t know how it will work with large number of nodes in path or with constrained PMTU).
If you add fragmentation then post card mode becomes a degenerate case of fragmentation where each node generates the report aka post card.

Also as Haoyu pointed out earlier there is no method defined in IOAM for co-relation of post cards for a given flow. You will need packetID/FragID or something of that intent to reconstruct the flow path for the packet.

Regards,
-Jai

From: ippm <[email-masked]<mailto:[email-masked]>> on behalf of Barak Gafni <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, March 20, 2019 at 4:39 PM
To: Haoyu song <[email-masked]<mailto:[email-masked]>>, "Frank Brockners (fbrockne)" <[email-masked]<mailto:[email-masked]>>, Tianran Zhou <[email-masked]<mailto:[email-masked]>>, Tommy Pauly <tpauly=[email-masked]<mailto:tpauly=[email-masked]>>
Cc: IETF IPPM WG <[email-masked]<mailto:[email-masked]>>
Subject: Re: [ippm] Draft agenda for IETF 104

Hi Haoyu,
Yes, you are right, I meant PBT-I. If you consider the description we added to the Immediate Export flag you may find more similarities in terms of use cases.
I think it can be a good topic to discuss f2f at Prague. Thanks for your comments!

Thanks,
Barak

From: Haoyu song <[email-masked]<mailto:[email-masked]>>
Sent: Wednesday, March 20, 2019 11:29 AM
To: Barak Gafni <[email-masked]<mailto:[email-masked]>>; Frank Brockners (fbrockne) <[email-masked]<mailto:[email-masked]>>; Tianran Zhou <[email-masked]<mailto:[email-masked]>>; Tommy Pauly <tpauly=[email-masked]<mailto:tpauly=[email-masked]>>
Cc: IETF IPPM WG <[email-masked]<mailto:[email-masked]>>
Subject: RE: [ippm] Draft agenda for IETF 104

Hi Barak,

Thank you for your comments!
I think you are mentioning the PBT-I (The variation which requires an instruction header)?  Although PBT-I and E2E shares similarities but they have different semantics and usage, therefore some difference may be inevitable. I agree we can try to align the header formats which may benefit the implementation, but it seems to me these are two independent modes with each having its specific purpose. Maybe you also mean the same thing.. If you have any specific suggestions, please don’t hesitate to propose. Thank you very much!

Best regards,
Haoyu

From: Barak Gafni [mailto:[email-masked]]
Sent: Tuesday, March 19, 2019 10:56 PM
To: Haoyu song <[email-masked]<mailto:[email-masked]>>; Frank Brockners (fbrockne) <[email-masked]<mailto:[email-masked]>>; Tianran Zhou <[email-masked]<mailto:[email-masked]>>; Tommy Pauly <tpauly=[email-masked]<mailto:tpauly=[email-masked]>>
Cc: IETF IPPM WG <[email-masked]<mailto:[email-masked]>>
Subject: RE: [ippm] Draft agenda for IETF 104

Hi Haoyu,
I think that there are some relations and similarities between PBT-M and IOAM e2e, it may be good to prevent yet another header format for implementations if we can converge on the already existing e2e format, potentially adding on additional header. Please take a look share your thoughts.

Thanks,
Barak

From: ippm <[email-masked]<mailto:[email-masked]>> On Behalf Of Haoyu song
Sent: Tuesday, March 19, 2019 3:09 PM
To: Frank Brockners (fbrockne) <[email-masked]<mailto:[email-masked]>>; Tianran Zhou <[email-masked]<mailto:[email-masked]>>; Tommy Pauly <tpauly=[email-masked]<mailto:tpauly=[email-masked]>>
Cc: IETF IPPM WG <[email-masked]<mailto:[email-masked]>>
Subject: Re: [ippm] Draft agenda for IETF 104

Hi Frank and Tommy,

Thanks for including our drafts! Please note we also request the IPPM WG adoption of this draft. This time we’d like to achieve rough consensus to make PBT-I a mode of IOAM (the name can be changed of course). This drafts also contains another option (PBT-M) which doesn’t need an instruction header. In this sense, we believe this draft can be developed in its own right. After it’s adopted, we’ll update it to make the alignment. Thanks!

Best regards,
Haoyu

From: Frank Brockners (fbrockne) [mailto:[email-masked]]
Sent: Tuesday, March 19, 2019 7:41 AM
To: Haoyu song <[email-masked]<mailto:[email-masked]>>; Tianran Zhou <[email-masked]<mailto:[email-masked]>>; Tommy Pauly <tpauly=[email-masked]<mailto:tpauly=[email-masked]>>
Cc: IETF IPPM WG <[email-masked]<mailto:[email-masked]>>
Subject: RE: [ippm] Draft agenda for IETF 104

Haoyu,

Thanks – per my other email, I’ve added a new category “IOAM additional options” and also added draft-song-mpls-extension-header-02 to the set of encap options which are covered by a lightening talk.

See: https://docs.google.com/presentation/d/1P1Kp9mXA0eKkws78p1tldFn8zqx0YPQ5TK5fnq6Vyz4/<https://eur03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdocs.google.com%2Fpresentation%2Fd%2F1P1Kp9mXA0eKkws78p1tldFn8zqx0YPQ5TK5fnq6Vyz4%2F&data=02%7C01%7Cgbarak%40mellanox.com%7Cbdb809a6dba045a9671a08d6ad913d00%7Ca652971c7d2e4d9ba6a4d149256f461b%7C0%7C0%7C636887236676337329&sdata=1LTz5Yq4ifpd7NYjRyBkn0szAQbYWEjq2U5gnH0a68E%3D&reserved=0>

Frank

From: Haoyu song <[email-masked]<mailto:[email-masked]>>
Sent: Montag, 18. März 2019 18:28
To: Frank Brockners (fbrockne) <[email-masked]<mailto:[email-masked]>>; Tianran Zhou <[email-masked]<mailto:[email-masked]>>; Tommy Pauly <tpauly=[email-masked]<mailto:tpauly=[email-masked]>>
Cc: IETF IPPM WG <[email-masked]<mailto:[email-masked]>>
Subject: RE: [ippm] Draft agenda for IETF 104

We currently positioned a part of the draft (PBT-I) a mode of IOAM so it could fit in the IOAM data session.

We also have another draft https://tools.ietf.org/html/draft-song-mpls-extension-header-02<https://eur03.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-song-mpls-extension-header-02&data=02%7C01%7Cgbarak%40mellanox.com%7Cbdb809a6dba045a9671a08d6ad913d00%7Ca652971c7d2e4d9ba6a4d149256f461b%7C0%7C0%7C636887236676347338&sdata=mqMuHhSCpEZQNWp21gmu1FkUFO3%2BYXGPBIbLVGXEdTc%3D&reserved=0> for IOAM encapsulation in MPLS networks. We can also use 1 min 1 slide to mention it.
Thanks!

Haoyu

From: ippm [mailto:[email-masked]] On Behalf Of Frank Brockners (fbrockne)
Sent: Monday, March 18, 2019 3:11 AM
To: Tianran Zhou <[email-masked]<mailto:[email-masked]>>; Tommy Pauly <tpauly=[email-masked]<mailto:tpauly=[email-masked]>>
Cc: IETF IPPM WG <[email-masked]<mailto:[email-masked]>>
Subject: Re: [ippm] Draft agenda for IETF 104

Hi Tianran,

in which category would the draft fit?

Thanks, Frank

From: Tianran Zhou <[email-masked]<mailto:[email-masked]>>
Sent: Montag, 18. März 2019 10:42
To: Frank Brockners (fbrockne) <[email-masked]<mailto:[email-masked]>>; Tommy Pauly <tpauly=[email-masked]<mailto:tpauly=[email-masked]>>
Cc: IETF IPPM WG <[email-masked]<mailto:[email-masked]>>
Subject: RE: [ippm] Draft agenda for IETF 104

Hi Frank and Tommy,

I just want to know where the draft-song-ippm-postcard-based-telemetry-02 fit into the agenda?
https://datatracker.ietf.org/doc/draft-song-ippm-postcard-based-telemetry/<https://eur03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-song-ippm-postcard-based-telemetry%2F&data=02%7C01%7Cgbarak%40mellanox.com%7Cbdb809a6dba045a9671a08d6ad913d00%7Ca652971c7d2e4d9ba6a4d149256f461b%7C0%7C0%7C636887236676347338&sdata=AmT33401XjultbFX%2BqcgCO3ky6htkVUf%2BjzbBAkea40%3D&reserved=0>
Personally, I want to be included in the IOAM slot.

Best,
Tianran

From: ippm [mailto:[email-masked]] On Behalf Of Frank Brockners (fbrockne)
Sent: Monday, March 18, 2019 5:28 PM
To: Tommy Pauly <tpauly=[email-masked]<mailto:tpauly=[email-masked]>>
Cc: IETF IPPM WG <[email-masked]<mailto:[email-masked]>>
Subject: Re: [ippm] Draft agenda for IETF 104

Hi IPPM WG,

Tommy asked me to facilitate the IOAM discussion. Per Tommy’s note below, we want to discuss the entire set of IOAM related documents and decide on next steps.

Given that we have a pretty large set of IOAM related individual drafts (currently 13 drafts, if I counted things correctly), I suggest that we do a very brief lightening talk (< 1 min – hard policed) on each document and then have a discussion on which categories and documents IPPM WG should consider for adoption.  In order to ease the “lightening talk” section – I’ve created a template https://docs.google.com/presentation/d/1P1Kp9mXA0eKkws78p1tldFn8zqx0YPQ5TK5fnq6Vyz4<https://eur03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdocs.google.com%2Fpresentation%2Fd%2F1P1Kp9mXA0eKkws78p1tldFn8zqx0YPQ5TK5fnq6Vyz4&data=02%7C01%7Cgbarak%40mellanox.com%7Cbdb809a6dba045a9671a08d6ad913d00%7Ca652971c7d2e4d9ba6a4d149256f461b%7C0%7C0%7C636887236676357347&sdata=QOrgP0Ojg%2Bx8UPctRa%2FpIRgIZV6j1B3IwWAFQg%2BIDhI%3D&reserved=0> - where each draft is listed with title and abstract. An author of each draft should present the key points of the drafts – as well as answer the question, whether IPPM should consider WG adoption.
If you’re an author, please feel free to update the particular slide of your draft according to what you think is required.

Here’s a draft agenda for the 40min IOAM slot:

·        IOAM data draft  / WG document (10min)

·        draft-ietf-ippm-ioam-data-05 – 10min

·        Review of individual IOAM drafts by category  (13min, 1min each max)

·        IOAM encapsulation (9min)

·        Draft-weis-ippm-ioam-eth-01 (new)

·        Draft-ioametal-ippm-6man-ioam-ipv6-options-01

·        Draft-ioametal-ippm-6man-ioam-ipv6-deployment-00 (new)

·        Draft-brockners-ippm-ioam-geneve-02 (new)

·        Draft-gafni-ippm-ioam-ipv4-options-00 (new)

·        Draft-ali-6man-spring-srv6-oam-00 (new)

·        Draft-anand-ippm-po-ioam-02 (new)

·        Draft-gandhi-spring-ioam-sr-mpls-00

·        Draft-ali-spring-ioam-srv6-00

·        IOAM data export (1min)

·        Draft-spiegel-ippm-ioam-rawexport-01

·        IOAM YANG models/operations (2 min)

·        Draft-zhou-ippm-ioam-yang-03 (new)

·        Draft-mizrahi-ippm-ioam-profile-00 (new)

·        IOAM tools (1min)

·        Draft-xiao-ippm-ioam-conf-state-03 (new)

·        Discussion and Hums (15min)

·        Which categories of IOAM documents make sense for IPPM to adopt?

·        WG adoption of certain drafts (for those categories and drafts which apply)?

Did I miss any document that should be added to the list above? If so, please let us know – and add another slide to the google slide deck.
The deck should be editable by anyone.

Thanks, Frank

From: ippm <[email-masked]<mailto:[email-masked]>> On Behalf Of Tommy Pauly
Sent: Mittwoch, 13. März 2019 01:24
To: Greg Mirsky <[email-masked]<mailto:[email-masked]>>
Cc: IETF IPPM WG <[email-masked]<mailto:[email-masked]>>
Subject: Re: [ippm] Draft agenda for IETF 104

To clarify, the time allocated for IOAM is not allocated just to discuss draft-ietf-ippm-ioam-data. That currently is the one IOAM document that is a WG document, but there is a list of many other documents that have been submitted as "-ippm" individual drafts. We want to use this time to figure out collectively as a group how we want to approach this work going forward, and where the documents best belong. The goal of this discussion is to come out with a clear picture of what work we think makes sense for IPPM. This will hopefully be more fruitful than having many individual lightning talks for these topics.

Best,
Tommy

On Mar 12, 2019, at 11:12 AM, Greg Mirsky <[email-masked]<mailto:[email-masked]>> wrote:

Hi Tommy,
given how dense is our agenda for Prague, allotting 40 minutes for one draft seems as overgenerous. If there are updates to IOAM individual drafts, then should these be explicitly listed among other individual drafts that have allocated 5 minutes each?

Kind regards,
Greg

On Tue, Mar 12, 2019 at 10:35 AM Tommy Pauly <tpauly=[email-masked]<mailto:[email-masked]>> wrote:
Hello IPPM,

We've posted our draft agent for IETF 104 here:
https://datatracker.ietf.org/meeting/104/materials/agenda-104-ippm-00<https://eur03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fmeeting%2F104%2Fmaterials%2Fagenda-104-ippm-00&data=02%7C01%7Cgbarak%40mellanox.com%7Cbdb809a6dba045a9671a08d6ad913d00%7Ca652971c7d2e4d9ba6a4d149256f461b%7C0%7C0%7C636887236676357347&sdata=qEuvsnGNcnyRMwd%2F3tLt7RrLJN8UvE%2FgfB99Be97Dg4%3D&reserved=0>

We have a two-hour slot, and are pretty full! The chairs have discussed and would like to have two more extended discussions this time about:
- Finalizing the metrics and initial registries, so we can get those out the door
- How we should progress with IOAM and the large cluster of related documents. We'll ask that instead of having any lightning talks on related IOAM documents, we have a broader discussion about what we're doing for these.

After that, the agenda is made up of 5 minute lightning talks, with a group of related alt-mark documents at the start. Apologies that we can't have longer time for these!

Suggestions or bashing welcome!

Best,
Tommy

_______________________________________________
ippm mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ippm<https://eur03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fippm&data=02%7C01%7Cgbarak%40mellanox.com%7Cbdb809a6dba045a9671a08d6ad913d00%7Ca652971c7d2e4d9ba6a4d149256f461b%7C0%7C0%7C636887236676367352&sdata=fupsOOFFHTrHtFWW8lKsKdsONuGyoCjPhTGBFEm0yxY%3D&reserved=0>

_______________________________________________ ippm mailing list [email-masked]<mailto:[email-masked]> https://www.ietf.org/mailman/listinfo/ippm

---

From: Barak Gafni <[email-masked]>
Date: Thu, 21 Mar 2019 06:32:02 +0000

Hi Tianran,
I will be glad to meet you in Prague and walk through the questions below together, as I am not sure that I fully understand them all. We can then update the forum.

Thanks,
Barak

From: Tianran Zhou <[email-masked]>
Sent: Wednesday, March 20, 2019 6:31 PM
To: Barak Gafni <[email-masked]>; Jai Kumar <[email-masked]>; Haoyu song <[email-masked]>; Frank Brockners (fbrockne) <[email-masked]>; Tommy Pauly <tpauly=[email-masked]>
Cc: IETF IPPM WG <[email-masked]>
Subject: use of flag bit in IOAM

Hi Barak,

https://mailarchive.ietf.org/arch/msg/ippm/H_d6ArjpD5izt5kg4cOERu2kR4w<https://eur03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fmailarchive.ietf.org%2Farch%2Fmsg%2Fippm%2FH_d6ArjpD5izt5kg4cOERu2kR4w&data=02%7C01%7Cgbarak%40mellanox.com%7Cb3332b0ca8e7415f63c108d6ad9ce318%7Ca652971c7d2e4d9ba6a4d149256f461b%7C0%7C0%7C636887286714138798&sdata=PCP1er2HLHXYxd51998AcQxpcKSRhH3SMwEqKVs6kIg%3D&reserved=0>

Thanks,
Tianran

To: Jai Kumar <[email-masked]<mailto:[email-masked]>>; Haoyu song <[email-masked]<mailto:[email-masked]>>; Frank Brockners (fbrockne) <[email-masked]<mailto:[email-masked]>>; Tianran Zhou <[email-masked]<mailto:[email-masked]>>; Tommy Pauly <tpauly=[email-masked]<mailto:tpauly=[email-masked]>>

Jai,
Thanks for the comments.
Please take a look at the new IPv4 options draft, where we did started the discussion about fragmentation, see https://tools.ietf.org/html/draft-gafni-ippm-ioam-ipv4-options-00#section-3.1.5<https://eur03.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-gafni-ippm-ioam-ipv4-options-00%23section-3.1.5&data=02%7C01%7Cgbarak%40mellanox.com%7Cb3332b0ca8e7415f63c108d6ad9ce318%7Ca652971c7d2e4d9ba6a4d149256f461b%7C0%7C0%7C636887286714148807&sdata=qXDnX9pjIw%2FKSCf9UXZNutO6RkdbSyMXbJmG9eQrJcw%3D&reserved=0>. As a side note, this discussion for the same use case started in RFC 791 chapter 3.1, which we refer to as well. We should continue this discussion and enhance it, appreciate your comments.
For the flow tracking: There are implementations that don’t need this identifier, for them this marking should be enough. For the ones who need it, as part of the discussion on Immediate Export at 05 we suggested to use e2e which can include these indicators, and plan to extend this discussion in the next draft.

Thanks,
Barak

Barak,

Please take a look at the IFA draft ver 01.
https://datatracker.ietf.org/doc/draft-kumar-ippm-ifa/<https://eur03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-kumar-ippm-ifa%2F&data=02%7C01%7Cgbarak%40mellanox.com%7Cb3332b0ca8e7415f63c108d6ad9ce318%7Ca652971c7d2e4d9ba6a4d149256f461b%7C0%7C0%7C636887286714148807&sdata=v7zfMreH6X0VYE5cen7kWnka0dF8J4GLdFJHlZN3KqY%3D&reserved=0>

Regards,
-Jai

Hi Haoyu,

Thanks,
Barak

Hi Barak,

Best regards,
Haoyu

Hi Haoyu,

Thanks,
Barak

Hi Frank and Tommy,

Best regards,
Haoyu

Haoyu,

See: https://docs.google.com/presentation/d/1P1Kp9mXA0eKkws78p1tldFn8zqx0YPQ5TK5fnq6Vyz4/<https://eur03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdocs.google.com%2Fpresentation%2Fd%2F1P1Kp9mXA0eKkws78p1tldFn8zqx0YPQ5TK5fnq6Vyz4%2F&data=02%7C01%7Cgbarak%40mellanox.com%7Cb3332b0ca8e7415f63c108d6ad9ce318%7Ca652971c7d2e4d9ba6a4d149256f461b%7C0%7C0%7C636887286714158817&sdata=tpheBS8qRCQdwq7FfKJdaQ3mIQQBo7h7k3lLSck7uCw%3D&reserved=0>

Frank

We also have another draft https://tools.ietf.org/html/draft-song-mpls-extension-header-02<https://eur03.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-song-mpls-extension-header-02&data=02%7C01%7Cgbarak%40mellanox.com%7Cb3332b0ca8e7415f63c108d6ad9ce318%7Ca652971c7d2e4d9ba6a4d149256f461b%7C0%7C0%7C636887286714168817&sdata=5L%2BItDm9HC8eqIF3gK1GfBb3dQTeI8W8P0%2Fq9uBc4q0%3D&reserved=0> for IOAM encapsulation in MPLS networks. We can also use 1 min 1 slide to mention it.
Thanks!

Haoyu

Hi Tianran,

Thanks, Frank

Hi Frank and Tommy,

I just want to know where the draft-song-ippm-postcard-based-telemetry-02 fit into the agenda?
https://datatracker.ietf.org/doc/draft-song-ippm-postcard-based-telemetry/<https://eur03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-song-ippm-postcard-based-telemetry%2F&data=02%7C01%7Cgbarak%40mellanox.com%7Cb3332b0ca8e7415f63c108d6ad9ce318%7Ca652971c7d2e4d9ba6a4d149256f461b%7C0%7C0%7C636887286714168817&sdata=o91Mg8bQfac%2Bv0jStAP%2Bn%2Bfs8U0KUacTmkkR32gBnzY%3D&reserved=0>
Personally, I want to be included in the IOAM slot.

Best,
Tianran

Hi IPPM WG,

Given that we have a pretty large set of IOAM related individual drafts (currently 13 drafts, if I counted things correctly), I suggest that we do a very brief lightening talk (< 1 min – hard policed) on each document and then have a discussion on which categories and documents IPPM WG should consider for adoption.  In order to ease the “lightening talk” section – I’ve created a template https://docs.google.com/presentation/d/1P1Kp9mXA0eKkws78p1tldFn8zqx0YPQ5TK5fnq6Vyz4<https://eur03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdocs.google.com%2Fpresentation%2Fd%2F1P1Kp9mXA0eKkws78p1tldFn8zqx0YPQ5TK5fnq6Vyz4&data=02%7C01%7Cgbarak%40mellanox.com%7Cb3332b0ca8e7415f63c108d6ad9ce318%7Ca652971c7d2e4d9ba6a4d149256f461b%7C0%7C0%7C636887286714178827&sdata=wnnfo3rN0k3ssbr4IEWd9kMxgRE5wM3cFUoLzGf3tRU%3D&reserved=0> - where each draft is listed with title and abstract. An author of each draft should present the key points of the drafts – as well as answer the question, whether IPPM should consider WG adoption.
If you’re an author, please feel free to update the particular slide of your draft according to what you think is required.

·         IOAM tools (1min)

Thanks, Frank

Best,
Tommy

Hi Tommy,

Kind regards,
Greg

We've posted our draft agent for IETF 104 here:
https://datatracker.ietf.org/meeting/104/materials/agenda-104-ippm-00<https://eur03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fmeeting%2F104%2Fmaterials%2Fagenda-104-ippm-00&data=02%7C01%7Cgbarak%40mellanox.com%7Cb3332b0ca8e7415f63c108d6ad9ce318%7Ca652971c7d2e4d9ba6a4d149256f461b%7C0%7C0%7C636887286714178827&sdata=jNDsSbfUYy7yMdypsBxyrs8TjD2%2BUJ4D4ef%2BPxnAfeQ%3D&reserved=0>

Best,
Tommy

_______________________________________________
ippm mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ippm<https://eur03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fippm&data=02%7C01%7Cgbarak%40mellanox.com%7Cb3332b0ca8e7415f63c108d6ad9ce318%7Ca652971c7d2e4d9ba6a4d149256f461b%7C0%7C0%7C636887286714188837&sdata=HYhLgeJXfHJfwEKk8GdlyGXUhd6QWZCHwt0ENXYSNxU%3D&reserved=0>

_______________________________________________ ippm mailing list [email-masked]<mailto:[email-masked]> https://www.ietf.org/mailman/listinfo/ippm<https://eur03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fippm&data=02%7C01%7Cgbarak%40mellanox.com%7Cb3332b0ca8e7415f63c108d6ad9ce318%7Ca652971c7d2e4d9ba6a4d149256f461b%7C0%7C0%7C636887286714198846&sdata=J4DJ9zHCaSHEwqTtGDAcBibMLWDgWksyILk9cG3%2BxIU%3D&reserved=0>

---

From: Tianran Zhou <[email-masked]>
Date: Thu, 21 Mar 2019 06:36:52 +0000

Oh, yes, sure. :-）

Tianran

From: Barak Gafni [mailto:[email-masked]]
Sent: Thursday, March 21, 2019 2:32 PM
To: Tianran Zhou <[email-masked]>; Jai Kumar <[email-masked]>; Haoyu song <[email-masked]>; Frank Brockners (fbrockne) <[email-masked]>; Tommy Pauly <tpauly=[email-masked]>
Cc: IETF IPPM WG <[email-masked]>
Subject: RE: use of flag bit in IOAM

Hi Tianran,

Thanks,
Barak

To: Barak Gafni <[email-masked]<mailto:[email-masked]>>; Jai Kumar <[email-masked]<mailto:[email-masked]>>; Haoyu song <[email-masked]<mailto:[email-masked]>>; Frank Brockners (fbrockne) <[email-masked]<mailto:[email-masked]>>; Tommy Pauly <tpauly=[email-masked]<mailto:tpauly=[email-masked]>>

Hi Barak,

Thanks,
Tianran

Jai,
Thanks for the comments.

Thanks,
Barak

Barak,

Regards,
-Jai

Hi Haoyu,

Thanks,
Barak

Hi Barak,

Best regards,
Haoyu

Hi Haoyu,

Thanks,
Barak

Hi Frank and Tommy,

Best regards,
Haoyu

Haoyu,

Frank

Haoyu

Hi Tianran,

Thanks, Frank

Hi Frank and Tommy,

Best,
Tianran

Hi IPPM WG,

·        IOAM tools (1min)

Thanks, Frank

Best,
Tommy

Hi Tommy,

Kind regards,
Greg

Best,
Tommy