Subject: [ippm] Draft agenda for IETF 104

From: Tommy Pauly <[email-masked]>
Date: Tue, 12 Mar 2019 10:34:43 -0700

Hello IPPM,

We've posted our draft agent for IETF 104 here:
https://datatracker.ietf.org/meeting/104/materials/agenda-104-ippm-00

We have a two-hour slot, and are pretty full! The chairs have discussed and would like to have two more extended discussions this time about:
- Finalizing the metrics and initial registries, so we can get those out the door
- How we should progress with IOAM and the large cluster of related documents. We'll ask that instead of having any lightning talks on related IOAM documents, we have a broader discussion about what we're doing for these.

After that, the agenda is made up of 5 minute lightning talks, with a group of related alt-mark documents at the start. Apologies that we can't have longer time for these!

Suggestions or bashing welcome!

Best,
Tommy

---

From: Haoyu song <[email-masked]>
Date: Tue, 12 Mar 2019 17:41:51 +0000

Hi Tommy,

Could you please identify in the agenda the list of the related document that will be covered by IOAM discussion session? Thanks!

Best,
Haoyu

-----Original Message-----
From: ippm [mailto:[email-masked]] On Behalf Of Tommy Pauly
Sent: Tuesday, March 12, 2019 10:35 AM
To: [email-masked]
Subject: [ippm] Draft agenda for IETF 104

Hello IPPM,

Best,
Tommy

_______________________________________________
ippm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ippm

---

From: Greg Mirsky <[email-masked]>
Date: Tue, 12 Mar 2019 11:12:55 -0700

Hi Tommy,
given how dense is our agenda for Prague, allotting 40 minutes for one
draft seems as overgenerous. If there are updates to IOAM individual
drafts, then should these be explicitly listed among other individual
drafts that have allocated 5 minutes each?

Kind regards,
Greg

On Tue, Mar 12, 2019 at 10:35 AM Tommy Pauly <tpauly=
[email-masked]> wrote:

> We have a two-hour slot, and are pretty full! The chairs have discussed
> and would like to have two more extended discussions this time about:
> - How we should progress with IOAM and the large cluster of related
> documents. We'll ask that instead of having any lightning talks on related
> IOAM documents, we have a broader discussion about what we're doing for
> these.
>
> After that, the agenda is made up of 5 minute lightning talks, with a
> group of related alt-mark documents at the start. Apologies that we can't
> have longer time for these!
>

---

From: Tommy Pauly <[email-masked]>
Date: Tue, 12 Mar 2019 17:14:16 -0700

Hi Haoyu,

We'll be wanting an overall discussion on our plans for all of the documents and where they should progress. The list I am tracking of documents currently are the ones that mention IOAM here:

https://datatracker.ietf.org/group/ippm/documents/

Frank will also be preparing a summary of all of the related work, which includes documents currently tracked in other groups.

Thanks,
Tommy

> On Mar 12, 2019, at 10:41 AM, Haoyu song <[email-masked]> wrote:
> 
> Hi Tommy,
>

---

From: Tommy Pauly <[email-masked]>
Date: Tue, 12 Mar 2019 17:24:12 -0700

To clarify, the time allocated for IOAM is not allocated just to discuss draft-ietf-ippm-ioam-data. That currently is the one IOAM document that is a WG document, but there is a list of many other documents that have been submitted as "-ippm" individual drafts. We want to use this time to figure out collectively as a group how we want to approach this work going forward, and where the documents best belong. The goal of this discussion is to come out with a clear picture of what work we think makes sense for IPPM. This will hopefully be more fruitful than having many individual lightning talks for these topics.

Best,
Tommy

> On Mar 12, 2019, at 11:12 AM, Greg Mirsky <[email-masked]> wrote:
> 
> Hi Tommy,
> given how dense is our agenda for Prague, allotting 40 minutes for one draft seems as overgenerous. If there are updates to IOAM individual drafts, then should these be explicitly listed among other individual drafts that have allocated 5 minutes each?
> 
> Kind regards,
> Greg
> 
> On Tue, Mar 12, 2019 at 10:35 AM Tommy Pauly <tpauly=[email-masked] <mailto:[email-masked]>> wrote:
> Hello IPPM,
> 
> https://datatracker.ietf.org/meeting/104/materials/agenda-104-ippm-00 <https://datatracker.ietf.org/meeting/104/materials/agenda-104-ippm-00>
> 
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/ippm <https://www.ietf.org/mailman/listinfo/ippm>

---

From: Greg Mirsky <[email-masked]>
Date: Tue, 12 Mar 2019 17:51:09 -0700

Hi Tommy,
I understand and agree that the group needs such discussion. But I'm not
sure we, as a group championing IPPM, can say more than These drafts don't
really fit in. To help authors to find other groups they need to reach out
to Area Directors.

Regards,
Greg

On Tue, Mar 12, 2019 at 5:24 PM Tommy Pauly <[email-masked]> wrote:

> To clarify, the time allocated for IOAM is not allocated just to
> discuss draft-ietf-ippm-ioam-data. That currently is the one IOAM document
> that is a WG document, but there is a list of many other documents that
> have been submitted as "-ippm" individual drafts. We want to use this time
> to figure out collectively as a group how we want to approach this work
> going forward, and where the documents best belong. The goal of this
> discussion is to come out with a clear picture of what work we think makes
> sense for IPPM. This will hopefully be more fruitful than having many
> individual lightning talks for these topics.
>
> Best,
> Tommy
>

---

From: "Frank Brockners (fbrockne)" <[email-masked]>
Date: Mon, 18 Mar 2019 09:27:45 +0000

Hi IPPM WG,

Tommy asked me to facilitate the IOAM discussion. Per Tommy's note below, we want to discuss the entire set of IOAM related documents and decide on next steps.

Given that we have a pretty large set of IOAM related individual drafts (currently 13 drafts, if I counted things correctly), I suggest that we do a very brief lightening talk (< 1 min - hard policed) on each document and then have a discussion on which categories and documents IPPM WG should consider for adoption.  In order to ease the "lightening talk" section - I've created a template https://docs.google.com/presentation/d/1P1Kp9mXA0eKkws78p1tldFn8zqx0YPQ5TK5fnq6Vyz4 - where each draft is listed with title and abstract. An author of each draft should present the key points of the drafts - as well as answer the question, whether IPPM should consider WG adoption.
If you're an author, please feel free to update the particular slide of your draft according to what you think is required.

Here's a draft agenda for the 40min IOAM slot:

·        IOAM data draft  / WG document (10min)

·        draft-ietf-ippm-ioam-data-05 - 10min

·        Review of individual IOAM drafts by category  (13min, 1min each max)

·        IOAM encapsulation (9min)

·        Draft-weis-ippm-ioam-eth-01 (new)

·        Draft-ioametal-ippm-6man-ioam-ipv6-options-01

·        Draft-ioametal-ippm-6man-ioam-ipv6-deployment-00 (new)

·        Draft-brockners-ippm-ioam-geneve-02 (new)

·        Draft-gafni-ippm-ioam-ipv4-options-00 (new)

·        Draft-ali-6man-spring-srv6-oam-00 (new)

·        Draft-anand-ippm-po-ioam-02 (new)

·        Draft-gandhi-spring-ioam-sr-mpls-00

·        Draft-ali-spring-ioam-srv6-00

·        IOAM data export (1min)

·        Draft-spiegel-ippm-ioam-rawexport-01

·        IOAM YANG models/operations (2 min)

·        Draft-zhou-ippm-ioam-yang-03 (new)

·        Draft-mizrahi-ippm-ioam-profile-00 (new)

·        IOAM tools (1min)

·        Draft-xiao-ippm-ioam-conf-state-03 (new)

·        Discussion and Hums (15min)

·        Which categories of IOAM documents make sense for IPPM to adopt?

·        WG adoption of certain drafts (for those categories and drafts which apply)?

Did I miss any document that should be added to the list above? If so, please let us know - and add another slide to the google slide deck.
The deck should be editable by anyone.

Thanks, Frank

From: ippm <[email-masked]> On Behalf Of Tommy Pauly
Sent: Mittwoch, 13. März 2019 01:24
To: Greg Mirsky <[email-masked]>
Cc: IETF IPPM WG <[email-masked]>
Subject: Re: [ippm] Draft agenda for IETF 104

Best,
Tommy

On Mar 12, 2019, at 11:12 AM, Greg Mirsky <[email-masked]<mailto:[email-masked]>> wrote:

Hi Tommy,

Kind regards,
Greg

On Tue, Mar 12, 2019 at 10:35 AM Tommy Pauly <tpauly=[email-masked]<mailto:[email-masked]>> wrote:
Hello IPPM,

Best,
Tommy

_______________________________________________
ippm mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ippm

---

From: Tianran Zhou <[email-masked]>
Date: Mon, 18 Mar 2019 09:41:39 +0000

Hi Frank and Tommy,

I just want to know where the draft-song-ippm-postcard-based-telemetry-02 fit into the agenda?
https://datatracker.ietf.org/doc/draft-song-ippm-postcard-based-telemetry/
Personally, I want to be included in the IOAM slot.

Best,
Tianran

From: ippm [mailto:[email-masked]] On Behalf Of Frank Brockners (fbrockne)
Sent: Monday, March 18, 2019 5:28 PM
To: Tommy Pauly <tpauly=[email-masked]>
Cc: IETF IPPM WG <[email-masked]>
Subject: Re: [ippm] Draft agenda for IETF 104

Hi IPPM WG,

·        IOAM tools (1min)

Thanks, Frank

From: ippm <[email-masked]<mailto:[email-masked]>> On Behalf Of Tommy Pauly
Sent: Mittwoch, 13. März 2019 01:24
To: Greg Mirsky <[email-masked]<mailto:[email-masked]>>
Cc: IETF IPPM WG <[email-masked]<mailto:[email-masked]>>
Subject: Re: [ippm] Draft agenda for IETF 104

Best,
Tommy

Hi Tommy,

Kind regards,
Greg

Best,
Tommy

---

From: Greg Mirsky <[email-masked]>
Date: Mon, 18 Mar 2019 10:42:18 +0100

Hi Frank,
thank you for taking the proactive step to have a productive discussion in
Prague. I think that we have a pretty good understanding of the iOAM
related drafts presented to IPPM WG, some several times, before. Thus, I
cannot see another 13+ minutes being spent on re-representing them as
efficient use of everyone time. The scope of the draft-ietf-ippm-ioam-data
is declared as "the data fields and associated data types for in-situ OAM".
Based on that, I suggest that authors of the iOAM encapsulations drafts,
e.g., Ethernet, IPv6, Optical, etc., work with the Responsible AD to help
them find WGs to work on their respective documents. The rest is what we
could discuss. How many non-encapsulation iOAM drafts that will be?

Regards,
Greg

On Mon, Mar 18, 2019 at 10:28 AM Frank Brockners (fbrockne) <
[email-masked]> wrote:

> Hi IPPM WG,
>
>
>
> Tommy asked me to facilitate the IOAM discussion. Per Tommy’s note below,
> we want to discuss the entire set of IOAM related documents and decide on
> next steps.
>
>
>
> Given that we have a pretty large set of IOAM related individual drafts
> (currently 13 drafts, if I counted things correctly), I suggest that we do
> a very brief lightening talk (< 1 min – hard policed) on each document and
> then have a discussion on which categories and documents IPPM WG should
> consider for adoption.  In order to ease the “lightening talk” section –
> I’ve created a template
> https://docs.google.com/presentation/d/1P1Kp9mXA0eKkws78p1tldFn8zqx0YPQ5TK5fnq6Vyz4
> - where each draft is listed with title and abstract. An author of each
> draft should present the key points of the drafts – as well as answer the
> question, whether IPPM should consider WG adoption.
> If you’re an author, please feel free to update the particular slide of
> your draft according to what you think is required.
>
>
>
> Here’s a draft agenda for the 40min IOAM slot:
>
>
>
> ·        draft-ietf-ippm-ioam-data-05 – 10min
>
> ·        *IOAM encapsulation (9min)*
>
> ·        *IOAM data export (1min)*
>
> ·        *IOAM YANG models/operations (2 min)*
>
> Did I miss any document that should be added to the list above? If so,
> please let us know – and add another slide to the google slide deck.
> *From:* ippm <[email-masked]> *On Behalf Of * Tommy Pauly
> *Sent:* Mittwoch, 13. März 2019 01:24
> *To:* Greg Mirsky <[email-masked]>
> *Cc:* IETF IPPM WG <[email-masked]>
> *Subject:* Re: [ippm] Draft agenda for IETF 104
>
>
>

---

From: "Frank Brockners (fbrockne)" <[email-masked]>
Date: Mon, 18 Mar 2019 10:10:37 +0000

Hi Tianran,

in which category would the draft fit?

Thanks, Frank

From: Tianran Zhou <[email-masked]>
Sent: Montag, 18. März 2019 10:42
To: Frank Brockners (fbrockne) <[email-masked]>; Tommy Pauly <tpauly=[email-masked]>
Cc: IETF IPPM WG <[email-masked]>
Subject: RE: [ippm] Draft agenda for IETF 104

Hi Frank and Tommy,

Best,
Tianran

To: Tommy Pauly <tpauly=[email-masked]<mailto:tpauly=[email-masked]>>

Hi IPPM WG,

·        IOAM tools (1min)

Thanks, Frank

Best,
Tommy

Hi Tommy,

Kind regards,
Greg

Best,
Tommy

---

From: "Frank Brockners (fbrockne)" <[email-masked]>
Date: Mon, 18 Mar 2019 10:14:41 +0000

Hi Greg,

From what I understand, it is chair’s objective to address the question you raise below (i.e. what categories should IPPM WG consider for adoption?) as part of the planned WG discussion. In order to have a meaningful discussion – and given the fact that quite a few of the drafts are new/revised, it makes sense to get everyone on the same page, hence the superbrief lightening talks.

Frank

From: Greg Mirsky <[email-masked]>
Sent: Montag, 18. März 2019 10:42
To: Frank Brockners (fbrockne) <[email-masked]>
Cc: Tommy Pauly <tpauly=[email-masked]>; IETF IPPM WG <[email-masked]>
Subject: Re: [ippm] Draft agenda for IETF 104

Hi Frank,
thank you for taking the proactive step to have a productive discussion in Prague. I think that we have a pretty good understanding of the iOAM related drafts presented to IPPM WG, some several times, before. Thus, I cannot see another 13+ minutes being spent on re-representing them as efficient use of everyone time. The scope of the draft-ietf-ippm-ioam-data is declared as "the data fields and associated data types for in-situ OAM". Based on that, I suggest that authors of the iOAM encapsulations drafts, e.g., Ethernet, IPv6, Optical, etc., work with the Responsible AD to help them find WGs to work on their respective documents. The rest is what we could discuss. How many non-encapsulation iOAM drafts that will be?

Regards,
Greg

On Mon, Mar 18, 2019 at 10:28 AM Frank Brockners (fbrockne) <[email-masked]<mailto:[email-masked]>> wrote:

Hi IPPM WG,

Tommy asked me to facilitate the IOAM discussion. Per Tommy’s note below, we want to discuss the entire set of IOAM related documents and decide on next steps.

Given that we have a pretty large set of IOAM related individual drafts (currently 13 drafts, if I counted things correctly), I suggest that we do a very brief lightening talk (< 1 min – hard policed) on each document and then have a discussion on which categories and documents IPPM WG should consider for adoption.  In order to ease the “lightening talk” section – I’ve created a template https://docs.google.com/presentation/d/1P1Kp9mXA0eKkws78p1tldFn8zqx0YPQ5TK5fnq6Vyz4 - where each draft is listed with title and abstract. An author of each draft should present the key points of the drafts – as well as answer the question, whether IPPM should consider WG adoption.
If you’re an author, please feel free to update the particular slide of your draft according to what you think is required.

•        IOAM data draft  / WG document (10min)

•        draft-ietf-ippm-ioam-data-05 – 10min

•        Review of individual IOAM drafts by category  (13min, 1min each max)

•        IOAM encapsulation (9min)

•        Draft-weis-ippm-ioam-eth-01 (new)

•        Draft-ioametal-ippm-6man-ioam-ipv6-options-01

•        Draft-ioametal-ippm-6man-ioam-ipv6-deployment-00 (new)

•        Draft-brockners-ippm-ioam-geneve-02 (new)

•        Draft-gafni-ippm-ioam-ipv4-options-00 (new)

•        Draft-ali-6man-spring-srv6-oam-00 (new)

•        Draft-anand-ippm-po-ioam-02 (new)

•        Draft-gandhi-spring-ioam-sr-mpls-00

•        Draft-ali-spring-ioam-srv6-00

•        IOAM data export (1min)

•        Draft-spiegel-ippm-ioam-rawexport-01

•        IOAM YANG models/operations (2 min)

•        Draft-zhou-ippm-ioam-yang-03 (new)

•        Draft-mizrahi-ippm-ioam-profile-00 (new)

•        IOAM tools (1min)

•        Draft-xiao-ippm-ioam-conf-state-03 (new)

•        Discussion and Hums (15min)

•        Which categories of IOAM documents make sense for IPPM to adopt?

•        WG adoption of certain drafts (for those categories and drafts which apply)?

Did I miss any document that should be added to the list above? If so, please let us know – and add another slide to the google slide deck.
The deck should be editable by anyone.

Thanks, Frank

Best,
Tommy

Hi Tommy,

Kind regards,
Greg

Best,
Tommy

---

From: Greg Mirsky <[email-masked]>
Date: Mon, 18 Mar 2019 11:41:37 +0100

Hi Frank,
I've expressed my POV, that's all. Everyone can read the new/revised drafts
before the meeting to save us precious time in Prague. I still
maintain that 13 minutes is way more than should be spent to refresh
memory. I believe we are capable of doing our homework diligently and come
to the meeting already with a good understanding of the scope of each of
the related drafts. So we can get to the productive discussion right from
the start and give fair time to other groups of authors.
As for the home assignment, would you kindly list these 13 iOAM drafts
you've intended for the discussion in Prague?

Regards,
Greg

On Mon, Mar 18, 2019 at 11:14 AM Frank Brockners (fbrockne) <
[email-masked]> wrote:

> Hi Greg,
>
>
>
> From what I understand, it is chair’s objective to address the question
> you raise below (i.e. what categories should IPPM WG consider for
> adoption?) as part of the planned WG discussion. In order to have a
> meaningful discussion – and given the fact that quite a few of the drafts
> are new/revised, it makes sense to get everyone on the same page, hence the
> superbrief lightening talks.
>
>
>
> Frank
>
>
>
> *From:* Greg Mirsky <[email-masked]>
> *Sent:* Montag, 18. März 2019 10:42
> *To:* Frank Brockners (fbrockne) <[email-masked]>
> *Cc:* Tommy Pauly <tpauly=[email-masked]>; IETF IPPM WG <
> [email-masked]>
> *From:* ippm <[email-masked]> *On Behalf Of *Tommy Pauly

---

From: "Frank Brockners (fbrockne)" <[email-masked]>
Date: Mon, 18 Mar 2019 10:56:37 +0000

Hi Greg,

Please see the draft agenda in the original email I sent (see below) or the google presentation link – it has references to all the drafts that would be highlighted in the IOAM session. If I missed a draft, please drop us a note.

Thanks, Frank

Sent: Montag, 18. März 2019 11:42

Hi Frank,
I've expressed my POV, that's all. Everyone can read the new/revised drafts before the meeting to save us precious time in Prague. I still maintain that 13 minutes is way more than should be spent to refresh memory. I believe we are capable of doing our homework diligently and come to the meeting already with a good understanding of the scope of each of the related drafts. So we can get to the productive discussion right from the start and give fair time to other groups of authors.
As for the home assignment, would you kindly list these 13 iOAM drafts you've intended for the discussion in Prague?

Regards,
Greg

On Mon, Mar 18, 2019 at 11:14 AM Frank Brockners (fbrockne) <[email-masked]<mailto:[email-masked]>> wrote:
Hi Greg,

Frank

From: Greg Mirsky <[email-masked]<mailto:[email-masked]>>
Sent: Montag, 18. März 2019 10:42
To: Frank Brockners (fbrockne) <[email-masked]<mailto:[email-masked]>>
Cc: Tommy Pauly <tpauly=[email-masked]<mailto:[email-masked]>>; IETF IPPM WG <[email-masked]<mailto:[email-masked]>>
Subject: Re: [ippm] Draft agenda for IETF 104

Hi Frank,

Regards,
Greg

Hi IPPM WG,

•        IOAM tools (1min)

Thanks, Frank

Best,
Tommy

Hi Tommy,

Kind regards,
Greg

Best,
Tommy

---

From: Haoyu song <[email-masked]>
Date: Mon, 18 Mar 2019 17:28:14 +0000

We currently positioned a part of the draft (PBT-I) a mode of IOAM so it could fit in the IOAM data session.

We also have another draft https://tools.ietf.org/html/draft-song-mpls-extension-header-02 for IOAM encapsulation in MPLS networks. We can also use 1 min 1 slide to mention it.
Thanks!

Haoyu

From: ippm [mailto:[email-masked]] On Behalf Of Frank Brockners (fbrockne)
Sent: Monday, March 18, 2019 3:11 AM
To: Tianran Zhou <[email-masked]>; Tommy Pauly <tpauly=[email-masked]>
Cc: IETF IPPM WG <[email-masked]>
Subject: Re: [ippm] Draft agenda for IETF 104

Hi Tianran,

Thanks, Frank

From: Tianran Zhou <[email-masked]<mailto:[email-masked]>>
Sent: Montag, 18. März 2019 10:42
To: Frank Brockners (fbrockne) <[email-masked]<mailto:[email-masked]>>; Tommy Pauly <tpauly=[email-masked]<mailto:tpauly=[email-masked]>>
Cc: IETF IPPM WG <[email-masked]<mailto:[email-masked]>>
Subject: RE: [ippm] Draft agenda for IETF 104

Hi Frank and Tommy,

Best,
Tianran

Hi IPPM WG,

·        IOAM tools (1min)

Thanks, Frank

Best,
Tommy

Hi Tommy,

Kind regards,
Greg

Best,
Tommy

---

From: Tianran Zhou <[email-masked]>
Date: Tue, 19 Mar 2019 08:54:40 +0000

Hi Frank,

As Haoyu mentioned, the draft-song-ippm-postcard-based-telemetry includes a PBT-I mode which is going to align with IOAM data and provide an additional option to the existing 3 options.
So maybe it can be adjacent to IOAM-data draft, or can we create another category on "IOAM option extension" or so?

Thanks,
Tianran

From: Frank Brockners (fbrockne) [mailto:[email-masked]]
Sent: Monday, March 18, 2019 6:11 PM
To: Tianran Zhou <[email-masked]>; Tommy Pauly <tpauly=[email-masked]>
Cc: IETF IPPM WG <[email-masked]>
Subject: RE: [ippm] Draft agenda for IETF 104

Hi Tianran,

Thanks, Frank

Hi Frank and Tommy,

Best,
Tianran

Hi IPPM WG,

·        IOAM tools (1min)

Thanks, Frank

Best,
Tommy

Hi Tommy,

Kind regards,
Greg

Best,
Tommy

---

From: "Frank Brockners (fbrockne)" <[email-masked]>
Date: Tue, 19 Mar 2019 14:38:04 +0000

Hi Tianran, Haoyu,

Thanks. I've updated the agenda and slides accordingly (a new category: IOAM additional options got added) - see
https://docs.google.com/presentation/d/1P1Kp9mXA0eKkws78p1tldFn8zqx0YPQ5TK5fnq6Vyz4/

Frank

Sent: Dienstag, 19. März 2019 09:55

Hi Frank,

Thanks,
Tianran

To: Tianran Zhou <[email-masked]<mailto:[email-masked]>>; Tommy Pauly <tpauly=[email-masked]<mailto:tpauly=[email-masked]>>

Hi Tianran,

Thanks, Frank

Hi Frank and Tommy,

Best,
Tianran

Hi IPPM WG,

·        IOAM tools (1min)

Thanks, Frank

Best,
Tommy

Hi Tommy,

Kind regards,
Greg

Best,
Tommy

---

From: "Frank Brockners (fbrockne)" <[email-masked]>
Date: Tue, 19 Mar 2019 14:40:32 +0000

Haoyu,

Thanks - per my other email, I've added a new category "IOAM additional options" and also added draft-song-mpls-extension-header-02 to the set of encap options which are covered by a lightening talk.

See: https://docs.google.com/presentation/d/1P1Kp9mXA0eKkws78p1tldFn8zqx0YPQ5TK5fnq6Vyz4/

Frank

From: Haoyu song <[email-masked]>
Sent: Montag, 18. März 2019 18:28
To: Frank Brockners (fbrockne) <[email-masked]>; Tianran Zhou <[email-masked]>; Tommy Pauly <tpauly=[email-masked]>
Cc: IETF IPPM WG <[email-masked]>
Subject: RE: [ippm] Draft agenda for IETF 104

Haoyu

Hi Tianran,

Thanks, Frank

Hi Frank and Tommy,

Best,
Tianran

Hi IPPM WG,

·        IOAM tools (1min)

Thanks, Frank

Best,
Tommy

Hi Tommy,

Kind regards,
Greg

Best,
Tommy

---

From: Lizhenbin <[email-masked]>
Date: Tue, 19 Mar 2019 16:11:32 +0000

Hi Frank,

There is one more draft as belows:

https://tools.ietf.org/html/draft-li-6man-ipv6-sfc-ifit-00

It is to discuss if there can be optimization for the IOAM encausulation in the scenario of IPv6 other than an independent header.

It should belong to the category "IOAM encapsulation".

Best Regards,

Zhenbin (Robin)

________________________________
发件人: ippm [[email-masked]] 代表 Frank Brockners (fbrockne) [[email-masked]]
发送时间: 2019年3月18日 17:27
收件人: Tommy Pauly
抄送: IETF IPPM WG
主题: Re: [ippm] Draft agenda for IETF 104

Hi IPPM WG,

•        IOAM tools (1min)

Thanks, Frank

Best,
Tommy

Hi Tommy,

Kind regards,
Greg

Best,
Tommy

---

From: "Frank Brockners (fbrockne)" <[email-masked]>
Date: Tue, 19 Mar 2019 16:16:17 +0000

Hi Robin,

Thanks. It just got added: https://docs.google.com/presentation/d/1P1Kp9mXA0eKkws78p1tldFn8zqx0YPQ5TK5fnq6Vyz4

Frank

From: Lizhenbin <[email-masked]>
Sent: Dienstag, 19. März 2019 17:12
To: Frank Brockners (fbrockne) <[email-masked]>; Tommy Pauly <tpauly=[email-masked]>
Cc: IETF IPPM WG <[email-masked]>; Pengshuping (Peng Shuping) <[email-masked]>
Subject: 答复: [ippm] Draft agenda for IETF 104

Hi Frank,

Best Regards,

Zhenbin (Robin)

Hi IPPM WG,

•        IOAM tools (1min)

Thanks, Frank

Best,
Tommy

Hi Tommy,

Kind regards,
Greg

Best,
Tommy

---

From: Haoyu song <[email-masked]>
Date: Tue, 19 Mar 2019 22:09:27 +0000

Hi Frank and Tommy,

Thanks for including our drafts! Please note we also request the IPPM WG adoption of this draft. This time we'd like to achieve rough consensus to make PBT-I a mode of IOAM (the name can be changed of course). This drafts also contains another option (PBT-M) which doesn't need an instruction header. In this sense, we believe this draft can be developed in its own right. After it's adopted, we'll update it to make the alignment. Thanks!

Best regards,
Haoyu

From: Frank Brockners (fbrockne) [mailto:[email-masked]]
Sent: Tuesday, March 19, 2019 7:41 AM
To: Haoyu song <[email-masked]>; Tianran Zhou <[email-masked]>; Tommy Pauly <tpauly=[email-masked]>
Cc: IETF IPPM WG <[email-masked]>
Subject: RE: [ippm] Draft agenda for IETF 104

Haoyu,

Frank

From: Haoyu song <[email-masked]<mailto:[email-masked]>>
Sent: Montag, 18. März 2019 18:28
To: Frank Brockners (fbrockne) <[email-masked]<mailto:[email-masked]>>; Tianran Zhou <[email-masked]<mailto:[email-masked]>>; Tommy Pauly <tpauly=[email-masked]<mailto:tpauly=[email-masked]>>
Cc: IETF IPPM WG <[email-masked]<mailto:[email-masked]>>
Subject: RE: [ippm] Draft agenda for IETF 104

Haoyu

Hi Tianran,

Thanks, Frank

Hi Frank and Tommy,

Best,
Tianran

Hi IPPM WG,

·        IOAM tools (1min)

Thanks, Frank

Best,
Tommy

Hi Tommy,

Kind regards,
Greg

Best,
Tommy

---

From: Barak Gafni <[email-masked]>
Date: Wed, 20 Mar 2019 05:55:32 +0000

Hi Haoyu,
I think that there are some relations and similarities between PBT-M and IOAM e2e, it may be good to prevent yet another header format for implementations if we can converge on the already existing e2e format, potentially adding on additional header. Please take a look share your thoughts.

Thanks,
Barak

From: ippm <[email-masked]> On Behalf Of Haoyu song
Sent: Tuesday, March 19, 2019 3:09 PM
To: Frank Brockners (fbrockne) <[email-masked]>; Tianran Zhou <[email-masked]>; Tommy Pauly <tpauly=[email-masked]>
Cc: IETF IPPM WG <[email-masked]>
Subject: Re: [ippm] Draft agenda for IETF 104

Hi Frank and Tommy,

Best regards,
Haoyu

To: Haoyu song <[email-masked]<mailto:[email-masked]>>; Tianran Zhou <[email-masked]<mailto:[email-masked]>>; Tommy Pauly <tpauly=[email-masked]<mailto:tpauly=[email-masked]>>

Haoyu,

See: https://docs.google.com/presentation/d/1P1Kp9mXA0eKkws78p1tldFn8zqx0YPQ5TK5fnq6Vyz4/<https://eur03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdocs.google.com%2Fpresentation%2Fd%2F1P1Kp9mXA0eKkws78p1tldFn8zqx0YPQ5TK5fnq6Vyz4%2F&data=02%7C01%7Cgbarak%40mellanox.com%7C171cdb8dc46c47bf932508d6acb79d7e%7Ca652971c7d2e4d9ba6a4d149256f461b%7C0%7C0%7C636886301954022448&sdata=cLSe8kau6nt1DQtQGTZbbwplAmVNyJKIcuAYQM0bq1s%3D&reserved=0>

Frank

We also have another draft https://tools.ietf.org/html/draft-song-mpls-extension-header-02<https://eur03.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-song-mpls-extension-header-02&data=02%7C01%7Cgbarak%40mellanox.com%7C171cdb8dc46c47bf932508d6acb79d7e%7Ca652971c7d2e4d9ba6a4d149256f461b%7C0%7C0%7C636886301954022448&sdata=0XH0mput5dDYxCD0915euX%2BukVj4zo%2Fz6gzl67BgCwE%3D&reserved=0> for IOAM encapsulation in MPLS networks. We can also use 1 min 1 slide to mention it.
Thanks!

Haoyu

Hi Tianran,

Thanks, Frank

Hi Frank and Tommy,

I just want to know where the draft-song-ippm-postcard-based-telemetry-02 fit into the agenda?
https://datatracker.ietf.org/doc/draft-song-ippm-postcard-based-telemetry/<https://eur03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-song-ippm-postcard-based-telemetry%2F&data=02%7C01%7Cgbarak%40mellanox.com%7C171cdb8dc46c47bf932508d6acb79d7e%7Ca652971c7d2e4d9ba6a4d149256f461b%7C0%7C0%7C636886301954032453&sdata=iOXf13YkMHmo9ZPvp8YiMJVx44DUy%2FLsjhE6PiAc5Cs%3D&reserved=0>
Personally, I want to be included in the IOAM slot.

Best,
Tianran

Hi IPPM WG,

Given that we have a pretty large set of IOAM related individual drafts (currently 13 drafts, if I counted things correctly), I suggest that we do a very brief lightening talk (< 1 min - hard policed) on each document and then have a discussion on which categories and documents IPPM WG should consider for adoption.  In order to ease the "lightening talk" section - I've created a template https://docs.google.com/presentation/d/1P1Kp9mXA0eKkws78p1tldFn8zqx0YPQ5TK5fnq6Vyz4<https://eur03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdocs.google.com%2Fpresentation%2Fd%2F1P1Kp9mXA0eKkws78p1tldFn8zqx0YPQ5TK5fnq6Vyz4&data=02%7C01%7Cgbarak%40mellanox.com%7C171cdb8dc46c47bf932508d6acb79d7e%7Ca652971c7d2e4d9ba6a4d149256f461b%7C0%7C0%7C636886301954032453&sdata=pW0OAngo3KHJl46XDNi50cOZmy8tUpTZYzlV3Zjc2rI%3D&reserved=0> - where each draft is listed with title and abstract. An author of each draft should present the key points of the drafts - as well as answer the question, whether IPPM should consider WG adoption.
If you're an author, please feel free to update the particular slide of your draft according to what you think is required.

·         IOAM tools (1min)

Thanks, Frank

Best,
Tommy

Hi Tommy,

Kind regards,
Greg

We've posted our draft agent for IETF 104 here:
https://datatracker.ietf.org/meeting/104/materials/agenda-104-ippm-00<https://eur03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fmeeting%2F104%2Fmaterials%2Fagenda-104-ippm-00&data=02%7C01%7Cgbarak%40mellanox.com%7C171cdb8dc46c47bf932508d6acb79d7e%7Ca652971c7d2e4d9ba6a4d149256f461b%7C0%7C0%7C636886301954042462&sdata=rCTj48UkFMShC4%2ByymrNxmh2OsiI3fBQVe2iLvmONsY%3D&reserved=0>

Best,
Tommy

_______________________________________________
ippm mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ippm<https://eur03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fippm&data=02%7C01%7Cgbarak%40mellanox.com%7C171cdb8dc46c47bf932508d6acb79d7e%7Ca652971c7d2e4d9ba6a4d149256f461b%7C0%7C0%7C636886301954042462&sdata=6zjqX6BMmk%2FRBltbqGjWc9x94hqeNiWnLpQmJhHJvHc%3D&reserved=0>

---

From: Haoyu song <[email-masked]>
Date: Wed, 20 Mar 2019 18:29:17 +0000

Hi Barak,

Thank you for your comments!
I think you are mentioning the PBT-I (The variation which requires an instruction header)?  Although PBT-I and E2E shares similarities but they have different semantics and usage, therefore some difference may be inevitable. I agree we can try to align the header formats which may benefit the implementation, but it seems to me these are two independent modes with each having its specific purpose. Maybe you also mean the same thing. If you have any specific suggestions, please don't hesitate to propose. Thank you very much!

Best regards,
Haoyu

From: Barak Gafni [mailto:[email-masked]]
Sent: Tuesday, March 19, 2019 10:56 PM
To: Haoyu song <[email-masked]>; Frank Brockners (fbrockne) <[email-masked]>; Tianran Zhou <[email-masked]>; Tommy Pauly <tpauly=[email-masked]>
Cc: IETF IPPM WG <[email-masked]>
Subject: RE: [ippm] Draft agenda for IETF 104

Hi Haoyu,

Thanks,
Barak

From: ippm <[email-masked]<mailto:[email-masked]>> On Behalf Of Haoyu song

Hi Frank and Tommy,

Best regards,
Haoyu

Haoyu,

Frank

Haoyu

Hi Tianran,

Thanks, Frank

Hi Frank and Tommy,

Best,
Tianran

Hi IPPM WG,

·        IOAM tools (1min)

Thanks, Frank

Best,
Tommy

Hi Tommy,

Kind regards,
Greg

Best,
Tommy

---

From: Barak Gafni <[email-masked]>
Date: Wed, 20 Mar 2019 23:38:04 +0000

Hi Haoyu,
Yes, you are right, I meant PBT-I. If you consider the description we added to the Immediate Export flag you may find more similarities in terms of use cases.
I think it can be a good topic to discuss f2f at Prague. Thanks for your comments!

Thanks,
Barak

From: Haoyu song <[email-masked]>
Sent: Wednesday, March 20, 2019 11:29 AM
To: Barak Gafni <[email-masked]>; Frank Brockners (fbrockne) <[email-masked]>; Tianran Zhou <[email-masked]>; Tommy Pauly <tpauly=[email-masked]>
Cc: IETF IPPM WG <[email-masked]>
Subject: RE: [ippm] Draft agenda for IETF 104

Hi Barak,

Best regards,
Haoyu

To: Haoyu song <[email-masked]<mailto:[email-masked]>>; Frank Brockners (fbrockne) <[email-masked]<mailto:[email-masked]>>; Tianran Zhou <[email-masked]<mailto:[email-masked]>>; Tommy Pauly <tpauly=[email-masked]<mailto:tpauly=[email-masked]>>

Hi Haoyu,

Thanks,
Barak

Hi Frank and Tommy,

Best regards,
Haoyu

Haoyu,

See: https://docs.google.com/presentation/d/1P1Kp9mXA0eKkws78p1tldFn8zqx0YPQ5TK5fnq6Vyz4/<https://eur03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdocs.google.com%2Fpresentation%2Fd%2F1P1Kp9mXA0eKkws78p1tldFn8zqx0YPQ5TK5fnq6Vyz4%2F&data=02%7C01%7Cgbarak%40mellanox.com%7Ce5dbebbc0d904975a56008d6ad61feb4%7Ca652971c7d2e4d9ba6a4d149256f461b%7C0%7C0%7C636887033734765994&sdata=1Y%2F5kLRvOp9r06Zjz%2FBALb61G7do13d6%2B2tGsKM9Xp4%3D&reserved=0>

Frank

We also have another draft https://tools.ietf.org/html/draft-song-mpls-extension-header-02<https://eur03.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-song-mpls-extension-header-02&data=02%7C01%7Cgbarak%40mellanox.com%7Ce5dbebbc0d904975a56008d6ad61feb4%7Ca652971c7d2e4d9ba6a4d149256f461b%7C0%7C0%7C636887033734775999&sdata=fKgQLaPRyk5ibi75GiUrEzsjA6gN0jYaCZHjNTNZVUc%3D&reserved=0> for IOAM encapsulation in MPLS networks. We can also use 1 min 1 slide to mention it.
Thanks!

Haoyu

Hi Tianran,

Thanks, Frank

Hi Frank and Tommy,

I just want to know where the draft-song-ippm-postcard-based-telemetry-02 fit into the agenda?
https://datatracker.ietf.org/doc/draft-song-ippm-postcard-based-telemetry/<https://eur03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-song-ippm-postcard-based-telemetry%2F&data=02%7C01%7Cgbarak%40mellanox.com%7Ce5dbebbc0d904975a56008d6ad61feb4%7Ca652971c7d2e4d9ba6a4d149256f461b%7C0%7C0%7C636887033734775999&sdata=BT2bzaCdsh9w3AGBKz4S621rS5Rpq0y0N7NXD65o9ek%3D&reserved=0>
Personally, I want to be included in the IOAM slot.

Best,
Tianran

Hi IPPM WG,

Given that we have a pretty large set of IOAM related individual drafts (currently 13 drafts, if I counted things correctly), I suggest that we do a very brief lightening talk (< 1 min - hard policed) on each document and then have a discussion on which categories and documents IPPM WG should consider for adoption.  In order to ease the "lightening talk" section - I've created a template https://docs.google.com/presentation/d/1P1Kp9mXA0eKkws78p1tldFn8zqx0YPQ5TK5fnq6Vyz4<https://eur03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdocs.google.com%2Fpresentation%2Fd%2F1P1Kp9mXA0eKkws78p1tldFn8zqx0YPQ5TK5fnq6Vyz4&data=02%7C01%7Cgbarak%40mellanox.com%7Ce5dbebbc0d904975a56008d6ad61feb4%7Ca652971c7d2e4d9ba6a4d149256f461b%7C0%7C0%7C636887033734786008&sdata=Z9B9WRh9BFgmR1opKRh%2FtwryPFcyZbHka5tsu7ImN0U%3D&reserved=0> - where each draft is listed with title and abstract. An author of each draft should present the key points of the drafts - as well as answer the question, whether IPPM should consider WG adoption.
If you're an author, please feel free to update the particular slide of your draft according to what you think is required.

·         IOAM tools (1min)

Thanks, Frank

Best,
Tommy

Hi Tommy,

Kind regards,
Greg

We've posted our draft agent for IETF 104 here:
https://datatracker.ietf.org/meeting/104/materials/agenda-104-ippm-00<https://eur03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fmeeting%2F104%2Fmaterials%2Fagenda-104-ippm-00&data=02%7C01%7Cgbarak%40mellanox.com%7Ce5dbebbc0d904975a56008d6ad61feb4%7Ca652971c7d2e4d9ba6a4d149256f461b%7C0%7C0%7C636887033734796018&sdata=DThZZ32IPQfSOv%2FZ%2Fer9HaAZOnl8YHe1mfYMWsjApA4%3D&reserved=0>

Best,
Tommy

_______________________________________________
ippm mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ippm<https://eur03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fippm&data=02%7C01%7Cgbarak%40mellanox.com%7Ce5dbebbc0d904975a56008d6ad61feb4%7Ca652971c7d2e4d9ba6a4d149256f461b%7C0%7C0%7C636887033734806018&sdata=VfoWRWPlyjVhVMe%2BlgS%2FISoT8M%2BYvXT3cC5G4ZSTs1w%3D&reserved=0>

---

From: Jai Kumar <[email-masked]>
Date: Wed, 20 Mar 2019 17:07:33 -0700

Barak,

Please take a look at the IFA draft ver 01.

https://datatracker.ietf.org/doc/draft-kumar-ippm-ifa/

You do not need to add a separate flag. Currently IOAM doesn’t take care of fragmentation (don’t know how it will work with large number of nodes in path or with constrained PMTU).

If you add fragmentation then post card mode becomes a degenerate case of fragmentation where each node generates the report aka post card.

Also as Haoyu pointed out earlier there is no method defined in IOAM for co-relation of post cards for a given flow. You will need packetID/FragID or something of that intent to reconstruct the flow path for the packet.

Regards,

-Jai

From: ippm <[email-masked]> on behalf of Barak Gafni <[email-masked]>
Date: Wednesday, March 20, 2019 at 4:39 PM
To: Haoyu song <[email-masked]>, "Frank Brockners (fbrockne)" <[email-masked]>, Tianran Zhou <[email-masked]>, Tommy Pauly <tpauly=[email-masked]>
Cc: IETF IPPM WG <[email-masked]>
Subject: Re: [ippm] Draft agenda for IETF 104

Hi Haoyu,

Thanks,

Barak

Hi Barak,

I think you are mentioning the PBT-I (The variation which requires an instruction header)?  Although PBT-I and E2E shares similarities but they have different semantics and usage, therefore some difference may be inevitable. I agree we can try to align the header formats which may benefit the implementation, but it seems to me these are two independent modes with each having its specific purpose. Maybe you also mean the same thing.. If you have any specific suggestions, please don’t hesitate to propose. Thank you very much!

Best regards,

Haoyu 

Hi Haoyu,

Thanks,

Barak

Hi Frank and Tommy,

Thanks for including our drafts! Please note we also request the IPPM WG adoption of this draft. This time we’d like to achieve rough consensus to make PBT-I a mode of IOAM (the name can be changed of course). This drafts also contains another option (PBT-M) which doesn’t need an instruction header. In this sense, we believe this draft can be developed in its own right. After it’s adopted, we’ll update it to make the alignment. Thanks!

Best regards,

Haoyu 

Haoyu,

Thanks – per my other email, I’ve added a new category “IOAM additional options” and also added draft-song-mpls-extension-header-02 to the set of encap options which are covered by a lightening talk.

Frank

Thanks!

Haoyu

Hi Tianran,

Thanks, Frank

Hi Frank and Tommy,

Best,

Tianran

Hi IPPM WG,

·         IOAM tools (1min)

Thanks, Frank

Best,

Tommy

Hi Tommy,

Kind regards,

Greg

On Tue, Mar 12, 2019 at 10:35 AM Tommy Pauly <tpauly=[email-masked]> wrote:

Hello IPPM,

Best,
Tommy

_______________________________________________ ippm mailing list [email-masked] https://www.ietf.org/mailman/listinfo/ippm

---

From: Barak Gafni <[email-masked]>
Date: Thu, 21 Mar 2019 00:21:14 +0000

Jai,
Thanks for the comments.
Please take a look at the new IPv4 options draft, where we did started the discussion about fragmentation, see https://tools.ietf.org/html/draft-gafni-ippm-ioam-ipv4-options-00#section-3.1.5. As a side note, this discussion for the same use case started in RFC 791 chapter 3.1, which we refer to as well. We should continue this discussion and enhance it, appreciate your comments.
For the flow tracking: There are implementations that don’t need this identifier, for them this marking should be enough. For the ones who need it, as part of the discussion on Immediate Export at 05 we suggested to use e2e which can include these indicators, and plan to extend this discussion in the next draft.

Thanks,
Barak

From: Jai Kumar <[email-masked]>
Sent: Wednesday, March 20, 2019 5:08 PM
To: Barak Gafni <[email-masked]>; Haoyu song <[email-masked]>; Frank Brockners (fbrockne) <[email-masked]>; Tianran Zhou <[email-masked]>; Tommy Pauly <tpauly=[email-masked]>
Cc: IETF IPPM WG <[email-masked]>
Subject: Re: [ippm] Draft agenda for IETF 104

Barak,

Please take a look at the IFA draft ver 01.
https://datatracker.ietf.org/doc/draft-kumar-ippm-ifa/<https://eur03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-kumar-ippm-ifa%2F&data=02%7C01%7Cgbarak%40mellanox.com%7Cbdb809a6dba045a9671a08d6ad913d00%7Ca652971c7d2e4d9ba6a4d149256f461b%7C0%7C0%7C636887236676327324&sdata=0dThk870RrTXTBR34KSUgs7zA6jCsXUYyJFrEBK3D9E%3D&reserved=0>

Regards,
-Jai

From: ippm <[email-masked]<mailto:[email-masked]>> on behalf of Barak Gafni <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, March 20, 2019 at 4:39 PM
To: Haoyu song <[email-masked]<mailto:[email-masked]>>, "Frank Brockners (fbrockne)" <[email-masked]<mailto:[email-masked]>>, Tianran Zhou <[email-masked]<mailto:[email-masked]>>, Tommy Pauly <tpauly=[email-masked]<mailto:tpauly=[email-masked]>>
Cc: IETF IPPM WG <[email-masked]<mailto:[email-masked]>>
Subject: Re: [ippm] Draft agenda for IETF 104

Hi Haoyu,

Thanks,
Barak

To: Barak Gafni <[email-masked]<mailto:[email-masked]>>; Frank Brockners (fbrockne) <[email-masked]<mailto:[email-masked]>>; Tianran Zhou <[email-masked]<mailto:[email-masked]>>; Tommy Pauly <tpauly=[email-masked]<mailto:tpauly=[email-masked]>>

Hi Barak,

Best regards,
Haoyu

Hi Haoyu,

Thanks,
Barak

Hi Frank and Tommy,

Best regards,
Haoyu

Haoyu,

See: https://docs.google.com/presentation/d/1P1Kp9mXA0eKkws78p1tldFn8zqx0YPQ5TK5fnq6Vyz4/<https://eur03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdocs.google.com%2Fpresentation%2Fd%2F1P1Kp9mXA0eKkws78p1tldFn8zqx0YPQ5TK5fnq6Vyz4%2F&data=02%7C01%7Cgbarak%40mellanox.com%7Cbdb809a6dba045a9671a08d6ad913d00%7Ca652971c7d2e4d9ba6a4d149256f461b%7C0%7C0%7C636887236676337329&sdata=1LTz5Yq4ifpd7NYjRyBkn0szAQbYWEjq2U5gnH0a68E%3D&reserved=0>

Frank

We also have another draft https://tools.ietf.org/html/draft-song-mpls-extension-header-02<https://eur03.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-song-mpls-extension-header-02&data=02%7C01%7Cgbarak%40mellanox.com%7Cbdb809a6dba045a9671a08d6ad913d00%7Ca652971c7d2e4d9ba6a4d149256f461b%7C0%7C0%7C636887236676347338&sdata=mqMuHhSCpEZQNWp21gmu1FkUFO3%2BYXGPBIbLVGXEdTc%3D&reserved=0> for IOAM encapsulation in MPLS networks. We can also use 1 min 1 slide to mention it.
Thanks!

Haoyu

Hi Tianran,

Thanks, Frank

Hi Frank and Tommy,

I just want to know where the draft-song-ippm-postcard-based-telemetry-02 fit into the agenda?
https://datatracker.ietf.org/doc/draft-song-ippm-postcard-based-telemetry/<https://eur03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-song-ippm-postcard-based-telemetry%2F&data=02%7C01%7Cgbarak%40mellanox.com%7Cbdb809a6dba045a9671a08d6ad913d00%7Ca652971c7d2e4d9ba6a4d149256f461b%7C0%7C0%7C636887236676347338&sdata=AmT33401XjultbFX%2BqcgCO3ky6htkVUf%2BjzbBAkea40%3D&reserved=0>
Personally, I want to be included in the IOAM slot.

Best,
Tianran

Hi IPPM WG,

Given that we have a pretty large set of IOAM related individual drafts (currently 13 drafts, if I counted things correctly), I suggest that we do a very brief lightening talk (< 1 min – hard policed) on each document and then have a discussion on which categories and documents IPPM WG should consider for adoption.  In order to ease the “lightening talk” section – I’ve created a template https://docs.google.com/presentation/d/1P1Kp9mXA0eKkws78p1tldFn8zqx0YPQ5TK5fnq6Vyz4<https://eur03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdocs.google.com%2Fpresentation%2Fd%2F1P1Kp9mXA0eKkws78p1tldFn8zqx0YPQ5TK5fnq6Vyz4&data=02%7C01%7Cgbarak%40mellanox.com%7Cbdb809a6dba045a9671a08d6ad913d00%7Ca652971c7d2e4d9ba6a4d149256f461b%7C0%7C0%7C636887236676357347&sdata=QOrgP0Ojg%2Bx8UPctRa%2FpIRgIZV6j1B3IwWAFQg%2BIDhI%3D&reserved=0> - where each draft is listed with title and abstract. An author of each draft should present the key points of the drafts – as well as answer the question, whether IPPM should consider WG adoption.
If you’re an author, please feel free to update the particular slide of your draft according to what you think is required.

·         IOAM tools (1min)

Thanks, Frank

Best,
Tommy

Hi Tommy,

Kind regards,
Greg

We've posted our draft agent for IETF 104 here:
https://datatracker.ietf.org/meeting/104/materials/agenda-104-ippm-00<https://eur03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fmeeting%2F104%2Fmaterials%2Fagenda-104-ippm-00&data=02%7C01%7Cgbarak%40mellanox.com%7Cbdb809a6dba045a9671a08d6ad913d00%7Ca652971c7d2e4d9ba6a4d149256f461b%7C0%7C0%7C636887236676357347&sdata=qEuvsnGNcnyRMwd%2F3tLt7RrLJN8UvE%2FgfB99Be97Dg4%3D&reserved=0>

Best,
Tommy

_______________________________________________
ippm mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ippm<https://eur03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fippm&data=02%7C01%7Cgbarak%40mellanox.com%7Cbdb809a6dba045a9671a08d6ad913d00%7Ca652971c7d2e4d9ba6a4d149256f461b%7C0%7C0%7C636887236676367352&sdata=fupsOOFFHTrHtFWW8lKsKdsONuGyoCjPhTGBFEm0yxY%3D&reserved=0>

_______________________________________________ ippm mailing list [email-masked]<mailto:[email-masked]> https://www.ietf.org/mailman/listinfo/ippm

---

From: Jai Kumar <[email-masked]>
Date: Wed, 20 Mar 2019 19:43:14 -0700

Thanks Barak,

But this is what is my issue or customers complain is with IOAM. Each case is handled on a case by case basis. What happens to IPSec or other packets where inserting options is not an option. How would it work in IPv6 or SR and so on.

My apologies but right the whole slew of IOAM drafts looks like a PhD thesis.

Regards,
-Jai

> On Mar 20, 2019, at 5:21 PM, Barak Gafni <[email-masked]> wrote:
> 
> Jai,
> Thanks for the comments.

---

From: "Shwetha Bhandari (shwethab)" <[email-masked]>
Date: Thu, 21 Mar 2019 05:16:09 +0000

Jai,
> My apologies but right the whole slew of IOAM drafts looks like a PhD thesis.
If you are finding navigating through the IOAM drafts challenging, we can help with that.
Many of us will be in Prague please feel free to reach out and we can meet.

The idea of breaking this into data, encapsulations, export and everything else is to help operators focus only on what interests the specific deployments.
As we have discussed in person at IETF103 too, IFA could use the IOAM data and decide to carry it else where in the packet.
No one is expected to implement and deploy all encapsulations.

Thanks,
Shwetha

From: ippm <[email-masked]> on behalf of Jai Kumar <jai.kumar=[email-masked]>
Date: Thursday, March 21, 2019 at 8:13 AM
To: Barak Gafni <[email-masked]>
Cc: IETF IPPM WG <[email-masked]>, Tommy Pauly <tpauly=[email-masked]>
Subject: Re: [ippm] Draft agenda for IETF 104

Thanks Barak,

Regards,
-Jai

On Mar 20, 2019, at 5:21 PM, Barak Gafni <[email-masked]<mailto:[email-masked]>> wrote:
Jai,
Thanks for the comments.
Please take a look at the new IPv4 options draft, where we did started the discussion about fragmentation, see https://tools.ietf.org/html/draft-gafni-ippm-ioam-ipv4-options-00#section-3.1.5. As a side note, this discussion for the same use case started in RFC 791 chapter 3.1, which we refer to as well. We should continue this discussion and enhance it, appreciate your comments.
For the flow tracking: There are implementations that don’t need this identifier, for them this marking should be enough. For the ones who need it, as part of the discussion on Immediate Export at 05 we suggested to use e2e which can include these indicators, and plan to extend this discussion in the next draft.

Thanks,
Barak

From: Jai Kumar <[email-masked]<mailto:[email-masked]>>
Sent: Wednesday, March 20, 2019 5:08 PM
To: Barak Gafni <[email-masked]<mailto:[email-masked]>>; Haoyu song <[email-masked]<mailto:[email-masked]>>; Frank Brockners (fbrockne) <[email-masked]<mailto:[email-masked]>>; Tianran Zhou <[email-masked]<mailto:[email-masked]>>; Tommy Pauly <tpauly=[email-masked]<mailto:tpauly=[email-masked]>>
Cc: IETF IPPM WG <[email-masked]<mailto:[email-masked]>>
Subject: Re: [ippm] Draft agenda for IETF 104

Barak,

Please take a look at the IFA draft ver 01.
https://datatracker.ietf.org/doc/draft-kumar-ippm-ifa/<https://eur03.safelinks.protection.outlook..com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-kumar-ippm-ifa%2F&data=02%7C01%7Cgbarak%40mellanox.com%7Cbdb809a6dba045a9671a08d6ad913d00%7Ca652971c7d2e4d9ba6a4d149256f461b%7C0%7C0%7C636887236676327324&sdata=0dThk870RrTXTBR34KSUgs7zA6jCsXUYyJFrEBK3D9E%3D&reserved=0>

Regards,
-Jai

Hi Haoyu,

Thanks,
Barak

Hi Barak,

Best regards,
Haoyu

Hi Haoyu,

Thanks,
Barak

Hi Frank and Tommy,

Best regards,
Haoyu

Haoyu,

Frank

We also have another draft https://tools.ietf.org/html/draft-song-mpls-extension-header-02<https://eur03.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-song-mpls-extension-header-02&data=02%7C01%7Cgbarak%40mellanox.com%7Cbdb809a6dba045a9671a08d6ad913d00%7Ca652971c7d2e4d9ba6a4d149256f461b%7C0%7C0%7C636887236676347338&sdata=mqMuHhSCpEZQNWp21gmu1FkUFO3%2BYXGPBIbLVGXEdTc%3D&reserved=0> for IOAM encapsulation in MPLS networks. We can also use 1 min 1 slide to mention it..
Thanks!

Haoyu

To: Tianran Zhou <[email-masked]<mailto:[email-masked]>>; Tommy Pauly <tpauly=[email-masked]<mailto:tpauly=[email-masked]>>

Hi Tianran,

Thanks, Frank

Hi Frank and Tommy,

Best,
Tianran

To: Tommy Pauly <tpauly=[email-masked]<mailto:tpauly=[email-masked]..org>>

Hi IPPM WG,

·         IOAM tools (1min)

Thanks, Frank

Best,
Tommy

Hi Tommy,

Kind regards,
Greg

Best,
Tommy

---

From: Jai Kumar <[email-masked]>
Date: Thu, 21 Mar 2019 09:03:45 -0700

Shwetha,

I propose to move IOAM metadata to something like https://datatracker.ietf.org/doc/html/draft-ietf-ippm-metric-registry-18

As the IOAM metadata is now evolved to use “global name spaces” or template IDs, I feel the name space itself should be standardized.

This will give silicon vendors to pick and choose what name spaces to support and to operators what name spaces makes most sense in the deployment.

If this separation is clean enough then this name space can be carried in IOAM protocol extensions, PBT post cards or IFA protocol header based on the operators requirements.

This also gives us as IPPM community to let each evolve in their own domain.

I would like to solicit opinion of IPPM WG on this. 

Regards,

-Jai

From: "Shwetha Bhandari (shwethab)" <[email-masked]>
Date: Wednesday, March 20, 2019 at 10:16 PM
To: Jai Kumar <[email-masked]>
Cc: IETF IPPM WG <[email-masked]>
Subject: Re: [ippm] Draft agenda for IETF 104

Jai,

Thanks,

Shwetha

Thanks Barak,

Regards,

-Jai

Jai,

Thanks for the comments.

Thanks,

Barak

Barak,

 

Regards,

-Jai

Hi Haoyu,

Thanks,

Barak

Hi Barak,

Best regards,

Haoyu 

Hi Haoyu,

Thanks,

Barak

Hi Frank and Tommy,

Best regards,

Haoyu 

Haoyu,

Frank

We also have another draft https://tools.ietf.org/html/draft-song-mpls-extension-header-02 for IOAM encapsulation in MPLS networks. We can also use 1 min 1 slide to mention it.. 

Thanks!

Haoyu

Hi Tianran,

Thanks, Frank

Hi Frank and Tommy,

Best,

Tianran

Hi IPPM WG,

·         IOAM tools (1min)

Thanks, Frank

Best,

Tommy

Hi Tommy,

Kind regards,

Greg

Hello IPPM,

Best,
Tommy

---

From: "Brian Trammell (IETF)" <[email-masked]>
Date: Sun, 24 Mar 2019 21:06:20 +0100

hi Frank, all,

Apologies that I'm just now getting to this...

> On 18 Mar 2019, at 11:14, Frank Brockners (fbrockne) <[email-masked]> wrote:
> 
> Hi Greg,
>  
> From what I understand, it is chair’s objective to address the question you raise below (i.e. what categories should IPPM WG consider for adoption?) as part of the planned WG discussion.

There's an action item still on the chairs' list post-Bangkok that we should follow up on this week -- figuring out one of the following three cases for each proposed encapsulation:

(1) Send the encapsulation draft to the relevant working group for the encapsulating protocol for adoption.

(2) Send the encapsulation draft to the a working group relevant to the area defining the encapsulating protocol, in case the encapsulating protocol does not have a most-relevant working group (RTGWG? INTAREA?)

(3) Adopt the encapsulating protocol in IPPM. For example, this is already clearly the correct thing to do for IPv6 encapsulation in an option, since 6man doesn't want to be in the business of defining options.

In cases 1 or 2, the document might come back to IPPM if the relevant WG is okay with it, but the discussion does need to have happened there first.

In cases where documents clearly require coordination with external standards organizations (Ethertype and Packet-Optical seem to be in this class), we need to liaise with the relevant organization before an adoption call can be made.

> In order to have a meaningful discussion – and given the fact that quite a few of the drafts are new/revised, it makes sense to get everyone on the same page, hence the superbrief lightening talks.

This seems reasonable, but during the meeting tomorrow morning, I'd like the discussion on encaps to focus on addressing the questions above. We need to be very clear on the answers before we can move to adopt any of them.

Cheers,

Brian (as co-chair IPPM)

> On Mon, Mar 18, 2019 at 10:28 AM Frank Brockners (fbrockne) <[email-masked]> wrote:
> Hi IPPM WG,
> 
>  
>