Subject: Re: [ippm] Merging deployment considerations into IPv6 IOAM document

From: Tommy Pauly <[email-masked]>
Date: Mon, 12 Oct 2020 09:17:24 -0700

Hi Frank,

I’ve provided some editorial suggestions here:

https://github.com/inband-oam/ietf/pull/198 <https://github.com/inband-oam/ietf/pull/198>

Also, we should clean up the long author list on this document:

https://github.com/inband-oam/ietf/issues/197 <https://github.com/inband-oam/ietf/issues/197>

Best,
Tommy

> On Sep 29, 2020, at 11:24 AM, Frank Brockners (fbrockne) <[email-masked]> wrote:
> 
> Hi Tommy,
> 
> Thanks for your feedback. Here's the git link:
> https://github.com/inband-oam/ietf/blob/master/drafts/draft-ietf-ippm-ioam-ipv6-options.xml
> Text version is here: https://github.com/inband-oam/ietf/blob/master/drafts/versions/03/draft-ietf-ippm-ioam-ipv6-options-03.txt
> 
> Looking forward to your comments.
> 
> Thanks, Frank
> 
>> -----Original Message-----
>> From: Tommy Pauly <[email-masked]>
>> Sent: Dienstag, 29. September 2020 20:19
>> To: Frank Brockners (fbrockne) <[email-masked]>
>> Cc: [email-masked]; draft-ioametal-ippm-6man-
>> [email-masked]; IPPM Chairs <[email-masked]>; Martin
>> Duke <[email-masked]>; IETF IPPM WG ([email-masked])
>> <[email-masked]>
>> Subject: Re: Merging deployment considerations into IPv6 IOAM document
>> 
>> Hi Frank, all,
>> 
>> Thanks for providing this update. The combined document makes sense and, I
>> believe, will provide a more useful resource to implementors.
>> 
>> Looking through the new text, I had a few textual/editorial nits. Is this available
>> on a GitHub for comments or a PR?
>> 
>> Thanks,
>> Tommy
>> 
>>> On Sep 18, 2020, at 1:56 AM, Frank Brockners (fbrockne)
>> <[email-masked]> wrote:
>>> 
>>> Hi Tommy, IPPM WG,
>>> 
>>> we just posted an updated draft-ietf-ippm-ioam-ipv6-options-03 which merges
>> draft-ioametal-ippm-6man-ioam-ipv6-deployment into draft-ietf-ippm-ioam-
>> ipv6-options plus it reflects the WG discussion of the last IPPM meeting.
>>> 
>>> The updates to draft-ietf-ippm-ioam-ipv6-options-03 are
>>> 
>>> * implement the guidance from the WG chairs: Merge in draft-ioametal-ippm-
>> 6man-ioam-ipv6-deployment "as is", i.e. only editorial changes were made (e.g.
>> resolve references which would have been circular).
>>> * implement the result of discussion in the last WG meeting: Removed the
>> paragraph that started with " In order for IOAM to work in IPv6 networks.."
>> which included deployment considerations.
>>> 
>>> Moving forward, we'll need to further evolve the deployment section (now
>> section 4).
>>> There were already comments raised in the IOAM DT wrt/ what is now section
>> 4.4.1 by Haoyu. I asked  Haoyu to take those to the IPPM list.
>>> 
>>> Cheers, Frank
>>> 
>>>> -----Original Message-----
>>>> From: Tommy Pauly <[email-masked]>
>>>> Sent: Freitag, 14. August 2020 23:12
>>>> To: [email-masked];
>>>> draft-ioametal-ippm-6man- [email-masked]
>>>> Cc: IPPM Chairs <[email-masked]>; Martin Duke
>>>> <[email-masked]>
>>>> Subject: Merging deployment considerations into IPv6 IOAM document
>>>> 
>>>> Hi IOAM IPv6 authors,
>>>> 
>>>> At IETF 108, we discussed draft-ietf-ippm-ioam-ipv6-options and
>>>> draft-ioametal- ippm-6man-ioam-ipv6-deployment, and how to progress
>>>> with the deployment considerations. Since the hums showed no strong
>>>> opinions one way or the other in the WG, Ian and I have discussed and
>>>> would prefer to see the deployment considerations merged into the existing
>> and adopted IPv6 options document.
>>>> Both documents are short, and readers will benefit from any
>>>> discussion of deployment being available in the same document that
>>>> defines the extension header.
>>>> 
>>>> Please post an update for draft-ietf-ippm-ioam-ipv6-options with this
>>>> content added when you have a chance!
>>>> 
>>>> Thanks,
>>>> Tommy

---

From: "Frank Brockners (fbrockne)" <[email-masked]>
Date: Mon, 12 Oct 2020 16:51:34 +0000

Hi Tommy,

Thanks much. The too long author list is a common – and not easily addressable issue as we all know.

Cheers, Frank

From: Tommy Pauly <[email-masked]>
Sent: Montag, 12. Oktober 2020 18:17
To: Frank Brockners (fbrockne) <[email-masked]>
Cc: [email-masked]; [email-masked]; IPPM Chairs <[email-masked]>; Martin Duke <[email-masked]>; IETF IPPM WG ([email-masked]) <[email-masked]>
Subject: Re: Merging deployment considerations into IPv6 IOAM document

Hi Frank,

https://github.com/inband-oam/ietf/pull/198

https://github.com/inband-oam/ietf/issues/197

Best,
Tommy

On Sep 29, 2020, at 11:24 AM, Frank Brockners (fbrockne) <[email-masked]<mailto:[email-masked]>> wrote:

Hi Tommy,

Thanks, Frank

-----Original Message-----
From: Tommy Pauly <[email-masked]<mailto:[email-masked]>>
Sent: Dienstag, 29. September 2020 20:19
To: Frank Brockners (fbrockne) <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>; draft-ioametal-ippm-6man-
[email-masked]<mailto:[email-masked]>; IPPM Chairs <[email-masked]<mailto:[email-masked]>>; Martin
Duke <[email-masked]<mailto:[email-masked]>>; IETF IPPM WG ([email-masked]<mailto:[email-masked]>)
<[email-masked]<mailto:[email-masked]>>
Subject: Re: Merging deployment considerations into IPv6 IOAM document

Hi Frank, all,

Thanks,
Tommy

On Sep 18, 2020, at 1:56 AM, Frank Brockners (fbrockne)
<[email-masked]<mailto:[email-masked]>> wrote:

Hi Tommy, IPPM WG,

Cheers, Frank

-----Original Message-----
From: Tommy Pauly <[email-masked]<mailto:[email-masked]>>
Sent: Freitag, 14. August 2020 23:12
To: [email-masked]<mailto:[email-masked]>;
draft-ioametal-ippm-6man- [email-masked]<mailto:[email-masked]>
Cc: IPPM Chairs <[email-masked]<mailto:[email-masked]>>; Martin Duke
<[email-masked]<mailto:[email-masked]>>
Subject: Merging deployment considerations into IPv6 IOAM document

Hi IOAM IPv6 authors,

Thanks,
Tommy

---

From: Tommy Pauly <[email-masked]>
Date: Fri, 30 Oct 2020 15:24:27 -0700

Hi Frank, authors,

I’d strongly suggest going down the same route we did for the IOAM data draft, which was to have an editor model with all authors listed out separately. That allows us to have a document that both recognizes input and meets the submission guidelines. 

Best,
Tommy

> On Oct 12, 2020, at 9:51 AM, Frank Brockners (fbrockne) <[email-masked]> wrote:
> 
> 
> Hi Tommy,
>