Subject: [ippm] New Version for draft-wang-ippm-stamp-hbh-extensions-01

From: wangyali <[email-masked]>
Date: Tue, 27 Oct 2020 13:48:33 +0000

Hello WG,

Draft about extensions to STAMP enable hop-by-hop OAM data measurement and collection has been updated, which was presented in IETF108. Questions and comments are welcome.

Because the performance of intermediate nodes and links that STAMP test packets traverse are invisible, to solve this problem, this draft extents optional TLVs to STAMP and inserts IOAM Trace option data in the test packets or dispatches test packets to the OAM process at OAM Endpoint.  

In this case, the STAMP instance does not need to be configured at every intermediate node to measure the performance of intermediate nodes, which decreases the complexity of OAM in large-scale networks.

What do you think? 

Best regards,
Yali

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Tuesday, October 27, 2020 9:03 PM
To: wangyali <[email-masked]>; Tianran Zhou <[email-masked]>
Subject: New Version Notification for draft-wang-ippm-stamp-hbh-extensions-01.txt

A new version of I-D, draft-wang-ippm-stamp-hbh-extensions-01.txt
has been successfully submitted by Yali Wang and posted to the IETF repository.

Name:		draft-wang-ippm-stamp-hbh-extensions
Revision:	01
Title:		Simple Two-way Active Measurement Protocol Extensions for Hop-by-Hop OAM Data Collection
Document date:	2020-10-27
Group:		Individual Submission
Pages:		10
URL:            https://www.ietf.org/archive/id/draft-wang-ippm-stamp-hbh-extensions-01.txt
Status:         https://datatracker.ietf.org/doc/draft-wang-ippm-stamp-hbh-extensions/
Htmlized:       https://datatracker.ietf.org/doc/html/draft-wang-ippm-stamp-hbh-extensions
Htmlized:       https://tools.ietf.org/html/draft-wang-ippm-stamp-hbh-extensions-01
Diff:           https://www.ietf.org/rfcdiff?url2=draft-wang-ippm-stamp-hbh-extensions-01

Abstract:
   This document defines optional TLVs which are carried in Simple Two-
   way Active Measurement Protocol (STAMP) test packets to enhance the
   STAMP base functions.  Such extensions to STAMP enable OAM data
   measurement and collection at every node and link along a STAMP test
   packet's delivery path.

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: yanghongwei <[email-masked]>
Date: Fri, 30 Oct 2020 10:32:17 +0800

Hi Yali,

I think this is a useful solution. Hop-by-hop network measurement is very necessary in many scenarios. 
I have a few questions.
1. Why is it combined with OAM packets and how to deal with devices that do not support OAM?
2. Latency, jitter, and packet loss are mentioned in the document, but link bandwidth utilization is also an important indicator. Can it also be implemented in this solution?

Thanks and Best Regards,
Hongwei.

Hongwei Yang
 
From: wangyali
Date: 2020-10-27 21:48
To: ippm
Subject: [ippm] New Version for draft-wang-ippm-stamp-hbh-extensions-01
Hello WG,

 
 
What do you think?
 
Best regards,
Yali

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Tuesday, October 27, 2020 9:03 PM
To: wangyali <[email-masked]>; Tianran Zhou <[email-masked]>
Subject: New Version Notification for draft-wang-ippm-stamp-hbh-extensions-01.txt

 
Abstract:

 
The IETF Secretariat

_______________________________________________
ippm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ippm

---

From: wangyali <[email-masked]>
Date: Fri, 30 Oct 2020 08:22:01 +0000

Hi Hongwei,

Thanks for your questions and comments. Please see inline [Yali].

From: yanghongwei [mailto:[email-masked]]
Sent: Friday, October 30, 2020 10:32 AM
To: wangyali <[email-masked]>; ippm <[email-masked]>
Subject: Re: [ippm] New Version for draft-wang-ippm-stamp-hbh-extensions-01

Hi Yali,

I think this is a useful solution. Hop-by-hop network measurement is very necessary in many scenarios.
I have a few questions.
1. Why is it combined with OAM packets and how to deal with devices that do not support OAM?
[Yali] Good question. In this draft, we propose two kinds of way to measure and collect metrics per node or link. One kind of the way is taking advantage of IOAM-Trace-Type or extending IPv6 Hop-by-Hop Options header encoded in the STAMP test packets, which are examined and processed in Fast Path. Another way we proposed in this draft is timestamping and punting packet to control plane and recorded in Forward or Backward HbH Delay TLVs.

2. Latency, jitter, and packet loss are mentioned in the document, but link bandwidth utilization is also an important indicator. Can it also be implemented in this solution?
[Yali] Yes. I agree with your vision. I have a suggestion of extending a Link Bandwidth Utilization TLV in this draft. What do you think? I hope you would agree to join in the work on this draft. I'd be glad to welcome you as a co-author.

Thanks and Best Regards,
Hongwei.

________________________________
Hongwei Yang

From: wangyali<mailto:[email-masked]>
Date: 2020-10-27 21:48
To: ippm<mailto:[email-masked]>
Subject: [ippm] New Version for draft-wang-ippm-stamp-hbh-extensions-01
Hello WG,

What do you think?

Best regards,
Yali

-----Original Message-----
From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]]
Sent: Tuesday, October 27, 2020 9:03 PM
To: wangyali <[email-masked]<mailto:[email-masked]>>; Tianran Zhou <[email-masked]<mailto:[email-masked]>>
Subject: New Version Notification for draft-wang-ippm-stamp-hbh-extensions-01.txt

Abstract:

The IETF Secretariat

_______________________________________________
ippm mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ippm