Subject: Re: [ippm] Request for WG adoption: Marking-based PBT

From: Haoyu Song <[email-masked]>
Date: Thu, 15 Oct 2020 20:23:34 +0000

Hi Tommy and DEX authors/editor,

The original PBT draft contains two related but different approaches. PBT-I evolves into IOAM DEX, while PBT-M is left out. PBT-M needs to deal with different issues (e.g., where to set the trigger and how to correlate the export data).

Since you suggest “anything related to Direct Export should be folded into draft-ietf-ippm-ioam-direct-export”, I would ask the authors/editor of the DEX draft to examine the case and see if it’s possible. As an author of the DEX draft myself I have no problem of that and I can prepare the text to merge. If the editor/other authors believe it’s better to keep the current DEX draft as is, I would continue to push this as a standalone draft. Please the IPPM chairs and DEX editor provide a response on this issue .

I believe the approach has its value. The SRv6 OAM has adopted the approach but we need to hammer out the details to make it a general approach, just like IOAM, DEX which can be applied in different types of networks.

Best regards,
Haoyu

From: Tommy Pauly <[email-masked]>
Sent: Monday, July 13, 2020 12:59 PM
To: Haoyu Song <[email-masked]>
Cc: ippm-chairs <[email-masked]>; [email-masked]; IETF IPPM WG ([email-masked]) <[email-masked]>
Subject: Re: [ippm] Request for WG adoption: Marking-based PBT

Hello Haoyu,

The WG discussion at our last meeting, the chairs provided guidance that anything related to Direct Export should be folded into draft-ietf-ippm-ioam-direct-export, but we do not see the need to adopt this as a separate document.

Minutes are here:
https://datatracker.ietf.org/doc/minutes-interim-2020-ippm-01-202004010800/<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fminutes-interim-2020-ippm-01-202004010800%2F&data=02%7C01%7Chaoyu.song%40futurewei.com%7Cf4f53ec9d3f945b0fd9608d82767430e%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637302671749654638&sdata=XlvVra6aPRS0GRN4ykn7XlBM3UPsjMv1SuO%2F8t0OJaM%3D&reserved=0>

We will not be issuing an adoption call for this at this time, based on the previous discussions.

Thanks,
Tommy

On Jul 13, 2020, at 10:50 AM, Haoyu Song <[email-masked]<mailto:[email-masked]>> wrote:

https://datatracker.ietf.org/doc/draft-song-ippm-postcard-based-telemetry/<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-song-ippm-postcard-based-telemetry%2F&data=02%7C01%7Chaoyu.song%40futurewei.com%7Cf4f53ec9d3f945b0fd9608d82767430e%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637302671749664541&sdata=%2BghHqd5d5y1BrPbvlToyoEUAhxNqGzCWFzXjCgUgnWQ%3D&reserved=0>

Dear IPPM Chairs,

After the WG discussion in last meeting, the above draft has been truncated to only include the marking-based PBT. The instruction-based PBT has been merged into the WG document IOAM DEX a while ago.
Since IOAM data draft is in its WGLC, we think it’s time to request the WG adoption for this draft for the following reasons:
1)     It has been discussed a lot in WG email list and meetings.
2)     Just like IOAM trace, IOAM DEX, and HTS, PBT-M merits to be an independent approach for network telemetry.
3)     The approach has been used in SRv6 OAM (the draft is currently in WGLC at 6man)  in which o-bit is used as a data collection trigger.
4)     Just like the IOAM data draft, we need a PBT-M draft to specify the related details so that it can be universally apply to each application scenario.
5)     Since the approach is closely related to other works in IPPM, we think it’s better to coordinate the work in WG as early as possible.
Therefore, we request the IPPM to adopt the draft. Thank you very much for your consideration!

Best regards,
Haoyu Song

_______________________________________________
ippm mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ippm<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fippm&data=02%7C01%7Chaoyu.song%40futurewei.com%7Cf4f53ec9d3f945b0fd9608d82767430e%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637302671749664541&sdata=zsEJqPJz3h88xJtUDkkkN4lKch63iyZ39MuZFhfMZyI%3D&reserved=0>

---

From: Ian Swett <[email-masked]>
Date: Thu, 15 Oct 2020 16:31:45 -0400

Haoyu,

Given that, per Tommy's email, I believe the updated draft needs to
have sufficient interest on the list to be considered for adoption.

I'd suggest starting a separate thread about the updated draft to solicit
feedback and ask for interest.

Thanks, Ian

On Thu, Oct 15, 2020 at 4:23 PM Haoyu Song <[email-masked]> wrote:

> The original PBT draft contains two related but different approaches.
> PBT-I evolves into IOAM DEX, while PBT-M is left out. PBT-M needs to deal
> with different issues (e.g., where to set the trigger and how to correlate
> the export data).
>
>
>
> Since you suggest “anything related to Direct Export should be folded into
> draft-ietf-ippm-ioam-direct-export”, I would ask the authors/editor of the
> DEX draft to examine the case and see if it’s possible. As an author of the
> DEX draft myself I have no problem of that and I can prepare the text to
> merge. If the editor/other authors believe it’s better to keep the current
> DEX draft as is, I would continue to push this as a standalone draft.
> Please the IPPM chairs and DEX editor provide a response on this issue .
>
>
>
> I believe the approach has its value. The SRv6 OAM has adopted the
> approach but we need to hammer out the details to make it a general
> approach, just like IOAM, DEX which can be applied in different types of
> networks.
>
>
>
> Best regards,
>
> Haoyu
>
>
>
> *From:* Tommy Pauly <[email-masked]>
> *Sent:* Monday, July 13, 2020 12:59 PM
> *To:* Haoyu Song <[email-masked]>
> *Cc:* ippm-chairs <[email-masked]>;
> [email-masked]; IETF IPPM WG (
> [email-masked]) <[email-masked]>
> *Subject:* Re: [ippm] Request for WG adoption: Marking-based PBT
>
>
>
> Hello Haoyu,
>
>
>
> The WG discussion at our last meeting, the chairs provided guidance that
> anything related to Direct Export should be folded into
> draft-ietf-ippm-ioam-direct-export, but we do not see the need to adopt
> this as a separate document.
>
>
>
> Minutes are here:
>
> https://datatracker.ietf.org/doc/minutes-interim-2020-ippm-01-202004010800/
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fminutes-interim-2020-ippm-01-202004010800%2F&data=02%7C01%7Chaoyu.song%40futurewei.com%7Cf4f53ec9d3f945b0fd9608d82767430e%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637302671749654638&sdata=XlvVra6aPRS0GRN4ykn7XlBM3UPsjMv1SuO%2F8t0OJaM%3D&reserved=0>
>
>
>
> On Jul 13, 2020, at 10:50 AM, Haoyu Song <[email-masked]> wrote:
>
>
>
> https://datatracker.ietf.org/doc/draft-song-ippm-postcard-based-telemetry/
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-song-ippm-postcard-based-telemetry%2F&data=02%7C01%7Chaoyu.song%40futurewei.com%7Cf4f53ec9d3f945b0fd9608d82767430e%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637302671749664541&sdata=%2BghHqd5d5y1BrPbvlToyoEUAhxNqGzCWFzXjCgUgnWQ%3D&reserved=0>
>
>
>
>
> Dear IPPM Chairs,
>
>
>
> After the WG discussion in last meeting, the above draft has been
> truncated to only include the marking-based PBT. The instruction-based PBT
> has been merged into the WG document IOAM DEX a while ago.
>
> Since IOAM data draft is in its WGLC, we think it’s time to request the WG
> adoption for this draft for the following reasons:
>
> 2)     Just like IOAM trace, IOAM DEX, and HTS, PBT-M merits to be an
> independent approach for network telemetry.
>
> 3)     The approach has been used in SRv6 OAM (the draft is currently in
> WGLC at 6man)  in which o-bit is used as a data collection trigger.
>
> 4)     Just like the IOAM data draft, we need a PBT-M draft to specify
> the related details so that it can be universally apply to each application
> scenario.
>
> 5)     Since the approach is closely related to other works in IPPM, we
> think it’s better to coordinate the work in WG as early as possible.
>
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ippm
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fippm&data=02%7C01%7Chaoyu.song%40futurewei.com%7Cf4f53ec9d3f945b0fd9608d82767430e%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637302671749664541&sdata=zsEJqPJz3h88xJtUDkkkN4lKch63iyZ39MuZFhfMZyI%3D&reserved=0>
>
>
>

---

From: Haoyu Song <[email-masked]>
Date: Thu, 15 Oct 2020 20:37:35 +0000

Ian,

Sound good. Will do. Thanks!

Best regards,
Haoyu

From: Ian Swett <[email-masked]>
Sent: Thursday, October 15, 2020 1:32 PM
To: Haoyu Song <[email-masked]>
Cc: Tommy Pauly <[email-masked]>; [email-masked]; ippm-chairs <[email-masked]>; [email-masked]; IETF IPPM WG ([email-masked]) <[email-masked]>
Subject: Re: [ippm] Request for WG adoption: Marking-based PBT

Haoyu,

Given that, per Tommy's email, I believe the updated draft needs to have sufficient interest on the list to be considered for adoption.

I'd suggest starting a separate thread about the updated draft to solicit feedback and ask for interest.

Thanks, Ian

On Thu, Oct 15, 2020 at 4:23 PM Haoyu Song <[email-masked]<mailto:[email-masked]>> wrote:
Hi Tommy and DEX authors/editor,

Best regards,
Haoyu

From: Tommy Pauly <[email-masked]<mailto:[email-masked]>>
Sent: Monday, July 13, 2020 12:59 PM
To: Haoyu Song <[email-masked]<mailto:[email-masked]>>
Cc: ippm-chairs <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; IETF IPPM WG ([email-masked]<mailto:[email-masked]>) <[email-masked]<mailto:[email-masked]>>
Subject: Re: [ippm] Request for WG adoption: Marking-based PBT

Hello Haoyu,

Minutes are here:
https://datatracker.ietf.org/doc/minutes-interim-2020-ippm-01-202004010800/<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fminutes-interim-2020-ippm-01-202004010800%2F&data=04%7C01%7Chaoyu.song%40futurewei.com%7C772249ec538540d7329308d871495d25%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637383907217468042%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=URvHqIIdccKXyIKtLEh1sgLQcTehLlKe5EaS%2Bk6%2BgJo%3D&reserved=0>

Thanks,
Tommy

https://datatracker.ietf.org/doc/draft-song-ippm-postcard-based-telemetry/<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-song-ippm-postcard-based-telemetry%2F&data=04%7C01%7Chaoyu.song%40futurewei.com%7C772249ec538540d7329308d871495d25%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637383907217478036%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=DnITt60sguZmBCo0QTBbD9TjMzOykXPbzrWy9XjLUD4%3D&reserved=0>

Dear IPPM Chairs,

Best regards,
Haoyu Song

_______________________________________________
ippm mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ippm<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fippm&data=04%7C01%7Chaoyu.song%40futurewei.com%7C772249ec538540d7329308d871495d25%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637383907217488037%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=dDbSvfJM4bGJx3sk3Hh%2Fcp%2FnQvC6Guy7V2E93pwHiLQ%3D&reserved=0>