Subject: Re: [ippm] New version about Performance Measurement on LAG

From: Tal Mizrahi <[email-masked]>
Date: Wed, 21 Oct 2020 10:35:14 +0300

Hi Authors,

Thanks for posting this new draft.
I believe it is definitely worth discussing in the IPPM working group.

A couple of comments and questions:
- It would be worth clarifying at the beginning that the scope of this
draft is a measurement that is performed between two adjacent IEEE
802.1 bridges that are connected by a LAG. A small diagram may be very
helpful.
- More discussion is needed in the draft about how the <Member Link
ID> field in the packets is correlated with the local link through
which the packet was received. How does the session sender know the
link ID of the session reflector? Is it pre-configured?

Cheers,
Tal.

On Wed, Jul 15, 2020 at 6:48 PM [email-masked]
<[email-masked]> wrote:
>
> Hello All,
>
> Please review and comment the doc which defines extensions to OWAMP, TWAMP and STAMP to implement performance measurement on every member link of a Link Aggregation Group (LAG).  With the measured metrics of each member links of a LAG, it enables operators to enforce performance metric based traffic steering policy among the member links.
>
> URL: https://www.ietf.org/internet-drafts/draft-li-ippm-pm-on-lag-01.txt
> Status: https://datatracker.ietf.org/doc/draft-li-ippm-pm-on-lag/
> Htmlized: https://tools.ietf.org/html/draft-li-ippm-pm-on-lag-01
> Htmlized: https://datatracker.ietf.org/doc/html/draft-li-ippm-pm-on-lag
>
> Best Regards,
> Zhenqiang Li
> ________________________________
> [email-masked]
> _______________________________________________
> ippm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ippm

---

From: Mach Chen <[email-masked]>
Date: Tue, 27 Oct 2020 02:03:49 +0000

Hi Tal,

Thanks for reviewing the draft and the value comments!

Some responses inline ...

> -----Original Message-----
> From: ippm [mailto:[email-masked]] On Behalf Of Tal Mizrahi
> Sent: Wednesday, October 21, 2020 3:35 PM
> To: [email-masked]
> Cc: ippm <[email-masked]>
> Subject: Re: [ippm] New version about Performance Measurement on LAG
> 
> Hi Authors,
> 

Thanks.

> - It would be worth clarifying at the beginning that the scope of this draft is a
> measurement that is performed between two adjacent IEEE
> 802.1 bridges that are connected by a LAG. A small diagram may be very helpful.

OK, will do that.

> which the packet was received. How does the session sender know the link ID of
> the session reflector? Is it pre-configured?

For now, it assumes that reflector member link id is pre-configured. There may be other ways that can be used to learn the ID dynamically, for example, using the first Test packet to learn it. 

Best regards,
Mach

> > Please review and comment the doc which defines extensions to OWAMP,
> TWAMP and STAMP to implement performance measurement on every member
> link of a Link Aggregation Group (LAG).  With the measured metrics of each
> member links of a LAG, it enables operators to enforce performance metric
> based traffic steering policy among the member links.
> >
> > URL:
> > https://www.ietf.org/internet-drafts/draft-li-ippm-pm-on-lag-01.txt
> > Htmlized:
> > https://datatracker.ietf.org/doc/html/draft-li-ippm-pm-on-lag
> >
> > Best Regards,
> > Zhenqiang Li