Subject: [ippm] Request for WG adoption

From: Haoyu Song <[email-masked]>
Date: Wed, 30 Jun 2021 17:59:58 +0000

Dear IPPM Chairs,

I'm writing to request the IPPM WG to adopt the following draft "Postcard-based On-Path Flow Data Telemetry using Packet Marking"
https://datatracker.ietf.org/doc/draft-song-ippm-postcard-based-telemetry/

Now the draft is in -09 version and we have colleagues from Cisco, ZTE, Huawei as well as some network operators to coauthor this work.
As another on-path telemetry technique, PBT based on packet marking complements the other works such as IOAM, DEX, and HTS to make the ecosystem complete, and I believe each can find its application scenarios. For example, the PBT based on packet marking has been applied in "draft-ietf-6man-spring-srv6-oam" (https://datatracker.ietf.org/doc/html/draft-ietf-6man-spring-srv6-oam) which I believe has passed the last call, but the detailed mechanisms such as configuration, data format, and export method are not covered there. Given the technique is equally applicable to other types of networks, we believe it's necessary to have a  document to formalized the method.

The draft has undergone a long line of developments since it was published in 2018. It originally covers two related but different techniques. One was latter stripped off to form an independent draft, IOAM DEX, which has been adopted by IPPM. The remaining one, PBT based on packet marking, is the core of the current draft. Thanks for the numerous discussions and feedbacks from the WG, we now have a draft with focused direction and relatively mature content.

Given the community interest and the technical merit, we now request the WG to adopt the draft and engage the WG to work on it.
Please let us know if there are any concerns, comments, and suggestions.   Thank you very much for your consideration!

Best regards,
Haoyu

---

From: Tianran Zhou <[email-masked]>
Date: Thu, 1 Jul 2021 01:42:37 +0000

I support the WG to consider adoption of this draft.

Tianran

From: ippm [mailto:[email-masked]] On Behalf Of Haoyu Song
Sent: Thursday, July 1, 2021 2:00 AM
To: IPPM Chairs <[email-masked]>; IETF IPPM WG <[email-masked]>
Cc: [email-masked]
Subject: [ippm] Request for WG adoption

Dear IPPM Chairs,

Best regards,
Haoyu