Subject: Re: [ippm] Request for WG adoption

From: Tommy Pauly <[email-masked]>
Date: Thu, 01 Jul 2021 09:57:54 -0700

Hi Haoyu,

Thanks for bringing this up again. As we’ve discussed in several previous meetings, this seems to be mainly a high-level description of work that is already concrete in IOAM, DEX, etc. As such, I am inclined to say that its content should be in other drafts (as has been done).

Any adoption call would need to be predicated on more list discussion of the content.

Best,
Tommy

> On Jun 30, 2021, at 10:59 AM, Haoyu Song <[email-masked]> wrote:
> 
> Dear IPPM Chairs,
>  
> I’m writing to request the IPPM WG to adopt the following draft “Postcard-based On-Path Flow Data Telemetry using Packet Marking”
> https://datatracker.ietf.org/doc/draft-song-ippm-postcard-based-telemetry/ <https://datatracker.ietf.org/doc/draft-song-ippm-postcard-based-telemetry/>
>  
> Now the draft is in -09 version and we have colleagues from Cisco, ZTE, Huawei as well as some network operators to coauthor this work.
> As another on-path telemetry technique, PBT based on packet marking complements the other works such as IOAM, DEX, and HTS to make the ecosystem complete, and I believe each can find its application scenarios. For example, the PBT based on packet marking has been applied in “draft-ietf-6man-spring-srv6-oam” (https://datatracker.ietf.org/doc/html/draft-ietf-6man-spring-srv6-oam <https://datatracker.ietf.org/doc/html/draft-ietf-6man-spring-srv6-oam>) which I believe has passed the last call, but the detailed mechanisms such as configuration, data format, and export method are not covered there. Given the technique is equally applicable to other types of networks, we believe it’s necessary to have a  document to formalized the method.
>  
> The draft has undergone a long line of developments since it was published in 2018. It originally covers two related but different techniques. One was latter stripped off to form an independent draft, IOAM DEX, which has been adopted by IPPM. The remaining one, PBT based on packet marking, is the core of the current draft. Thanks for the numerous discussions and feedbacks from the WG, we now have a draft with focused direction and relatively mature content.
>  
> Given the community interest and the technical merit, we now request the WG to adopt the draft and engage the WG to work on it.
> Please let us know if there are any concerns, comments, and suggestions.   Thank you very much for your consideration!  
>  
> Best regards,
> Haoyu

---

From: Haoyu Song <[email-masked]>
Date: Thu, 1 Jul 2021 17:34:01 +0000

Hi Tommy,

I think here I need to give some clarification. One the one hand, the draft indeed provides some descriptions to summarize the high level ideas of the related proposals (under the on-path telemetry), but this is not the core of the draft but to help understand the field and it can be removed if considered improper in such a draft. On the other hand, the core of the draft is about the approach to use some flag to trigger the telemetry data collection. In this sense, it's an independent proposal along with IOAM, DEX, and HTS. I believe they are equally important and needed to complete the ecosystem for on-path telemetry.

I would also like to take this chance to seek more feedback from the WG and to see the level of interest and support on this work. Thanks!

Best regards,
Haoyu

From: Tommy Pauly <[email-masked]>
Sent: Thursday, July 1, 2021 9:58 AM
To: Haoyu Song <[email-masked]>
Cc: IPPM Chairs <[email-masked]>; IETF IPPM WG <[email-masked]>; [email-masked]
Subject: Re: Request for WG adoption

Hi Haoyu,

Thanks for bringing this up again. As we've discussed in several previous meetings, this seems to be mainly a high-level description of work that is already concrete in IOAM, DEX, etc. As such, I am inclined to say that its content should be in other drafts (as has been done).

Best,
Tommy

On Jun 30, 2021, at 10:59 AM, Haoyu Song <[email-masked]<mailto:[email-masked]>> wrote:

Dear IPPM Chairs,

I'm writing to request the IPPM WG to adopt the following draft "Postcard-based On-Path Flow Data Telemetry using Packet Marking"
https://datatracker.ietf.org/doc/draft-song-ippm-postcard-based-telemetry/<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-song-ippm-postcard-based-telemetry%2F&data=04%7C01%7Chaoyu.song%40futurewei.com%7C4cae751d53a845bc600a08d93cb15fdb%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637607554783193667%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=%2FA57w%2FrWm3TXoEvBCcHT2IPQQJi%2BrcgQwlTvs18EX48%3D&reserved=0>

Now the draft is in -09 version and we have colleagues from Cisco, ZTE, Huawei as well as some network operators to coauthor this work.
As another on-path telemetry technique, PBT based on packet marking complements the other works such as IOAM, DEX, and HTS to make the ecosystem complete, and I believe each can find its application scenarios. For example, the PBT based on packet marking has been applied in "draft-ietf-6man-spring-srv6-oam" (https://datatracker.ietf.org/doc/html/draft-ietf-6man-spring-srv6-oam<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-ietf-6man-spring-srv6-oam&data=04%7C01%7Chaoyu.song%40futurewei.com%7C4cae751d53a845bc600a08d93cb15fdb%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637607554783203623%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=VODdVGhSLsLDmfpWzFWIXltte8A7p2%2FA1okRktL3DMI%3D&reserved=0>) which I believe has passed the last call, but the detailed mechanisms such as configuration, data format, and export method are not covered there. Given the technique is equally applicable to other types of networks, we believe it's necessary to have a  document to formalized the method.

Best regards,
Haoyu

---

From: Haoyu Song <[email-masked]>
Date: Fri, 9 Jul 2021 18:34:44 +0000

Dear IPPM chairs,

Could you please suggest what we can do to meet the criteria for a WG adoption call?
Could you please assign a slot in the coming IETF WG meeting for me to present the draft and solicit comments? Thank you very much!

Best regards,
Haoyu

From: Haoyu Song
Sent: Thursday, July 1, 2021 10:34 AM
To: Tommy Pauly <[email-masked]>
Cc: IPPM Chairs <[email-masked]>; IETF IPPM WG <[email-masked]>; [email-masked]
Subject: RE: Request for WG adoption

Hi Tommy,

Best regards,
Haoyu

From: Tommy Pauly <[email-masked]<mailto:[email-masked]>>
Sent: Thursday, July 1, 2021 9:58 AM
To: Haoyu Song <[email-masked]<mailto:[email-masked]>>
Cc: IPPM Chairs <[email-masked]<mailto:[email-masked]>>; IETF IPPM WG <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Re: Request for WG adoption

Hi Haoyu,

Best,
Tommy

Dear IPPM Chairs,

Best regards,
Haoyu

---

From: Haoyu Song <[email-masked]>
Date: Fri, 9 Jul 2021 22:49:58 +0000

Dear IPPM chairs,

We just published a -10 version of the draft https://datatracker.ietf.org/doc/draft-song-ippm-postcard-based-telemetry/10/. In this draft we focus only on the PBT-M scheme itself and discuss its own challenges and solutions.
We believe that PBT-M is complementary to the other schemes currently in the WG including IOAM trace/E2E/DEX and it should be considered as well. Thank you very much for your consideration!

Best regards,
Haoyu

From: Haoyu Song
Sent: Friday, July 9, 2021 11:35 AM
To: Tommy Pauly <[email-masked]>
Cc: IPPM Chairs <[email-masked]>; IETF IPPM WG <[email-masked]>; [email-masked]
Subject: RE: Request for WG adoption

Dear IPPM chairs,

Best regards,
Haoyu

From: Haoyu Song
Sent: Thursday, July 1, 2021 10:34 AM
To: Tommy Pauly <[email-masked]<mailto:[email-masked]>>
Cc: IPPM Chairs <[email-masked]<mailto:[email-masked]>>; IETF IPPM WG <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: RE: Request for WG adoption

Hi Tommy,

Best regards,
Haoyu

Hi Haoyu,

Best,
Tommy

Dear IPPM Chairs,

Best regards,
Haoyu

---

From: Pedro Martinez-Julia <[email-masked]>
Date: Tue, 13 Jul 2021 09:06:00 +0900

Dear all,

I have reviewed the draft and I support it to be adopted by IPPM. The
postcard mechanism and others, such as DEX, are quite different, both in
terms of requesting telemetry (flagging data traffic) and in terms of
providing it (incorporated in packets vs direct submission to the
collector). Therefore, this draft has good base to be evolved as a WG
draft.

Regards,
Pedro

> _______________________________________________
> ippm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ippm

-- 
Pedro Martinez-Julia
Network Architecture Laboratory, Network Research Institute
National Institute of Information and Communications Technology (NICT)
4-2-1, Nukui-Kitamachi, Koganei, Tokyo 184-8795, Japan
Email: [email-masked]
---------------------------------------------------------
*** Entia non sunt multiplicanda praeter necessitatem ***

---

From: Martin Duke <[email-masked]>
Date: Wed, 14 Jul 2021 11:30:56 -0700

Forgive the strange question, but what is this draft hoping to accomplish?

IIUC it's basically DEX but with the details left to out-of-band
communication rather than a header. So is the intent simply to inform
people that this control-plane approach is something that is happening in
the Internet, and give some advice on how to do it? Or this meant to inform
a future standardization effort?

On Mon, Jul 12, 2021 at 5:06 PM Pedro Martinez-Julia <[email-masked]>
wrote:

> > We just published a -10 version of the draft
> https://datatracker.ietf.org/doc/draft-song-ippm-postcard-based-telemetry/10/.
> In this draft we focus only on the PBT-M scheme itself and discuss its own
> challenges and solutions.
> > We believe that PBT-M is complementary to the other schemes currently in
> the WG including IOAM trace/E2E/DEX and it should be considered as well.
> Thank you very much for your consideration!
> >
> > Best regards,
> > Haoyu
> >
> > From: Haoyu Song
> > Cc: IPPM Chairs <[email-masked]>; IETF IPPM WG <[email-masked]>;
> [email-masked]
> > Could you please assign a slot in the coming IETF WG meeting for me to
> present the draft and solicit comments? Thank you very much!
> >
> > Best regards,
> > Haoyu
> >
> > From: Haoyu Song
> > Cc: IPPM Chairs <[email-masked]<mailto:[email-masked]>>;
> IETF IPPM WG <[email-masked]<mailto:[email-masked]>>;
> [email-masked]<mailto:
> [email-masked]>
> > I think here I need to give some clarification. One the one hand, the
> draft indeed provides some descriptions to summarize the high level ideas
> of the related proposals (under the on-path telemetry), but this is not the
> core of the draft but to help understand the field and it can be removed if
> considered improper in such a draft. On the other hand, the core of the
> draft is about the approach to use some flag to trigger the telemetry data
> collection. In this sense, it's an independent proposal along with IOAM,
> DEX, and HTS. I believe they are equally important and needed to complete
> the ecosystem for on-path telemetry.
> >
> > I would also like to take this chance to seek more feedback from the WG
> and to see the level of interest and support on this work. Thanks!
> >
> > Best regards,
> > Haoyu
> >
> > To: Haoyu Song <[email-masked]<mailto:[email-masked]
> >>
> > Cc: IPPM Chairs <[email-masked]<mailto:[email-masked]>>;
> IETF IPPM WG <[email-masked]<mailto:[email-masked]>>;
> [email-masked]<mailto:
> [email-masked]>
> > Thanks for bringing this up again. As we've discussed in several
> previous meetings, this seems to be mainly a high-level description of work
> that is already concrete in IOAM, DEX, etc. As such, I am inclined to say
> that its content should be in other drafts (as has been done).
> >
> > On Jun 30, 2021, at 10:59 AM, Haoyu Song <[email-masked]
> <mailto:[email-masked]>> wrote:
> >
> > Dear IPPM Chairs,
> >
> > I'm writing to request the IPPM WG to adopt the following draft
> "Postcard-based On-Path Flow Data Telemetry using Packet Marking"
> >
> https://datatracker.ietf.org/doc/draft-song-ippm-postcard-based-telemetry/
> <
> https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-song-ippm-postcard-based-telemetry%2F&data=04%7C01%7Chaoyu.song%40futurewei.com%7C4cae751d53a845bc600a08d93cb15fdb%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637607554783193667%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=%2FA57w%2FrWm3TXoEvBCcHT2IPQQJi%2BrcgQwlTvs18EX48%3D&reserved=0
> >
> >
> > Now the draft is in -09 version and we have colleagues from Cisco, ZTE,
> Huawei as well as some network operators to coauthor this work.
> > As another on-path telemetry technique, PBT based on packet marking
> complements the other works such as IOAM, DEX, and HTS to make the
> ecosystem complete, and I believe each can find its application scenarios.
> For example, the PBT based on packet marking has been applied in
> "draft-ietf-6man-spring-srv6-oam" (
> https://datatracker.ietf.org/doc/html/draft-ietf-6man-spring-srv6-oam<
> https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-ietf-6man-spring-srv6-oam&data=04%7C01%7Chaoyu.song%40futurewei.com%7C4cae751d53a845bc600a08d93cb15fdb%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637607554783203623%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=VODdVGhSLsLDmfpWzFWIXltte8A7p2%2FA1okRktL3DMI%3D&reserved=0>)
> which I believe has passed the last call, but the detailed mechanisms such
> as configuration, data format, and export method are not covered there.
> Given the technique is equal
>  ly applicable to other types of networks, we believe it's necessary to
> have a  document to formalized the method.
> >
> > The draft has undergone a long line of developments since it was
> published in 2018. It originally covers two related but different
> techniques. One was latter stripped off to form an independent draft, IOAM
> DEX, which has been adopted by IPPM. The remaining one, PBT based on packet
> marking, is the core of the current draft. Thanks for the numerous
> discussions and feedbacks from the WG, we now have a draft with focused
> direction and relatively mature content.
> >
> > Given the community interest and the technical merit, we now request the
> WG to adopt the draft and engage the WG to work on it.
> > Please let us know if there are any concerns, comments, and
> suggestions.   Thank you very much for your consideration!
> >
> > Best regards,
> > Haoyu
> >
>

---

From: Haoyu Song <[email-masked]>
Date: Wed, 14 Jul 2021 19:14:51 +0000

Hi Martin,

Thank you for the question! Actually PBT-M is quite different from DEX.

  1.  There's no header but not a mark involved, so the encapsulation requirement is totally different
  2.  Due to the lack of a header, the export data correlation problem stands out and we need to have solutions to address that. This is unique problem to PBT-M
  3.  PBT-M technique has been applied in SRv6 OAM, but no details on the related correlation, configuration, and export issues for which we'd better have general solutions applicable to each different network scenario.

So in brief we hope to use this draft to formalize this unique approach and provide solution for its unique issues.
Further questions and comments are welcome!

Best regards,
Haoyu

From: Martin Duke <[email-masked]>
Sent: Wednesday, July 14, 2021 11:31 AM
To: Pedro Martinez-Julia <[email-masked]>
Cc: Haoyu Song <[email-masked]>; [email-masked]; IPPM Chairs <[email-masked]>; IETF IPPM WG <[email-masked]>
Subject: Re: [ippm] Request for WG adoption

IIUC it's basically DEX but with the details left to out-of-band communication rather than a header. So is the intent simply to inform people that this control-plane approach is something that is happening in the Internet, and give some advice on how to do it? Or this meant to inform a future standardization effort?

On Mon, Jul 12, 2021 at 5:06 PM Pedro Martinez-Julia <[email-masked]<mailto:[email-masked]>> wrote:
Dear all,

Regards,
Pedro

On Fri, Jul 09, 2021 at 10:49:58PM +0000, Haoyu Song wrote:
> Dear IPPM chairs,
>
> We just published a -10 version of the draft https://datatracker.ietf.org/doc/draft-song-ippm-postcard-based-telemetry/10/<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-song-ippm-postcard-based-telemetry%2F10%2F&data=04%7C01%7Chaoyu.song%40futurewei.com%7Cbf96f079405345a6cd2d08d946f58d0c%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637618842743087591%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=DqIgY%2FY7curkFTocTHwgKS3jgo38tAkhVXPp6yK%2FtdM%3D&reserved=0>. In this draft we focus only on the PBT-M scheme itself and discuss its own challenges and solutions.
> To: Tommy Pauly <[email-masked]<mailto:[email-masked]><mailto:[email-masked]<mailto:[email-masked]>>>
> Cc: IPPM Chairs <[email-masked]<mailto:[email-masked]><mailto:[email-masked]<mailto:[email-masked]>>>; IETF IPPM WG <[email-masked]<mailto:[email-masked]><mailto:[email-masked]<mailto:[email-masked]>>>; [email-masked]<mailto:[email-masked]><mailto:[email-masked]<mailto:[email-masked]>>
> From: Tommy Pauly <[email-masked]<mailto:[email-masked]><mailto:[email-masked]<mailto:[email-masked]>>>
> To: Haoyu Song <[email-masked]<mailto:[email-masked]><mailto:[email-masked]<mailto:[email-masked]>>>
> Cc: IPPM Chairs <[email-masked]<mailto:[email-masked]><mailto:[email-masked]<mailto:[email-masked]>>>; IETF IPPM WG <[email-masked]<mailto:[email-masked]><mailto:[email-masked]<mailto:[email-masked]>>>; [email-masked]<mailto:[email-masked]><mailto:[email-masked]<mailto:[email-masked]>>
> On Jun 30, 2021, at 10:59 AM, Haoyu Song <[email-masked]<mailto:[email-masked]><mailto:[email-masked]<mailto:[email-masked]>>> wrote:
>
> Dear IPPM Chairs,
>
> https://datatracker.ietf.org/doc/draft-song-ippm-postcard-based-telemetry/<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-song-ippm-postcard-based-telemetry%2F&data=04%7C01%7Chaoyu.song%40futurewei.com%7Cbf96f079405345a6cd2d08d946f58d0c%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637618842743097547%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=zN5rKZWU3A4Kz%2FVQ%2F05ouhqj0hF73iUV38gkYa2SYa0%3D&reserved=0><https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-song-ippm-postcard-based-telemetry%2F&data=04%7C01%7Chaoyu.song%40futurewei.com%7C4cae751d53a845bc600a08d93cb15fdb%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637607554783193667%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=%2FA57w%2FrWm3TXoEvBCcHT2IPQQJi%2BrcgQwlTvs18EX48%3D&reserved=0<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-song-ippm-postcard-based-telemetry%2F&data=04%7C01%7Chaoyu.song%40futurewei.com%7Cbf96f079405345a6cd2d08d946f58d0c%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637618842743097547%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=zN5rKZWU3A4Kz%2FVQ%2F05ouhqj0hF73iUV38gkYa2SYa0%3D&reserved=0>>
>
> As another on-path telemetry technique, PBT based on packet marking complements the other works such as IOAM, DEX, and HTS to make the ecosystem complete, and I believe each can find its application scenarios. For example, the PBT based on packet marking has been applied in "draft-ietf-6man-spring-srv6-oam" (https://datatracker.ietf.org/doc/html/draft-ietf-6man-spring-srv6-oam<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-ietf-6man-spring-srv6-oam&data=04%7C01%7Chaoyu.song%40futurewei.com%7Cbf96f079405345a6cd2d08d946f58d0c%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637618842743107503%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=licfG9Es7vx9mAoXdp4mdYhasRtImhxunvHkj7onjN4%3D&reserved=0><https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-ietf-6man-spring-srv6-oam&data=04%7C01%7Chaoyu.song%40futurewei.com%7C4cae751d53a845bc600a08d93cb15fdb%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637607554783203623%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=VODdVGhSLsLDmfpWzFWIXltte8A7p2%2FA1okRktL3DMI%3D&reserved=0<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-ietf-6man-spring-srv6-oam&data=04%7C01%7Chaoyu.song%40futurewei.com%7Cbf96f079405345a6cd2d08d946f58d0c%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637618842743117461%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=Cu8laHEhkIv%2ByCuGZrNp2kNSZtVaxfe%2FP0swWtxQcLQ%3D&reserved=0>>) which I believe has passed the last call, but the detailed mechanisms such as configuration, data format, and export method are not covered there. Given the technique is equal
 ly applicable to other types of networks, we believe it's necessary to have a  document to formalized the method.

> [email-masked]<mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/ippm<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fippm&data=04%7C01%7Chaoyu.song%40futurewei.com%7Cbf96f079405345a6cd2d08d946f58d0c%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637618842743117461%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=YjhV0T8pMO43xQxfxBhd4cgDJM7d4C3cufb8ytvvhsQ%3D&reserved=0>

Email: [email-masked]<mailto:[email-masked]>

_______________________________________________
ippm mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ippm<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fippm&data=04%7C01%7Chaoyu.song%40futurewei.com%7Cbf96f079405345a6cd2d08d946f58d0c%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637618842743127417%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=Pq1tOFBojlSGiroizUH%2FNuzhuyw2C%2F3thBnkyar0rGs%3D&reserved=0>

---

From: Haoyu Song <[email-masked]>
Date: Tue, 20 Jul 2021 17:08:55 +0000

Dear IPPM chairs,

I think the draft PBT-M has been discussed many times in email list and should be put in to the category "Proposed Work - Individual drafts that have received list discussion and are candidates for adoption." Unfortunately, it was list as the last item in lighting talks. Based on my past experience, it has little chance to be presented at all, let alone any discussion about it.  I also find some non-WG drafts which was never discussed can always be included in the main agenda and I'm curious about the selection criteria.

In the past email exchanges, I have explained the content and scope of the draft and answered some questions and concerns. In addition to the coauthors from three major vendors and two operators, we also received some support from other attendees. We also see a real application for it will become RFC soon. I'd like to know the clear expectation from the WG on how we can progress the work. Thank you very much for your consideration!

Best regards,
Haoyu

From: Haoyu Song
Sent: Friday, July 9, 2021 3:50 PM
To: Tommy Pauly <[email-masked]>
Cc: IPPM Chairs <[email-masked]>; IETF IPPM WG <[email-masked]>; [email-masked]
Subject: RE: Request for WG adoption

Dear IPPM chairs,

Best regards,
Haoyu

From: Haoyu Song

Dear IPPM chairs,

Best regards,
Haoyu

From: Haoyu Song

Hi Tommy,

Best regards,
Haoyu

Hi Haoyu,

Best,
Tommy

Dear IPPM Chairs,

Best regards,
Haoyu