Subject: [ippm] IOAM - Linux kernel

From: Justin Iurman <[email-masked]>
Date: Thu, 29 Jul 2021 21:32:21 +0200 (CEST)

Hi all,

As I already mentioned during yesterday's meeting, IOAM w/ IPv6 is now officially part of the Linux kernel (more specifically, the pre-allocated trace option). It will come with release 5.14 (you can expect it in ~6 weeks, I'd say). I think this is definitely great news for IPPM, but also for the IOAM team involved. So kudos to everyone.

On the same topic, now that IOAM has finally made it to the kernel, we hope that draft-ietf-ippm-ioam-ipv6-options will follow the same path as draft-ietf-ippm-ioam-data in short term.

Thanks,

Justin

---

From: "Frank Brockners (fbrockne)" <[email-masked]>
Date: Sat, 31 Jul 2021 15:16:52 +0000

Hi Justin,

This is AWESOME news. We all know how much effort it is to get a new feature into the Linux Kernel. Thanks a lot for driving this effort.

Your great news points to a draft that we've forgotten about at the IPPM WG meeting this week:
draft-ietf-ippm-ioam-ipv6-options.

I've just posted a minor revision of draft-ietf-ippm-ioam-ipv6-options (rev 06) which finally reflects what Tommy asked for several times:
Move to an editor model with an associated section listing all the contributors - and that way, shorten the list of authors.

Given that draft-ietf-ippm-ioam-ipv6-options is stable for a while now and IOAM is now in the Linux Kernel,
plus the fact, that the Kernel community isn't a big fan of code point changes, could we also evolve draft-ietf-ippm-ioam-ipv6-options-06 to WGLC?
That way we would (hopefully) not ask for another extension of the early allocation of the code-points - and we'd give the community of implementors a lot of stability.

Thanks, Frank

> -----Original Message-----
> From: Justin Iurman <[email-masked]>
> Sent: Donnerstag, 29. Juli 2021 21:32
> To: IETF IPPM WG <[email-masked]>
> Cc: IPPM Chairs <[email-masked]>; Frank Brockners (fbrockne)
> <[email-masked]>; Tal Mizrahi <[email-masked]>; Shwetha
> <[email-masked]>
> Subject: IOAM - Linux kernel
> 
> Hi all,
> 
> As I already mentioned during yesterday's meeting, IOAM w/ IPv6 is now
> officially part of the Linux kernel (more specifically, the pre-allocated trace
> option). It will come with release 5.14 (you can expect it in ~6 weeks, I'd say). I
> think this is definitely great news for IPPM, but also for the IOAM team involved.
> So kudos to everyone.
> 
> On the same topic, now that IOAM has finally made it to the kernel, we hope
> that draft-ietf-ippm-ioam-ipv6-options will follow the same path as draft-ietf-
> ippm-ioam-data in short term.
> 
> Thanks,
> 
> Justin