Subject: Re: [ippm] Fw: New Version Notification for draft-elkins-ippm-encrypted-pdmv2-00.txt

From: "[email-masked]" <[email-masked]>
Date: Thu, 1 Jul 2021 17:44:39 +0000 (UTC)

IPPM,

Please do take a look at this draft.

I think that iOAM will need encryption as well.   We have spent quite a bit of time thinking over these issues.  We even have 2 cryptographers from Italy involved as co-authors.   I want to do a side meeting where we can have quite a bit more time to discuss this but would love to have comments from the group on the list.

I am very reluctant to push PDM out to the wider world without encryption.  I feel that we will become the attacker's best friend.
We have modified the Linux kernel to include PDM but as I say, without encryption, we do not wish to release.

Thanks,

Nalini Elkins
CEO and Founder
Inside Products, Inc.
www.insidethestack.com
(831) 659-8360

On Tuesday, June 1, 2021, 09:06:39 AM PDT, [email-masked] <[email-masked]> wrote: 

Hello IPPMers!

We have just posted a new draft to encrypt PDM data.   We feel that this is an important feature to add before promoting widespread adoption of PDM.

We would appreciate any thoughts or comments from the group.

Thanks,

Nalini Elkins
CEO and Founder
Inside Products, Inc.
www.insidethestack.com
(831) 659-8360

----- Forwarded Message -----

From: "[email-masked]" <[email-masked]>
To: [email-masked] <[email-masked]>; Adnan Rashid <[email-masked]>; Ameya Deshpande <[email-masked]>; Michael Ackermann <[email-masked]>; Nalini Elkins <[email-masked]>; Tommaso Pecorella <[email-masked]>
Sent: Tuesday, June 1, 2021, 12:01:47 PM EDT
Subject: New Version Notification for draft-elkins-ippm-encrypted-pdmv2-00.txt

A new version of I-D, draft-elkins-ippm-encrypted-pdmv2-00.txt
has been successfully submitted by Nalini Elkins and posted to the
IETF repository.

Name:        draft-elkins-ippm-encrypted-pdmv2
Revision:    00
Title:        Encrypted IPv6 Performance and Diagnostic Metrics Version 2 (EPDMv2) Destination Option
Document date:    2021-06-01
Group:        Individual Submission
Pages:        16
URL:            https://www.ietf.org/archive/id/draft-elkins-ippm-encrypted-pdmv2-00.txt
Status:        https://datatracker.ietf.org/doc/draft-elkins-ippm-encrypted-pdmv2/
Htmlized:      https://datatracker.ietf.org/doc/html/draft-elkins-ippm-encrypted-pdmv2

Abstract:
  RFC8250 describes an optional Destination Option (DO) header embedded
  in each packet to provide sequence numbers and timing information as
  a basis for measurements.  As this data is sent in clear- text, this
  may create an opportunity for malicious actors to get information for
  subsequent attacks.  This document defines PDMv2 which has a
  lightweight handshake (registration procedure) and encryption to
  secure this data.  Additional performance metrics which may be of use
  are also defined.

The IETF Secretariat

_______________________________________________
ippm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ippm

---

From: "Hamilton, Robert" <[email-masked]>
Date: Thu, 1 Jul 2021 21:05:14 +0000

I am interested in the encryption of the PDM header, just because I've done symmetric-key encryption with pseudorandom numbers and pseudorandom obfuscation algorithms for key management. I see that we are interested in using HPKE. I have just a few concerns:

 - The latest HPKE draft expired just last week. That means it's some time before general implementation. I'm a mainframer, mostly, so I suspect that makes it even longer before I'll see implementation for _production_ use. Further, I don't want the implementation of PDM in more secure environments delayed because of encryption-method concerns.

 - When we generate the PDM structure and determine the timing, we want that to be as close to the wire as possible. The PDM timing was very granular, so this will add a variable amount of time to the time the packet is determined to be spending in transmission; the encryption delay is now part of the transmission time.

Still reviewing; I'll be back with more thoughts.

R;

Rob Hamilton
Infrastructure Engineer
Chemical Abstracts Service

-----Original Message-----
From: ippm <[email-masked]> On Behalf Of [email-masked]
Sent: Thursday, July 1, 2021 1:45 PM
To: IETF IPPM WG <[email-masked]>
Cc: [email-masked]
Subject: [EXT] Re: [ippm] Fw: New Version Notification for draft-elkins-ippm-encrypted-pdmv2-00.txt

[Actual Sender is [email-masked]]

IPPM,

Thanks,

Nalini Elkins
CEO and Founder
Inside Products, Inc.
https://smex12-5-en-ctp.trendmicro.com:443/wis/clicktime/v1/query?url=www.insidethestack.com&umid=61654d20-9615-453c-80b2-c06c82268e9d&auth=3c97381e9a30865a1a3f3ad58750d85b2b059558-86a3cb083390e2163fd0daaf45646c2a55adf702
(831) 659-8360

Hello IPPMers!

Thanks,

Nalini Elkins
CEO and Founder
Inside Products, Inc.
https://smex12-5-en-ctp.trendmicro.com:443/wis/clicktime/v1/query?url=www.insidethestack.com&umid=61654d20-9615-453c-80b2-c06c82268e9d&auth=3c97381e9a30865a1a3f3ad58750d85b2b059558-86a3cb083390e2163fd0daaf45646c2a55adf702
(831) 659-8360

----- Forwarded Message -----

Abstract:

The IETF Secretariat

_______________________________________________
ippm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ippm
Confidentiality Notice: This electronic message transmission, including any attachment(s), may contain confidential, proprietary, or privileged information from CAS, a division of the American Chemical Society ("ACS"). If you have received this transmission in error, be advised that any disclosure, copying, distribution, or use of the contents of this information is strictly prohibited. Please destroy all copies of the message and contact the sender immediately by either replying to this message or calling 614-447-3600.

---

From: Tommy Pauly <[email-masked]>
Date: Thu, 01 Jul 2021 18:23:16 -0700

> On Jul 1, 2021, at 2:05 PM, Hamilton, Robert <RHamilton=[email-masked]> wrote:
> 

As a note on this, HPKE does not in fact seem to be expired: https://www.ietf.org/archive/id/draft-irtf-cfrg-hpke-09.html

This is an official RG document that in IRSG and getting prepared for RFC publication. It also is a stable protocol, and we at Apple are already deploying it and relying on it. So, this protocol is ready for production (and is being used as such) already. 

Best,
Tommy

---

From: "[email-masked]" <[email-masked]>
Date: Fri, 2 Jul 2021 14:13:43 +0000 (UTC)

Rob,
Our cryptographers are working on a full answer to your question.  I will be back to you with that.
But, this is a very complex area and is actually why I will be scheduling a side meeting (once I am able to do it!) so that we can talk over all these issues in detail and with enough time to discuss.
Thanks,

Nalini Elkins
CEO and Founder
Inside Products, Inc.
www.insidethestack.com
(831) 659-8360 

    On Thursday, July 1, 2021, 02:05:31 PM PDT, Hamilton, Robert <rhamilton=[email-masked]> wrote:  

R;

Rob Hamilton
Infrastructure Engineer

-----Original Message-----
From: ippm <[email-masked]> On Behalf Of [email-masked]
Sent: Thursday, July 1, 2021 1:45 PM
To: IETF IPPM WG <[email-masked]>
Cc: [email-masked]
Subject: [EXT] Re: [ippm] Fw: New Version Notification for draft-elkins-ippm-encrypted-pdmv2-00.txt

IPPM,

Thanks,

Nalini Elkins
CEO and Founder
Inside Products, Inc.

Hello IPPMers!

Thanks,

Nalini Elkins
CEO and Founder
Inside Products, Inc.

----- Forwarded Message -----

Abstract:

The IETF Secretariat

---

From: Paolo Volpato <[email-masked]>
Date: Fri, 2 Jul 2021 14:25:46 +0000

Hi Nalini,

Thanks for advising.

I have a couple of general questions.

At a first glance, it seems to me that PDMv2 is expected to be used mainly in the enterprise domain. Is it so? 
Do you have any thoughts on what may happen if e.g. a multinational company runs the protocol over multiple external backbones where the IPv6 extension headers (in general, not necessarily just the destination options header) may not be handled? Does this represent a serious issue?

Also,  I assume that PDMv2 is mainly used by end stations (e.g. hosts instead of routers). If this is the case, then I don’t expect that the performance degradation due to encryption is a serious issue. Do you see other different cases where instead degradation may be a concern?

Regards
Paolo

-----Original Message-----
From: ippm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Thursday, July 1, 2021 7:45 PM
To: IETF IPPM WG <[email-masked]>
Cc: [email-masked]
Subject: Re: [ippm] Fw: New Version Notification for draft-elkins-ippm-encrypted-pdmv2-00.txt

IPPM,

Thanks,

Nalini Elkins
CEO and Founder
Inside Products, Inc.
www.insidethestack.com
(831) 659-8360

Hello IPPMers!

Thanks,

Nalini Elkins
CEO and Founder
Inside Products, Inc.
www.insidethestack.com
(831) 659-8360

----- Forwarded Message -----

A new version of I-D, draft-elkins-ippm-encrypted-pdmv2-00.txt
has been successfully submitted by Nalini Elkins and posted to the IETF repository.

Title:        Encrypted IPv6 Performance and Diagnostic Metrics Version 2 (EPDMv2) Destination Option Document date:    2021-06-01

Abstract:

The IETF Secretariat

---

From: "[email-masked]" <[email-masked]>
Date: Fri, 2 Jul 2021 14:51:16 +0000 (UTC)

Paolo,

Thanks so much for your comments.

> At a first glance, it seems to me that PDMv2 is expected to be used mainly in the enterprise domain. Is it so?

Yes.

> Do you have any thoughts on what may happen if e.g. a multinational company runs the protocol over multiple external
> backbones where the IPv6 extension headers (in general, not necessarily just the destination options header) may not be
> handled? Does this represent a serious issue?

We need to do a more in depth study in this area.  I have done some minor testing with PDM enabled servers located in Singapore, San Jose and Europe.   These were not blocked.   I am well-aware that a number of studies in v6ops shows IPv6 extension headers being blocked.   

Having said that, I am hoping that enterprises will let PDM extension headers through their firewalls because of the functionality they provide.   

APNIC has been kind enough to give our team a grant for IPv6 deployment at enterprises.  We are applying again and we wish to do an in-depth study on PDM (and potential blockage / performance) in particular as a part of the new grant.   

> Also,  I assume that PDMv2 is mainly used by end stations (e.g. hosts instead of routers). If this is the case, then I don’t expect > that the performance degradation due to encryption is a serious issue. Do you see other different cases where instead 
> degradation may be a concern?

Our cryptographers are working on a full answer to this question.  But, what I can say for now, is that there is always a cost for the choices that you make.  We have thought over and over again about how to make our implementation as light-weight as possible.   I hope to be able to explain more at the IPPM session at IETF111,

Thanks,

Nalini Elkins
CEO and Founder
Inside Products, Inc.
www.insidethestack.com
(831) 659-8360

On Friday, July 2, 2021, 07:25:51 AM PDT, Paolo Volpato <[email-masked]> wrote: 

Hi Nalini,

Thanks for advising.

Regards
Paolo

-----Original Message-----
From: ippm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Thursday, July 1, 2021 7:45 PM
To: IETF IPPM WG <[email-masked]>
Cc: [email-masked]
Subject: Re: [ippm] Fw: New Version Notification for draft-elkins-ippm-encrypted-pdmv2-00.txt

IPPM,

Thanks,

Nalini Elkins
CEO and Founder
Inside Products, Inc.
www.insidethestack.com
(831) 659-8360

Hello IPPMers!

Thanks,

Nalini Elkins
CEO and Founder
Inside Products, Inc.
www.insidethestack.com
(831) 659-8360

----- Forwarded Message -----

Abstract:

The IETF Secretariat

---

From: "Hamilton, Robert" <[email-masked]>
Date: Fri, 2 Jul 2021 19:12:40 +0000

Paolo:

I'm particularly interested in PDM for helping with Enterprise Extender connections. Since we  are using the internet for these connections we are subject to the vagaries of ISP traffic management and outages on multiple continents. It's not just multinational companies that could make good use of this protocol, but any companies with business partners with whom they require reliable internet connectivity. In those cases I expect the end-node encryption is a relatively smaller portion of the total packet transmission time.

I don't want to slow down the PDM implementation, and in general I think the encryption is a good idea. Encryption is fast on this platform, but to my knowledge it doesn't do HPKE. I've just looked through the RFE site and haven't seen any asking for HPKE support.

Getting good value from PDM requires that destination headers be passed reliably from end to end. We probably have to lobby for that first, good extension header handling network-wide. I'll be happy when I see PDM headers show up in my Policy Agent logs.

R;

Rob Hamilton
Infrastructure Engineer

-----Original Message-----
From: ippm <[email-masked]> On Behalf Of Paolo Volpato
Sent: Friday, July 2, 2021 10:26 AM
To: [email-masked]
Cc: [email-masked]; IETF IPPM WG <[email-masked]>
Subject: [EXT] Re: [ippm] Fw: New Version Notification for draft-elkins-ippm-encrypted-pdmv2-00.txt

Hi Nalini,

Thanks for advising.

Regards
Paolo

-----Original Message-----
From: ippm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Thursday, July 1, 2021 7:45 PM
To: IETF IPPM WG <[email-masked]>
Cc: [email-masked]
Subject: Re: [ippm] Fw: New Version Notification for draft-elkins-ippm-encrypted-pdmv2-00.txt

IPPM,

Thanks,

Nalini Elkins
CEO and Founder
Inside Products, Inc.
https://smex12-5-en-ctp.trendmicro.com:443/wis/clicktime/v1/query?url=www.insidethestack.com&umid=ae63ba6f-614c-40c5-9a6d-dbc4bc0fbb82&auth=3c97381e9a30865a1a3f3ad58750d85b2b059558-117b9ada8970552b00544efe952da754c5c92078
(831) 659-8360

Hello IPPMers!

Thanks,

Nalini Elkins
CEO and Founder
Inside Products, Inc.
https://smex12-5-en-ctp.trendmicro.com:443/wis/clicktime/v1/query?url=www.insidethestack.com&umid=ae63ba6f-614c-40c5-9a6d-dbc4bc0fbb82&auth=3c97381e9a30865a1a3f3ad58750d85b2b059558-117b9ada8970552b00544efe952da754c5c92078
(831) 659-8360

----- Forwarded Message -----

Abstract:

The IETF Secretariat

---

From: "[email-masked]" <[email-masked]>
Date: Fri, 2 Jul 2021 19:36:45 +0000 (UTC)

Rob,
> I don't want to slow down the PDM implementation, and in general I think the encryption is a good idea. 
> Encryption is fast on this platform, but to my knowledge it doesn't do HPKE. I've just looked through the > RFE site and haven't seen any asking for HPKE support.
For a bit of context to IPPMers, I have had some offline interactions with Rob.  He is speaking of the IBM mainframe platform which something north of 90% of the Fortune 500 use.
I spoke recently to someone at ARM who is looking at implementing HPKE.  I believe Tommy stated that Apple is also using it.
Rob, I will work with you offline about possibly putting in a Request For Enhancement (RFE) to IBM for HPKE.
Thanks,

Nalini Elkins
CEO and Founder
Inside Products, Inc.
www.insidethestack.com
(831) 659-8360 

    On Friday, July 2, 2021, 12:12:44 PM PDT, Hamilton, Robert <[email-masked]> wrote:  
 
 Paolo:

R;

Rob Hamilton
Infrastructure Engineer

-----Original Message-----
From: ippm <[email-masked]> On Behalf Of Paolo Volpato
Sent: Friday, July 2, 2021 10:26 AM
To: [email-masked]
Cc: [email-masked]; IETF IPPM WG <[email-masked]>
Subject: [EXT] Re: [ippm] Fw: New Version Notification for draft-elkins-ippm-encrypted-pdmv2-00.txt

Hi Nalini,

Thanks for advising.

Regards
Paolo

-----Original Message-----
From: ippm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Thursday, July 1, 2021 7:45 PM
To: IETF IPPM WG <[email-masked]>
Cc: [email-masked]
Subject: Re: [ippm] Fw: New Version Notification for draft-elkins-ippm-encrypted-pdmv2-00.txt

IPPM,

Thanks,

Nalini Elkins
CEO and Founder
Inside Products, Inc.

Hello IPPMers!

Thanks,

Nalini Elkins
CEO and Founder
Inside Products, Inc.

----- Forwarded Message -----

Abstract:

The IETF Secretariat

---

From: "Ackermann, Michael" <[email-masked]>
Date: Sat, 3 Jul 2021 01:49:58 +0000

Just a quick word of thanks to Rob. 
For verbalizing the value that PDM and Extension Headers in general will have, for EE and many other Mainframe Apps at hundreds or even thousands of Enterprises.    And similar benefits will be extended to many other platforms as well.    
These organizations are not directly represented or involved at IETF,  but will definitely be beneficiaries of developments such as PDM.  

Thanks again!

Mike

-----Original Message-----
From: Hamilton, Robert <[email-masked]> 
Sent: Friday, July 2, 2021 3:13 PM
To: IETF IPPM WG <[email-masked]>
Cc: [email-masked]; [email-masked]
Subject: RE: [ippm] Fw: New Version Notification for draft-elkins-ippm-encrypted-pdmv2-00.txt

[External email]

Paolo:

R;

Rob Hamilton
Infrastructure Engineer

-----Original Message-----
From: ippm <[email-masked]> On Behalf Of Paolo Volpato
Sent: Friday, July 2, 2021 10:26 AM
To: [email-masked]
Cc: [email-masked]; IETF IPPM WG <[email-masked]>
Subject: [EXT] Re: [ippm] Fw: New Version Notification for draft-elkins-ippm-encrypted-pdmv2-00.txt

Hi Nalini,

Thanks for advising.

Regards
Paolo

-----Original Message-----
From: ippm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Thursday, July 1, 2021 7:45 PM
To: IETF IPPM WG <[email-masked]>
Cc: [email-masked]
Subject: Re: [ippm] Fw: New Version Notification for draft-elkins-ippm-encrypted-pdmv2-00.txt

IPPM,

Thanks,

Nalini Elkins
CEO and Founder
Inside Products, Inc.

Hello IPPMers!

Thanks,

Nalini Elkins
CEO and Founder
Inside Products, Inc.

----- Forwarded Message -----

Abstract:

The IETF Secretariat

The information contained in this communication is highly confidential and is intended solely for the use of the individual(s) to whom this communication is directed. If you are not the intended recipient, you are hereby notified that any viewing, copying, disclosure or distribution of this information is prohibited. Please notify the sender, by electronic mail or telephone, of any unintended receipt and delete the original message without making any copies.
 
 Blue Cross Blue Shield of Michigan and Blue Care Network of Michigan are nonprofit corporations and independent licensees of the Blue Cross and Blue Shield Association.

This message was secured by Zix(R).

---

From: "Mohit P. Tahiliani" <[email-masked]>
Date: Sun, 4 Jul 2021 09:33:25 +0530

Greetings!

I am new to the IPPM list but I have been following the conversation on
IOAM integrity: https://github.com/inband-oam/ietf/pull/222

I am wondering why you have chosen to do confidentiality (encryption of the
data) as well as integrity.

Thanks,
Mohit P. Tahiliani

On Thu, Jul 1, 2021 at 11:15 PM [email-masked] <
[email-masked]> wrote:

> I think that iOAM will need encryption as well.   We have spent quite a
> bit of time thinking over these issues.  We even have 2 cryptographers from
> Italy involved as co-authors.   I want to do a side meeting where we can
> have quite a bit more time to discuss this but would love to have comments
> from the group on the list.
>
> I am very reluctant to push PDM out to the wider world without
> encryption.  I feel that we will become the attacker's best friend.
> On Tuesday, June 1, 2021, 09:06:39 AM PDT,
> [email-masked] <[email-masked]>
> wrote:
>
>
>
>
>
> Hello IPPMers!
>
> We have just posted a new draft to encrypt PDM data.   We feel that this
> is an important feature to add before promoting widespread adoption of PDM.
>
> To: [email-masked] <[email-masked]>; Adnan Rashid <
> [email-masked]>; Ameya Deshpande <[email-masked]>; Michael
> Ackermann <[email-masked]>; Nalini Elkins <
> [email-masked]>; Tommaso Pecorella <
> [email-masked]>
> URL:
> https://www.ietf.org/archive/id/draft-elkins-ippm-encrypted-pdmv2-00.txt
> Status:
> https://datatracker.ietf.org/doc/draft-elkins-ippm-encrypted-pdmv2/
> Htmlized:
> https://datatracker.ietf.org/doc/html/draft-elkins-ippm-encrypted-pdmv2
>
>
> Abstract:

---

From: Ameya Deshpande <[email-masked]>
Date: Sun, 4 Jul 2021 15:00:21 +0000 (UTC)

Hi Mohit,
Thanks for your comments.  I am one of the co-authors of the PDMv2 draft.
PDM provides important information on the server delay, round-trip delay, and correlating the flow packets. In PDMv2, we have also added a new metric called the global pointer, which provides information on the amount of traffic being processed at the sender node.
We think that PDMv2, with all its useful data, should provide encryption as well as integrity because it is possible for a malicious intermediate node to mislead the destination with modified data.
Thanks,Ameya Deshpande

    On Sunday, 4 July, 2021, 9:33:57 am IST, Mohit P. Tahiliani <[email-masked]> wrote:  
 
 Greetings!

I am new to the IPPM list but I have been following the conversation on IOAM integrity: https://github.com/inband-oam/ietf/pull/222

I am wondering why you have chosen to do confidentiality (encryption of the data) as well as integrity.

Thanks,Mohit P. Tahiliani
On Thu, Jul 1, 2021 at 11:15 PM [email-masked] <[email-masked]> wrote:

IPPM,

Thanks,

Nalini Elkins
CEO and Founder
Inside Products, Inc.
www.insidethestack.com
(831) 659-8360

Hello IPPMers!

Thanks,

Nalini Elkins
CEO and Founder
Inside Products, Inc.
www.insidethestack.com
(831) 659-8360

----- Forwarded Message -----

Abstract:

The IETF Secretariat

---

From: "[email-masked]" <[email-masked]>
Date: Mon, 5 Jul 2021 16:27:12 +0000 (UTC)

Hi Robert,[Posting for some of the co-authors.]We fully agree with your concerns. However, we’re confident that HPKE will reach the RFC status soon. Moreover, also other protocols (e.g., MLS, see https://www.ietf.org/archive/id/draft-ietf-mls-architecture-06.txt) are using it.About HPKE itself, there are two different aspects to consider: HPKE (as an architecture, API, etc.) and the cryptographic functions used by HKPE. While HPKE is still in draft, the cryptographic functions are well-known and proven. Hence, we don’t expect any concern related to the encryption methods used by HPKE.The fact that Tommy confirms that it is being implemented and deployed reinforces our confidence on the fact that its availability is not going to be a critical point.
In any case, we will take this point into consideration, as it is a valid concern.
Best regards,
Nalini, Tom, and Adnan

R;

Rob Hamilton
Infrastructure Engineer

-----Original Message-----
From: ippm <[email-masked]> On Behalf Of [email-masked]
Sent: Thursday, July 1, 2021 1:45 PM
To: IETF IPPM WG <[email-masked]>
Cc: [email-masked]
Subject: [EXT] Re: [ippm] Fw: New Version Notification for draft-elkins-ippm-encrypted-pdmv2-00.txt

IPPM,

Thanks,

Nalini Elkins
CEO and Founder
Inside Products, Inc.

Hello IPPMers!

Thanks,

Nalini Elkins
CEO and Founder
Inside Products, Inc.

----- Forwarded Message -----

Abstract:

The IETF Secretariat

---

From: Ameya Deshpande <[email-masked]>
Date: Mon, 5 Jul 2021 16:48:49 +0000 (UTC)

Hi Robert,
Thanks for your comments. Please check the inline comments.
> - The latest HPKE draft expired just last week. That means it's some time before general implementation. I'm a mainframer, mostly, so I suspect that makes it even longer before I'll see implementat…

We have kept an option for no-encryption in PDMv2 as well. And it is kept exactly for
 the same reason you mentioned. Connections over encrypted medium (say VPN tunnels),link-local network, or any secured company domain can choose to use PDMv2 unencrypted.
> - When we generate the PDM structure and determine the timing, we want that to be as close to the wire as possible. The PDM timing was very granular, so this will add a variable amount of time to t…
Yes, for a PDM-to-PDM machine, the round trip time, a.k.a DELTATLS, will include the two encryptionand two decryption times. We are trying our best to minimize any added timing due to the encryption in PDMv2, but we feel that encryption is important, so we're trying to achieve a correct balance.
Thanks,Ameya Deshpande

    On Monday, 5 July, 2021, 9:57:51 pm IST, [email-masked] <[email-masked]> wrote:  

 

R;

Rob Hamilton
Infrastructure Engineer

-----Original Message-----
From: ippm <[email-masked]> On Behalf Of [email-masked]
Sent: Thursday, July 1, 2021 1:45 PM
To: IETF IPPM WG <[email-masked]>
Cc: [email-masked]
Subject: [EXT] Re: [ippm] Fw: New Version Notification for draft-elkins-ippm-encrypted-pdmv2-00.txt

IPPM,

Thanks,

Nalini Elkins
CEO and Founder
Inside Products, Inc.

Hello IPPMers!

Thanks,

Nalini Elkins
CEO and Founder
Inside Products, Inc.

----- Forwarded Message -----

Abstract:

The IETF Secretariat

---

From: Ameya Deshpande <[email-masked]>
Date: Mon, 5 Jul 2021 16:52:41 +0000 (UTC)

Hi Paolo,
Thanks for your comments. Please check the inline reply.
> Also,  I assume that PDMv2 is mainly used by end stations (e.g. hosts instead of routers). If this is the case, then I don’t expect that the performance degradation due to encryption is a serious i…

When using encrypted PDMv2, we have a bigger packet to send asthe size of encrypted data is more than the corresponding plaintext data.This can increase the timing slightly as the packet size has increased.

For using encrypted PDMv2, we have an initial registration phase wherewe negotiate the shared secret (using KEM). We have also given a registrationmechanism for enterprises with many servers and clients. However, this willbe done before transmitting PDMv2 packets.
We intend to have a side-meeting where we will explain HPKE and be able to thoroughly discuss these points.  When we are able to schedule it, we will let you know.  The registration to schedule side meetings has not yet opened.
Thanks,Ameya Deshpande
    On Monday, 5 July, 2021, 10:19:21 pm IST, Ameya Deshpande <ameyanrd=[email-masked]> wrote:  
 
  Hi Robert,

 

R;

Rob Hamilton
Infrastructure Engineer

-----Original Message-----
From: ippm <[email-masked]> On Behalf Of [email-masked]
Sent: Thursday, July 1, 2021 1:45 PM
To: IETF IPPM WG <[email-masked]>
Cc: [email-masked]
Subject: [EXT] Re: [ippm] Fw: New Version Notification for draft-elkins-ippm-encrypted-pdmv2-00.txt

IPPM,

Thanks,

Nalini Elkins
CEO and Founder
Inside Products, Inc.

Hello IPPMers!

Thanks,

Nalini Elkins
CEO and Founder
Inside Products, Inc.

----- Forwarded Message -----

Abstract:

The IETF Secretariat

---

From: Tommy Pauly <[email-masked]>
Date: Tue, 06 Jul 2021 20:22:06 -0700

Hi IPPM,

To help discuss the PDMv2 proposal, and clarify the use of HPKE, Nalini has set up a side meeting during the IETF 111 week on Wednesday July 28 at 18:00 UTC.

Details are here:

https://trac.ietf.org/trac/ietf/meeting/wiki/111sidemeetings <https://trac.ietf.org/trac/ietf/meeting/wiki/111sidemeetings>

If you’re interested or have been engaging so far, I encourage you to show up!

Best,
Tommy (as IPPM co-chair)

> On Jul 1, 2021, at 10:44 AM, [email-masked] wrote:
> 
> IPPM,
>

---

From: Tommaso Pecorella <[email-masked]>
Date: Wed, 7 Jul 2021 15:56:09 +0200

Hi all,

I’d like to share my 2cents on some points that have been mentioned about encryption use in PDMv2.

Yes, encryption will add some delays to the PDM processing. In particular we expect delays in the following points:
- Encryption and decryption time
- Packet transmission
- Key renewal
- Registration phase time

Encryption and decryption time shouldn’t be a major concern since PDMv2 is an end-to-end header, and we assume that end devices will have enough processing power. Moreover, the data to encrypt is small and fixed-length. Hence, the encryption can be considered as a near-constant-time operation (caveats apply, we’ll discuss about them in the presentation). 

Packet transmission (encrypted headers are larger) can be taken into account as well, as the size is known in advance.

Key renewal can be optimized, so that it doesn’t affect the packet processing time.

Registration phase is a one-time phase that should happen very infrequently, and it is not going to affect the actual PDMv2 packet flow.

We do not expect any other significant points of time degradation due to encryption and decryption. Of course we might find something we don’t expect, and that’s why we always welcome comments and suggestions.

Last but not least, even if Encryption is important (for confidentiality and integrity), we want to stress that encryption is optional.
If the network administrator can be reasonably sure that an attacker can not leverage PDMv2 headers to build an attack on the infrastructure, then encryption can be skipped.

In the RFC we will fully describe why confidentiality and integrity are important, what kind of attacks we foresee if the headers are not protected, and what countermeasures the network administrator can use as a substitute of header encryption.

Best regards,

Tommaso and Adnan

> On 5 Jul 2021, at 18:52, Ameya Deshpande <ameyanrd=[email-masked]> wrote:
> 
> Hi Paolo,
> 
> When using encrypted PDMv2, we have a bigger packet to send as
> the size of encrypted data is more than the corresponding plaintext data.
> This can increase the timing slightly as the packet size has increased.
> 
> For using encrypted PDMv2, we have an initial registration phase where
> we negotiate the shared secret (using KEM). We have also given a registration
> mechanism for enterprises with many servers and clients. However, this will
> be done before transmitting PDMv2 packets.
> 
> We intend to have a side-meeting where we will explain HPKE and be able
> to thoroughly discuss these points.  When we are able to schedule it, we will
> let you know.  The registration to schedule side meetings has not yet opened.
> 
> Thanks,
> Ameya Deshpande
> the same reason you mentioned. Connections over encrypted medium (say VPN tunnels),
> link-local network, or any secured company domain can choose to use PDMv2 unencrypted.
> 
> Yes, for a PDM-to-PDM machine, the round trip time, a.k.a DELTATLS, will include the two encryption
> and two decryption times. We are trying our best to minimize any added timing due to the encryption
> in PDMv2, but we feel that encryption is important, so we're trying to achieve a correct balance.
> 
> Thanks,
> Ameya Deshpande
> 
> [Posting for some of the co-authors.]
> We fully agree with your concerns. However, we’re confident that HPKE will reach the RFC status soon. Moreover, also other protocols (e.g., MLS, see https://www.ietf.org/archive/id/draft-ietf-mls-architecture-06.txt <https://www.ietf.org/archive/id/draft-ietf-mls-architecture-06.txt>) are using it.
> About HPKE itself, there are two different aspects to consider: HPKE (as an architecture, API, etc.) and the cryptographic functions used by HKPE. While HPKE is still in draft, the cryptographic functions are well-known and proven. Hence, we don’t expect any concern related to the encryption methods used by HPKE.
> The fact that Tommy confirms that it is being implemented and deployed reinforces our confidence on the fact that its availability is not going to be a critical point.
> 
> From: ippm <[email-masked] <mailto:[email-masked]>> On Behalf Of [email-masked] <mailto:[email-masked]>
> To: IETF IPPM WG <[email-masked] <mailto:[email-masked]>>
> Cc: [email-masked] <mailto:[email-masked]>
> [Actual Sender is [email-masked] <mailto:[email-masked]>]
> 
> IPPM,
> 
> https://smex12-5-en-ctp.trendmicro.com:443/wis/clicktime/v1/query?url=www.insidethestack.com&umid=61654d20-9615-453c-80b2-c06c82268e9d&auth=3c97381e9a30865a1a3f3ad58750d85b2b059558-86a3cb083390e2163fd0daaf45646c2a55adf702 <https://smex12-5-en-ctp.trendmicro.com/wis/clicktime/v1/query?url=www.insidethestack.com&umid=61654d20-9615-453c-80b2-c06c82268e9d&auth=3c97381e9a30865a1a3f3ad58750d85b2b059558-86a3cb083390e2163fd0daaf45646c2a55adf702>
> (831) 659-8360
> 
> 
> 
> 
> 
> 
> On Tuesday, June 1, 2021, 09:06:39 AM PDT, [email-masked] <mailto:[email-masked]> <[email-masked] <mailto:[email-masked]>> wrote: 
> 
> 
> 
> 
> 
> Hello IPPMers!
> 
> https://smex12-5-en-ctp.trendmicro.com:443/wis/clicktime/v1/query?url=www.insidethestack.com&umid=61654d20-9615-453c-80b2-c06c82268e9d&auth=3c97381e9a30865a1a3f3ad58750d85b2b059558-86a3cb083390e2163fd0daaf45646c2a55adf702 <https://smex12-5-en-ctp.trendmicro.com/wis/clicktime/v1/query?url=www.insidethestack.com&umid=61654d20-9615-453c-80b2-c06c82268e9d&auth=3c97381e9a30865a1a3f3ad58750d85b2b059558-86a3cb083390e2163fd0daaf45646c2a55adf702>
> (831) 659-8360
> 
> 
> 
> 
> 
> 
> From: "[email-masked] <mailto:[email-masked]>" <[email-masked] <mailto:[email-masked]>>
> To: [email-masked] <mailto:[email-masked]> <[email-masked] <mailto:[email-masked]>>; Adnan Rashid <[email-masked] <mailto:[email-masked]>>; Ameya Deshpande <[email-masked] <mailto:[email-masked]>>; Michael Ackermann <[email-masked] <mailto:[email-masked]>>; Nalini Elkins <[email-masked] <mailto:[email-masked]>>; Tommaso Pecorella <[email-masked] <mailto:[email-masked]>>
> URL:            https://www.ietf.org/archive/id/draft-elkins-ippm-encrypted-pdmv2-00.txt <https://www.ietf.org/archive/id/draft-elkins-ippm-encrypted-pdmv2-00.txt>
> Status:        https://datatracker.ietf.org/doc/draft-elkins-ippm-encrypted-pdmv2/ <https://datatracker.ietf.org/doc/draft-elkins-ippm-encrypted-pdmv2/>
> Htmlized:      https://datatracker.ietf.org/doc/html/draft-elkins-ippm-encrypted-pdmv2 <https://datatracker.ietf.org/doc/html/draft-elkins-ippm-encrypted-pdmv2>
> 
> 
> Abstract:
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/ippm <https://www.ietf.org/mailman/listinfo/ippm>
> 
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/ippm <https://www.ietf.org/mailman/listinfo/ippm>
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/ippm <https://www.ietf.org/mailman/listinfo/ippm>
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/ippm <https://www.ietf.org/mailman/listinfo/ippm>
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/ippm <https://www.ietf.org/mailman/listinfo/ippm>

--------------------------------------------------------------

When life gives you lemons, don’t make lemonade.
Make life take the lemons back! Get mad!
-- Cave Johnson

--------------------------------------------------------------

Tommaso Pecorella - Ph.D.

Assistant professor
Dpt. Ingegneria dell'Informazione
Università di Firenze

CNIT - Università di Firenze Unit

via di S. Marta 3
50139, Firenze
ITALY

email: [email-masked]
       [email-masked]

phone : +39-055-2758540
mobile: +39-320-4379803
fax   : +39-055-2758570

---

From: Ameya Deshpande <[email-masked]>
Date: Wed, 28 Jul 2021 18:00:46 +0000 (UTC)

Hi IPPM,
Greetings!
We are about to start the side meeting on PDMv2 and HPKE in 5 mins.

Zoom link: https://zoom.us/j/7058470584?pwd=SURkcmxIcHRqWVBiTVI0SXJJYS84dz09

Thanks,Ameya Deshpande

    On Wednesday, 7 July, 2021, 8:52:28 am IST, Tommy Pauly <tpauly=[email-masked]> wrote:  
 
 Hi IPPM,
To help discuss the PDMv2 proposal, and clarify the use of HPKE, Nalini has set up a side meeting during the IETF 111 week on Wednesday July 28 at 18:00 UTC.
Details are here:
https://trac.ietf.org/trac/ietf/meeting/wiki/111sidemeetings
If you’re interested or have been engaging so far, I encourage you to show up!
Best,Tommy (as IPPM co-chair)

Thanks,

Nalini Elkins
CEO and Founder
Inside Products, Inc.
www.insidethestack.com
(831) 659-8360

Hello IPPMers!

Thanks,

Nalini Elkins
CEO and Founder
Inside Products, Inc.
www.insidethestack.com
(831) 659-8360

----- Forwarded Message -----

Abstract:

The IETF Secretariat