Subject: [ippm] Refresh of IOAM drafts for "raw export" and "ethertype encap"

From: "Frank Brockners (fbrockne)" <[email-masked]>
Date: Mon, 21 Feb 2022 11:57:38 +0000

Dear IPPM,

new versions of
* “EtherType Protocol Identification of In-situ OAM Data” (draft-weis-ippm-ioam-eth-05) and
* “In-situ OAM raw data export with IPFIX” (draft-spiegel-ippm-ioam-rawexport-06)
are now available.

I decided to refresh the drafts, to allow for a discussion at our upcoming meeting on the path forward for the two drafts. Both drafts are around for quite some time – and haven’t seen a lot of updates nor discussion recently. In the past, we considered both drafts as important: The “Ethertype encap”, because it allowed for a generic approach to carry IOAM data fields with GRE or Geneve; the “raw export”, because we considered a standards-based approach to export IOAM data from a node as important (given that right now, different implementations follow their own approach).

Tommy, Marcus – it would be great if you could allocate a brief slot on the IPPM WG agenda for the discussion, with the objective to decide whether we want to evolve the drafts and WG-adopt them.

Thanks a lot, Frank

---

From: Tommy Pauly <[email-masked]>
Date: Tue, 22 Feb 2022 16:18:28 -0800

Hi Frank,

I recall this being presented several years ago. In that discussion, the discussion of allocating an Ethertype was something that was going to need to be brought up with IEEE. Was this done at any point?

I’d also like to understand how many people would intend to adopt and use these specifications; the ethertype specifically seems like it is not part of the remit of this group (unless we have a particular drive for it), and this could be progressed another way.

Thanks,
Tommy

> On Feb 21, 2022, at 3:57 AM, Frank Brockners (fbrockne) <[email-masked]> wrote:
> 
> Dear IPPM,
>  
> new versions of

---

From: "Frank Brockners (fbrockne)" <[email-masked]>
Date: Wed, 23 Feb 2022 10:44:24 +0000

Hi Tommy,

Please see the attached emails from Donald and Brian on the earlier discussion on Ethertype allocation.

From how I understand Donald’s guidance, in a nutshell, we’d require
1. WG adopted document with WG consensus (one can read this as WG last call completed)
2.  IESG needs to formally apply for an Ethertype with IEEE

Having a discussion on whether IPPM would take on draft-weis-ippm-ioam-eth-05 would be a first step towards (1.).

Cheers, Frank

From: Tommy Pauly <[email-masked]>
Sent: Wednesday, 23 February 2022 01:18
To: Frank Brockners (fbrockne) <[email-masked]>
Cc: [email-masked]; IPPM Chairs <[email-masked]>
Subject: Re: Refresh of IOAM drafts for "raw export" and "ethertype encap"

Hi Frank,

Thanks,
Tommy

On Feb 21, 2022, at 3:57 AM, Frank Brockners (fbrockne) <[email-masked]<mailto:[email-masked]>> wrote:

Dear IPPM,

new versions of

Thanks a lot, Frank

Subject: Re: allocating ethertypes for IOAM encapsulations: draft-weis-ippm-ioam-eth
From: "Brian Trammell (IETF)" <[email-masked]>
To: Donald Eastlake <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, "Frank Brockners (fbrockne)" <[email-masked]>
Date: Wed, 27 Mar 2019 09:57:39 +0000

hi Donald,

Many thanks, this is very helpful.

We'll have to have a discussion in the WG as to the process tradeoffs here.

Cheers,

Brian

> On 27 Mar 2019, at 10:37, Donald Eastlake <[email-masked]> wrote:
>
> Hi,
>
> So, a bunch of things:
>
> The IANA registry for Ethertypes is Informational. The authority for
> Ethertype assignment is the IEEE Registration Authority (RA),
> available at https://standards.ieee.org/products-services/regauth/index.html.
> Normally there would be no charge by the IEEE for an Ethertype
> assigned for standards use in the IETF.
>
> There are two "Local Experimental" EtherTypes assigned by IEEE for
> experimentation/development: 0x88B5 and 0x88B6.
>
> The IESG has established a policy on IETF requests for Ethertypes,
> documented here:
> https://www6.ietf.org/iesg/statement/ethertypes.html
>
> This is all a fairly heavyweight process. I don't follow IPPM but I
> think it unlikely the IESG would approve your applying for an
> Ethertype assignment without WG adoption and WG consensus for the
> draft.
>
> When an Ethertype assignment request gets to the IEEE RA, one thing
> they look for is a version number in the information identified by
> that Ethertype. Since Ethertypes are a limited resource, they do not
> want you coming back asking for another one just because your
> information has changed a bit.
>
> Hope the above helps. Feel free to ask if you have more questions.
>
> Thanks,
> Donald
> ===============================
> Donald E. Eastlake 3rd   +1-508-333-2270 (cell)
> 1424 Pro Shop Court, Davenport, FL 33896 USA
> [email-masked]
>
>
> On Mon, Mar 25, 2019 at 6:45 AM Brian Trammell (IETF) <[email-masked]> wrote:
>>
>> hi Donald,
>>
>> I'm writing you in your capacity as the IANA expert for the ethertypes registry. IPPM discussed draft-weis-ippm-ioam-eth today, which wants to allocate an ethertype to be used for IOAM (In-Situ OAM, which adds metadata to tunnels for measurement purposes) in protocols that use ethertypes as a next-protocol header (GRE and Geneve); as IPPM chair, I took an AI to help them figure out the right way to do this.
>>
>> Can you point us to the process here, or is "ask IANA to ask the expert" the process?
>>
>> Thanks, cheers,
>>
>> Brian
>