Subject: Re: [ippm] New Version Notification for draft-li-ippm-otwamp-on-lag-02.txt

From: "[email-masked]" <[email-masked]>
Date: Mon, 7 Feb 2022 10:24:02 +0800

Hi Jeff and Haoyu,

The effect of load balencing in LAG depends on the implementation. It is common now to use 1 or 10 links in a LAG even in backbone networks. It is up to the operator to determine the number of member links used in  a LAG, usually taking into account both the requirement of the traffic and the ability of the devices. 

The figure and text in our docs are used to show the case that it is necessary to extend TWAMP/OWAMP/STAMP to measure the performance of each link in a LAG. We have no intent to present a BCP for the nember of member links in a LAG.

Best Regards,
Zhenqiang Li

[email-masked]
 
From: Haoyu Song
Date: 2022-02-05 03:02
To: Jeff Tantsura; Tianran Zhou; IETF IPPM WG ([email-masked])
Subject: Re: [ippm] New Version Notification for draft-li-ippm-otwamp-on-lag-02.txt
Hi Jeff,
 
It’s interesting to know. Any idea how the load is balanced on the odd number of links?
BTW, in your example, a single link is also power of 2 (i.e., 2^0) and there’s no need for load balancing.
 
Best,
Haoyu
 
From: Jeff Tantsura <[email-masked]> 
Sent: Friday, February 4, 2022 10:57 AM
To: Tianran Zhou <zhoutianran=[email-masked]>; Haoyu Song <[email-masked]>; IETF IPPM WG ([email-masked]) <[email-masked]>
Subject: RE: [ippm] New Version Notification for draft-li-ippm-otwamp-on-lag-02.txt
 
Hi,
 
Wrt power of two comment from Haoyu.
This used to be the case in the early days because of poorly implemented load-balancing in the silicon, it was often the case that with odd number of constituents we’d see a rather uneven distribution.
Most of these issues have been fixed in the last 3 years, these days - it is very common (especially in DC) to use a LAG as an operational construct and  provision a LAG with a single link, so the future upgrade doesn’t require changes to L3 infra.
 
I don’t’ think there a need to update the drawing nor to explicitly mentioning  “power of two” assumption anywhere in the text .
 
Cheers,
Jeff
 
From: Tianran Zhou
Sent: Monday, January 24, 2022 5:06 PM
To: Haoyu Song; Tianran Zhou; IETF IPPM WG ([email-masked])
Subject: Re: [ippm] New Version Notification for draft-li-ippm-otwamp-on-lag-02.txt
 
Hi Haoyu,
 
Thanks very much for your comments. Your perspective is correct.
I will revise the document in the next version.
 
Best,
Tianran
 
-----Original Message-----
From: ippm [mailto:[email-masked]] On Behalf Of Haoyu Song
Sent: Tuesday, January 25, 2022 1:07 AM
To: Tianran Zhou <zhoutianran=[email-masked]>; IETF IPPM WG ([email-masked]) <[email-masked]>
Subject: Re: [ippm] New Version Notification for draft-li-ippm-otwamp-on-lag-02.txt
 
WG,
 
I think the scenario for LAG performance measurement is practical and the method is sound, so I support this work.
For Figure 1, I think usually for load balancing with hashing, the number of links of a LAG would be power of two.
 
Best,
Haoyu Song
 
-----Original Message-----
From: ippm <[email-masked]> On Behalf Of Tianran Zhou
Sent: Sunday, January 23, 2022 10:23 PM
To: IETF IPPM WG ([email-masked]) <[email-masked]>
Subject: [ippm] FW: New Version Notification for draft-li-ippm-otwamp-on-lag-02.txt
 
Hi WG,
 
We think this is an useful work on adapting OWAMP/TWAMP in LAG performance measurement.
We updated this draft based on the comments from the meeting discussion and mailing list.
Thanks for all the suggestions.
More reviews and comments are welcome.
 
Cheers,
Tianran
 
-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Monday, January 24, 2022 2:17 PM
To: Greg Mirsky <[email-masked]>; Guo Jun <[email-masked]>; Jun Guo <[email-masked]>; Rakesh Gandhi <[email-masked]>; Tianran Zhou <[email-masked]>; Zhenqiang Li <[email-masked]>
Subject: New Version Notification for draft-li-ippm-otwamp-on-lag-02.txt

A new version of I-D, draft-li-ippm-otwamp-on-lag-02.txt
has been successfully submitted by Tianran Zhou and posted to the IETF repository.
 
Name:               draft-li-ippm-otwamp-on-lag
Revision:           02
Title:                  One-way/Two-way Active Measurement Protocol Extensions for Performance Measurement on LAG
Document date:           2022-01-24
Group:               Individual Submission
Pages:               13
URL:            https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Farchive%2Fid%2Fdraft-li-ippm-otwamp-on-lag-02.txt&amp;data=04%7C01%7Chaoyu.song%40futurewei.com%7Ca16115736bab48d99c2f08d9df020bed%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637786022170908705%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=O1SD54x5%2FM99g7YjxnzaMjaZuJ9S4UxNGcm6NAkTXng%3D&amp;reserved=0
Status:         https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-li-ippm-otwamp-on-lag%2F&amp;data=04%7C01%7Chaoyu.song%40futurewei.com%7Ca16115736bab48d99c2f08d9df020bed%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637786022170908705%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=UYUXVf0BvrCuH20ydOjxCI26KjgpAopEIV40%2BqjuxKY%3D&amp;reserved=0
Htmlized:       https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-li-ippm-otwamp-on-lag&amp;data=04%7C01%7Chaoyu.song%40futurewei.com%7Ca16115736bab48d99c2f08d9df020bed%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637786022170908705%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=gN9hSIQaMM%2BE%2BtDLSFxe95J%2FyX4omBdv6rtBTMB4B8o%3D&amp;reserved=0
Diff:           https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Frfcdiff%3Furl2%3Ddraft-li-ippm-otwamp-on-lag-02&amp;data=04%7C01%7Chaoyu.song%40futurewei.com%7Ca16115736bab48d99c2f08d9df020bed%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637786022170908705%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=NPJcFQoHUAw47%2FJ%2BO4SeOLEaQUNe%2FAI4UDUGMA%2BKK%2Fo%3D&amp;reserved=0
 
Abstract:
   This document defines extensions to One-way Active Measurement
   Protocol (OWAMP), and Two-way Active Measurement Protocol (TWAMP) to
   implement performance measurement on every member link of a Link
   Aggregation Group (LAG).  Knowing the measured metrics of each member
   link of a LAG enables operators to enforce the performance based
   traffic steering policy across the member links.

The IETF Secretariat

_______________________________________________
ippm mailing list
[email-masked]
https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fippm&amp;data=04%7C01%7Chaoyu.song%40futurewei.com%7Ca16115736bab48d99c2f08d9df020bed%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637786022170908705%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=DHVbIOrP6nfAfjGnIl5N%2F%2B5B0O6qDonb%2F%2Beq2uTEJu4%3D&amp;reserved=0
 
_______________________________________________
ippm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ippm
 
_______________________________________________
ippm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ippm

---

From: Jeff Tantsura <[email-masked]>
Date: Mon, 7 Feb 2022 22:42:02 -0800

Hi Zhenqiang,

That was my point, to keep the drawing and text as is.

Cheers,
Jeff

> On Feb 6, 2022, at 18:23, [email-masked] wrote:
> 
> 
> Hi Jeff and Haoyu,
>