Subject: [ippm] I-D Action: draft-ietf-ippm-capacity-protocol-01.txt

From: [email-masked]
Date: Fri, 25 Feb 2022 11:13:27 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the IP Performance Measurement WG of the IETF.

        Title           : Test Protocol for One-way IP Capacity Measurement
        Authors         : Len Ciavattone
                          Al Morton
	Filename        : draft-ietf-ippm-capacity-protocol-01.txt
	Pages           : 32
	Date            : 2022-02-25

Abstract:
   This memo addresses the problem of protocol support for measuring
   Network Capacity metrics in RFC 9097, where the method deploys a
   feedback channel from the receiver to control the sender's
   transmission rate in near-real-time.  This memo defines a simple
   protocol to perform the RFC 9097 (and other) measurements.

   See Section 10: The authors seek feedback to determine what
   additional features will be necessary for an IETF Standards Track
   Protocol, beyond what is present in the running code available now.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-ippm-capacity-protocol/

There is also an htmlized version available at:
https://datatracker.ietf.org/doc/html/draft-ietf-ippm-capacity-protocol-01

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-ippm-capacity-protocol-01

Internet-Drafts are also available by rsync at rsync.ietf.org::internet-drafts

---

From: "MORTON JR., AL" <[email-masked]>
Date: Fri, 25 Feb 2022 19:50:44 +0000

Hi IPPM,

The authors have implemented/proposed some user-requested features in this update of the draft, including:

+ Implementation of Randomized payload option. Performance suggests very limited compressibility.
+ Server can set a BW limit for mission-control; Client would supply a max BW for its specific testing to help the server manage tests within its limit.
+ Optional Start rate for load-adjustment algorithm (fixed-rate option remains).
+ Backward compatibility: Servers can test with both protocol version 8 and version 9.

Delay and delay variation measurements during Capacity tests remain one of the protocol's strengths (loss too).

One way to evaluate the protocol is to try-out the running code [0].

We hope you'll make some time for review and comments leading-up to IETF-113.

Al and Len

[0] https://github.com/BroadbandForum/obudpst

> -----Original Message-----
> From: ippm <[email-masked]> On Behalf Of [email-masked]
> Sent: Friday, February 25, 2022 2:13 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: [ippm] I-D Action: draft-ietf-ippm-capacity-protocol-01.txt
> 
> 
> https://urldefense.com/v3/__https://datatracker.ietf.org/doc/draft-ietf-ippm-
> capacity-protocol/__;!!BhdT!hU7TX2-
> _MzrINiXgiMqcLWAvfe12cv2YVrKPpG8DWj_GZpVwifCpy7rCx28NK1EqCsK_Bk3Gu0hrpj77_BSPk
> A$
> 
> https://urldefense.com/v3/__https://datatracker.ietf.org/doc/html/draft-ietf-
> ippm-capacity-protocol-01__;!!BhdT!hU7TX2-
> _MzrINiXgiMqcLWAvfe12cv2YVrKPpG8DWj_GZpVwifCpy7rCx28NK1EqCsK_Bk3Gu0hrpj6L_rj1f
> w$
> 
> https://urldefense.com/v3/__https://www.ietf.org/rfcdiff?url2=draft-ietf-ippm-
> capacity-protocol-01__;!!BhdT!hU7TX2-
> _MzrINiXgiMqcLWAvfe12cv2YVrKPpG8DWj_GZpVwifCpy7rCx28NK1EqCsK_Bk3Gu0hrpj6ks1pSK
> A$
> 
> 
> _______________________________________________
> ippm mailing list
> [email-masked]
> https://urldefense.com/v3/__https://www.ietf.org/mailman/listinfo/ippm__;!!Bhd
> T!hU7TX2-
> _MzrINiXgiMqcLWAvfe12cv2YVrKPpG8DWj_GZpVwifCpy7rCx28NK1EqCsK_Bk3Gu0hrpj4g5dGdH
> Q$