Subject: [ippm] Adoption call for Encrypted PDMv2

From: Tommy Pauly <[email-masked]>
Date: Tue, 29 Mar 2022 09:19:18 -0700

Hello IPPM,

This email starts an adoption call in the IPPM working group for draft-elkins-ippm-encrypted-pdmv2-02, which updates PDM (RFC 8250) to add encryption to the data. This document was discussed at our meeting at IETF 113, and has had several side meetings.

https://datatracker.ietf.org/doc/draft-elkins-ippm-encrypted-pdmv2/ <https://datatracker.ietf.org/doc/draft-elkins-ippm-encrypted-pdmv2/>
https://datatracker.ietf.org/doc/html/draft-elkins-ippm-encrypted-pdmv2 <https://datatracker.ietf.org/doc/html/draft-elkins-ippm-encrypted-pdmv2>

Please reply to this email by April 12, 2022, to indicate if you support adopting this document.

Best,
Tommy & Marcus

---

From: "Ackermann, Michael" <[email-masked]>
Date: Tue, 29 Mar 2022 16:50:43 +0000

As an Enterprise representative,  I strongly support this document and work.

As Enterprises deploy IPv6,  they will want/need better management, monitoring and diagnostic capabilities.   Extension Headers and   PDM (rfc8250) in particular,  can provide this in an embedded, accurate, non disruptive,  and FREE way.     This will be critical to successful deployments.

As Security (and related sub topics), continue to evolve and gain in importance,  to enterprises and others,  the ability to control and protect information on our networks, becomes increasingly important.     There is currently no good solution for providing these levels of protection on  Extension Header data,  for PDM data and for EH data in general.    And this is NOT an easy, simple or swift solution to design and implement.
 This is a huge gap that must be addressed and is what the PDMv2 project is doing and seems to have made incredible progress on.

Once again strong support for this work!

Thanks

Mike

From: ippm <[email-masked]> On Behalf Of Tommy Pauly
Sent: Tuesday, March 29, 2022 12:19 PM
To: IETF IPPM WG ([email-masked]) <[email-masked]>
Subject: [ippm] Adoption call for Encrypted PDMv2

[External email]
Hello IPPM,

https://datatracker.ietf.org/doc/draft-elkins-ippm-encrypted-pdmv2/
https://datatracker.ietf.org/doc/html/draft-elkins-ippm-encrypted-pdmv2

Best,
Tommy & Marcus

The information contained in this communication is highly confidential and is intended solely for the use of the individual(s) to whom this communication is directed. If you are not the intended recipient, you are hereby notified that any viewing, copying, disclosure or distribution of this information is prohibited. Please notify the sender, by electronic mail or telephone, of any unintended receipt and delete the original message without making any copies.
 
 Blue Cross Blue Shield of Michigan and Blue Care Network of Michigan are nonprofit corporations and independent licensees of the Blue Cross and Blue Shield Association.

This message was secured by Zix(R).

---

From: "Hamilton, Robert" <[email-masked]>
Date: Tue, 29 Mar 2022 19:27:18 +0000

As one of the authors of RFC8250, I feel this is a valuable addition to the PDM Extension Header, protecting what is important network performance and monitoring data. As our IPv6 networks expand it will be important to maintain the reliability and integrity of the data that says how well these networks are working.

I strongly support this document and the work going into it.

R;

Rob Hamilton
Infrastructure Engineer
Chemical Abstracts Service

From: ippm <[email-masked]> On Behalf Of Tommy Pauly
Sent: Tuesday, March 29, 2022 12:19 PM
To: IETF IPPM WG ([email-masked]) <[email-masked]>
Subject: [EXT] [ippm] Adoption call for Encrypted PDMv2

[Actual Sender is [email-masked]<mailto:[email-masked]>]
Hello IPPM,

Best,
Tommy & Marcus
Confidentiality Notice: This electronic message transmission, including any attachment(s), may contain confidential, proprietary, or privileged information from CAS, a division of the American Chemical Society ("ACS"). If you have received this transmission in error, be advised that any disclosure, copying, distribution, or use of the contents of this information is strictly prohibited. Please destroy all copies of the message and contact the sender immediately by either replying to this message or calling 614-447-3600.

---

From: Greg Mirsky <[email-masked]>
Date: Wed, 30 Mar 2022 09:20:11 -0700

Hi Tommy,
I've read the draft. It is well-written and adds an essential functionality
to PDM. I support the adoption of the draft.

Regards,
Greg

On Tue, Mar 29, 2022 at 9:19 AM Tommy Pauly <tpauly=
[email-masked]> wrote:

> Hello IPPM,
>
> This email starts an adoption call in the IPPM working group
> for draft-elkins-ippm-encrypted-pdmv2-02, which updates PDM (RFC 8250) to
> add encryption to the data. This document was discussed at our meeting at
> IETF 113, and has had several side meetings.
>
> Please reply to this email *by April 12, 2022*, to indicate if you
> support adopting this document.
>
> Best,
> Tommy & Marcus
> _______________________________________________
> ippm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ippm
>

---

From: Giuseppe Fioccola <[email-masked]>
Date: Thu, 31 Mar 2022 12:09:26 +0000

Hi Tommy, All,
I have read the draft and I support its adoption.
It adds an important feature to PDM, indeed PDMv2 introduces confidentiality, integrity and authentication to the base RFC8250.
I think that the protocol flow described in the document may also be a future reference for other methodologies that uses Option Headers embedded in the packets.

Regards,

Giuseppe

From: ippm <[email-masked]> On Behalf Of Tommy Pauly
Sent: Tuesday, March 29, 2022 6:19 PM
To: IETF IPPM WG ([email-masked]) <[email-masked]>
Subject: [ippm] Adoption call for Encrypted PDMv2

Hello IPPM,

Best,
Tommy & Marcus

---

From: <[email-masked]>
Date: Fri, 1 Apr 2022 08:49:07 +0800 (CST)

Hi Tommy and Marcus,

I support WG adoption of this draft.

Best Regards,
Xiao Min
------------------原始邮件------------------
发件人：TommyPauly
收件人：IETF IPPM WG ([email-masked]);
日 期 ：2022年03月30日 00:19
主 题 ：[ippm] Adoption call for Encrypted PDMv2
_______________________________________________
ippm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ippm

Hello IPPM,
This email starts an adoption call in the IPPM working group for draft-elkins-ippm-encrypted-pdmv2-02, which updates PDM (RFC 8250) to add encryption to the data. This document was discussed at our meeting at IETF 113, and has had several side meetings.
https://datatracker.ietf.org/doc/draft-elkins-ippm-encrypted-pdmv2/https://datatracker.ietf.org/doc/html/draft-elkins-ippm-encrypted-pdmv2
Please reply to this email by April 12, 2022, to indicate if you support adopting this document.
Best,
Tommy & Marcus