Subject: drafts

From: Steve Bellovin <[email-masked]>
Date: Tue, 09 Jul 2002 09:40:55 -0400

Folks should take a look at draft-bradner-ipr-technology-00.txt and
draft-bradner-submission-rights-00.txt.  (We're not a working group 
yet, so the drafts aren't draft-ietf-ipr...)

		--Steve Bellovin, http://www.research.att.com/~smb (me)
		http://www.wilyhacker.com ("Firewalls" book)

_______________________________________________
Ipr-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipr-wg

---

From: Riegel Maximilian <[email-masked]>
Date: Thu, 18 Jul 2002 02:46:17 +0200

It is my experience that RFC2026 does not provide much guidance in 
explaining the concrete actions to be taken for IPR declarations. 
draft-bradner-ipr-technology-00 provides more details but I found it is 
still missing to be a complete description of the procedure. Why?

Let's outline the procedure:
(references are made to draft-bradner-ipr-technology-00):

   [6.1 How to make a disclosure
     - send a message to [email-masked]]

   [6.2 Contents of a disclosure
     - claim as specific as possible
     - reference to the IETF contribution(s), to which the claim applies
     - (optional) licensing terms]

A problem arises with the reference to the IETF contribution, if
the reference points to a tempory document like an Internet Draft,
or the reference can't be made, as there is nothing to point to
(like a verbal statement during an IETF meeting).

   When to make a disclosure:

There are two cases to consider, own submissions and submission of others.

   [9.1  IPR claimed in contributions to the IETF
      If an author, contributor, or editor of a document being submitted
      for publication as an Internet Draft knows of IPR related to the
      technology covered by the submission, the author must submit an IPR
      disclosure at the same time...]

This statement does only mention Internet Drafts, but does nothing explain 
about
- email submissions to IETF mailing lists
- verbal submissions during IETF meetings

   [9.2.  IPR claimed in contributions by others]

Also in this case at least three different cases should be considered:
- Internet Draft (what is happening when the I-D gets updated, loosing
   the exact reference)
- email submission to IETF mailing lists
- verbal submissions during IETF meetings

Hopefully this shows the points I found likely to be missing.
Bye
Max
-- 
_____________________________________________________
Maximilian Riegel, <[email-masked]>
ICM N Advanced Standards & Fora; Ph: +49 89 722 49557