Subject: AW: what "relates"?

From: Sebestyen Istvan ICN M SR 3 <[email-masked]>
Date: Thu, 18 Jul 2002 08:56:58 +0200

Hi,

As a not IETF participant, I am less familiar with all the details of the
IETF IPR policy and practice, but the original question is in my view a
valid one. Randy describes a case when one could use a so-called
"non-essential" patent in an implementation. Several standards bodies tend
to concentrate only on "essential" patents (those that are believed to be
needed in all implementation, so there is no "work around"). So, the
question is legitimate: What about "non-essential" patents? Is there a
requirement to inform the IETF standards developing communinity about its
existence? My "fair-play" feeling would be "yes", such information would be
useful to know. Of course, I would say, I would require such information on
"best effort" basis.

Regards,
Istvan Sebestyen   

-----Ursprungliche Nachricht-----
Von: Randy Presuhn [mailto:[email-masked]]
Gesendet: Donnerstag, 18. Juli 2002 03:55
An: [email-masked]
Betreff: Re: what "relates"?

Hi -

> Date: Thu, 18 Jul 2002 10:19:58 +0900
> From: Scott Brim <[email-masked]>
> To: Randy Presuhn <[email-masked]>
> Cc: [email-masked]
> Subject: Re: what "relates"?
> Message-ID: <[email-masked]>
> References: <[email-masked]>
...
> > It would be really nice if the BOF discussion went into the question
> > of what is meant by "relates".  Specifically, I'm curious about this
> > scenario:
> > 
> > 	Specification requires that data must be sorted,
> > 	but does not dictate which sort algorithm to use.
> > 	(Specification of the choice of mechanism is not
> > 	necessary for interoperability.)  A particpant's
> > 	company has patented bubble sort (a possible, though
> > 	not necessarily optimal mechanism), and participant
> > 	is aware of patent.  Must participant disclose?
> 
> (1) Ask your lawyer.  (2) ianalbimho if you think that in the future you
> might want to inform anyone, another company in your area or a consumer,
> of what you believe your rights are in relation to the specification,
> you should disclose now.
...

I am not asking for legal advice.  I already know that lawyers
tend to read "related" rather broadly.  I seek clarification
of the clarification of 2026, in order to ensure that we
all understand when the IETF process is intended to require
notification.

I repeat the question: for the example given above, would
the process (either currently or as clarified) require
notification?

 ------------------------------------------------------
 Randy Presuhn          BMC Software, Inc.  1-3141
 [email-masked]  2141 North First Street
 Tel: +1 408 546-1006   San Jose, California 95131  USA
 ------------------------------------------------------
 My opinions and BMC's are independent variables.
 ------------------------------------------------------

_______________________________________________
Ipr-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipr-wg

_______________________________________________
Ipr-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipr-wg

---

From: Pekka Savola <[email-masked]>
Date: Thu, 18 Jul 2002 10:01:56 +0300 (EEST)

> useful to know. Of course, I would say, I would require such information on

There are two cases in the original scenario:

1) company has patented a sorting algorithm ('bubble sort') in general
2) company has patented a sorting algorithm for this specific scenario.

IMO, it does not seem necessary to inform of 1); implementors should be
aware of sorting patents if they have to implement sorting.

On the countrary, 2) maybe should be informed in the spirit of 
"fair-play".  A specific patent, one that you would assume people may not 
have come up with before, in other circumtances, might catch people 
unawares.

-- 
Pekka Savola                 "Tell me of difficulties surmounted,
Netcore Oy                   not those you stumble over and fall"
Systems. Networks. Security.  -- Robert Jordan: A Crown of Swords