Subject: RE: Rechartering to focus on problem

From: Powers Chuck-rxcp20 <[email-masked]>
Date: Wed, 19 Mar 2003 13:02:40 -0700

Larry,

   No, what I am really interested in is spending a couple more years being demonized as an evil patent holder out to control the world by those who don't have patents (whether by choice or not), but who want access to anyone else's patents, regardless of the R&D costs which might have gone into creating them, if it appears they are attractive to a wide audience.

<rant>

   Personally, I am growing tired of the attempts to paint "software patents" as some new evil which creates a unique minefield for software developers, who might never know if they are infringing someone else's patent or not. This is not a "new" issue at all, nor is it unique to the software space; it is just (apparently) new to software developers.

   Those of us who have spent years in hardware know that the exact same issues have always existed - there is not a hardware developer out there who is not aware that any design could infringe someone else's patent claim, issued or not. It is something that the hardware developers have chosen to deal with pragmatically, even in standards, while apparently some in the software community think that software requires special rules. Have some of the patents issue in the software space been dumb, obvious, etc? Sure. So have a lot that have been granted in the hardware space. So what? It didn't bring the entire hardware industry to its knees, and IMO it won't have that impact on the software industry, either.

   Last time I checked, the Internet runs on both hardware and software, and no one has yet made a viable case that the Internet will come crashing down if some licensable technology is used in either component.

</rant>

   Again, my opinion is that rechartering the working group at this time would be premature.

chuck

> -----Original Message-----
> From: Lawrence E. Rosen [mailto:[email-masked]]
> Sent: Wednesday, March 19, 2003 1:00 PM
> To: 'Powers Chuck-rxcp20'; 'Allen Lo'; 'Brian E Carpenter';
> [email-masked]
> Subject: RE: Rechartering to focus on problem
> 
> 
> Hi Chuck,
> 
> Let me make sure I understand your proposal.  Motorola wants at least
> 1-2 years more in which to mine its patent portfolio for possible
> assertion against IETF's standards without incurring any RF licensing
> obligation?
> 
> I vote NO.
> 
> /Larry Rosen
> 
> > -----Original Message-----
> > From: [email-masked] [mailto:[email-masked]] On 
> > Behalf Of Powers Chuck-rxcp20
> > Sent: Wednesday, March 19, 2003 6:58 AM
> > To: 'Allen Lo'; Brian E Carpenter; [email-masked]
> > Subject: RE: Rechartering to focus on problem
> > 
> > 
> > If the idea of creating the "new code" was intended to 
> > clarify the current policy, but not actually solve problems, 
> > then the new code would never have been developed in the 
> > first place. In fact, the entire purpose of the IPR working 
> > group has been to clarify the existing policy, and therefore 
> > fix most (if not all) of the problems encountered to date by 
> > the IETF, and the group is well on their way to doing this 
> > with the completion of the three documents.
> > 
> > As I see it, the attempt to change the IETF IPR policy is not 
> > an attempt to actually fix an existing problem, but to try 
> > and promote "RAND" as a major problem in the IETF (which it 
> > has not really been), and then claim it can only be fixed by 
> > adopting an RF-only IPR policy.
> > 
> > Brian is spot-on: We need to allow the new code to run for 
> > some period of time (1-2 years) before it can be determined 
> > if any _real_ (as opposed to theoretical) problems still 
> > exist. Rechartering before this has occured would be 
> > premature, at best.
> > 
> > In addition, for those touting the W3C policy as "the 
> > solution" the IETF should adopt, it would also be foolish to 
> > adopt that model until it has been proven to work, as well. 
> > While some folks claim that the W3C has "fixed" the problem, 
> > in fact nothing related to actually developing technical 
> > standards has been shown to be fixed; a new IPR policy has 
> > been drafted, and now we must await the inevitable train 
> > wreck that will ensue as the W3C attempts to implement the 
> > policy. I would give that 1-2 years as well, before passing 
> > judgment on whether or not it actually had any positive 
> > impact on the W3C's ability to develop standards.
> > 
> > Lastly, the FTC hearings last year were not about discussing 
> > "the anti-competitiveness of RAND in standards"; they were 
> > about the effect of IPR in standards overall, and many valid 
> > presentations were made which supported the RAND model, which 
> > is why many major standards development organizations support 
> > that model, and will continue to do so, without interference 
> > from the FTC.
> > 
> > chuck
> > 
> > > -----Original Message-----
> > > From: Allen Lo [mailto:[email-masked]]
> > > Sent: Wednesday, March 19, 2003 12:08 AM
> > > To: Brian E Carpenter; [email-masked]
> > > Subject: RE: Rechartering to focus on problem
> > > 
> > > 
> > > It's been made very clear throughout the process that the
> > > "new code" is
> > > only a clarification of existing policy, not a change of 
> > that policy.
> > > Whatever problems existed before (at the very least, the ones 
> > > I noted in
> > > my original message) will still exist.  I don't expect we 
> > should have
> > > perfect information.  But I think it is fair to try to 
> have the best
> > > information so we can assess whether changes are needed.  I don't
> > > understand what the downside is.
> > 
> > 
> > > 
> > > > -----Original Message-----
> > > > From: Brian E Carpenter [mailto:[email-masked]]
> > > > Sent: Tuesday, March 18, 2003 8:31 PM
> > > > To: [email-masked]
> > > > Subject: Re: Rechartering to focus on problem
> > > > 
> > > > I also heard the statement that we should run the new 
> > code (i.e. the
> > > > clarified documents) for a reasonable time, such as a 
> year, before
> > > > attempting to judge whether there actually is anything broken
> > > > that needs fixing. [I heard that statement because I 
> made it, but
> > > > people seemed to agree.]
> > > > 
> > > > In other words, rechartering *now* would simply be 
> > > premature, because
> > > > we have no basis for making judgements about the clarified 
> > > documents.
> > > > 
> > > >    Brian
> > > _______________________________________________
> > > Ipr-wg mailing list
> > > [email-masked]
> > > https://www1.ietf.org/mailman/listinfo/ipr-wg
> > > 
> > _______________________________________________
> > Ipr-wg mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/ipr-wg
> > 
> 
_______________________________________________
Ipr-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipr-wg

---

From: Spencer Dawkins <[email-masked]>
Date: Wed, 19 Mar 2003 12:34:36 -0800 (PST)

I am sympathetic to one point here - could we focus on
rechartering, and not guessing what motivations for someone's
position might or might not be?

My personal guess is that we'd probably be surprised by a lot of
people's motivations, but none of the motivations matter to THIS
question.

Spencer

--- Powers Chuck-rxcp20 <[email-masked]> wrote:
> Larry,
> 
>    No, what I am really interested in is spending a couple
> more years being demonized as an evil patent holder out to
> control the world 

[snipped WAY too much replied text, and that's a problem, too

__________________________________________________
Do you Yahoo!?
Yahoo! Platinum - Watch CBS' NCAA March Madness, live on your desktop!
http://platinum.yahoo.com
_______________________________________________
Ipr-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipr-wg

---

From: Russell Nelson <[email-masked]>
Date: Wed, 19 Mar 2003 15:41:49 -0500

Powers Chuck-rxcp20 writes:
 >    No, what I am really interested in is spending a couple more
 > years being demonized as an evil patent holder out to control the
 > world by those who don't have patents (whether by choice or not),
 > but who want access to anyone else's patents,

Chuck, it's not that.  It's that we don't want *standards* which
include patents which are not licensed without royalties.  You're
welcome to your patents.  License them for whatever price you want.
Just don't expect the community to help you for free.

If you want cooperation, you have to cooperate.  This should surprise
no one, but it does.

 > ... "software patents" as some new evil ...

You got that right!  They're new, and they're evil.

Once again, Chuck, you refuse to admit that independent or
simultaneous reinvention occurs.  This problem is special to the
software industry because so little capital is needed to create
software.  I can go to Wal*Mart and buy a computer for $1,000.  Even
the least amount of electronics on a board costs $10,000 to sell the
first one.

-- 
-russ nelson   angry-economist.russnelson.com   | "What Problem Are You Trying
Crynwr sells support for free software  | PGPok | To Solve?" is a service mark
521 Pleasant Valley Rd. | +1 315 268 1925 voice | of Crynwr Software.
Potsdam, NY 13676-3213  | +1 315 268 9201 FAX   | 
_______________________________________________
Ipr-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipr-wg

---

From: "Lawrence E. Rosen" <[email-masked]>
Date: Wed, 19 Mar 2003 12:56:22 -0800

Chuck Powers wrote:
> control the world by those who don't have patents (whether by 
> choice or not), but who want access to anyone else's patents, 
> regardless of the R&D costs which might have gone into 
> creating them, if it appears they are attractive to a wide audience.

Nothing I have ever proposed or supported would require you or any other
patent holder ("evil" or not) to give away your patents without you
signing up for that by actively participating in a standards-setting
activity relating to those patents.  So please don't demonize me by
mischaracterizing my views on this subject.

/Larry

---

From: Scott W Brim <[email-masked]>
Date: Wed, 19 Mar 2003 16:00:30 -0500

> Just don't expect the community to help you for free.

This has nothing to do with the question of rechartering.  Stop, please,
both of you.
_______________________________________________
Ipr-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipr-wg

---

From: "Lawrence E. Rosen" <[email-masked]>
Date: Wed, 19 Mar 2003 13:11:05 -0800

Spencer,

I know Chuck Powers well and I like him.  We participated together on
the W3C patent policy working group.  We even sat next to each other
from time to time at delightful dinners.  I'm not trying to attack him
personally.

He and I both understand that he represents the views of Motorola and I
represent the views of Open Source Initiative, to the best of our
abilities.

"Motivations" matter a great deal in policy debates.  Others on this
list needed to be reminded of that, is all.  :-)  Chuck and I have
argued this before and will continue to argue it.  I haven't silenced
him and he hasn't silenced me.  I'm certainly not adversely affected by
<rant> ... </rant>.  

/Larry Rosen

> Behalf Of Spencer Dawkins
> Sent: Wednesday, March 19, 2003 12:35 PM
> To: [email-masked]
> My personal guess is that we'd probably be surprised by a lot 
> of people's motivations, but none of the motivations matter 
> to THIS question.
> 
> Spencer
> 
> more years 
> > being demonized as an evil patent holder out to control the world
> 
> Yahoo! Platinum - Watch CBS' NCAA March Madness, live on your 
> desktop! http://platinum.yahoo.com

---

From: Spencer Dawkins <[email-masked]>
Date: Wed, 19 Mar 2003 14:20:49 -0800 (PST)

Sigh. So, one definition of the difference between lawyers and
salesmen is that lawyers think off-topic colleague-bashing is
going to help people agree with them?

At the risk of providing insights that I'll regret - at least
one of you would benefit a lot from people staying subscribed to
this list when the working group goes dormant for subsequent
discussions. This snappy repartee is giving people an incentive
to unsubscribe when the current documents are forwarded because
the signal-to-noise ratio is falling. Is this REALLY what you
want?

Spencer

---

From: Keith Moore <[email-masked]>
Date: Wed, 19 Mar 2003 20:07:21 -0500

> represent the views of Open Source Initiative, to the best of our

so you admit you are in violation of IETF rules?

then I formally request that Mr. Rosen be excluded from this group.
get out, and stop abusing our process.

Keith

---

From: [email-masked] (Bruce Perens)
Date: Wed, 19 Mar 2003 19:21:15 -0800 (PST)

From: Keith Moore <[email-masked]>
> so you admit you are in violation of IETF rules?

Keith,

While I was employed by HP, I was the only employee of the company who
had explicit permission to represent himself rather than the company in
this sort of setting. And that permission was so unique in the industry
that it generated a good deal of press coverage. I don't know of anyone
else in the industry who has it from their employer.

I've come to the conclusion that _most_ IETF working group members are
participating against their own employer's rules.

At the Atlanta meeting, I saw Microsoft's attorney, a lady who reports
directly to Craig Mundie, feeding questions to engineers on her team who
would ask them as "individuals". This practice has become known in the
standards community as "Michelle and the Seven Dwarves".

We've got our heads in the sand when we say that everybody here's
participating as an individual. It's not legal in terms of our employment
agreements. It's not what we can see happening. It's self-deception.

	Thanks

	Bruce

---

From: Keith Moore <[email-masked]>
Date: Wed, 19 Mar 2003 22:45:22 -0500

> participating against their own employer's rules.

as long as they're not violating our rules, that' s not our concern.

> standards community as "Michelle and the Seven Dwarves".

if it can be shown to be happening, those people should be expelled.

> agreements. It's not what we can see happening. It's self-deception.

It's self-deception to think that engineers can produce good work when 
their opinions are dictated by self-serving companies.

Keith

---

From: [email-masked] (Bruce Perens)
Date: Wed, 19 Mar 2003 21:53:21 -0800 (PST)

> as long as they're not violating our rules, that' s not our concern.

I contend that they _are_ violating IETF rules, because they have a
pre-existing agreement with their employer that explicitly requires
them to violate the IETF rules. Thus, their agreement to the IETF rules
is in bad faith. Take a look at these issues in employment agreements:

	Lending assistance to competitors: against HP's standard
	business practices, and no doubt similar for other companies.
	I had to write an exception into this policy to allow Open Source
	development by the employee, but it doesn't mention standards
	working groups (and I have no idea if it's still in force, anyway).

	Intellectual property: if you write it in your spare time, or in
	an outside activity, it's still your employers property, and you
	are required to disclose it to them and assist them in gaining
	patents, etc. True for HP unless you've negotiated an exception
	(which we did for only a handful of people) and again, true for
	most other companies.

	No authority to sign agreements: your employment agreement
	generally tells you that you don't have authority to make
	contracts for the company, even copyright licenses. Thus,
	again, you don't have authority to agree to the IETF rules.

And so on.

> if it can be shown to be happening, those people should be expelled.

It's going on right under your nose, and not just by MS, and you allow
yourselves to be gamed by those folks.

> their opinions are dictated by self-serving companies.

I agree entirely. A good many of the companies understand this too, and
are willing to relinquish some authority in exchange for participation in
the standards process. At W3C, they will do this in a proper signed agreement
that you can take to court and defend yourself, rather than the nebulous thing
we have at IETF.

After you do that, the only problem remaining is the self-serving
companies that aren't on the working group. We can do some policy to
help with that too, but over the long term we should also be working
on legislation.

	Thanks

	Bruce

---

From: Keith Moore <[email-masked]>
Date: Thu, 20 Mar 2003 01:22:42 -0500

On Thursday, March 20, 2003, at 12:53  AM, Bruce Perens wrote:

> is in bad faith.

maybe their agreement with their employer is in bad faith.  or maybe 
their employers' agreements differ from the one you signed, or maybe 
they've negotiated their own amendments to those agreements.  I realize 
that conflicts can sometimes exist, that the agreements that employers 
want you to sign are often overbroad.  Individual participants can 
address those conflicts in different ways.

If an employer makes it part of an employee's job to participate in 
IETF, then it is also part of the employee's job to follow IETF rules.  
And if the employer dictates that the employee break IETF rules that 
are necessary to ensure quality results and fairness, I hope there is a 
legal remedy to that problem.

Keith

---

From: Spencer Dawkins <[email-masked]>
Date: Wed, 19 Mar 2003 22:23:49 -0800 (PST)

OK, this is a thrilling discussion, but could we maybe trim the
To: list back to ipr-wg when we share wisdom?

Some of us are seeing it in stereo, and once is bad enough...

Spencer