Subject: Followup on disclosure form question

From: "Valerie See" <[email-masked]>
Date: Thu, 6 Mar 2003 10:15:33 -0800

Scott Brim wrote:
> 
> On Thu, Mar 06, 2003 12:54:33PM +0100, Brian E Carpenter allegedly
wrote:
> > Valerie See wrote:
> > ...
> > > 24. Section 6.4 - I know that the "disclosure template" idea has
no
> > > consensus (at all) as a "requirement" - nor do I think it _has_ to
be 
> > > a requirement. But do people think it could work as a "suggested"
> > > mechanism?
> > 
> > I think that would be very useful.
> > 
> >   Brian
> 
> Who would it be a suggestion to?  Do you want the RFC to suggest to
> disclosers that they create a template and use it?  I don't think so.
> The alternative is that you want to suggest to IETF administration
that
> they create templates -- but that doesn't belong in this RFC, if in
any.

What I had thought would be that in Scott's (Bradner) section 6.4, the 
"form" could be placed as a suggested format for disclosures (that would

still be made according to the practices in section 6.3). I'd thought
that 
this placement would be consistent given the references to copyright 
notices in "submissions", but if not, and it would be more appropriate
to
formulate this idea as a separate I-D for consideration, I would
be happy to do so - what would the preference be?

thanks, Val
_______________________________________________
Ipr-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipr-wg

---

From: Scott Bradner <[email-masked]>
Date: Thu, 6 Mar 2003 13:24:04 -0500 (EST)

> "form" could be placed as a suggested format for disclosures (that would

I would much rather not have the form in this doc - it seems much better
to not have to revisit this doc if a minor change is seen to be
useful in the form

I do think we need to do one of the following:
	1/ decide we will not use a form and just leave the text
	   the way it is (modulo tweaks) in my & teh other Scott's
	   documents
	2/ decide we will have a form and change the text to say that
	   a discloser needs to go to a particular URL to get the form
	3/ punt and say "look at this URL to find out how to submit
	   a disclosure" - which can be simple text (send mail to 
	   [email-masked] - where xxx chould change) or a form (or
	   pointer to a form)

Scott

---

From: Scott W Brim <[email-masked]>
Date: Thu, 6 Mar 2003 13:32:23 -0500

> 	   [email-masked] - where xxx chould change) or a form (or

Something in the middle.  In the draft, point them to a general URL (or
an autoresponding email address) for information, and have whatever we
need to, including a required or sample template, there.
_______________________________________________
Ipr-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipr-wg

---

From: "Robert Barr " <[email-masked]>
Date: Thu, 6 Mar 2003 10:59:19 -0800

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Scott Bradner
> Sent: Thursday, March 06, 2003 10:24 AM
> To: [email-masked]; [email-masked]; [email-masked]
> Cc: [email-masked]
> Subject: Re: Followup on disclosure form question
> 
> 
I strongly support #2

---

From: John C Klensin <[email-masked]>
Date: Thu, 06 Mar 2003 14:14:42 -0500

--On Thursday, 06 March, 2003 13:24 -0500 Scott Bradner 
<[email-masked]> wrote:

>> What I had thought would be that in Scott's (Bradner) section
>> 6.4, the  "form" could be placed as a suggested format for
>> disclosures (that would
>
> I would much rather not have the form in this doc - it seems
> much better to not have to revisit this doc if a minor change
> is seen to be useful in the form
>

Scott,

I think we need to avoid creating another one of those 
situations that becomes a topic for the problem-statement 
effort.  What we have discovered over the last few years is that 
every interpretation or reinterpretation of 2026 (especially 
section 10) sets off a flurry of concerns among vendors about 
whether the changes are substantive or problematic relative to 
their internal procedures for compliance with previous versions. 
If the IESG proposes a change in form, details, or 
interpretation and exposes it for community comment (via a Last 
Call or equivalent) we get a huge flurry of amateur lawyering; 
if they simply announce it as a clarification (or don't announce 
it in a public way, on the "gotcha" model), we get (often 
legitimate, IMO) concerns about abuse of authority.

A "minor change" often still needs to be passed by vendor 
lawyers  to be sure that it doesn't have major (even if 
unintended) impact.  That can turn it into a major process.

So, while I'm very sympathetic to the desire to avoid opening 
RFC-type documents for minor changes, I think anything based on 
a "just point somewhere so we can change the target" model 
should come with some guidance about how changes are made, who 
makes them, how "minor" (if that is a criterion) is determined, 
and so on.

Sorry to be the thrower of spanners into the works, but I think 
we've had bad experiences in closely-related areas.

regards,
   john

---

From: Harald Tveit Alvestrand <[email-masked]>
Date: Fri, 07 Mar 2003 08:47:53 +0100

> 	   [email-masked] - where xxx chould change) or a form (or

I like #2 AND #3.... I think that it's a WG task to get the form created, 
discussed and justified, and that it should be published as an RFC.
I think the procedure docs still need to point to a mechanism (URL, I 
guess) for finding out what the current form and the current procedures are 
- among other things because I'd like to have the procedure docs done Real 
Soon Now, and they shouldn't have to wait for the final form of the form.

(English is such an unambiguous form of communication .... "final form of 
the form" indeed....)

                     Harald