Subject: RE: "Hum" -- should we recharter now?

From: "Lars-Erik Jonsson (EAB)" <[email-masked]>
Date: Thu, 27 Mar 2003 11:48:40 +0100

> 	Should the IPR working group recharter at this time to devise
> 	a substantially new IPR policy?

No! The current policy is designed for the way the IETF operates,
    it gives an appropriate degree of flexibility to working groups,
    and it has not been shown to be broken.

/L-E 
_______________________________________________
Ipr-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipr-wg

---

From: D F <[email-masked]>
Date: Thu, 27 Mar 2003 09:08:48 -0500

On March 27, 2003 05:48, Lars-Erik Jonsson (EAB) wrote:
>     it gives an appropriate degree of flexibility to working
> groups, and it has not been shown to be broken.
>

Nice try, but attempts to show that the current policy is broken 
were essentially ruled as off-topic during the discussion to this 
point. To me, your statement is more an argument FOR rechartering 
rather than AGAINST.

IMO, the group should be rechartered so that those who feel the 
current policy is broken have the opportunity to state their case 
and not be told, continually, that such discussion is off-topic.

- -- 
Dave Fluri
PGP Public Key-ID 3F64B9AC

---

From: Russell Nelson <[email-masked]>
Date: Thu, 27 Mar 2003 10:18:08 -0500

>     and it has not been shown to be broken.

Not been shown to be broken??  Here's the algorithm to show you that
it's broken:

1) Go to http://www.ietf.org/ipr/
2) Choose a disclosure.
3) See if it offers RF terms.  If so, pick another.
4) Find an open source implementation of the standard (if there is
one).
5) Go to the maintainer of the software and say "Do you realize that
Well-Funded IPR-holder claims that your software infringes their patent?"

I could implement this algorithm, but I think it will be much more
instructive if you implement it yourself.

-- 
-russ nelson   angry-economist.russnelson.com   | If war is the answer, the
Crynwr sells support for free software  | PGPok | the question must really
521 Pleasant Valley Rd. | +1 315 268 1925 voice | suck.
Potsdam, NY 13676-3213  | +1 315 268 9201 FAX   | 
_______________________________________________
Ipr-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipr-wg

---

From: "Randy Presuhn" <[email-masked]>
Date: Thu, 27 Mar 2003 09:51:09 -0800

Hi -

> From: "Russell Nelson" <[email-masked]>
> To: <[email-masked]>
> Sent: Thursday, March 27, 2003 7:18 AM
> Subject: not broken?
...
> Well-Funded IPR-holder claims that your software infringes their patent?"
....

This algorithm is broken.  It assumes that the IPR disclosures are for
"essential" technology.  The word in RFC 2026 is "relevant".  The
disclosure of relevant IPR is *not* the same thing as claiming infringement.

Randy

---

From: Harald Tveit Alvestrand <[email-masked]>
Date: Fri, 28 Mar 2003 09:07:53 +0100

> instructive if you implement it yourself.

I thought I saw Scott Bradner asking for almost exactly the same 
verification - in his case, he seemed to think that you would have a hard 
time finding an example; in your case, you seem to think that it is trivial 
to find an example.

One example, which I know enough about to recognize when I see it: CALSCH

Disclosures:

http://www.ietf.org/ietf/IPR//IBM-CALSCH (RAND)
http://www.ietf.org/ietf/IPR//ACTIONTECH-CALSCH (RAND)
http://www.ietf.org/ietf/IPR//SUN-CALSCH (RAND)

Implementations:

http://softwarestudio.org/libical/
Licensing terms: NPL and LGPL
http://www.softwarestudio.org/libical/UsingLibical/node4.html

The project pages seem to show a low activity level, with last postings in 
December of last year.

I have not gone to step 5.

                        Harald

---

From: Harald Tveit Alvestrand <[email-masked]>
Date: Mon, 31 Mar 2003 08:10:36 +0200

--On fredag, mars 28, 2003 09:07:53 +0100 Harald Tveit Alvestrand 
<[email-masked]> wrote:

> time finding an example; in your case, you seem to think that it is
> trivial to find an example.
>
> The project pages seem to show a low activity level, with last postings
> in December of last year.
>

After sending this, I did contact the chief developer, Eric Busboom (yes, 
he did give me permission to use his name), and he said:

>> - Are/were you aware of those patent claims when developing libical?
>
> I was vaguely aware of them, and had read at least one of the notices.
>
>> - If yes: Did those claims cause any problem for you?
>
> No. I completely ignored them. I am certain that there are dozens to
> hundreds of patents that apply to nearly anything that I create in
> software, so I just try not to worry about it. I can't afford to do a
> patent search before I  begin work on a project, and any search I did do
> would likely miss or misinterpret applicable patents, so I just ignore
> the whole thing.
>
> And, I figure the real patent threat to libical is not from the companies
> that filed claim notices, but from those that did not.

from our next exchange:

>>
>> Not the safest course, I think, but likely the one that's possible.
>
> True, but the only real alternative would have been not to write the
> library, and that would have been a bigger loss. If we let the patent
> attourneys keep us from writting software, the patent attournies will
> have won! Wait... are we talking about patent lawyers or terrorists? :-)

His words speak for themselves.

                          Harald

---

From: Pekka Savola <[email-masked]>
Date: Mon, 31 Mar 2003 09:29:47 +0300 (EEST)

Hello,

Interesting discussion.

Is libical included in any open source distributions?

If yes, I believe it's going to be removed.

If not, that's not a problem as such.  If you release a code completely 
free on web, but don't sell it anywhere or have anyone distribute it, in 
case someone requests its removal of facing IPR charges, you can just 
remove that.

For distributors rather than app writers this seems to be a pretty 
much different issue, as they're more enticing target and face the 
collective risk of all the software in the distribution.

-- 
Pekka Savola                 "You each name yourselves king, yet the
Netcore Oy                    kingdom bleeds."
Systems. Networks. Security. -- George R.R. Martin: A Clash of Kings

---

From: [email-masked] (Bruce Perens)
Date: Mon, 31 Mar 2003 04:46:11 -0800 (PST)

Thanks, this example will be helpful in selling my point to the general public.

	Thanks

	Bruce