Subject: RE: royalty-free blanket statements and reasonable terms

From: Powers Chuck-rxcp20 <[email-masked]>
Date: Mon, 25 Aug 2003 13:47:48 -0700

Scott,

   In its current form, this definition of RF, if it applied to any RF commitment made by an IETF contributor, would constitute a substantial change in running code, as it would obligate participants (and their employers/sponsors) to a licensing commitment beyond that currently defined in the IETF IPR policy (e.g. include patents they are not personally aware of, etc).

   The RF definition in the W3C Patent Policy was drafted, in part, as the definition of what licensing commitment W3C Members are to be obligated to (e.g. impacts any applicable patents they own, whether they are aware of that patent or not), rather than as an RF commitment that a member would _choose_ to adopt when making an IPR licensing commitment. As such, either some edits need to be made for IETF use, or it needs to be made clear that this RF definition only applies to a "blanket" RF commitment made to the IETF.

   I have made some proposed edits to the text below which are in line with the IETF IPR policy, although the wordsmithing is probably less than optimal.

regards,

Chuck

------------------------

Appendix A. Royalty-Free Licensing
    The following description of what constitutes royalty-free licensing
    has been adapted from the W3C.
 
    With respect to a Recommendation developed under this policy, a
    Royalty-Free license shall mean a non-assignable, non-sublicensable
    license to make, have made, use, sell, have sold, offer to sell,
    import, and distribute and dispose of implementations of the
    Recommendation that:
 
    1. shall be available to all, worldwide;
 
    2. shall apply to the IPR which Covers the specified IETF Document
       which is specifically identified by the licensor making the RF
       licensing commitment; [Note: in the case of a blanket RF
       commitment, specifically identified could be "all IPR we own"]
 
    3. may be limited to implementations of the technology in
       the specified IETF Document, and to what is required by the
       specified IETF Document;
 
    4. may be conditioned on a grant of a reciprocal RF license (as
       defined in this appendix) to all IPR that Covers technology in a
       specified IETF Document owned or controlled by the licensee.
 
    5. may not be conditioned on payment of royalties, fees or other   
       consideration;
 
    6. may be suspended with respect to any licensee when licensor is
       sued by licensee for infringement of claims essential to implement
       the technology in any IETF Document; 
 
    7. may not impose any further conditions or restrictions on the use  
       of any technology, intellectual property rights, or other
       restrictions on behavior of the licensee, but may include
       reasonable, customary terms relating to operation or maintenance  
       of the license relationship such as the following: choice of law
       and dispute resolution; 
 
    8. shall not be considered accepted by an implementer who manifests
       an intent not to accept the terms of a Royalty-Free license as  
       offered by the licensor.
 
    License term:
 
    9. The RF license conforming to the requirements in this policy shall
       be for the life of the patents in question.

> -----Original Message-----
> From: Scott Bradner [mailto:[email-masked]]
> Sent: Monday, August 25, 2003 11:18 AM
> To: [email-masked]
> Subject: Re: royalty-free blanket statements and reasonable terms
> 
> 
> 
> if we were to put a version of the W3C RFC definiition on as an
> appendix it might look like this
> 
> Appendix A. Royalty-Free Licensing
>    The following description of what constitutes 
> royality-free licensing
>    has been adapted from the W3C.
> 
>    With respect to a Recommendation developed under this policy, a
>    Royalty-Free license shall mean a non-assignable, non-sublicensable
>    license to make, have made, use, sell, have sold, offer to sell,
>    import, and distribute and dispose of implementations of the
>    Recommendation that:
> 
>    1. shall be available to all, worldwide;
> 
>    2. shall extend to all IPR that Covers technology in a 
> specified IETF
>       Document owned or controlled by the licensor;
> 
>    3. may be limited to implementations of the IETF of the 
> technology in
>       the specified IETF Document, and to what is required by the
>       specified IETF Document;
> 
>    4. may be conditioned on a grant of a reciprocal RF license (as
>       defined in this appendix) to all IPR that Covers technology in a
>       specified IETF Document owned or controlled by the licensee. A
>       reciprocal license may be required to be available to all, and a
>       reciprocal license may itself be conditioned on a further
>       reciprocal license from all.
> 
>    5. may not be conditioned on payment of royalties, fees or other   
>       consideration;
> 
>    6. may be suspended with respect to any licensee when licensor is
>       sued by licensee for infringement of claims essential 
> to implement
>       the technology in any IETF Document; 
> 
>    7. may not impose any further conditions or restrictions 
> on the use  
>       of any technology, intellectual property rights, or other
>       restrictions on behavior of the licensee, but may include
>       reasonable, customary terms relating to operation or 
> maintenance  
>       of the license relationship such as the following: choice of law
>       and dispute resolution; 
> 
>    8. shall not be considered accepted by an implementer who manifests
>       an intent not to accept the terms of a Royalty-Free license as  
>       offered by the licensor.
> 
>    License term:
> 
>    9. The RF license conforming to the requirements in this 
> policy shall
>       be for the life of the patents in question.
> 
> 
> 
> 
> _______________________________________________
> Ipr-wg mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ipr-wg
> 

_______________________________________________
Ipr-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipr-wg

---

From: Scott Bradner <[email-masked]>
Date: Mon, 25 Aug 2003 16:52:20 -0400 (EDT)

tnx for the edits - they look reasonable to me

Scott

---

---

From: "Lawrence E. Rosen" <[email-masked]>
Date: Tue, 26 Aug 2003 13:26:39 -0700

Chuck,

IETF should quote the W3C policy definition of "RF" intact with an
appropriate hyperlink to the W3C website.  

I've heard your proposal before, Chuck.  As far as I know Motorola is
still a member of W3C and you are still its assigned representative
there.  You can again propose your changes in that organization's
committees.  I assume you remember that you were resoundingly out-voted
on the W3C committee when Motorola first proposed this change to the W3C
policy.  Hardly anybody agreed with your attempt to allow a company
(e.g., Motorola) to plead that it didn't know what was in its own patent
portfolio when it made a licensing commitment.  The scienter requirement
you proposed in W3C and are proposing now in IETF is impossible of
proof.  It's just a giant loophole and you know it.

In any event, an RF commitment isn't required by IETF, so Motorola can
continue to limit its patent grants for IETF standards any way it wants.
It just won't be able to pretend to be RF (in W3C terms) when it isn't.

Regards,

/Larry Rosen

> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Powers Chuck-rxcp20
> Sent: Monday, August 25, 2003 1:48 PM
> To: 'Scott Bradner'
> Cc: [email-masked]
> Subject: RE: royalty-free blanket statements and reasonable terms
> 
> 
> Scott,
> 
>    In its current form, this definition of RF, if it applied 
> to any RF commitment made by an IETF contributor, would 
> constitute a substantial change in running code, as it would 
> obligate participants (and their employers/sponsors) to a 
> licensing commitment beyond that currently defined in the 
> IETF IPR policy (e.g. include patents they are not personally 
> aware of, etc).
> 
>    The RF definition in the W3C Patent Policy was drafted, in 
> part, as the definition of what licensing commitment W3C 
> Members are to be obligated to (e.g. impacts any applicable 
> patents they own, whether they are aware of that patent or 
> not), rather than as an RF commitment that a member would 
> _choose_ to adopt when making an IPR licensing commitment. As 
> such, either some edits need to be made for IETF use, or it 
> needs to be made clear that this RF definition only applies 
> to a "blanket" RF commitment made to the IETF.
> 
>    I have made some proposed edits to the text below which 
> are in line with the IETF IPR policy, although the 
> wordsmithing is probably less than optimal.
> 
> regards,
> 
> Chuck
> 
> ------------------------
> 
> royalty-free licensing