Subject: RE: Q: EAP Message Format

From: Gregory Lebovitz <[email-masked]>
Date: Mon, 14 Jul 2003 12:13:41 -0700

so, Francis and Charlie, will your suggested change to the text be made in
the -09?

> -----Original Message-----
> From: Francis Dupont [mailto:[email-masked]]
> Sent: Wednesday, July 09, 2003 1:13 AM
> To: Ricky Charlet
> Cc: ipsec mailingList
> Subject: Re: Q: EAP Message Format 
> 
> 
>  In your previous mail you wrote:
> 
>    	So, as currently specified in draft-08, the length 
> field of the EAP 
>    message format may be either 2 or 4 bytes depending upon the type.
> 
> => no, the text in the draft is buggy but is simpler than 
> your proposal.
> Current text is:
> 
>    o  Type (one octet) is present only if the Code field is Request
>       (1) or Response (2). For other types, the EAP message length
>       MUST be four octets and the Type and Type_Data fields MUST NOT
>       be present. ...
> 
> The fixed text should be:
> 
>    o  Type (one octet) is present only if the Code field is Request
>       (1) or Response (2). For other codes, the EAP message length
>                                      ^^^^^
>       MUST be four octets and the Type and Type_Data fields MUST NOT
>       be present. ...
> 
> So if the code is not Request or Response the length field 
> *value* is 4
> and there is nothing after the length field.
> 
> Regards
> 
> [email-masked]
>

---

From: Francis Dupont <[email-masked]>
Date: Mon, 14 Jul 2003 22:46:59 +0200

=> please change "types" for "codes".

=> IMHO it is not necessary to add that the message length is the value
of the length field and not its length. If we'd like to add something
in the document or its companion, I suggest more an example.

Thanks