Subject: Re: SIP clarification

From: "Vipin Palawat" <[email-masked]>
Date: Tue, 6 Apr 1999 14:08:44 +0530

Hello Arjun,

As my understanding, the REGISTERation request should be followed by a 2XX
success response or some 4XX/5XX/6XX error response from SIP server to
acknowledge the
sucessful registration or error.

If your message get lost or due to some other reason you did'nt get the
response back then you have to retransmit the message again and wait for
time out of response.

Regards
Vipin...
________________________________________________
Have  a  Nice  Day!!!

Vipin  Palawat
Wipro  Infotech :Enterprise Solutions (Telecom Division)
K-312, 5th Block , Koramangala,
Bangalore - 560 095 (India)
Ph: 91-80-5538301 Extn:2419
mailto:[email-masked]

-----Original Message-----
From: Arjun RC <[email-masked]>
To: [email-masked] <[email-masked]>
Date: Tuesday, April 06, 1999 1:55 PM
Subject: SIP clarification

Hi,
we are  trying to implement a minimal version of SIP on UDP and have the
following
doubt:

The RFC (2543) dated Mar '99 sights an example of Users REGISTERing with
the SIP Server.
However, it does not show the server sending a response (e.g 200 OK) for
the same. (16.1 pg 120)

However, section 10.4.1, pg 90 states that REGISTER should be
retransmitted. Hence it seems logical that a response should be returned.

Could anyone pls clarify the exact procedure (ie whether as response
follows a register request)

Thx
Cheers
ARC

---------
This message came from the IETF IPTEL Working Group Mailing List.

---------
This message came from the IETF IPTEL Working Group Mailing List.

---

From: Jonathan Rosenberg <[email-masked]>
Date: Tue, 06 Apr 1999 15:20:40 -0400

Yes, REGISTER like all other requests is responded to. The reliability
mechanisms for all non-INVITE requests are described in section 10.4.

In general, SIP issues like this are for the mmusic list,
[email-masked], not iptel.

-Jonathan R.

-- 
Jonathan D. Rosenberg                       Lucent Technologies
Member of Technical Staff                   101 Crawfords Corner Rd.
High Speed Networks Research                Holmdel, NJ 07733
FAX:   (732) 834-5379                       Rm. 4C-526
EMAIL: [email-masked]
URL: http://www.cs.columbia.edu/~jdrosen

---------