Subject: Re: H.323 with ATM

From: Abhishek Singh <[email-masked]>
Date: Wed, 21 Apr 1999 08:13:14 -0700 (PDT)

Hi Henning,

RMOA is rather revolutiory. I know SIP would work over
any damn thing, but so would H.323. But the beauty of
RMOA work is that instead of using RTP/UDP/IP over ATM
in an unintelligent way it does use the QOS feautures
of ATM rather than using RTP. At the same time it also
carries the RTP/UDP/IP headers(compressed) to ensure
interoperability with non ATM networks(ie translating
it back at the egress). They use something called Real
Time AAL5. The same concept could be extended to SIP
without much(any) effort. Wonder if anybody is doing
that.

cheers
Abhishek

--- Henning Schulzrinne <[email-masked]>
wrote:
> Abhishek Singh wrote:
> > 
> > Hi Eric,
> > 
> > There is work going on in the ATM Forum and it is
> > called RMOA(realtime multimedia over ATM). Seems
> > pretty good way for H.323 transport over ATM. Not
> > aware of SIP efforts though.
> > 
> This topis doesn't really belong here, but to answer
> the question:
> 
> There is no particular need to specify how SIP works
> with ATM, as it
> works just fine either with ATM transport for media
> or for sending SIP
> across (say) AAL5. The only minor item to be settled
> is how to represent
> ATM addresses in SDP. Presumably, H.332-for-ATM will
> have to solve that
> problem.
> 
> 
> -- 
> Henning Schulzrinne  
> http://www.cs.columbia.edu/~hgs
> 
> ---------
> This message came from the IETF IPTEL Working Group
> Mailing List.
> 

===
Go to 
http://abhishekrs.eCode.com 
to pick up my online Business Card.
_________________________________________________________
Do You Yahoo!?
Get your free @yahoo.com address at http://mail.yahoo.com

---------
This message came from the IETF IPTEL Working Group Mailing List.

---

From: Jonathan Rosenberg <[email-masked]>
Date: Wed, 21 Apr 1999 17:05:43 -0400

Abhishek Singh wrote:
> of ATM rather than using RTP.

Rather than using RTP?? RTP doesn't provide QoS... There is nothing
which prevents you from taking an RTP packet at an ATM boundary,
extracting it, and sending it over an ATM VC that has some QoS
associated with it (CBR or something), RTP in tact. Whether or not you
compress RTP is a separate issue.

Of course, this poor edge box now has to do some application level
processing instead of being a pure layer 3/2 device. Any end to end
security will make it impossible for the box to find the RTP packets as
well. It seems like it would be easier to stay at layer 3, and establish
VC's based on RSVP or diffserv, or something like that... but thats a
separate issue.

-Jonathan R.

-- 
Jonathan D. Rosenberg                       Lucent Technologies
Member of Technical Staff                   101 Crawfords Corner Rd.
High Speed Networks Research                Holmdel, NJ 07733
FAX:   (732) 834-5379                       Rm. 4C-526
EMAIL: [email-masked]
URL: http://www.cs.columbia.edu/~jdrosen

---------