Subject: [IPTEL] Question about CPL DTD

From: David Bertrand <[email-masked]>
Date: Fri, 12 Jan 2001 17:38:43 +0100

Hi all,

Should every script submitted to a CPL server contain a doctype
declaration  and if yes, should this exactly be:  <!DOCTYPE cpl PUBLIC
"-//IETF//DTD RFCxxxx CPL 1.0//EN" "cpl.dtd"> ?

Thanks in advance
David

--
David Bertrand
Software Engineer
Indigo Software
50 Rue Wiertz
Brussels, 1050 - Belgium
Phone : +32 2 235 09 44
Fax: +32 2 280 26 76
[email-masked]
http://www.indigosw.com

_______________________________________________
IPTEL mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/iptel

---

From: James Undery <[email-masked]>
Date: Fri, 12 Jan 2001 16:50:36 +0000 (GMT)

> "-//IETF//DTD RFCxxxx CPL 1.0//EN" "cpl.dtd"> ?

In XML the document type declaration is optional and although all the
examples in the internet draft contain an external reference they could
just as easily contain the full DTD !! Our implementation doesn't require
the document declaration as it uses an internal representation of the DTD
anyway and won't accept generic XML (it's meaningless out of context).

James Undery