Subject: RE: [IPTEL] Question about CPL DTD

From: Jonathan Rosenberg <[email-masked]>
Date: Sat, 13 Jan 2001 15:10:59 -0500

> -----Original Message-----
> From: James Undery [mailto:[email-masked]]
> Sent: Friday, January 12, 2001 11:51 AM
> To: David Bertrand
> Cc: [email-masked]'
> Subject: Re: [IPTEL] Question about CPL DTD
> 
> 
> 
> 
> On Fri, 12 Jan 2001, David Bertrand wrote:
> 
> > Hi all,
> > 
> > Should every script submitted to a CPL server contain a doctype
> > declaration  and if yes, should this exactly be:  <!DOCTYPE 
> cpl PUBLIC
> > "-//IETF//DTD RFCxxxx CPL 1.0//EN" "cpl.dtd"> ?
> 
> In XML the document type declaration is optional and although all the
> examples in the internet draft contain an external reference 
> they could
> just as easily contain the full DTD !! Our implementation 
> doesn't require
> the document declaration as it uses an internal 
> representation of the DTD
> anyway and won't accept generic XML (it's meaningless out of context).
> 
> James Undery
> 
> 
> _______________________________________________
> IPTEL mailing list
> [email-masked]
> http://lists.bell-labs.com/mailman/listinfo/iptel
> 

_______________________________________________
IPTEL mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/iptel

---

From: Jonathan Rosenberg <[email-masked]>
Date: Sat, 13 Jan 2001 15:13:14 -0500

(sorry about the previous incomplete response)

> anyway and won't accept generic XML (it's meaningless out of context).

Well, I'd prefer it be there in any case, since it lends context to CPL
scripts. 

ALso, note that the format of the declaration would not be RFCxxxx; this
will be replaced by the ultimate RFC number assigned to CPL. 

-Jonathan R.
---
Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.cs.columbia.edu/~jdrosen         PHONE: (973) 952-5000
http://www.dynamicsoft.com