Subject: Re: [IPTEL] TRIP question on routing numbers

From: "Hussein F. Salama" <[email-masked]>
Date: Thu, 08 Feb 2001 23:21:07 -0800

Philip Mart wrote:

> Hussein,
>
> If prefixes are to be included where are they specified so that implementations
> may interoperate?

Not in TRIP. TRIP's specification of the address families is loose, on purpose, to
maximize the utility of the protocol with different number plans.

> I guess I should also ask why a "Nature of Address" field
> wasn't included instead of the unspecified prefixes?

We, TRIP's authors, had a long discussion about the NoA field a few months ago. At
the end, we decided , we don't need an NoA field, because when an administrator
places an LS in a certain domain, it will definitely know the meaning of the
prefixes used in that domain. So the NoA can be inferred from the prefix. This is
identical to the case with IP routing.

A TRIP LS located at the egress from an ITAD may have to manipulate the prefix by
prependinng/stripping off digits as necessary before forwarding an UPDATE to its
inter-domain peer in order to accommodate the prefix conventions in that peer's
ITAD.

Hussein

> This would have the
> advantage of not mandating a particular national, local or even hypothetical
> dialling plan which may in any case conflict with interconnect arrangements.
>
> Phil Mart
>
> "Hussein F. Salama" <[email-masked]> on 08/02/2001 03:37:36
>
> Please respond to [email-masked]
>
>
>
>
>
>
>
>  To:      Jeff Hinchey <[email-masked]>
>
>  cc:      "[email-masked]'"
>           <[email-masked]>(bcc: Philip
>           Mart/MAIN/MC1)
>
>
>
>  Subject: Re: [IPTEL] TRIP question on routing numbers
>
>
> Jeff Hinchey wrote:
>
> >
> >
> > I was reviewing the latest version of the TRIP draft and was a little
> > confused over a statement in section 5.1.1.2, second paragraph, which
> > reads:
> >
> >      "The type of Decimal Routing Number (private, local, national, or
> >      international) can be deduced from the first few digits of the
> >      prefix"
> >
> > How is this accomplished? Telephone numbers only have meaning within
> > the context of a specific number plan. E.164 public numbers and
> > numbers from private number plans can begin with the same digits.
> > Also, there is no way to determine if a public number is local,
> > national or international based on leading digits. There is no
> > reliable way to determine what number plan a number belongs to from
> > only the number itself.
> >
> > Is the intent to include dial plan prefixes in addition to numbering
> > plan addressing information in the routing numbers specified in the
> > TRIP route?
>
> Yes, otherwise how can an LS differentiate between a local prefix, a
> national prefix, and international prefix?
>
> > If so, how will this work when TRIP information is disseminated
> > between ITADs serving different regions with different dial plans?
>
> A TRIP LS located at the egress from an ITAD may have to manipulate the
> prefix by prependinng/stripping off digits as necessary.
>
> Hussein
>
> >
> >
> > Jeff Hinchey
> > Succession Network Architecture                           Nortel
> > Networks
> > 613 763 8007 / 613 765 4881 (fax)                       3500 Carling
> > Ave.
> > [email-masked]                               Nepean,
> > Canada  K2H 8E9
> >
>
> --
> Hussein F. Salama
> Cisco Systems
> Mail Stop SJC-21/3, 170 W. Tasman Drive, San Jose, CA 95134
> Voice: +1 (408) 527-7147, Fax: +1 (408) 527-7147
>
>   ------------------------------------------------------------------------
>                   Name: att1.htm
>    att1.htm       Type: Hypertext Markup Language (text/html)
>               Encoding: base64
>            Description: Internet HTML

--
Hussein F. Salama
Cisco Systems
Mail Stop SJC-21/3, 170 W. Tasman Drive, San Jose, CA 95134
Voice: +1 (408) 527-7147, Fax: +1 (408) 527-7147

_______________________________________________
IPTEL mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/iptel

---

From: "Philip Mart" <[email-masked]>
Date: Thu, 8 Feb 2001 12:52:07 +0000

Hussein,

If prefixes are to be included where are they specified so that implementations
may interoperate? I guess I should also ask why a "Nature of Address" field
wasn't included instead of the unspecified prefixes? This would have the
advantage of not mandating a particular national, local or even hypothetical
dialling plan which may in any case conflict with interconnect arrangements.

Phil Mart

                                                                                

                                                              

Hussein