Subject: RE: [IPTEL] Negation in CPL

From: Jonathan Rosenberg <[email-masked]>
Date: Fri, 7 Dec 2001 22:41:26 -0500

> -----Original Message-----
> From: Daniel Amyot [mailto:[email-masked]]
> Sent: Wednesday, December 05, 2001 5:18 PM
> To: [email-masked]
> Subject: [IPTEL] Negation in CPL
> 
> 
> Hello,
> 
> I have been taking a closer look at CPL recently and 
> concluded that it would
> be difficult to create and maintain a single CPL script for a 
> complex set of
> rules/policies. 

Since CPL is not a real programming language, there is a lot you can't do...

Now, if I go with multiple scripts (one per 
> user policy) and
> assume that they are ordered according to their priority 
> (total ordering), I
> find myself facing a few other problems.

The spec makes no mention of the concept of multiple scripts with differing
priorities. I don't know how such a thing would work; seems like a feature
interaction nightmare. How do you know which scripts are associated with
each request? 

> Right now, CPL supports OTHERWISE, but this still creates 
> problems with other
> rules based on Jacques that have a lower priority (the latter 
> won't get fired,
> although they should according to the user's expectations):

I don't understand. If you want a script which forwards all calls from
Jacques to my cell phone, and to radiology otherwise, this is trivially done
in CPL. What is the specific problem?

-Jonathan R.
---
Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com

_______________________________________________
IPTEL mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/iptel

---

From: Daniel Amyot <[email-masked]>
Date: Tue, 11 Dec 2001 10:11:56 -0500

Hello,

> interaction nightmare. How do you know which scripts are associated with

Indeed, having multiple scripts is not an option discussed in the standard,
and it causes interaction problems. However, the issue with a single CPL
script is one of usability and maintenance. It is difficult for a user to
add/remove individual policies from a single script where existing policies
are tightly integrated together. But thinking more about it, this is probably
more of a UI or front-end problem than a problem with CPL itself.

Thanks,

Daniel