Subject: [IPTEL] updated agenda

From: Jonathan Rosenberg <[email-masked]>
Date: Sat, 8 Dec 2001 02:42:07 -0500

Folks,

Due to an itchy trigger finger, I sent in the agenda to IETF without a list
of reading materials. Below is an updated agenda that includes reading
materials.

IP Telephony Working Group (iptel)

Tuesday, December 11 at 1415 - 1515
===================================

CHAIR: Jonathan Rosenberg <[email-masked]>

AGENDA:

1. Agenda Bashing [Rosenberg]          

2. CPL, TRIP Updates  [Rosenberg]      5m

Reading:
http://search.ietf.org/internet-drafts/draft-ietf-iptel-cpl-05.txt

3. TRIP MIB [Walker]                   10m

Reading:
http://search.ietf.org/internet-drafts/draft-ietf-iptel-trip-mib-00.txt

4. Gateway Registration

     Scenarios Discussion 
       [Internet2 - hgs]               10m
       [Carrier - jdr]
      
     Requirements Discussion
       [Rosenberg]                     20m

     Attributes Discussion
       [Bangalore]                     10m

Reading:
http://search.ietf.org/internet-drafts/draft-rosenberg-iptel-gwreg-req-00.tx
t
http://search.ietf.org/internet-drafts/draft-roy-iptel-gw-server-discovery-0
0.txt
http://search.ietf.org/internet-drafts/draft-roy-iptel-gw-server-registratio
n-00.txt
http://search.ietf.org/internet-drafts/draft-zhao-iptel-gwloc-slp-02.txt
http://search.ietf.org/internet-drafts/draft-rs-trip-gw-03.txt

---
Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com

_______________________________________________
IPTEL mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/iptel

---

From: "Roy, Radhika R, ALCTA" <[email-masked]>
Date: Sat, 8 Dec 2001 17:45:37 -0500

Hi, Everyone:

I am providing the description of the VGs that have been submitted for the upcoming IETF-52 IPTEL meeting. As many of us including myself will not be able to attend the meeting, I am providing this information for your review and comments (URLs for I-Ds can be found below [in agenda]):

A. Discovery Protocol (draft-roy-iptel-gw-server-discovery-00.txt)

VG #1: Discovery protocol characteristics (draft-roy-iptel-gw-server-discovery-00.txt): 

* Provides semantics for discovery for all types of GWs and SIP Server/LS with following attributes 
	- Alternate Peers, Capability Negotiations, and others
* Syntax of the protocol
	- Can be defined as appropriate, for example:
	- TRIP format and messages with some minor or no modifications
	- A new format and messages as appropriate
* Can provide discovery using either multicast or unicast
	- Unicast method is used as an alternative with especial DNS-look up procedures if   multicast is not used
* Can be used for server-to-server communications for the intra-ITAD

VG #2: Issues with other proposed protocol:

* TRIP-GW (draft-rs-trip-gw-03.txt)
	- Not extensible for "Discovery" mechanisms as the protocol is "hard-wired" for a given mechanism
* SLP (draft-zhao-iptel-gwloc-slp-02.txt)
	- Not optimized for "Discovery" of limited number (3 or so) of attributes like "SIP-ISUP GW," "SIP-H.323 GW," and "SIP-BICC GW" that are needed in an ITAD
	- Only optimized for "Discovery" of services where 100s or 1000s of services need advertised for discovery
	- Requires to implement the whole complex set of SLP protocol that has little or no relevance in the intra-ITAD
	- Cannot use TRIP format and messages sets, if needed
* Server and Registration Protocol (draft-roy-iptel-gw-server-discovery-00.txt)
	- Optimized to be used in an ITAD and does NOT have any issues as mentioned above for TRIP-GW and SLP protocol

B. Registration Protocol (draft-roy-iptel-gw-server-registration-00.txt)

VG # 1: Characteristics of Registration Protocol (draft-roy-iptel-gw-server-registration-00.txt)

* Provides semantics for registration for all types of GWs and SIP Server/LS with following attributes 
	- Addresses [e.g., Telephone numbers, Email Ids, URL Ids],  Alternate Peers, Registration Time, Registration Time 	Extension, Alternate GW, capability negotiations, Capacity/Performance, Registration Cancellation, and others
* Can use any transport protocol (e.g., TCP, UDP)
* Syntax of the protocol
	- Can be defined as appropriate, for example:
		->TRIP format and messages with some minor or no modifications
		-> A new format and messages as appropriate
* Same protocol can be used for server-to-server communications within an ITAD

VG #2: Issues with other Proposed Protocols

* TRIP-GW (draft-rs-trip-gw-03.txt)
	- Not generalized enough that can be used by other gateways other than the SIP-ISUP gateway 
	- Does not provide any attributes for addresses like email Ids, URL Ids, etc. that may be needed by gateways like SIP-H.323 and others
	- Uses TRIP's complex message format
	- Inefficient as it mandates to use TCP as the only transport
	- Not extensible for "Discovery" mechanisms as the protocol is "hard-wired" for a given mechanism
	- Inefficient or difficult to use for the server-to-server communications in an ITAD, if needed, as if the protocol is 	"hardwired" for a given environment
	- Only optimized for the SIP-ISUP Gateway and will also force, indirectly, to use inefficient I-TRIP protocol for the 	intra-ITAD communications TRIP protocol (hence violates the spirit of the charter)
* SLP (draft-zhao-iptel-gwloc-slp-02.txt)
	- Only optimized for "Discovery" of services where 100s or 1000s of services need advertised for discovery
	- Optimized to REGISTER attributes that differentiate one service from another and not designed to transfer data 	related to each service
	- Only limited number (3 or so) of services attributes like "SIP-ISUP GW," "SIP-H.323 GW," and "SIP-BICC GW" are needed in an ITAD, but a huge amount of data needs to be transferred for each GW service
	- Requires to implement the whole complex set of SLP protocol that has little or no relevance in an ITAD
	- Cannot use TRIP format and messages sets, if needed
* Server and Registration Protocol (draft-roy-iptel-gw-server-registration-00.txt)
	- Optimized to be used in an ITAD and does NOT have any issues as mentioned above for TRIP-GW and SLP protocol

Best regards,

Radhika R. Roy
[email-masked]

-----Original Message-----
From: Jonathan Rosenberg [mailto:[email-masked]]
Sent: Saturday, December 08, 2001 2:42 AM
To: List Iptel (E-mail)
Subject: [IPTEL] updated agenda

Folks,

AGENDA:

Reading:

3. TRIP MIB [Walker]                   10m

Reading:

4. Gateway Registration

     Scenarios Discussion 
       [Internet2 - hgs]               10m
       [Carrier - jdr]
      
     Requirements Discussion
       [Rosenberg]                     20m

     Attributes Discussion
       [Bangalore]                     10m

Reading:

---