Subject: [IPTEL] Structure of tel: URI

From: "Alexeitsev, D" <[email-masked]>
Date: Mon, 5 Aug 2002 14:19:27 +0200

Hello All

Why does the tel: URI has no definition of the whole number (something like address-signal), but the separated phonedigits? So it could be something like this:

subscriber          =  global-number / local-number
global-number       =  global-number-part [isdn-subaddress]
global-number-part  =  "+" address-signal
local-number        =  local-number-part [isdn-subaddress]
                       [context]
local-number-part   =  address-signal
address-signal	  =  1*phonedigit

Greetings,
Denis Alexeitsev

_______________________________________________
IPTEL mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/iptel

---

From: Henning Schulzrinne <[email-masked]>
Date: Tue, 06 Aug 2002 04:12:14 -0400

I'm not sure what draft you're referring to. draft-antti-rfc2806bis-05
has the following definition; I agree that 1*phonedigit could be 
replaced by a term. Do you see any particular reason for doing so?

         telephone-uri       =  "tel:" subscriber *param

         global-number-part  =  "+" 1*phonedigit

                                [context]

         local-number-part   =  1*phonedigit

         isdn-subaddress     =  ";isub=" 1*uric

         context             =  ";phone-context=" descriptor *(","
descriptor)

Alexeitsev, D wrote:
 > Hello All
 >
 > Why does the tel: URI has no definition of the whole number
 > (something like address-signal), but the separated phonedigits? So it
 > could be something like this:
 >
 > subscriber          =  global-number / local-number global-number
 > =  global-number-part [isdn-subaddress] global-number-part  =  "+"
 > address-signal local-number        =  local-number-part
 > [isdn-subaddress] [context] local-number-part   =  address-signal
 > Greetings, Denis Alexeitsev
 >
 >
 > _______________________________________________ IPTEL mailing list