Subject: Re: [IPTEL] Structure of tel: URI

From: "Alexeitsev, D" <[email-masked]>
Date: Tue, 6 Aug 2002 10:50:30 +0200

Thanks for the comment

>I'm not sure what draft you're referring to. draft-antti-rfc2806bis-05
>has the following definition; I agree that 1*phonedigit could be 
>replaced by a term. Do you see any particular reason for doing so?

I was looking at the draft-antti-rfc2806bis-04, but after a short comparation it has no difference concerning the definition of global-number-part and local-number-part.

The reason why I asked it was my confusion about how to reference the number itself. The application of this reference was the interworking between the CalledPartyNumber parameter in ISUP and the subscriber component of tel: URI.
The mapping I got for the number information itself was: 

Address Signal = 1*phonedigit

This seemed to me somehow confusing as the number information has only the definition of format but not a name.

Btw the "+" sign could be named somehow as well so it would give the reference to distinguish the international and the national number formats.

Greetings,
Denis Alexeitsev

_______________________________________________
IPTEL mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/iptel

---

From: Henning Schulzrinne <[email-masked]>
Date: Tue, 06 Aug 2002 13:40:47 -0400

I will remove local-number-part, which is also 1*phonedigit, and just
call it phone-number. I don't see the need to label "+" - you can just 
as well refer to it literally.

Alexeitsev, D wrote:
 > Thanks for the comment
 >
 >
 >> I'm not sure what draft you're referring to.
 >> draft-antti-rfc2806bis-05 has the following definition; I agree
 >> that 1*phonedigit could be replaced by a term. Do you see any
 >> particular reason for doing so?
 >
 >
 >
 > I was looking at the draft-antti-rfc2806bis-04, but after a short
 > comparation it has no difference concerning the definition of
 > global-number-part and local-number-part.
 >
 > The reason why I asked it was my confusion about how to reference the
 > number itself. The application of this reference was the interworking
 > between the CalledPartyNumber parameter in ISUP and the subscriber
 > component of tel: URI. The mapping I got for the number information
 > itself was:
 >
 > This seemed to me somehow confusing as the number information has
 > only the definition of format but not a name.
 >
 > Btw the "+" sign could be named somehow as well so it would give the
 > reference to distinguish the international and the national number
 > formats.
 >
 > Greetings, Denis Alexeitsev
 >

---

From: Michael Hammer <[email-masked]>
Date: Tue, 06 Aug 2002 17:35:31 -0400

Going from memory, one time when I looked into this, there was a difference 
between global and local numbers in their use of over-decadic 
digits.  Local allowed them, global did not.  I would have to chase down 
the reference.

Is this saying that over-decadic can be used in global or that local digits 
can now not be over-decadic.

Mike

At 01:40 PM 8/6/2002 -0400, Henning Schulzrinne wrote:
>call it phone-number. I don't see the need to label "+" - you can just as 
>well refer to it literally.
>
>Alexeitsev, D wrote:
> > Thanks for the comment
> >
> >

---

From: Lawrence Conroy <[email-masked]>
Date: Wed, 7 Aug 2002 10:22:15 +0100

At 5:35 pm -0400 6/8/02, Michael Hammer wrote:
>Going from memory, one time when I looked into this, there was a 
>difference between global and local numbers in their use of 
>over-decadic digits.  Local allowed them, global did not.  I would 
>have to chase down the reference.
>
>Is this saying that over-decadic can be used in global or that local 
>digits can now not be over-decadic.
>
>Mike
>
Hi Mike, Folks,
   "Over-decadic" was used for local numbers only to express RNs that 
were (?are?) used within some Netz.
e.g. Cxxx and Fxxx to indicate "this is a network-internal routing number".
It's mentioned in the BNF (as HEXDIG) and in ss 5.1.2 (line 264 onwards).

The suggestion was that, as routing numbers are "network-internal", 
there's no need for this to be
allowed in global numbers - an RN is not (necessarily) valid outside 
its context. Hence 5.1.2 says
that it's unspecified but not prohibited for local numbers only.

James Yu's draft on RN and CIC may make use of HEXDIG, so please 
let's not prohibit it.

all the best,
   Lawrence
-- 
-----------------------------------------------------------------------
Roke Manor Research    : This information is provided "as is" and is not
<mailto:[email-masked]>: intended to create any contractual or legal
<tel:+441794833666>    : relationship.

---

From: Michael Hammer <[email-masked]>
Date: Wed, 07 Aug 2002 12:14:19 -0400

As mentioned, RN values may be over-decadic as described in E.164 supp 2, 
11/98.  So would it be fair to say that so long as RN and DN definitions 
are distinct and that other parameters point to use of either RN, DN, or 
both (or incorporate equivalent definitions), then this can be kept 
straight?  Also, does CIC follow RN definition?

Mike

At 10:22 AM 8/7/2002 +0100, Lawrence Conroy wrote:
>>difference between global and local numbers in their use of over-decadic 
>   "Over-decadic" was used for local numbers only to express RNs that were 
> (?are?) used within some Netz.
>allowed in global numbers - an RN is not (necessarily) valid outside its 
>context. Hence 5.1.2 says
>James Yu's draft on RN and CIC may make use of HEXDIG, so please let's not 
>prohibit it.
>
>all the best,
>   Lawrence
>--

---

From: Michael Hammer <[email-masked]>
Date: Wed, 07 Aug 2002 12:21:57 -0400

Also, note how phone-string is being defined in:

draft-allocchio-gstn-04.txt:

       phone-string = 1*( DTMF / pause / tonewait / written-sep )

       DTMF = ( DIGIT / "#" / "*" / "A" / "B" / "C" / "D" )

       written-sep = ( "-" / "." )

       pause = "p"

       tonewait = "w"

       gstn-phone = ( global-phone / local-phone )

       global-phone = "+" 1*( DIGIT / written-sep )

       local-phone =  [ exit-code ] dial-number

       local-phone =/ exit-code [ dial-number ]

       exit-code = phone-string

       dial-number = phone-string

       subaddr-string = phone-string

       post-dial = phone-string

Mike

---

From: Henning Schulzrinne <[email-masked]>
Date: Wed, 07 Aug 2002 12:24:22 -0400

Yes, and that's a problem that's going to be causing confusion in the 
future if the allocchio draft goes forward. We had, I believe, 
intentionally decided not to support the various pauses and such in 
2806bis, since they are dial strings, not directory or routing numbers. 
The idea was that adding pauses and such depended too strongly on the 
local environment to be useful in a URI.

Michael Hammer wrote:
>> James Yu's draft on RN and CIC may make use of HEXDIG, so please let's 
>> not prohibit it.
>>
>> all the best,
>>   Lawrence
>> --

---

From: Lawrence Conroy <[email-masked]>
Date: Wed, 7 Aug 2002 17:52:46 +0100

At 12:24 pm -0400 7/8/02, Henning Schulzrinne wrote:
>Yes, and that's a problem that's going to be causing confusion in 
>the future if the allocchio draft goes forward. We had, I believe, 
>2806bis, since they are dial strings, not directory or routing 
>numbers. The idea was that adding pauses and such depended too 
>strongly on the local environment to be useful in a URI.
>
>Michael Hammer wrote:

Yup.
Agree wholeheartedly with Henning on this.
Dial strings are the wrong way to go.

That draft is just....complex I think that the Internet Fax WG
(from which this abomination came) are trying to solve some other problem
- it is not at all clear to me what this is, and why they need pauses, etc.

atb,   Lawrence

---

From: Michael Hammer <[email-masked]>
Date: Wed, 07 Aug 2002 13:32:30 -0400

Yes, I agree also.  Just pointing out the over-decadic.  I do not believe 
that things like pauses intended to compensate the difference between the 
speed of two machines locally should be included.

Follow KISS principle

Mike

---

From: Lawrence Conroy <[email-masked]>
Date: Wed, 7 Aug 2002 18:09:34 +0100

At 12:14 pm -0400 7/8/02, Michael Hammer wrote:
>As mentioned, RN values may be over-decadic as described in E.164 
>supp 2, 11/98.  So would it be fair to say that so long as RN and DN 
>definitions are distinct and that other parameters point to use of 
>either RN, DN, or both (or incorporate equivalent definitions), then 
>this can be kept straight?  Also, does CIC follow RN definition?
>
>Mike
>
Hi again Mike, Folks,
   "Over-decadic"s are described in a number of places :).
RN and DN definitions may include the same digits - AFAIK there are 
few states that *still*
use the Hex prefix for RNs. Thus in the general case it is not 
possible to decide whether
a digit string is a DN or an RN merely by inspection of that string 
alone. Thus DN and RN
definitions are not disjoint in the BNF; the interpretation must be 
understood from context.

If the digit string is inside the RN parameter, then this is clear.

In the case of some uses of ENUM-like systems ("infrastructure 
ENUM"), ALL tel: URLs
within that system will be either CICs or RNs - in that case one may 
not need any
further indication, as it should be clear from context - it has come 
from a system
that only includes RNs, therefore it's an RN.

Re. CIC:
I believe that Carrier Identification Code is a joy as it's a national thing.

IMHO, it's difficult to specify this further than just 1*digitstring.

In North America CIC syntax will be a defined subset of this; I'm not 
sure if the
subset used is identical in Austria, for example.

Hence I think 2806bis includes enough definition to be useful, but 
not too much.

all the best,
   Lawrence